<!DOCTYPE html>
<html lang="en-US">
    <head>
        <meta charset="UTF-8"/>
        <meta name="viewport" content="width=device-width, initial-scale=1.0"/>
        <link rel="profile" href="http://gmpg.org/xfn/11"/>
        <link rel="pingback" href="https://www.intouchweekly.com/xmlrpc.php"/>
        <link rel="apple-touch-icon" sizes="180x180" href="https://www.intouchweekly.com/wp-content/themes/ami-bauer/assets/source/images/favicon/intouch/apple-touch-icon.png">
        <link rel="icon" type="image/png" sizes="32x32" href="https://www.intouchweekly.com/wp-content/themes/ami-bauer/assets/source/images/favicon/intouch/favicon-32x32.png">
        <link rel="icon" type="image/png" sizes="16x16" href="https://www.intouchweekly.com/wp-content/themes/ami-bauer/assets/source/images/favicon/intouch/favicon-16x16.png">
        <link rel="mask-icon" href="https://www.intouchweekly.com/wp-content/themes/ami-bauer/assets/source/images/favicon/intouch/safari-pinned-tab.svg" color="#636363">
        <meta name="theme-color" content="#ffffff">

					<link rel="preload" href="https://www.intouchweekly.com/wp-content/themes/ami-bauer/assets/build/fonts/FjallaOne-Regular.woff2" as="font" type="font/woff2" crossorigin>
			<link rel="preload" href="https://www.intouchweekly.com/wp-content/themes/ami-bauer/assets/build/fonts/Raleway-Bold.woff2" as="font" type="font/woff2" crossorigin>
			<link rel="preload" href="https://www.intouchweekly.com/wp-content/themes/ami-bauer/assets/build/fonts/Raleway-ExtraBold.woff2" as="font" type="font/woff2" crossorigin>
		
							<script type="text/javascript">
			window.googletag = window.googletag || {}, window.googletag.cmd = window.googletag.cmd || [], window.googletag.cmd.push( function() {
				if ( 0 === window.googletag.pubads().getTargeting( "permutive" ).length ) {
					var g = window.localStorage.getItem( "_pdfps" );
					window.googletag.pubads().setTargeting( "permutive", g ? JSON.parse( g ) : [] )
				}
			} );
			window.ntvConfig = window.ntvConfig || {};
			window.ntvConfig.keyValues = window.ntvConfig.keyValues || {};
			var segs = localStorage.getItem( '_pnativo' );
			if ( segs ) {
				window.ntvConfig.keyValues.permutive = segs;
			}
			!function( n, e, o, r, i ) {
				if ( !e ) {
					e = e || {}, window.permutive = e, e.q = [], e.config = i || {}, e.config.projectId = o, e.config.apiKey = r, e.config.environment = e.config.environment || "production";
					for ( var t = ["addon", "identify", "track", "trigger", "query", "segment", "segments", "ready", "on", "once", "user", "consent"], c = 0; c < t.length; c++ ) {
						var f = t[c];
						e[f] = function( n ) {
							return function() {
								var o = Array.prototype.slice.call( arguments, 0 );
								e.q.push( {functionName: n, arguments: o} )
							}
						}( f )
					}
				}
			}( document, window.permutive, "410f7cce-1402-4d0e-8d36-f430b2eb2066", "9fc95048-71ef-4f85-a2f7-d7e9ca5b8d45", {"consentRequired": true} );
			var permutiveData = {"page":{"url":"\/posts\/machine-gun-kelly-net-worth-how-much-does-the-rapper-make\/","category":"post","title":"Machine Gun Kelly&#8217;s Net Worth Proves He&#8217;s Staying on His Grind With His Chart-Topping Singles and Acting Roles","type":"article","id":336941,"article":{"title":"Machine Gun Kelly&#8217;s Net Worth Proves He&#8217;s Staying on His Grind With His Chart-Topping Singles and Acting Roles","category":["News"],"tags":["Machine Gun Kelly","Megan Fox","Net Worth"],"audience":{"category":[],"subCategory":[]},"retailers":[],"celebrity":[],"publishDate":"2021-11-23T10:00:39-05:00"}}};
			if ( localStorage.getItem( 'blueconic' ) ) {
				permutiveData.page.blueconic = JSON.parse( localStorage.getItem( 'blueconic' ) );
			}
			permutive.addon( "web", permutiveData );
		</script>
		<script type="text/javascript" async src="https://cdn.permutive.com/410f7cce-1402-4d0e-8d36-f430b2eb2066-web.js"></script>
		
	<!-- OneTrust Cookies Consent Notice start -->
	<script src="https://cdn.cookielaw.org/scripttemplates/otSDKStub.js"  type="text/javascript" charset="UTF-8" data-domain-script="36677945-95df-4551-ae71-315d352a975d"></script>
	<script src="https://cdn.cookielaw.org/opt-out/otCCPAiab.js" type="text/javascript" charset="UTF-8" ccpa-opt-out-ids="C0005,C0004,C0002,BG17" ccpa-opt-out-geo="ca" ccpa-opt-out-lspa="false"></script>
	<script type="text/javascript">
		function OptanonWrapper() {
			var allIframes = document.querySelectorAll( 'iframe[class*="optanon-category"]' );
			allIframes.forEach (function( iframe ) {
				var thisIframeCategories = iframe.classList.value.match(/C000\d+/g);

				// Check if user allowed every category assigned to this iframe
				var shouldBeLoaded = thisIframeCategories.every( function( item ) {
					return OptanonActiveGroups.match( item );
				});

				// Load iframe if every category is allowed
				if ( shouldBeLoaded ) {
					loadIframe( iframe );
				}
			});

			// load iframe element
			function loadIframe( element ) {
				if ( element.tagName.toLowerCase() == "iframe" && !element.getAttribute( "src" ) && element.dataset.src ) {
					element.setAttribute( "src", element.dataset.src );
				}
			}

			if ( window.permutive ) {
				if ( OptanonActiveGroups.indexOf( ',C0004,' ) === -1 ) {
					permutive.consent({ "opt_in": false });
				} else {
					permutive.consent({ "opt_in": true, "token": "AMI" });
				}
			}
		}
	</script>
	<!-- OneTrust Cookies Consent Notice end -->

	
			<script>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</script>

			<script type="text/plain" class="optanon-category-C0004" src="//d17tqr44y57o31.cloudfront.net/script.js"></script>
			<meta name='robots' content='index, follow, max-image-preview:large, max-snippet:-1, max-video-preview:-1' />
<!-- Jetpack Site Verification Tags -->
		<script>
			function getCookie(name) {
				var matches = document.cookie.match(new RegExp(
						"(?:^|; )" + name.replace(/([\.$?*|{}\(\)\[\]\\\/\+^])/g, '\\$1') + "=([^;]*)"
				));
				return matches ? decodeURIComponent(matches[1]) : undefined;
			}

			window.dataLayer = window.dataLayer || [];
			dataLayer = [{"pageCategory":"post","env":"prod","sponsored":"off","vupulse":"on","nodeId":336941,"contentType":"article","nodeCategory":["News"],"nodeTags":["Machine Gun Kelly","Megan Fox","Net Worth"],"contentUpdatedDate":"2021\/11\/23","contentPublishDate":"2021\/11\/23","pageTitle":"Machine Gun Kelly&#8217;s Net Worth Proves He&#8217;s Staying on His Grind With His Chart-Topping Singles and Acting Roles","sponsorshipName":"","comments":"on","author":"Samantha Benitz","skimlinks":"on","zergnet":"on","gotchosen":"on","audience_cat":[],"audience_subcat":[],"exclusive":"off","globaladrefresh":"20000","homepagerefresh":"on","gallerypostrefresh":"on","videopostrefresh":"on","audiopostrefresh":"on","standardpostrefresh":"on","desktoprefresh":"on","mobilerefresh":"on","tragedy":"off","advertorial":"off","refresh":"on"}];

			var site_display_format = 'desktop';

			if ( window.innerWidth < 768 ) {
				site_display_format = 'mobile';
			} else if ( window.innerWidth >= 768 && window.innerWidth <= 1024 ) {
				site_display_format = 'tablet';
			}

			dataLayer.push( { siteDisplayFormat : site_display_format } );

			var username = getCookie('mylo_username');
			if ( undefined !== username ) {
				dataLayer.push( {userName: username} );
			}

			var name = 'setAgeInfo';
			var matches = document.cookie.match(new RegExp(
				"(?:^|; )" + name.replace(/([\.$?*|{}\(\)\[\]\\\/\+^])/g, '\\$1') + "=([^;]*)"
			));

			dataLayer.push( { userAge : matches ? decodeURIComponent( matches[1] ) : '14' } );
		</script>
		
	<!-- This site is optimized with the Yoast SEO plugin v16.8 - https://yoast.com/wordpress/plugins/seo/ -->
	<title>Machine Gun Kelly Net Worth: How Much Does the Rapper Make?</title>
	<meta name="description" content="Machine Gun Kelly&#039;s net worth proves he&#039;s staying on his grind. Find out how the star makes money, from rapping to acting and more." />
	<link rel="canonical" href="https://www.intouchweekly.com/posts/machine-gun-kelly-net-worth-how-much-does-the-rapper-make/" />
	<meta property="og:locale" content="en_US" />
	<meta property="og:type" content="article" />
	<meta property="og:title" content="Machine Gun Kelly Makes a Pretty Penny! See His Impressive Net Worth" />
	<meta property="og:description" content="Machine Gun Kelly&#039;s net worth proves he&#039;s staying on his grind. Find out how the star makes money, from rapping to acting and more." />
	<meta property="og:url" content="https://www.intouchweekly.com/posts/machine-gun-kelly-net-worth-how-much-does-the-rapper-make/" />
	<meta property="og:site_name" content="In Touch Weekly" />
	<meta property="article:publisher" content="http://www.facebook.com/InTouchWeekly" />
	<meta property="article:published_time" content="2021-11-23T15:00:39+00:00" />
	<meta property="article:modified_time" content="2021-11-23T15:00:23+00:00" />
	<meta name="twitter:card" content="summary_large_image" />
	<meta name="twitter:title" content="Machine Gun Kelly Makes a Pretty Penny! See His Impressive Net Worth" />
	<meta name="twitter:description" content="Machine Gun Kelly&#039;s net worth proves he&#039;s staying on his grind. Find out how the star makes money, from rapping to acting and more." />
	<meta name="twitter:image" content="https://www.intouchweekly.com/wp-content/uploads/2020/05/Screen-Shot-2020-05-20-at-2.49.47-PM.png?resize=1200%2C630" />
	<meta name="twitter:creator" content="@intouchweekly" />
	<meta name="twitter:site" content="@intouchweekly" />
<script type="application/ld+json">{"@context":"http:\/\/schema.org","@type":"WebPage","@id":"https:\/\/www.intouchweekly.com\/posts\/machine-gun-kelly-net-worth-how-much-does-the-rapper-make\/#webpage","publisher":{"@id":"https:\/\/www.intouchweekly.com\/posts\/machine-gun-kelly-net-worth-how-much-does-the-rapper-make\/#organization"},"isPartOf":{"@id":"https:\/\/www.intouchweekly.com\/posts\/machine-gun-kelly-net-worth-how-much-does-the-rapper-make\/#website"}}</script>
<script type="application/ld+json">{"@context":"http:\/\/schema.org","@type":"Organization","name":"In Touch Weekly","url":"https:\/\/www.intouchweekly.com","parentOrganization":"a360 Media LLC","logo":{"@type":"ImageObject","url":"https:\/\/www.intouchweekly.com\/wp-content\/themes\/ami-bauer\/assets\/source\/images\/icons\/logo-intouch.svg"},"address":{"@type":"PostalAddress","streetAddress":"4 New York Plaza","addresslocality":"New York, NY","postalCode":"10004"},"telephone":"212-545-4800","sameAs":["http:\/\/www.facebook.com\/InTouchWeekly","https:\/\/twitter.com\/intouchweekly","https:\/\/www.instagram.com\/intouchweekly\/?hl=en","https:\/\/plus.google.com\/+intouchweekly"]}</script>
<script type="application/ld+json">{"@context":"http:\/\/schema.org","@type":"Article","@id":"https:\/\/www.intouchweekly.com\/posts\/machine-gun-kelly-net-worth-how-much-does-the-rapper-make\/#article","mainEntityOfPage":"https:\/\/www.intouchweekly.com\/posts\/machine-gun-kelly-net-worth-how-much-does-the-rapper-make\/","publisher":{"@type":"Organization","name":"In Touch Weekly","logo":{"@type":"ImageObject","url":"https:\/\/www.intouchweekly.com\/wp-content\/themes\/ami-bauer\/assets\/source\/images\/icons\/logo-intouch.svg"},"@id":"https:\/\/www.intouchweekly.com\/posts\/machine-gun-kelly-net-worth-how-much-does-the-rapper-make\/#organization"},"headline":"Machine Gun Kelly&#8217;s Net Worth Proves He&#8217;s Staying on His Grind With His Chart-Topping Singles and Acting Roles","datePublished":"2021-11-23T10:00:39-05:00","dateModified":"2021-11-23T10:00:23-05:00","author":{"@type":"Person","name":"Samantha Benitz"},"description":"By the age of 31, Machine Gun Kelly (real name: Colson Baker) has already earned a substantial amount of money. The Cleveland, Ohio native pursued his passion for music and adopted his stage...","articleBody":"By the age of 31, Machine Gun Kelly (real name: Colson Baker) has already earned a substantial amount of money. The Cleveland, Ohio native pursued his passion for music and adopted his stage name due to his speedy lyrical delivery, having taken his career to new heights in recent years. MGK released five studio albums, with his sixth set to drop in 2022. In May 2021, he solidified his bad boy presence by dropping a steamy music video for his song \u201cBloody Valentine\u201d featuring his girlfriend, Megan Fox. In addition to making music, the performer has also dabbled in the world of acting. Scroll down to find out the star\u2019s net worth and get more details. \r\nWhat Is MGK's Net Worth?\r\nAs of 2021, the \u201cGlass House\u201d rapper\u2019s net worth sits around $10 million, according to CelebrityNetWorth.com. After the success of his eight self-released mixtapes, including Stamp of Approval, Homecoming, 100 Words and Running and Lace Up, to name a few, he\u2019s gone on to create more chart-topping singles. \r\n\r\n\r\nHow Does He Make Money?\r\nMGK has continued to make a name for himself. He released his fifth studio album, Tickets to My Downfall, in September 2020, which peaked at number 1 on the Billboard 200 chart and was certified Platinum in America and Canada and Gold in the UK \u2014 and his sixth studio album, Born With Horns, is set to drop in 2022. The rapper also landed several movie gigs, appearing in films like Beyond the Lights, The Land, Bird Box and Big Time Adolescence. He even showed off his comedic chops during an episode of Wild \u2018N Out. \r\n\r\n[ami-related id=\"335052\" url=\"https:\/\/www.intouchweekly.com\/posts\/megan-fox-transformation-see-photos-of-actress-then-and-now\/\" title=\"Megan Fox's Transformation Proves She'll Always Be a ~Fox~\" target=\"_blank\" thumb=\"true\" showsubt=\"false\" imgsrc=\"https:\/\/www.intouchweekly.com\/wp-content\/uploads\/2020\/05\/Megan-Fox-Evolution-Feature-Photo.jpg?fit=2000%2C2000\" imgid=\"334232\" format=\"gallery\" flag=\"\" channel=\"2207\" subtitle=\"\"]\r\nWhat Keeps Him Motivated?\r\nMachine Gun Kelly is the proud father of a daughter, Casie Colson Baker, shared with his ex Emma Cannon. \"I\u2019m fortunate to have a baby girl who\u2019s super into everything that I say and do,\" he told Rolling Stone about his little one, revealing she's \"just fun to be around\" and keeps him on his grind.\r\n\r\n\r\nWho Does He Hang Out With?\r\nThe musician is close pals with Saturday Night Live star Pete Davidson. On top of that, he\u2019s formed a close bond with Travis Barker, the drummer of one of his favorite bands Blink-182 and now frequent collaborator, as well as Travis\u2019 fianc\u00e9e Kourtney Kardashian. The duo is often seen enjoying double dates with MGK and his girlfriend Megan, whom he grew close to during their time filming Midnight in the Switchgrass.\r\n\r\n[jwplayer Fvs5a00w-8t2DpQMJ]","isPartOf":{"@id":"https:\/\/www.intouchweekly.com\/posts\/machine-gun-kelly-net-worth-how-much-does-the-rapper-make\/#webpage"},"image":["https:\/\/www.intouchweekly.com\/wp-content\/uploads\/2020\/05\/Screen-Shot-2020-05-20-at-2.49.47-PM.png","https:\/\/www.intouchweekly.com\/wp-content\/uploads\/2020\/05\/Screen-Shot-2020-05-20-at-2.49.47-PM.png"]}</script>
	<script type="application/ld+json" class="yoast-schema-graph">{"@context":"https://schema.org","@graph":[{"@type":"WebSite","@id":"https://www.intouchweekly.com/#website","url":"https://www.intouchweekly.com/","name":"In Touch Weekly","description":"","inLanguage":"en-US"},{"@type":"ImageObject","@id":"https://www.intouchweekly.com/posts/machine-gun-kelly-net-worth-how-much-does-the-rapper-make/#primaryimage","inLanguage":"en-US","url":"https://www.intouchweekly.com/wp-content/uploads/2020/05/Screen-Shot-2020-05-20-at-2.49.47-PM.png?fit=1874%2C1120","contentUrl":"https://www.intouchweekly.com/wp-content/uploads/2020/05/Screen-Shot-2020-05-20-at-2.49.47-PM.png?fit=1874%2C1120","width":1874,"height":1120,"caption":"Machine Gun Kelly Net Worth"},{"@type":"WebPage","@id":"https://www.intouchweekly.com/posts/machine-gun-kelly-net-worth-how-much-does-the-rapper-make/#webpage","url":"https://www.intouchweekly.com/posts/machine-gun-kelly-net-worth-how-much-does-the-rapper-make/","name":"Machine Gun Kelly Net Worth: How Much Does the Rapper Make?","isPartOf":{"@id":"https://www.intouchweekly.com/#website"},"primaryImageOfPage":{"@id":"https://www.intouchweekly.com/posts/machine-gun-kelly-net-worth-how-much-does-the-rapper-make/#primaryimage"},"datePublished":"2021-11-23T15:00:39+00:00","dateModified":"2021-11-23T15:00:23+00:00","author":{"@id":"https://www.intouchweekly.com/#/schema/person/2aa148a044c5114d89895ce2d9c9ccb3"},"description":"Machine Gun Kelly's net worth proves he's staying on his grind. Find out how the star makes money, from rapping to acting and more.","breadcrumb":{"@id":"https://www.intouchweekly.com/posts/machine-gun-kelly-net-worth-how-much-does-the-rapper-make/#breadcrumb"},"inLanguage":"en-US","potentialAction":[{"@type":"ReadAction","target":["https://www.intouchweekly.com/posts/machine-gun-kelly-net-worth-how-much-does-the-rapper-make/"]}]},{"@type":"BreadcrumbList","@id":"https://www.intouchweekly.com/posts/machine-gun-kelly-net-worth-how-much-does-the-rapper-make/#breadcrumb","itemListElement":[{"@type":"ListItem","position":1,"name":"Home","item":"https://www.intouchweekly.com/"},{"@type":"ListItem","position":2,"name":"Machine Gun Kelly&#8217;s Net Worth Proves He&#8217;s Staying on His Grind With His Chart-Topping Singles and Acting Roles"}]},{"@type":"Person","@id":"https://www.intouchweekly.com/#/schema/person/2aa148a044c5114d89895ce2d9c9ccb3","name":"Samantha Benitz","image":{"@type":"ImageObject","@id":"https://www.intouchweekly.com/#personlogo","inLanguage":"en-US","url":"https://secure.gravatar.com/avatar/a9e75358136ee5eb4c8132bcfe55c294?s=96&d=mm&r=g","contentUrl":"https://secure.gravatar.com/avatar/a9e75358136ee5eb4c8132bcfe55c294?s=96&d=mm&r=g","caption":"Samantha Benitz"},"description":"Samantha Benitz is a digital staff writer\u00a0with a true passion for entertainment news. She loves to cover hot topics, including reality shows from 90 Day Fianc\u00e9 to Teen Mom and Love &amp; Hip Hop, as well as all of the star-studded events.\u00a0","sameAs":["https://intouchweekly.com"],"url":"https://www.intouchweekly.com/authors/samantha-benitz-100464/"}]}</script>
	<!-- / Yoast SEO plugin. -->


<meta content="593583017" property="fb:admins" /><meta content="75932763901" property="fb:pages" /><link rel='dns-prefetch' href='//static.adsafeprotected.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="text/xml" title="In Touch Weekly &raquo; Feed" href="https://www.intouchweekly.com/feed/" />
	<script>
		function gptAdsWindowWidth() {
			var w = window,
				d = document,
				e = d.documentElement,
				x = Math.max( e.scrollWidth, e.offsetWidth, e.clientWidth );
			return x;
		}

		function adsParseUrlParams( val ) {
			var result = false,
				tmp = [];
			var items = location.search.substr( 1 ).split( "&" );
			for ( var index = 0; index < items.length; index++ ) {
				tmp = items[ index ].split( "=" );
				if ( tmp[ 0 ] === val ) {
					result = decodeURIComponent( tmp[ 1 ] );
				}
			}
			return result;
		}

		function getCookie(name) {
			var matches = document.cookie.match(new RegExp(
				"(?:^|; )" + name.replace(/([\.$?*|{}\(\)\[\]\\\/\+^])/g, '\\$1') + "=([^;]*)"
			));
			return matches ? decodeURIComponent(matches[1]) : undefined;
		}

		function setCookie(name, value, options) {
			options = options || {};

			var expires = options.expires;

			if (typeof expires == "number" && expires) {
				var d = new Date();
				d.setTime(d.getTime() + expires * 1000);
				expires = options.expires = d;
			}
			if (expires && expires.toUTCString) {
				options.expires = expires.toUTCString();
			}

			value = encodeURIComponent(value);

			var updatedCookie = name + "=" + value;

			for (var propName in options) {
				updatedCookie += "; " + propName;
				var propValue = options[propName];
				if (propValue !== true) {
					updatedCookie += "=" + propValue;
				}
			}

			document.cookie = updatedCookie;
		}

		function amiGetCookie( name ) {
			return getCookie(name);
		}

		window.gptNetwork = '/4216/ami.itw/';
		window.pageID = '336941';
		window.keyword = 'post';
		window.cType = 'Article';
		window.adUnitZone = 'news';

		var spons = "no";

		window.adsRefresh = {};
		window.adsRefresh.impr = [];
		window.adsRefresh.ads = [];
	</script>    			<script type="text/plain" class="optanon-category-C0004" src="//d3jdulus8lb392.cloudfront.net/ami/intouch-weekly/main.js" async=""></script>
		<link rel="stylesheet" href="https://d3jdulus8lb392.cloudfront.net/ami/intouch-weekly/main.css">
			<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.1.0\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.1.0\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/www.intouchweekly.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.8.2"}};
			!function(e,a,t){var n,r,o,i=a.createElement("canvas"),p=i.getContext&&i.getContext("2d");function s(e,t){var a=String.fromCharCode;p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,e),0,0);e=i.toDataURL();return p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,t),0,0),e===i.toDataURL()}function c(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(o=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},r=0;r<o.length;r++)t.supports[o[r]]=function(e){if(!p||!p.fillText)return!1;switch(p.textBaseline="top",p.font="600 32px Arial",e){case"flag":return s([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])?!1:!s([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!s([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]);case"emoji":return!s([10084,65039,8205,55357,56613],[10084,65039,8203,55357,56613])}return!1}(o[r]),t.supports.everything=t.supports.everything&&t.supports[o[r]],"flag"!==o[r]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[o[r]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(n=t.source||{}).concatemoji?c(n.concatemoji):n.wpemoji&&n.twemoji&&(c(n.twemoji),c(n.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<link rel='stylesheet' id='all-css-0' href='https://www.intouchweekly.com/_static/??-eJyNTksOwiAQvZB0bNRqF8ajmClM6CjQhoEYbi91ZaMx7t7L+8JjVhy0y4YEbgKeDCM58hTSiswOC0XlyKIujefQaJEN/IpX7Z2vQnoKafGksWoC6FkNmCkCilASGDI7A9UNkoqjOpKmrMePvM9qdtlyqPOUZtR31W6bHVzrK7AUKHK1ynf4d5ufTHb1powYyaAx5QU52KXi4s9ttzt2fb8/nJ4IDHzW' type='text/css' media='all' />
<script type="text/javascript" src="https://www.intouchweekly.com/_static/??-eJzTLy/QzcxLzilNSS3WzwKiwtLUokoopZebmaeXVayjj0+Rbm5melFiSSpUsX2uraGZsbmZpaWJqUUWAK/PIjI=" ></script><link rel="https://api.w.org/" href="https://www.intouchweekly.com/wp-json/" /><link rel="alternate" type="application/json" href="https://www.intouchweekly.com/wp-json/wp/v2/posts/336941" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.intouchweekly.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://www.intouchweekly.com/wp-includes/wlwmanifest.xml" /> 
<meta name="generator" content="WordPress 5.8.2" />
<link rel='shortlink' href='https://wp.me/pa5Fxh-1pEx' />
<link rel="alternate" type="application/json+oembed" href="https://www.intouchweekly.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.intouchweekly.com%2Fposts%2Fmachine-gun-kelly-net-worth-how-much-does-the-rapper-make%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://www.intouchweekly.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.intouchweekly.com%2Fposts%2Fmachine-gun-kelly-net-worth-how-much-does-the-rapper-make%2F&#038;format=xml" />
<style type='text/css'>img#wpstats{display:none}</style>
		
<link rel="preconnect" href="https://content.jwplatform.com">		<script type="text/plain" class="optanon-category-C0004" async src="https://ovp.iris.tv/libs/context/iris-context.min.js"></script>
		<script>
			var irisToken = decodeURIComponent( "H3P3EPZRWRKIIFW" );
			// Initialize Iris Context API
			window.addEventListener('IrisContextAPI', function() {
				window.irisContext = window.IrisContextAPI({
					client_token: irisToken,
				});
			});
		</script>
			<script type="text/plain" class="optanon-category-C0004" async src="//js-sec.indexww.com/ht/p/183518-190707627379353.js"></script>
	<script>
		var headertag = headertag || {};
		headertag.cmd = headertag.cmd || [];
	</script>
	<meta property="og:updated_time" content="2021-11-23T15:00:23+00:00" />
<meta property="og:image" content="https://www.intouchweekly.com/wp-content/uploads/2020/05/Screen-Shot-2020-05-20-at-2.49.47-PM.png?resize=1200%2C630" />
<meta property="og:image:secure_url" content="https://www.intouchweekly.com/wp-content/uploads/2020/05/Screen-Shot-2020-05-20-at-2.49.47-PM.png?resize=1200%2C630" />
<meta property="og:image:width" content="1200" />
<meta property="og:image:height" content="630" />
	<script>
		/**
		 * Will resolve when amazon is loaded on DOM
		 * * @return {Promise}
		 */
		const waitForAmazon = new Promise((resolve, reject) => {
			amzn_check(resolve, 100, 50 );
			setTimeout(resolve, 5000);
		});

		function amzn_check(resolve, interval, retriesLeft) {
			if ( typeof window.apstag == 'object' && window.apstag ) {
				console.log( 'AMI jwp - Amazon loaded' );
				return resolve();
			}

			if ( --retriesLeft > 0 ) {
				if ( typeof window.apstag != 'object' && !window.apstag ) {
					setTimeout( function(){ amzn_check( resolve, interval, retriesLeft ); }, interval );
					console.log( 'AMI jwp Amazon not loaded ' );
				}
			} else {
				console.log( 'AMI jwp No Retries left - Amazon not loaded' );
				return resolve();
			}
		}


		window.jwVastTag = {};
		window.prerollTag = {};
		window.jwpDef = {};
		window.jwpBids = {};
	</script>
	<link rel="amphtml" href="https://www.intouchweekly.com/posts/machine-gun-kelly-net-worth-how-much-does-the-rapper-make/amp/"><link rel="icon" href="https://www.intouchweekly.com/wp-content/uploads/2020/11/android-chrome-192x192-1.png?fit=32%2C32" sizes="32x32" />
<link rel="icon" href="https://www.intouchweekly.com/wp-content/uploads/2020/11/android-chrome-192x192-1.png?fit=192%2C192" sizes="192x192" />
<link rel="apple-touch-icon" href="https://www.intouchweekly.com/wp-content/uploads/2020/11/android-chrome-192x192-1.png?fit=180%2C180" />
<meta name="msapplication-TileImage" content="https://www.intouchweekly.com/wp-content/uploads/2020/11/android-chrome-192x192-1.png?fit=192%2C192" />
			<!-- Google Tag Manager -->
			<script>( function( w, d, s, l, i ) {
					w[l] = w[l] || [];
					w[l].push( {
						'gtm.start':
							new Date().getTime(), event: 'gtm.js'
					} );
					var f = d.getElementsByTagName( s )[0],
						j = d.createElement( s ), dl = l != 'dataLayer' ? '&l=' + l : '';
					j.async = true;
					j.src =
						'https://www.googletagmanager.com/gtm.js?id=' + i + dl + "";
					f.parentNode.insertBefore( j, f );
				} )( window, document, 'script', 'dataLayer', "GTM-KRVDT6T");</script>		<!-- End Google Tag Manager -->
				<script>
		var gtm_lock = setTimeout( function() {
			if ( "undefined" === typeof OnetrustActiveGroups || OnetrustActiveGroups.indexOf( ',C0002,' ) || OnetrustActiveGroups.indexOf( ',C0003,' ) || OnetrustActiveGroups.indexOf( ',C0004,' ) ) {
				window.dataLayer = window.dataLayer || [];
				dataLayer.push( {event: 'delayed_load'} );
			}
		}, 5000 );

		window.addEventListener( 'load', function( event ) {
			if ( "undefined" === typeof OnetrustActiveGroups || OnetrustActiveGroups.indexOf( ',C0002,' ) || OnetrustActiveGroups.indexOf( ',C0003,' ) || OnetrustActiveGroups.indexOf( ',C0004,' ) ) {
				window.dataLayer = window.dataLayer || [];
				dataLayer.push( {event: 'delayed_load'} );
				clearTimeout( gtm_lock );
			}
		} );

	</script>
	<style type="text/css" id="wp-custom-css">/* Hide total on search page */
.search__total {
	display: none;
}

/* Fix for sharethrough units */
.post-content .dfp-slot[class*='sh-gal'] {
	margin: 30px auto 40px;
}

/* Center mobile ads */
.ds_cpp,
.dfp-wrapper.mobile-only {
	margin-left: auto;
	margin-right: auto;
}

/* Gallery slide caption text */
.list-gallery .gallery-item__caption {
	font-size: 18px;
  font-size: 1.125rem;
	line-height: 1.2;
}

/* Fix for SpotIm huge widget on mobile */
@media screen and (max-width: 1023px) {
	#comments-wrapper {
		max-width: 100vw;
	}
}</style>
		
    </head>

<body class="post-template-default single single-post postid-336941 single-format-standard">
				<!-- Google Tag Manager (noscript) -->
			<noscript>
				<iframe src="https://www.googletagmanager.com/ns.html?id=GTM-KRVDT6T" height="0" width="0" style="display:none;visibility:hidden"></iframe>
			</noscript>		<!-- End Google Tag Manager (noscript) -->
					<div id="page-box">
		<header id="header" class="header">
							<div class="desktop-only color__variation">
					<div class="color__variation-first"></div>
					<div class="color__variation-second"></div>
					<div class="color__variation-third"></div>
				</div>
						<div class="header__mobile">
				<div class="extended-menu-btn desktop-hidden">
					<div id="menu-trigger">
						<span></span><span></span><span></span>
						<div class="hidden-except-readers">Open main menu button</div>
					</div>
				</div>
				<a href="https://www.intouchweekly.com" class="container__full-block  header__logo">
					<svg class="site-logo">
													<use xlink:href="#logo-intouch"></use>
											</svg>
				</a>
				<div class="header__search">
					<div class="header-mylo__mobile">
						<a class="mylo-signin__mobile" href="https://www.mylo.id/login?client_id=6628dtuhkmdqca1squ18er2cq4&#038;redirect_uri=https://www.intouchweekly.com/auth/login">
							<span>Login</span>
						</a>
					</div>
					<a class="header__text-subscribe" href="https://w1.buysub.com/servlet/OrdersGateway?cds_mag_code=NTW&#038;cds_page_id=230030" target="blank" rel="nofollow">
						SUBSCRIBE
					</a>
										<svg class="header__search-icon">
						<use xlink:href="#icon-search"/>
					</svg>
					<div class="search__close-icon">
						<span></span><span></span>
					</div>
				</div>
				<div class="search-box">
					<form role="search" method="get" action="/search-results/">
						<input type="search" name="_s" placeholder="Search..." required value="">
						<button type="submit"><svg><use xlink:href="#icon-search"/></svg></button>
					</form>
				</div>
			</div>
			<div id="mobile-nav" class="container__full">
									<div class="color-line">
						<div class="color-line-one"></div>
						<div class="color-line-two"></div>
						<div class="color-line-three"></div>
					</div>
								<nav class="container__full-block header-nav-primary__wrapper" role="navigation"
					 aria-label="Header Primary Nav">
					<div class="header-nav-primary ae-exclude">
						<ul id="menu-main-redesign-menu" class="site-header__main-nav__list"><li id="menu-item-258605" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-258605 site-header__main-nav__list__item"><a href="https://www.intouchweekly.com/posts/category/news/">News</a></li>
<li id="menu-item-258606" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-258606 site-header__main-nav__list__item"><a href="https://www.intouchweekly.com/posts/category/reality-tv/">Reality TV</a></li>
<li id="menu-item-372340" class="menu-item--new menu-item menu-item-type-post_type menu-item-object-page menu-item-372340 site-header__main-nav__list__item"><a href="https://www.intouchweekly.com/sampler/">Top Picks</a></li>
<li id="menu-item-258607" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-258607 site-header__main-nav__list__item"><a href="https://www.intouchweekly.com/posts/category/true-crime/">True Crime</a></li>
<li id="menu-item-258609" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-258609 site-header__main-nav__list__item"><a href="https://www.intouchweekly.com/posts/category/entertainment/">Entertainment</a></li>
<li id="menu-item-258610" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-258610 site-header__main-nav__list__item"><a href="https://www.intouchweekly.com/posts/category/omg/">OMG!</a></li>
<li id="menu-item-258611" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-258611 site-header__main-nav__list__item"><a href="https://www.intouchweekly.com/posts/category/style/">Style</a></li>
<li id="menu-item-403229" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-403229 site-header__main-nav__list__item"><a href="https://www.intouchweekly.com/posts/category/must-haves/">Must-Haves</a></li>
<li id="menu-item-261937" class="desktop-hidden menu-item menu-item-type-custom menu-item-object-custom menu-item-261937 site-header__main-nav__list__item"><a href="https://shop.getspecialissues.com/">Shop Special Issues</a></li>
<li id="menu-item-261938" class="desktop-hidden menu-item menu-item-type-custom menu-item-object-custom menu-item-261938 site-header__main-nav__list__item"><a href="https://a360media.com/privacy-policy">Privacy Policy</a></li>
<li id="menu-item-261940" class="desktop-hidden menu-item menu-item-type-custom menu-item-object-custom menu-item-261940 site-header__main-nav__list__item"><a href="https://a360media.com/terms-and-conditions">Terms &#038; Conditions</a></li>
</ul>					</div>
				</nav>
				<a href="https://www.intouchweekly.com" class="container__full-block  header__logo desktop-l-only">
					<svg class="site-logo">
													<use xlink:href="#logo-intouch"></use>
											</svg>
				</a>

								<div class="header__tools">
								<div class="header__close">
					<div id="menu-trigger-close" class="desktop-hidden">
						<span></span><span></span>
					</div>
				</div>
				<div class="header__search">
					<svg class="header__search-icon desktop-l-only">
						<use xlink:href="#icon-search"/>
					</svg>
					<div class="search__close-icon">
						<span></span><span></span>
					</div>
					<div class="search-box">
						<form role="search" method="get" action="/search-results/">
							<input type="search" name="_s" placeholder="Search..." required value="">
							<button type="submit"><svg><use xlink:href="#icon-search"/></svg></button>
						</form>
					</div>
				</div>
                <div class="header__accessibility desktop-l-only">
                    <a href="/accessibility-statement/" target="_blank">
                        <svg class="header__accessibility-icon">
                            <use xlink:href="#icon-accessibility"/>
                        </svg>
                    </a>
                </div>
				<ul class="header__icons">
					<li class="cookies-dropdown__wrapper desktop-l-only">
						<span class="cookies-dropdown__trigger"><svg class="cookies-dropdown__icon"><use xlink:href="#icon-cookie"></use></svg></span>
						<ul class="cookies-dropdown__list">
							<li class="cookies-dropdown__item">
								<a href="https://a360media.com/privacy-policy/" target="_blank">Privacy Policy</a>
							</li>
							<li class="cookies-dropdown__item">
								<a href="https://a360media.com/cookie-policy/" target="_blank">Cookie Policy</a>
							</li>

							<li class="cookies-dropdown__item">
								<!-- OneTrust Cookies Settings button start -->
								<a class="optanon-toggle-display" name="Manage Cookies">Manage Cookies</a>
								<!-- OneTrust Cookies Settings button end -->
							</li>

						</ul>
					</li>

					<li class="header__icons-accessibility desktop-hidden">
                        <a class="header__icons-icon" href="/accessibility-statement/" target="_blank">
                            <svg class="icon-accessibility__icon"><use xlink:href="#icon-accessibility"></use></svg>
                        </a>
                    </li>

					<li class="cookies-icon__mobile">
						<!-- OneTrust Cookies Settings button start -->
						<a class="optanon-toggle-display">
							<svg class="cookies-mobile__icon"><use xlink:href="#icon-cookie"></use></svg>
						</a>
						<!-- OneTrust Cookies Settings button end -->
					</li>

					<li><a href="http://www.facebook.com/InTouchWeekly" class="header__icons-icon" rel="nofollow"> <span class="hidden-except-readers">Social icon facebook</span><svg class="icon icon-facebook"><use xlink:href="#icon-facebook-b"></use></svg></a></li><li><a href="https://www.instagram.com/intouchweekly/?hl=en" class="header__icons-icon" rel="nofollow"> <span class="hidden-except-readers">Social icon instagram</span><svg class="icon icon-instagram"><use xlink:href="#icon-instagram-b"></use></svg></a></li><li><a href="https://twitter.com/intouchweekly" class="header__icons-icon" rel="nofollow"> <span class="hidden-except-readers">Social icon twitter</span><svg class="icon icon-twitter"><use xlink:href="#icon-twitter-b"></use></svg></a></li>				</ul>
				<div class="header__text">
										<a class="header__text-subscribe" href="https://w1.buysub.com/servlet/OrdersGateway?cds_mag_code=NTW&#038;cds_page_id=230030" target="blank" rel="nofollow">
						SUBSCRIBE <span >NOW!</span>
					</a>
											<a class="header__text-pay" href="#" id="send-scoop-trigger">WE PAY FOR SCOOPS</a>
										<div class="header-mylo">
						<a class="header-mylo__signin" href="https://www.mylo.id/login?client_id=6628dtuhkmdqca1squ18er2cq4&#038;redirect_uri=https://www.intouchweekly.com/auth/login">
							<svg class="header-mylo__signin-icon"><use xlink:href="#icon-signin"></use></svg>
							<span>Login</span>
						</a>
					</div>
				</div>
								</div>
												<!--  Send us a scoop popup	-->
				<div class="send-scoop__container" id="send-scoop-popup">
					<div class="page-wrapper">
						<div class="send-scoop__close-btn" id="send-scoop-close"><span class="hidden-except-readers">Got a Hot tip form close button</span></div>
						<h2 class="send-scoop__title">Send us a scoop!</h2>
						<form id="send-scoop__form" class="send-scoop__form" novalidate="novalidate">
							<input type="hidden" name="action" value="ok_tip_form">
							<div class="sender-info">
								<div class="field-container">
									<label for="scoop-form-name" class="hidden-except-readers">Input your name</label> <input placeholder="Your name..." type="text" name="name" value="" required="required" aria-required="true" id="scoop-form-name">
								</div>
								<div class="field-container">
									<label for="scoop-form-email" class="hidden-except-readers">Input your email</label> <input placeholder="Your email..." type="email" name="email" value="" required="required" aria-required="true" id="scoop-form-email">
								</div>
								<div class="field-container">
									<label for="scoop-form-phone" class="hidden-except-readers">Input your phone number</label> <input placeholder="Your phone number..." type="text" name="phone" value="" required="required" aria-required="true" id="scoop-form-phone">
								</div>
								<div class="sender-msg">
									<label for="scoop-message" class="hidden-except-readers">Enter scoop message here</label> <textarea placeholder="The Scoop..." name="tip" required="required" aria-required="true" id="scoop-message"></textarea>
								</div>
								<button type="submit" class="send-scoop__submit" id="scoop-form-send-btn" value="scoop-form-send-btn">SEND THE GOODS!</button>
							</div>
						</form>
					</div>
				</div>
							</div>

		</header>
		<!-- First big banner block -->
		<div class="ad-slot-top banner first mobile-hidden">
			<div class="ad-container horizontal">
				<div class="dfp-wrapper  mobile-hidden" data-slot="leader1"><div id="leader1" class="dfp-slot dfp-container leader1 "></div></div>			</div>
		</div>
		<div class="l-container">
		<div class="l-grid__post">
			<div class="l-grid__post-content">
				
<div class="l-grid__main-post">
	<div class="l-grid__main-post_content">
		
					<header class="post-header__wrapper">
				<div class="post-header__inner">
																	<figure class="post-hero">
														<div style="padding-bottom:56.276595744681%;" class="ratio-based-placeholder"><img src="https://www.intouchweekly.com/wp-content/uploads/2020/05/Screen-Shot-2020-05-20-at-2.49.47-PM.png?resize=940%2C529" srcset="https://www.intouchweekly.com/wp-content/uploads/2020/05/Screen-Shot-2020-05-20-at-2.49.47-PM.png?resize=120%2C68 120w, https://www.intouchweekly.com/wp-content/uploads/2020/05/Screen-Shot-2020-05-20-at-2.49.47-PM.png?resize=230%2C129 230w, https://www.intouchweekly.com/wp-content/uploads/2020/05/Screen-Shot-2020-05-20-at-2.49.47-PM.png?resize=408%2C230 408w, https://www.intouchweekly.com/wp-content/uploads/2020/05/Screen-Shot-2020-05-20-at-2.49.47-PM.png?resize=480%2C270 480w, https://www.intouchweekly.com/wp-content/uploads/2020/05/Screen-Shot-2020-05-20-at-2.49.47-PM.png?resize=630%2C354 630w, https://www.intouchweekly.com/wp-content/uploads/2020/05/Screen-Shot-2020-05-20-at-2.49.47-PM.png?resize=940%2C529 940w, https://www.intouchweekly.com/wp-content/uploads/2020/05/Screen-Shot-2020-05-20-at-2.49.47-PM.png?resize=960%2C540 960w, https://www.intouchweekly.com/wp-content/uploads/2020/05/Screen-Shot-2020-05-20-at-2.49.47-PM.png?resize=1200%2C675 1200w, https://www.intouchweekly.com/wp-content/uploads/2020/05/Screen-Shot-2020-05-20-at-2.49.47-PM.png?resize=1260%2C709 1260w" sizes="(max-width: 600px) 100vw, 940px" alt="Machine Gun Kelly Net Worth" data-fallback-img="https://www.intouchweekly.com/wp-content/uploads/2020/05/Screen-Shot-2020-05-20-at-2.49.47-PM.png?fit=1874%2C1120" width="940" height="529"></div>															<p class="photo-credit">Richard Shotwell/Invision/AP/Shutterstock</p>
													</figure>
						
					
<div class="post-header">
	<h1 class="post-header__title">Machine Gun Kelly&#8217;s Net Worth Proves He&#8217;s Staying on His Grind With His Chart-Topping Singles and Acting Roles</h1>
	</div>

<div class="post-meta">
	
<div class="post-meta__category">
				<a class="article_category" href="https://www.intouchweekly.com/posts/category/news/">News</a>
	</div>
	<div class="post-meta__inner">
		
<div class="post-meta__inner-date">Nov 23, 2021 10:00 am<span class="divider-dot">· </span></div>
		    <div class="post-meta__inner-author"> By <span>
            <a href="https://www.intouchweekly.com/authors/samantha-benitz-100464/" title="Samantha Benitz" rel="author" class="">Samantha Benitz</a>        </span>
    </div>
    	</div>
</div>
				</div>

				<div class="post-header__sidebar">
					
<div class="post-sidebar__pictures">
	<div class="post-sidebar__header">
					<svg><use xlink:href="#icon-in-logo" /></svg>
							<span>Top stories</span>
			</div>

			<div class="post-sidebar__grid">
							<article class="article__item">

					<a class="article__item-thumbnail" href="https://www.intouchweekly.com/posts/octomom-nadya-sulemans-kids-today-see-her-14-children-now/">
																					<div class="gallery-icon gallery__block-icon"><svg><use xlink:href="#icon-photos" /></svg></div>
														<figure class="article__item-figure">
								<div class="item__figure-source ok-thumb ok-standard-thumb">
									<div style="padding-bottom:100%;" class="ratio-based-placeholder"><img src="https://www.intouchweekly.com/wp-content/themes/ami-bauer/assets/build/images/placeholders/placeholder-1x1.svg" data-src="https://www.intouchweekly.com/wp-content/uploads/2020/01/Octomom-Nadya-Suleman-Children.jpg?resize=90%2C90" data-srcset="https://www.intouchweekly.com/wp-content/uploads/2020/01/Octomom-Nadya-Suleman-Children.jpg?resize=90%2C90 90w, https://www.intouchweekly.com/wp-content/uploads/2020/01/Octomom-Nadya-Suleman-Children.jpg?resize=180%2C180 180w, https://www.intouchweekly.com/wp-content/uploads/2020/01/Octomom-Nadya-Suleman-Children.jpg?resize=300%2C300 300w, https://www.intouchweekly.com/wp-content/uploads/2020/01/Octomom-Nadya-Suleman-Children.jpg?resize=408%2C408 408w, https://www.intouchweekly.com/wp-content/uploads/2020/01/Octomom-Nadya-Suleman-Children.jpg?resize=600%2C600 600w, https://www.intouchweekly.com/wp-content/uploads/2020/01/Octomom-Nadya-Suleman-Children.jpg?resize=816%2C816 816w" sizes="(min-width: 1024px) 90px, 300px" alt="Octomom Nadya Suleman Children" data-fallback-img="https://www.intouchweekly.com/wp-content/uploads/2020/01/Octomom-Nadya-Suleman-Children.jpg?fit=2000%2C993" width="90" height="90"></div>								</div>
							</figure>
											</a>

					<h2 class="article__item-title">
						<a href="https://www.intouchweekly.com/posts/octomom-nadya-sulemans-kids-today-see-her-14-children-now/">'Octomom' Nadya Suleman Is a Proud Mom of 14: See Her Kids Today!</a>
					</h2>

				</article>
							<article class="article__item">

					<a class="article__item-thumbnail" href="https://www.intouchweekly.com/posts/duggar-kids-houses-154627/">
																					<div class="gallery-icon gallery__block-icon"><svg><use xlink:href="#icon-photos" /></svg></div>
														<figure class="article__item-figure">
								<div class="item__figure-source ok-thumb ok-standard-thumb">
									<div style="padding-bottom:100%;" class="ratio-based-placeholder"><img src="https://www.intouchweekly.com/wp-content/themes/ami-bauer/assets/build/images/placeholders/placeholder-1x1.svg" data-src="https://www.intouchweekly.com/wp-content/uploads/2020/02/The-Duggar-Kids-Keep-Their-Houses-Messy-and-Gross-Photos.png?crop=0px%2C0px%2C2400px%2C2400px&#038;resize=90%2C90" data-srcset="https://www.intouchweekly.com/wp-content/uploads/2020/02/The-Duggar-Kids-Keep-Their-Houses-Messy-and-Gross-Photos.png?crop=0px%2C0px%2C2400px%2C2400px&amp;resize=90%2C90 90w, https://www.intouchweekly.com/wp-content/uploads/2020/02/The-Duggar-Kids-Keep-Their-Houses-Messy-and-Gross-Photos.png?crop=0px%2C0px%2C2400px%2C2400px&amp;resize=180%2C180 180w, https://www.intouchweekly.com/wp-content/uploads/2020/02/The-Duggar-Kids-Keep-Their-Houses-Messy-and-Gross-Photos.png?crop=0px%2C0px%2C2400px%2C2400px&amp;resize=300%2C300 300w, https://www.intouchweekly.com/wp-content/uploads/2020/02/The-Duggar-Kids-Keep-Their-Houses-Messy-and-Gross-Photos.png?crop=0px%2C0px%2C2400px%2C2400px&amp;resize=408%2C408 408w, https://www.intouchweekly.com/wp-content/uploads/2020/02/The-Duggar-Kids-Keep-Their-Houses-Messy-and-Gross-Photos.png?crop=0px%2C0px%2C2400px%2C2400px&amp;resize=600%2C600 600w, https://www.intouchweekly.com/wp-content/uploads/2020/02/The-Duggar-Kids-Keep-Their-Houses-Messy-and-Gross-Photos.png?crop=0px%2C0px%2C2400px%2C2400px&amp;resize=816%2C816 816w, https://www.intouchweekly.com/wp-content/uploads/2020/02/The-Duggar-Kids-Keep-Their-Houses-Messy-and-Gross-Photos.png?crop=0px%2C0px%2C2400px%2C2400px&amp;resize=1200%2C1200 1200w" sizes="(min-width: 1024px) 90px, 300px" alt="The Duggar Kids Keep Their Houses Messy and Gross Photos" data-fallback-img="https://www.intouchweekly.com/wp-content/uploads/2020/02/The-Duggar-Kids-Keep-Their-Houses-Messy-and-Gross-Photos.png?fit=2400%2C2400" width="90" height="90"></div>								</div>
							</figure>
											</a>

					<h2 class="article__item-title">
						<a href="https://www.intouchweekly.com/posts/duggar-kids-houses-154627/">Is Every Duggar Ridiculously Messy? See the 'Counting On' Kids' Houses</a>
					</h2>

				</article>
							<article class="article__item">

					<a class="article__item-thumbnail" href="https://www.intouchweekly.com/posts/jen-arnold-and-bill-kleins-kids-little-couples-will-and-zoey-now/">
																					<div class="gallery-icon gallery__block-icon"><svg><use xlink:href="#icon-photos" /></svg></div>
														<figure class="article__item-figure">
								<div class="item__figure-source ok-thumb ok-standard-thumb">
									<div style="padding-bottom:100%;" class="ratio-based-placeholder"><img src="https://www.intouchweekly.com/wp-content/themes/ami-bauer/assets/build/images/placeholders/placeholder-1x1.svg" data-src="https://www.intouchweekly.com/wp-content/uploads/2021/02/The-Little-Couple-Jen-Arnold-Kids-With-Husband-Bill-William-and-Zoey.jpg?crop=0px%2C0px%2C1384px%2C1384px&#038;resize=90%2C90" data-srcset="https://www.intouchweekly.com/wp-content/uploads/2021/02/The-Little-Couple-Jen-Arnold-Kids-With-Husband-Bill-William-and-Zoey.jpg?crop=0px%2C0px%2C1384px%2C1384px&amp;resize=90%2C90 90w, https://www.intouchweekly.com/wp-content/uploads/2021/02/The-Little-Couple-Jen-Arnold-Kids-With-Husband-Bill-William-and-Zoey.jpg?crop=0px%2C0px%2C1384px%2C1384px&amp;resize=180%2C180 180w, https://www.intouchweekly.com/wp-content/uploads/2021/02/The-Little-Couple-Jen-Arnold-Kids-With-Husband-Bill-William-and-Zoey.jpg?crop=0px%2C0px%2C1384px%2C1384px&amp;resize=300%2C300 300w, https://www.intouchweekly.com/wp-content/uploads/2021/02/The-Little-Couple-Jen-Arnold-Kids-With-Husband-Bill-William-and-Zoey.jpg?crop=0px%2C0px%2C1384px%2C1384px&amp;resize=408%2C408 408w, https://www.intouchweekly.com/wp-content/uploads/2021/02/The-Little-Couple-Jen-Arnold-Kids-With-Husband-Bill-William-and-Zoey.jpg?crop=0px%2C0px%2C1384px%2C1384px&amp;resize=600%2C600 600w, https://www.intouchweekly.com/wp-content/uploads/2021/02/The-Little-Couple-Jen-Arnold-Kids-With-Husband-Bill-William-and-Zoey.jpg?crop=0px%2C0px%2C1384px%2C1384px&amp;resize=816%2C816 816w, https://www.intouchweekly.com/wp-content/uploads/2021/02/The-Little-Couple-Jen-Arnold-Kids-With-Husband-Bill-William-and-Zoey.jpg?crop=0px%2C0px%2C1384px%2C1384px&amp;resize=1200%2C1200 1200w" sizes="(min-width: 1024px) 90px, 300px" alt="The Little Couple Jen Arnold Kids With Husband Bill William and Zoey" data-fallback-img="https://www.intouchweekly.com/wp-content/uploads/2021/02/The-Little-Couple-Jen-Arnold-Kids-With-Husband-Bill-William-and-Zoey.jpg?fit=1384%2C2000" width="90" height="90"></div>								</div>
							</figure>
											</a>

					<h2 class="article__item-title">
						<a href="https://www.intouchweekly.com/posts/jen-arnold-and-bill-kleins-kids-little-couples-will-and-zoey-now/">Look How Much the Little Couple's Kids Will and Zoey Have Grown Up</a>
					</h2>

				</article>
							<article class="article__item">

					<a class="article__item-thumbnail" href="https://www.intouchweekly.com/posts/kardashian-jenner-family-2021-met-gala-outfits-and-photos/">
																					<div class="gallery-icon gallery__block-icon"><svg><use xlink:href="#icon-photos" /></svg></div>
														<figure class="article__item-figure">
								<div class="item__figure-source ok-thumb ok-standard-thumb">
									<div style="padding-bottom:100%;" class="ratio-based-placeholder"><img src="https://www.intouchweekly.com/wp-content/themes/ami-bauer/assets/build/images/placeholders/placeholder-1x1.svg" data-src="https://www.intouchweekly.com/wp-content/uploads/2021/09/Copy-of-Split-3.png?resize=90%2C90" data-srcset="https://www.intouchweekly.com/wp-content/uploads/2021/09/Copy-of-Split-3.png?resize=90%2C90 90w, https://www.intouchweekly.com/wp-content/uploads/2021/09/Copy-of-Split-3.png?resize=180%2C180 180w, https://www.intouchweekly.com/wp-content/uploads/2021/09/Copy-of-Split-3.png?resize=300%2C300 300w, https://www.intouchweekly.com/wp-content/uploads/2021/09/Copy-of-Split-3.png?resize=408%2C408 408w, https://www.intouchweekly.com/wp-content/uploads/2021/09/Copy-of-Split-3.png?resize=600%2C600 600w, https://www.intouchweekly.com/wp-content/uploads/2021/09/Copy-of-Split-3.png?resize=816%2C816 816w, https://www.intouchweekly.com/wp-content/uploads/2021/09/Copy-of-Split-3.png?resize=1200%2C1200 1200w" sizes="(min-width: 1024px) 90px, 300px" alt="kardashians at 2021 met gala red carpet" data-fallback-img="https://www.intouchweekly.com/wp-content/uploads/2021/09/Copy-of-Split-3.png?fit=2000%2C2000" width="90" height="90"></div>								</div>
							</figure>
											</a>

					<h2 class="article__item-title">
						<a href="https://www.intouchweekly.com/posts/kardashian-jenner-family-2021-met-gala-outfits-and-photos/">Every Look From the Kardashian-Jenner Family at the 2021 Met Gala</a>
					</h2>

				</article>
							<article class="article__item">

					<a class="article__item-thumbnail" href="https://www.intouchweekly.com/posts/gabby-petitos-final-text-messages-with-mom-show-more-tension-with-brian-laundrie/">
																					<div class="video-icon video__block-icon"><svg><use xlink:href="#icon-video" /></svg></div>
														<figure class="article__item-figure">
								<div class="item__figure-source ok-thumb ok-standard-thumb">
									<div style="padding-bottom:100%;" class="ratio-based-placeholder"><img src="https://www.intouchweekly.com/wp-content/themes/ami-bauer/assets/build/images/placeholders/placeholder-1x1.svg" data-src="https://www.intouchweekly.com/wp-content/uploads/2021/09/Copy-of-Single-Bubble-Blue-12.png?resize=90%2C90" data-srcset="https://www.intouchweekly.com/wp-content/uploads/2021/09/Copy-of-Single-Bubble-Blue-12.png?resize=90%2C90 90w, https://www.intouchweekly.com/wp-content/uploads/2021/09/Copy-of-Single-Bubble-Blue-12.png?resize=180%2C180 180w, https://www.intouchweekly.com/wp-content/uploads/2021/09/Copy-of-Single-Bubble-Blue-12.png?resize=300%2C300 300w, https://www.intouchweekly.com/wp-content/uploads/2021/09/Copy-of-Single-Bubble-Blue-12.png?resize=408%2C408 408w, https://www.intouchweekly.com/wp-content/uploads/2021/09/Copy-of-Single-Bubble-Blue-12.png?resize=600%2C600 600w, https://www.intouchweekly.com/wp-content/uploads/2021/09/Copy-of-Single-Bubble-Blue-12.png?resize=816%2C816 816w, https://www.intouchweekly.com/wp-content/uploads/2021/09/Copy-of-Single-Bubble-Blue-12.png?resize=1200%2C1200 1200w" sizes="(min-width: 1024px) 90px, 300px" alt="gabby-petito-missing-final-text" data-fallback-img="https://www.intouchweekly.com/wp-content/uploads/2021/09/Copy-of-Single-Bubble-Blue-12.png?fit=2400%2C2400" width="90" height="90"></div>								</div>
							</figure>
											</a>

					<h2 class="article__item-title">
						<a href="https://www.intouchweekly.com/posts/gabby-petitos-final-text-messages-with-mom-show-more-tension-with-brian-laundrie/">Gabby Petito's Texts Show 'More and More Tension' With Brian Laundrie</a>
					</h2>

				</article>
					</div>
	</div>
				</div>
			</header>
		
		<div class="post-content">
			<div class="dfp-wrapper ad_outer_med mobile-only" data-slot="mb1"><div id="mb1" class="dfp-slot dfp-container mb1 advertisement ad-in"></div></div>			<div class="dfp-wrapper  mobile-hidden" data-slot="leader-inline1"><div id="leader-inline1" class="dfp-slot dfp-container leader-inline1 "></div></div>
			<div class="track-ga">
				<p><span style="font-weight: 400;">By the age of 31, <a href="https://www.intouchweekly.com/tags/machine-gun-kelly/"><b>Machine Gun Kelly</b></a> (real name: Colson Baker) has already earned a substantial amount of money. The Cleveland, Ohio native pursued his passion for music and adopted his stage name due to his speedy lyrical delivery, having taken his career to new heights in recent years. MGK released five studio albums, with his sixth set to drop in 2022. In May 2021, he solidified his bad boy presence by dropping a steamy music video for his song “<a href="https://www.intouchweekly.com/posts/megan-fox-stars-in-machine-gun-kellys-music-video-amid-dating-rumors/">Bloody Valentine</a>” featuring his girlfriend, <a href="https://www.intouchweekly.com/tags/megan-fox-11733/"><b>Megan Fox</b></a>. In addition to making music, the performer has also dabbled in the world of acting. Scroll down to find out the star’s net worth and get more details. </span></p>
<h2><b>What Is MGK’s Net Worth?</b></h2>
<p><span style="font-weight: 400;">As of </span><span style="font-weight: 400;">2021</span><span style="font-weight: 400;">, the “Glass House” rapper’s net worth sits around $10 million, according to </span><a href="https://www.celebritynetworth.com/richest-celebrities/richest-rappers/machine-gun-kelly-net-worth/"><span style="font-weight: 400;">CelebrityNetWorth.com</span></a><span style="font-weight: 400;">. After </span><span style="font-weight: 400;">the success of his eight self-released mixtapes, including</span> <i><span style="font-weight: 400;">Stamp of Approval</span></i><span style="font-weight: 400;">, </span><i><span style="font-weight: 400;">Homecoming</span></i><span style="font-weight: 400;">, </span><i><span style="font-weight: 400;">100 Words and Running</span></i><span style="font-weight: 400;"> and</span><i><span style="font-weight: 400;"> Lace Up</span></i><span style="font-weight: 400;">, </span><span style="font-weight: 400;">to name a few,</span><span style="font-weight: 400;"> he’s gone on to create more chart-topping singles. </span></p>
<figure class="wp-caption alignnone"><div class="ratio-based-placeholder" style="padding-bottom:60%;"><img loading="lazy" class="alignnone size-full wp-image-336926" src="https://www.intouchweekly.com/wp-content/uploads/2020/05/megan-fox-machine-gun-kelly-music-video-2.jpg?resize=1180%2C707" alt="Megan Fox and Machine Gun Kelly in Music Video" width="1180" height="707" srcset="https://www.intouchweekly.com/wp-content/uploads/2020/05/megan-fox-machine-gun-kelly-music-video-2.jpg?resize=1180%2C707?w=400 400w, https://www.intouchweekly.com/wp-content/uploads/2020/05/megan-fox-machine-gun-kelly-music-video-2.jpg?resize=1180%2C707?w=600 600w, https://www.intouchweekly.com/wp-content/uploads/2020/05/megan-fox-machine-gun-kelly-music-video-2.jpg?resize=1180%2C707?w=800 800w, https://www.intouchweekly.com/wp-content/uploads/2020/05/megan-fox-machine-gun-kelly-music-video-2.jpg?resize=1180%2C707?w=830 830w, https://www.intouchweekly.com/wp-content/uploads/2020/05/megan-fox-machine-gun-kelly-music-video-2.jpg?resize=1180%2C707?w=1200 1200w, https://www.intouchweekly.com/wp-content/uploads/2020/05/megan-fox-machine-gun-kelly-music-video-2.jpg?resize=1180%2C707?w=1660 1660w" sizes="(max-width: 400px) 400px, (max-width: 600px) 600px, 830px" data-recalc-dims="1"></div><figcaption class="photo-credit"><span class="credit">Courtesy of Machine Gun Kelly/YouTube</span></figcaption></figure><h2><b>How Does He Make Money?</b></h2>
<p><span style="font-weight: 400;">MGK has continued to make a name for himself. </span><span style="font-weight: 400;">He released his fifth studio album, </span><i><span style="font-weight: 400;">Tickets to My Downfall</span></i><span style="font-weight: 400;">, in September 2020, which peaked at number 1 on the Billboard 200 chart and was certified Platinum in America and Canada and Gold in the UK — and his sixth studio album, </span><i><span style="font-weight: 400;">Born With Horns,</span></i><span style="font-weight: 400;"> is set to drop in 2022. </span><span style="font-weight: 400;">The rapper also landed several movie gigs, appearing in films like </span><i><span style="font-weight: 400;">Beyond the Lights</span></i><span style="font-weight: 400;">, </span><i><span style="font-weight: 400;">The Land</span></i><span style="font-weight: 400;">, </span><i><span style="font-weight: 400;">Bird Box</span></i><span style="font-weight: 400;"> and </span><i><span style="font-weight: 400;">Big Time Adolescence</span></i><span style="font-weight: 400;">. He even showed off his comedic chops during an episode of </span><i><span style="font-weight: 400;">Wild ‘N Out</span></i><span style="font-weight: 400;">. </span></p>
<div class="link-related link-related__with-thumb">
	<a href="https://www.intouchweekly.com/posts/megan-fox-transformation-see-photos-of-actress-then-and-now/" target="_blank" data-track-category="Article Page" data-track-action="Tap Interstitial Link" data-track-label="https://www.intouchweekly.com/posts/megan-fox-transformation-see-photos-of-actress-then-and-now/" class="link-related__link">
					<span class="link-related__image">
				<div style="padding-bottom:56.666666666667%;" class="ratio-based-placeholder"><img src="https://www.intouchweekly.com/wp-content/themes/ami-bauer/assets/build/images/placeholders/placeholder-16x9.svg" data-src="https://www.intouchweekly.com/wp-content/uploads/2020/05/Megan-Fox-Evolution-Feature-Photo.jpg?crop=0px%2C0px%2C2000px%2C1133px&amp;resize=120%2C68" data-srcset="https://www.intouchweekly.com/wp-content/uploads/2020/05/Megan-Fox-Evolution-Feature-Photo.jpg?crop=0px%2C0px%2C2000px%2C1133px&amp;resize=120%2C68 120w, https://www.intouchweekly.com/wp-content/uploads/2020/05/Megan-Fox-Evolution-Feature-Photo.jpg?crop=0px%2C0px%2C2000px%2C1133px&amp;resize=230%2C129 230w, https://www.intouchweekly.com/wp-content/uploads/2020/05/Megan-Fox-Evolution-Feature-Photo.jpg?crop=0px%2C0px%2C2000px%2C1133px&amp;resize=408%2C230 408w, https://www.intouchweekly.com/wp-content/uploads/2020/05/Megan-Fox-Evolution-Feature-Photo.jpg?crop=0px%2C0px%2C2000px%2C1133px&amp;resize=480%2C270 480w, https://www.intouchweekly.com/wp-content/uploads/2020/05/Megan-Fox-Evolution-Feature-Photo.jpg?crop=0px%2C0px%2C2000px%2C1133px&amp;resize=630%2C354 630w, https://www.intouchweekly.com/wp-content/uploads/2020/05/Megan-Fox-Evolution-Feature-Photo.jpg?crop=0px%2C0px%2C2000px%2C1133px&amp;resize=940%2C529 940w, https://www.intouchweekly.com/wp-content/uploads/2020/05/Megan-Fox-Evolution-Feature-Photo.jpg?crop=0px%2C0px%2C2000px%2C1133px&amp;resize=960%2C540 960w, https://www.intouchweekly.com/wp-content/uploads/2020/05/Megan-Fox-Evolution-Feature-Photo.jpg?crop=0px%2C0px%2C2000px%2C1133px&amp;resize=1200%2C675 1200w, https://www.intouchweekly.com/wp-content/uploads/2020/05/Megan-Fox-Evolution-Feature-Photo.jpg?crop=0px%2C0px%2C2000px%2C1133px&amp;resize=1260%2C709 1260w, https://www.intouchweekly.com/wp-content/uploads/2020/05/Megan-Fox-Evolution-Feature-Photo.jpg?crop=0px%2C0px%2C2000px%2C1133px&amp;resize=1920%2C1080 1920w" sizes="120px" alt="Megan Fox Evolution Feature Photo" data-fallback-img="https://www.intouchweekly.com/wp-content/uploads/2020/05/Megan-Fox-Evolution-Feature-Photo.jpg?fit=2000%2C2000" width="120" height="68"></div>									<div class="gallery-icon gallery__block-icon"><svg><use xlink:href="#icon-photos"></use></svg></div>
											</span>
		
		<span class="link-related__content">
			<span class="link-related__title">

						Megan Fox's Transformation Proves She'll Always Be a ~Fox~
			</span>

					</span>
	</a>
</div>

<h2><b>What Keeps Him Motivated?</b></h2>
<p><span style="font-weight: 400;">Machine Gun Kelly is the proud father of a daughter, Casie Colson Baker, shared with his ex </span><a href="https://www.intouchweekly.com/posts/who-is-machine-gun-kellys-ex-emma-cannon-meet-casies-mom/"><b>Emma Cannon</b></a><span style="font-weight: 400;">. “I’m fortunate to have a baby girl who’s super into everything that I say and do,” he told </span><a href="https://www.rollingstone.com/music/music-features/the-wild-life-and-wounded-heart-of-machine-gun-kelly-194400/"><i><span style="font-weight: 400;">Rolling Stone</span></i></a><span style="font-weight: 400;"> about his little one, revealing she’s “just fun to be around” and keeps him on his grind.</span></p>
<figure class="wp-caption alignnone"><div class="ratio-based-placeholder" style="padding-bottom:120.5%;"><img loading="lazy" class="alignnone size-full wp-image-303470" src="https://www.intouchweekly.com/wp-content/themes/ami-bauer/assets/build/images/placeholders/placeholder-16x9.svg" data-src="https://www.intouchweekly.com/wp-content/uploads/2020/01/Kate-Beckinsale-Spotted-Leaving-Golden-Globes-Party-With-Machine-Gun-Kelly-Pete-Davidson-Friend-03.jpg" alt="Kate Beckinsale Spotted Leaving Golden Globes Party With Machine Gun Kelly, Pete Davidson's Friend" width="1180" height="1421" data-srcset="https://www.intouchweekly.com/wp-content/uploads/2020/01/Kate-Beckinsale-Spotted-Leaving-Golden-Globes-Party-With-Machine-Gun-Kelly-Pete-Davidson-Friend-03.jpg?w=400 400w, https://www.intouchweekly.com/wp-content/uploads/2020/01/Kate-Beckinsale-Spotted-Leaving-Golden-Globes-Party-With-Machine-Gun-Kelly-Pete-Davidson-Friend-03.jpg?w=600 600w, https://www.intouchweekly.com/wp-content/uploads/2020/01/Kate-Beckinsale-Spotted-Leaving-Golden-Globes-Party-With-Machine-Gun-Kelly-Pete-Davidson-Friend-03.jpg?w=800 800w, https://www.intouchweekly.com/wp-content/uploads/2020/01/Kate-Beckinsale-Spotted-Leaving-Golden-Globes-Party-With-Machine-Gun-Kelly-Pete-Davidson-Friend-03.jpg?w=830 830w, https://www.intouchweekly.com/wp-content/uploads/2020/01/Kate-Beckinsale-Spotted-Leaving-Golden-Globes-Party-With-Machine-Gun-Kelly-Pete-Davidson-Friend-03.jpg?w=1200 1200w, https://www.intouchweekly.com/wp-content/uploads/2020/01/Kate-Beckinsale-Spotted-Leaving-Golden-Globes-Party-With-Machine-Gun-Kelly-Pete-Davidson-Friend-03.jpg?w=1660 1660w" sizes="(max-width: 400px) 400px, (max-width: 600px) 600px, 830px"></div><figcaption class="photo-credit"><span class="credit">George Frey/EPA-EFE/Shutterstock</span></figcaption></figure><h2><b>Who Does He Hang Out With?</b></h2>
<p><span style="font-weight: 400;">The musician is close pals with </span><a href="https://www.intouchweekly.com/tags/saturday-night-live-13475/"><i><span style="font-weight: 400;">Saturday Night Live</span></i></a><span style="font-weight: 400;"> star </span><a href="https://www.intouchweekly.com/tags/pete-davidson/"><b>Pete Davidson</b></a><span style="font-weight: 400;">. </span><span style="font-weight: 400;">On top of that, he’s formed a close bond with </span><a href="https://www.intouchweekly.com/tags/travis-barker/"><b>Travis Barker</b></a><span style="font-weight: 400;">, the drummer of one of his favorite bands Blink-182 and now frequent collaborator, as well as Travis’ fiancée </span><a href="https://www.intouchweekly.com/tags/kourtney-kardashian-11944/"><b>Kourtney Kardashian</b></a><span style="font-weight: 400;">. The duo is often seen enjoying double dates with MGK and his girlfriend Megan, whom he grew close to during their time filming </span><i><span style="font-weight: 400;">Midnight in the Switchgrass.</span></i></p>
<script type="text/plain" class="optanon-category-C0002-C0004 optanon-category-C0002-C0004" src="https://content.jwplatform.com/libraries/8t2DpQMJ.js"></script><div class="ami-fluid-video-wrapper"><div id="jwplayer_Fvs5a00w_8t2DpQMJ_div"></div>
		<script type="text/plain" class="optanon-category-C0002-C0004">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</script></div>				<div class="youtube-cta">
	<p>
		<strong>
			<em>For access to all our exclusive celebrity videos and interviews – <a href="https://www.youtube.com/channel/UC-pi_mLzGF4RoMfpHbYgtUg?sub_confirmation=1" target="_blank">Subscribe on YouTube!</a></em>
		</strong>
	</p>
</div>							</div>

			
			<div class="share-alt">
				<span class="comment-icon"><svg><use xlink:href="#comment"></use></svg></span><div class="sharedaddy sd-sharing-enabled"><div class="robots-nocontent sd-block sd-social sd-social-icon sd-sharing"><div class="sd-content"><ul><li class="share-facebook"><a rel="nofollow noopener noreferrer" data-shared="sharing-facebook-336941" class="share-facebook sd-button share-icon no-text" href="https://www.intouchweekly.com/posts/machine-gun-kelly-net-worth-how-much-does-the-rapper-make/?share=facebook" target="_blank" title="Click to share on Facebook"><span></span><span class="sharing-screen-reader-text">Click to share on Facebook (Opens in new window)</span></a></li><li class="share-twitter"><a rel="nofollow noopener noreferrer" data-shared="sharing-twitter-336941" class="share-twitter sd-button share-icon no-text" href="https://www.intouchweekly.com/posts/machine-gun-kelly-net-worth-how-much-does-the-rapper-make/?share=twitter" target="_blank" title="Click to share on Twitter"><span></span><span class="sharing-screen-reader-text">Click to share on Twitter (Opens in new window)</span></a></li><li class="share-pinterest"><a rel="nofollow noopener noreferrer" data-shared="sharing-pinterest-336941" class="share-pinterest sd-button share-icon no-text" href="https://www.intouchweekly.com/posts/machine-gun-kelly-net-worth-how-much-does-the-rapper-make/?share=pinterest" target="_blank" title="Click to share on Pinterest"><span></span><span class="sharing-screen-reader-text">Click to share on Pinterest (Opens in new window)</span></a></li><li class="share-end"></li></ul></div></div></div>			</div>

			<div id="rc-widget-intouchmb"></div>
				<div class="in-page__tags-block">
		<ul class="in-page__tags-block__tags-list">
			<li class="in-page__tags-block__title">Tags:</li>
			<li class="in-page__tags-block__tags-list__item"><a href="https://www.intouchweekly.com/tags/machine-gun-kelly/" rel="tag">Machine Gun Kelly</a></li><li class="in-page__tags-block__tags-list__item"><a href="https://www.intouchweekly.com/tags/megan-fox-11733/" rel="tag">Megan Fox</a></li><li class="in-page__tags-block__tags-list__item"><a href="https://www.intouchweekly.com/tags/net-worth-24590/" rel="tag">Net Worth</a></li>		</ul>
	</div>
	
			
		</div>
	</div>

			<div class="gcwp-carousel"></div>
		<div id="zergnet-widget-68225"></div>
	
	

	<div id="comments-wrapper"><div id="spotImCommentsDiv"
     data-spotim-module="recirculation"
     data-spot-id="sp_tcLBc9rX"
     data-post-id="336941"
     data-post-url="https://www.intouchweekly.com/?p=336941"
     data-post-tags="Machine Gun Kelly, Megan Fox, Net Worth">
</div>
</div></div>
				
<div class="post-sidebar">
	<div class="dfp-wrapper  desktop-only" data-slot="rr1"><div id="rr1" class="dfp-slot dfp-container rr1 ad-container sticky-top"></div></div>	
<div class="post-sidebar__pictures">
	<div class="post-sidebar__header">
					<svg><use xlink:href="#icon-in-logo" /></svg>
							<span>Top stories</span>
			</div>

			<div class="post-sidebar__grid">
							<article class="article__item">

					<a class="article__item-thumbnail" href="https://www.intouchweekly.com/posts/octomom-nadya-sulemans-kids-today-see-her-14-children-now/">
																					<div class="gallery-icon gallery__block-icon"><svg><use xlink:href="#icon-photos" /></svg></div>
														<figure class="article__item-figure">
								<div class="item__figure-source ok-thumb ok-standard-thumb">
									<div style="padding-bottom:100%;" class="ratio-based-placeholder"><img src="https://www.intouchweekly.com/wp-content/themes/ami-bauer/assets/build/images/placeholders/placeholder-1x1.svg" data-src="https://www.intouchweekly.com/wp-content/uploads/2020/01/Octomom-Nadya-Suleman-Children.jpg?resize=90%2C90" data-srcset="https://www.intouchweekly.com/wp-content/uploads/2020/01/Octomom-Nadya-Suleman-Children.jpg?resize=90%2C90 90w, https://www.intouchweekly.com/wp-content/uploads/2020/01/Octomom-Nadya-Suleman-Children.jpg?resize=180%2C180 180w, https://www.intouchweekly.com/wp-content/uploads/2020/01/Octomom-Nadya-Suleman-Children.jpg?resize=300%2C300 300w, https://www.intouchweekly.com/wp-content/uploads/2020/01/Octomom-Nadya-Suleman-Children.jpg?resize=408%2C408 408w, https://www.intouchweekly.com/wp-content/uploads/2020/01/Octomom-Nadya-Suleman-Children.jpg?resize=600%2C600 600w, https://www.intouchweekly.com/wp-content/uploads/2020/01/Octomom-Nadya-Suleman-Children.jpg?resize=816%2C816 816w" sizes="(min-width: 1024px) 90px, 300px" alt="Octomom Nadya Suleman Children" data-fallback-img="https://www.intouchweekly.com/wp-content/uploads/2020/01/Octomom-Nadya-Suleman-Children.jpg?fit=2000%2C993" width="90" height="90"></div>								</div>
							</figure>
											</a>

					<h2 class="article__item-title">
						<a href="https://www.intouchweekly.com/posts/octomom-nadya-sulemans-kids-today-see-her-14-children-now/">'Octomom' Nadya Suleman Is a Proud Mom of 14: See Her Kids Today!</a>
					</h2>

				</article>
							<article class="article__item">

					<a class="article__item-thumbnail" href="https://www.intouchweekly.com/posts/duggar-kids-houses-154627/">
																					<div class="gallery-icon gallery__block-icon"><svg><use xlink:href="#icon-photos" /></svg></div>
														<figure class="article__item-figure">
								<div class="item__figure-source ok-thumb ok-standard-thumb">
									<div style="padding-bottom:100%;" class="ratio-based-placeholder"><img src="https://www.intouchweekly.com/wp-content/themes/ami-bauer/assets/build/images/placeholders/placeholder-1x1.svg" data-src="https://www.intouchweekly.com/wp-content/uploads/2020/02/The-Duggar-Kids-Keep-Their-Houses-Messy-and-Gross-Photos.png?crop=0px%2C0px%2C2400px%2C2400px&#038;resize=90%2C90" data-srcset="https://www.intouchweekly.com/wp-content/uploads/2020/02/The-Duggar-Kids-Keep-Their-Houses-Messy-and-Gross-Photos.png?crop=0px%2C0px%2C2400px%2C2400px&amp;resize=90%2C90 90w, https://www.intouchweekly.com/wp-content/uploads/2020/02/The-Duggar-Kids-Keep-Their-Houses-Messy-and-Gross-Photos.png?crop=0px%2C0px%2C2400px%2C2400px&amp;resize=180%2C180 180w, https://www.intouchweekly.com/wp-content/uploads/2020/02/The-Duggar-Kids-Keep-Their-Houses-Messy-and-Gross-Photos.png?crop=0px%2C0px%2C2400px%2C2400px&amp;resize=300%2C300 300w, https://www.intouchweekly.com/wp-content/uploads/2020/02/The-Duggar-Kids-Keep-Their-Houses-Messy-and-Gross-Photos.png?crop=0px%2C0px%2C2400px%2C2400px&amp;resize=408%2C408 408w, https://www.intouchweekly.com/wp-content/uploads/2020/02/The-Duggar-Kids-Keep-Their-Houses-Messy-and-Gross-Photos.png?crop=0px%2C0px%2C2400px%2C2400px&amp;resize=600%2C600 600w, https://www.intouchweekly.com/wp-content/uploads/2020/02/The-Duggar-Kids-Keep-Their-Houses-Messy-and-Gross-Photos.png?crop=0px%2C0px%2C2400px%2C2400px&amp;resize=816%2C816 816w, https://www.intouchweekly.com/wp-content/uploads/2020/02/The-Duggar-Kids-Keep-Their-Houses-Messy-and-Gross-Photos.png?crop=0px%2C0px%2C2400px%2C2400px&amp;resize=1200%2C1200 1200w" sizes="(min-width: 1024px) 90px, 300px" alt="The Duggar Kids Keep Their Houses Messy and Gross Photos" data-fallback-img="https://www.intouchweekly.com/wp-content/uploads/2020/02/The-Duggar-Kids-Keep-Their-Houses-Messy-and-Gross-Photos.png?fit=2400%2C2400" width="90" height="90"></div>								</div>
							</figure>
											</a>

					<h2 class="article__item-title">
						<a href="https://www.intouchweekly.com/posts/duggar-kids-houses-154627/">Is Every Duggar Ridiculously Messy? See the 'Counting On' Kids' Houses</a>
					</h2>

				</article>
							<article class="article__item">

					<a class="article__item-thumbnail" href="https://www.intouchweekly.com/posts/jen-arnold-and-bill-kleins-kids-little-couples-will-and-zoey-now/">
																					<div class="gallery-icon gallery__block-icon"><svg><use xlink:href="#icon-photos" /></svg></div>
														<figure class="article__item-figure">
								<div class="item__figure-source ok-thumb ok-standard-thumb">
									<div style="padding-bottom:100%;" class="ratio-based-placeholder"><img src="https://www.intouchweekly.com/wp-content/themes/ami-bauer/assets/build/images/placeholders/placeholder-1x1.svg" data-src="https://www.intouchweekly.com/wp-content/uploads/2021/02/The-Little-Couple-Jen-Arnold-Kids-With-Husband-Bill-William-and-Zoey.jpg?crop=0px%2C0px%2C1384px%2C1384px&#038;resize=90%2C90" data-srcset="https://www.intouchweekly.com/wp-content/uploads/2021/02/The-Little-Couple-Jen-Arnold-Kids-With-Husband-Bill-William-and-Zoey.jpg?crop=0px%2C0px%2C1384px%2C1384px&amp;resize=90%2C90 90w, https://www.intouchweekly.com/wp-content/uploads/2021/02/The-Little-Couple-Jen-Arnold-Kids-With-Husband-Bill-William-and-Zoey.jpg?crop=0px%2C0px%2C1384px%2C1384px&amp;resize=180%2C180 180w, https://www.intouchweekly.com/wp-content/uploads/2021/02/The-Little-Couple-Jen-Arnold-Kids-With-Husband-Bill-William-and-Zoey.jpg?crop=0px%2C0px%2C1384px%2C1384px&amp;resize=300%2C300 300w, https://www.intouchweekly.com/wp-content/uploads/2021/02/The-Little-Couple-Jen-Arnold-Kids-With-Husband-Bill-William-and-Zoey.jpg?crop=0px%2C0px%2C1384px%2C1384px&amp;resize=408%2C408 408w, https://www.intouchweekly.com/wp-content/uploads/2021/02/The-Little-Couple-Jen-Arnold-Kids-With-Husband-Bill-William-and-Zoey.jpg?crop=0px%2C0px%2C1384px%2C1384px&amp;resize=600%2C600 600w, https://www.intouchweekly.com/wp-content/uploads/2021/02/The-Little-Couple-Jen-Arnold-Kids-With-Husband-Bill-William-and-Zoey.jpg?crop=0px%2C0px%2C1384px%2C1384px&amp;resize=816%2C816 816w, https://www.intouchweekly.com/wp-content/uploads/2021/02/The-Little-Couple-Jen-Arnold-Kids-With-Husband-Bill-William-and-Zoey.jpg?crop=0px%2C0px%2C1384px%2C1384px&amp;resize=1200%2C1200 1200w" sizes="(min-width: 1024px) 90px, 300px" alt="The Little Couple Jen Arnold Kids With Husband Bill William and Zoey" data-fallback-img="https://www.intouchweekly.com/wp-content/uploads/2021/02/The-Little-Couple-Jen-Arnold-Kids-With-Husband-Bill-William-and-Zoey.jpg?fit=1384%2C2000" width="90" height="90"></div>								</div>
							</figure>
											</a>

					<h2 class="article__item-title">
						<a href="https://www.intouchweekly.com/posts/jen-arnold-and-bill-kleins-kids-little-couples-will-and-zoey-now/">Look How Much the Little Couple's Kids Will and Zoey Have Grown Up</a>
					</h2>

				</article>
							<article class="article__item">

					<a class="article__item-thumbnail" href="https://www.intouchweekly.com/posts/kardashian-jenner-family-2021-met-gala-outfits-and-photos/">
																					<div class="gallery-icon gallery__block-icon"><svg><use xlink:href="#icon-photos" /></svg></div>
														<figure class="article__item-figure">
								<div class="item__figure-source ok-thumb ok-standard-thumb">
									<div style="padding-bottom:100%;" class="ratio-based-placeholder"><img src="https://www.intouchweekly.com/wp-content/themes/ami-bauer/assets/build/images/placeholders/placeholder-1x1.svg" data-src="https://www.intouchweekly.com/wp-content/uploads/2021/09/Copy-of-Split-3.png?resize=90%2C90" data-srcset="https://www.intouchweekly.com/wp-content/uploads/2021/09/Copy-of-Split-3.png?resize=90%2C90 90w, https://www.intouchweekly.com/wp-content/uploads/2021/09/Copy-of-Split-3.png?resize=180%2C180 180w, https://www.intouchweekly.com/wp-content/uploads/2021/09/Copy-of-Split-3.png?resize=300%2C300 300w, https://www.intouchweekly.com/wp-content/uploads/2021/09/Copy-of-Split-3.png?resize=408%2C408 408w, https://www.intouchweekly.com/wp-content/uploads/2021/09/Copy-of-Split-3.png?resize=600%2C600 600w, https://www.intouchweekly.com/wp-content/uploads/2021/09/Copy-of-Split-3.png?resize=816%2C816 816w, https://www.intouchweekly.com/wp-content/uploads/2021/09/Copy-of-Split-3.png?resize=1200%2C1200 1200w" sizes="(min-width: 1024px) 90px, 300px" alt="kardashians at 2021 met gala red carpet" data-fallback-img="https://www.intouchweekly.com/wp-content/uploads/2021/09/Copy-of-Split-3.png?fit=2000%2C2000" width="90" height="90"></div>								</div>
							</figure>
											</a>

					<h2 class="article__item-title">
						<a href="https://www.intouchweekly.com/posts/kardashian-jenner-family-2021-met-gala-outfits-and-photos/">Every Look From the Kardashian-Jenner Family at the 2021 Met Gala</a>
					</h2>

				</article>
							<article class="article__item">

					<a class="article__item-thumbnail" href="https://www.intouchweekly.com/posts/gabby-petitos-final-text-messages-with-mom-show-more-tension-with-brian-laundrie/">
																					<div class="video-icon video__block-icon"><svg><use xlink:href="#icon-video" /></svg></div>
														<figure class="article__item-figure">
								<div class="item__figure-source ok-thumb ok-standard-thumb">
									<div style="padding-bottom:100%;" class="ratio-based-placeholder"><img src="https://www.intouchweekly.com/wp-content/themes/ami-bauer/assets/build/images/placeholders/placeholder-1x1.svg" data-src="https://www.intouchweekly.com/wp-content/uploads/2021/09/Copy-of-Single-Bubble-Blue-12.png?resize=90%2C90" data-srcset="https://www.intouchweekly.com/wp-content/uploads/2021/09/Copy-of-Single-Bubble-Blue-12.png?resize=90%2C90 90w, https://www.intouchweekly.com/wp-content/uploads/2021/09/Copy-of-Single-Bubble-Blue-12.png?resize=180%2C180 180w, https://www.intouchweekly.com/wp-content/uploads/2021/09/Copy-of-Single-Bubble-Blue-12.png?resize=300%2C300 300w, https://www.intouchweekly.com/wp-content/uploads/2021/09/Copy-of-Single-Bubble-Blue-12.png?resize=408%2C408 408w, https://www.intouchweekly.com/wp-content/uploads/2021/09/Copy-of-Single-Bubble-Blue-12.png?resize=600%2C600 600w, https://www.intouchweekly.com/wp-content/uploads/2021/09/Copy-of-Single-Bubble-Blue-12.png?resize=816%2C816 816w, https://www.intouchweekly.com/wp-content/uploads/2021/09/Copy-of-Single-Bubble-Blue-12.png?resize=1200%2C1200 1200w" sizes="(min-width: 1024px) 90px, 300px" alt="gabby-petito-missing-final-text" data-fallback-img="https://www.intouchweekly.com/wp-content/uploads/2021/09/Copy-of-Single-Bubble-Blue-12.png?fit=2400%2C2400" width="90" height="90"></div>								</div>
							</figure>
											</a>

					<h2 class="article__item-title">
						<a href="https://www.intouchweekly.com/posts/gabby-petitos-final-text-messages-with-mom-show-more-tension-with-brian-laundrie/">Gabby Petito's Texts Show 'More and More Tension' With Brian Laundrie</a>
					</h2>

				</article>
					</div>
	</div>
<div id="promoblock-box"><div id="block-2" class="widget_block widget_media_image">
<figure class="wp-block-image size-full"><a href="https://www.lifetogo.com/collections/gift-guides/?utm_source=AMI&amp;utm_medium=display&amp;utm_campaign=ThanksgivingSale&amp;utm_term=300x490&amp;utm_content=ThanksgivingSale_111221_300x490"><img loading="lazy" width="300" height="490" src="https://www.intouchweekly.com/wp-content/uploads/2021/11/ThanksgivingSale_111221_300x490.png" alt="" class="wp-image-421729" srcset="https://www.intouchweekly.com/wp-content/uploads/2021/11/ThanksgivingSale_111221_300x490.png?w=300 300w, https://www.intouchweekly.com/wp-content/uploads/2021/11/ThanksgivingSale_111221_300x490.png?w=92 92w, https://www.intouchweekly.com/wp-content/uploads/2021/11/ThanksgivingSale_111221_300x490.png?w=184 184w" sizes="(max-width: 300px) 100vw, 300px" /></a></figure>
</div><div id="block-3" class="widget_block"><p><iframe loading="lazy" src="https://securepubads.g.doubleclick.net/gampad/adx?iu=/4216/ITW.LTG&amp;sz=1x1" width="1" height="1" style="position:absolute; visibility:hidden"></iframe></p></div></div>			<script>
				document.addEventListener("DOMContentLoaded", function() {
					if(window.innerWidth < 1024) {// Get the element
						var elem = document.getElementById('promoblock-box');
						var target = document.querySelector('.l-grid__main-post_content');
						elem.parentNode.removeChild(elem);
						target.appendChild(elem)
					}
				});
			</script>
			<div id="rc-widget-intouchdt"></div>	<div class="ad-container__sticky-wrapper">
		<div class="ad-container sticky-top">
			<div class="dfp-wrapper  desktop-only" data-slot="rr2"><div id="rr2" class="dfp-slot dfp-container rr2 "></div></div>		</div>
	</div>
</div>
			</div>
		</div>
	</div>

	
<div class="full-container">

			<div class="l-container">
			<div class="l-grid">
				<div class="l-grid__main-slider">
					<div class="block__title">
													<svg><use xlink:href="#icon-in-logo" /></svg>
												<span>Exclusives</span>
					</div>
					<div class="l-grid__main-sliderblock slider">
						
<article class="article__item">
			<a class="article__item-thumbnail" href="https://www.intouchweekly.com/posts/shiloh-jolie-pitt-enjoying-red-carpet-appearances-with-angelina-jolie/">
						<figure class="article__item-figure">
				<div style="padding-bottom:56.25%;" class="ratio-based-placeholder"><img src="https://www.intouchweekly.com/wp-content/themes/ami-bauer/assets/build/images/placeholders/placeholder-16x9.svg" data-src="https://www.intouchweekly.com/wp-content/uploads/2021/11/shutterstock_editorial_12553366cf-e1637698539390.jpg?crop=0px%2C48px%2C1542px%2C875px&#038;resize=480%2C270" data-srcset="https://www.intouchweekly.com/wp-content/uploads/2021/11/shutterstock_editorial_12553366cf-e1637698539390.jpg?crop=0px%2C48px%2C1542px%2C875px&amp;resize=120%2C68 120w, https://www.intouchweekly.com/wp-content/uploads/2021/11/shutterstock_editorial_12553366cf-e1637698539390.jpg?crop=0px%2C48px%2C1542px%2C875px&amp;resize=230%2C129 230w, https://www.intouchweekly.com/wp-content/uploads/2021/11/shutterstock_editorial_12553366cf-e1637698539390.jpg?crop=0px%2C48px%2C1542px%2C875px&amp;resize=408%2C230 408w, https://www.intouchweekly.com/wp-content/uploads/2021/11/shutterstock_editorial_12553366cf-e1637698539390.jpg?crop=0px%2C48px%2C1542px%2C875px&amp;resize=480%2C270 480w, https://www.intouchweekly.com/wp-content/uploads/2021/11/shutterstock_editorial_12553366cf-e1637698539390.jpg?crop=0px%2C48px%2C1542px%2C875px&amp;resize=630%2C354 630w, https://www.intouchweekly.com/wp-content/uploads/2021/11/shutterstock_editorial_12553366cf-e1637698539390.jpg?crop=0px%2C48px%2C1542px%2C875px&amp;resize=940%2C529 940w, https://www.intouchweekly.com/wp-content/uploads/2021/11/shutterstock_editorial_12553366cf-e1637698539390.jpg?crop=0px%2C48px%2C1542px%2C875px&amp;resize=960%2C540 960w, https://www.intouchweekly.com/wp-content/uploads/2021/11/shutterstock_editorial_12553366cf-e1637698539390.jpg?crop=0px%2C48px%2C1542px%2C875px&amp;resize=1200%2C675 1200w, https://www.intouchweekly.com/wp-content/uploads/2021/11/shutterstock_editorial_12553366cf-e1637698539390.jpg?crop=0px%2C48px%2C1542px%2C875px&amp;resize=1260%2C709 1260w" sizes="(max-width: 400px) 408px, 408px" alt="shiloh jolie pitt red carpet" data-fallback-img="https://www.intouchweekly.com/wp-content/uploads/2021/11/shutterstock_editorial_12553366cf-e1637698539390.jpg?fit=1542%2C2364" width="480" height="270"></div>			</figure>
		</a>
	
	<h2 class="article__item-title">
		<a href="https://www.intouchweekly.com/posts/shiloh-jolie-pitt-enjoying-red-carpet-appearances-with-angelina-jolie/">Angelina’s Mini-Me? Shiloh Jolie-Pitt Is ‘Enjoying’ Red Carpet Appearances</a>
	</h2>
</article>

<article class="article__item">
			<a class="article__item-thumbnail" href="https://www.intouchweekly.com/posts/cindy-crawford-rande-gerber-react-to-kaias-split-from-jacob-elordi/">
						<figure class="article__item-figure">
				<div style="padding-bottom:56.25%;" class="ratio-based-placeholder"><img src="https://www.intouchweekly.com/wp-content/themes/ami-bauer/assets/build/images/placeholders/placeholder-16x9.svg" data-src="https://www.intouchweekly.com/wp-content/uploads/2021/11/Copy-of-Single-Bubble-Blue-12-1.png?crop=0px%2C0px%2C2400px%2C1359px&#038;resize=480%2C270" data-srcset="https://www.intouchweekly.com/wp-content/uploads/2021/11/Copy-of-Single-Bubble-Blue-12-1.png?crop=0px%2C0px%2C2400px%2C1359px&amp;resize=120%2C68 120w, https://www.intouchweekly.com/wp-content/uploads/2021/11/Copy-of-Single-Bubble-Blue-12-1.png?crop=0px%2C0px%2C2400px%2C1359px&amp;resize=230%2C129 230w, https://www.intouchweekly.com/wp-content/uploads/2021/11/Copy-of-Single-Bubble-Blue-12-1.png?crop=0px%2C0px%2C2400px%2C1359px&amp;resize=408%2C230 408w, https://www.intouchweekly.com/wp-content/uploads/2021/11/Copy-of-Single-Bubble-Blue-12-1.png?crop=0px%2C0px%2C2400px%2C1359px&amp;resize=480%2C270 480w, https://www.intouchweekly.com/wp-content/uploads/2021/11/Copy-of-Single-Bubble-Blue-12-1.png?crop=0px%2C0px%2C2400px%2C1359px&amp;resize=630%2C354 630w, https://www.intouchweekly.com/wp-content/uploads/2021/11/Copy-of-Single-Bubble-Blue-12-1.png?crop=0px%2C0px%2C2400px%2C1359px&amp;resize=940%2C529 940w, https://www.intouchweekly.com/wp-content/uploads/2021/11/Copy-of-Single-Bubble-Blue-12-1.png?crop=0px%2C0px%2C2400px%2C1359px&amp;resize=960%2C540 960w, https://www.intouchweekly.com/wp-content/uploads/2021/11/Copy-of-Single-Bubble-Blue-12-1.png?crop=0px%2C0px%2C2400px%2C1359px&amp;resize=1200%2C675 1200w, https://www.intouchweekly.com/wp-content/uploads/2021/11/Copy-of-Single-Bubble-Blue-12-1.png?crop=0px%2C0px%2C2400px%2C1359px&amp;resize=1260%2C709 1260w, https://www.intouchweekly.com/wp-content/uploads/2021/11/Copy-of-Single-Bubble-Blue-12-1.png?crop=0px%2C0px%2C2400px%2C1359px&amp;resize=1920%2C1080 1920w" sizes="(max-width: 400px) 408px, 408px" alt="Cindy Crawford reacts to Kaia&#039;s Split from Jacob Elordi" data-fallback-img="https://www.intouchweekly.com/wp-content/uploads/2021/11/Copy-of-Single-Bubble-Blue-12-1.png?fit=2400%2C2400" width="480" height="270"></div>			</figure>
		</a>
	
	<h2 class="article__item-title">
		<a href="https://www.intouchweekly.com/posts/cindy-crawford-rande-gerber-react-to-kaias-split-from-jacob-elordi/">Cindy Crawford and Rande Gerber Support Kaia and Jacob Elordi’s Split</a>
	</h2>
</article>

<article class="article__item">
			<a class="article__item-thumbnail" href="https://www.intouchweekly.com/posts/90-day-fiance-yaras-husband-jovi-inspired-makeup-line/">
							<div class="video-icon video__block-icon"><svg><use xlink:href="#icon-video" /></svg></div>
						<figure class="article__item-figure">
				<div style="padding-bottom:56.25%;" class="ratio-based-placeholder"><img src="https://www.intouchweekly.com/wp-content/themes/ami-bauer/assets/build/images/placeholders/placeholder-16x9.svg" data-src="https://www.intouchweekly.com/wp-content/uploads/2021/11/90-day-fiance-yara-jovi-inspire-makeup-line.png?crop=0px%2C141px%2C2400px%2C1359px&#038;resize=480%2C270" data-srcset="https://www.intouchweekly.com/wp-content/uploads/2021/11/90-day-fiance-yara-jovi-inspire-makeup-line.png?crop=0px%2C141px%2C2400px%2C1359px&amp;resize=120%2C68 120w, https://www.intouchweekly.com/wp-content/uploads/2021/11/90-day-fiance-yara-jovi-inspire-makeup-line.png?crop=0px%2C141px%2C2400px%2C1359px&amp;resize=230%2C129 230w, https://www.intouchweekly.com/wp-content/uploads/2021/11/90-day-fiance-yara-jovi-inspire-makeup-line.png?crop=0px%2C141px%2C2400px%2C1359px&amp;resize=408%2C230 408w, https://www.intouchweekly.com/wp-content/uploads/2021/11/90-day-fiance-yara-jovi-inspire-makeup-line.png?crop=0px%2C141px%2C2400px%2C1359px&amp;resize=480%2C270 480w, https://www.intouchweekly.com/wp-content/uploads/2021/11/90-day-fiance-yara-jovi-inspire-makeup-line.png?crop=0px%2C141px%2C2400px%2C1359px&amp;resize=630%2C354 630w, https://www.intouchweekly.com/wp-content/uploads/2021/11/90-day-fiance-yara-jovi-inspire-makeup-line.png?crop=0px%2C141px%2C2400px%2C1359px&amp;resize=940%2C529 940w, https://www.intouchweekly.com/wp-content/uploads/2021/11/90-day-fiance-yara-jovi-inspire-makeup-line.png?crop=0px%2C141px%2C2400px%2C1359px&amp;resize=960%2C540 960w, https://www.intouchweekly.com/wp-content/uploads/2021/11/90-day-fiance-yara-jovi-inspire-makeup-line.png?crop=0px%2C141px%2C2400px%2C1359px&amp;resize=1200%2C675 1200w, https://www.intouchweekly.com/wp-content/uploads/2021/11/90-day-fiance-yara-jovi-inspire-makeup-line.png?crop=0px%2C141px%2C2400px%2C1359px&amp;resize=1260%2C709 1260w, https://www.intouchweekly.com/wp-content/uploads/2021/11/90-day-fiance-yara-jovi-inspire-makeup-line.png?crop=0px%2C141px%2C2400px%2C1359px&amp;resize=1920%2C1080 1920w" sizes="(max-width: 400px) 408px, 408px" alt="90 day fiance yara jovi inspire makeup line" data-fallback-img="https://www.intouchweekly.com/wp-content/uploads/2021/11/90-day-fiance-yara-jovi-inspire-makeup-line.png?fit=2400%2C2400" width="480" height="270"></div>			</figure>
		</a>
	
	<h2 class="article__item-title">
		<a href="https://www.intouchweekly.com/posts/90-day-fiance-yaras-husband-jovi-inspired-makeup-line/">How '90 Day Fiance' Star Yara's Husband Jovi Inspired Her Makeup Line</a>
	</h2>
</article>

<article class="article__item">
			<a class="article__item-thumbnail" href="https://www.intouchweekly.com/posts/who-is-90-day-fiance-amira-dating-moves-on-from-ex-andrew/">
						<figure class="article__item-figure">
				<div style="padding-bottom:56.25%;" class="ratio-based-placeholder"><img src="https://www.intouchweekly.com/wp-content/themes/ami-bauer/assets/build/images/placeholders/placeholder-16x9.svg" data-src="https://www.intouchweekly.com/wp-content/uploads/2021/11/90-Day-Fiances-Amira-Lollysa-Moves-On-From-Ex-Andrew-With-Mystery-Man-001.jpg?crop=0px%2C0px%2C1200px%2C680px&#038;resize=480%2C270" data-srcset="https://www.intouchweekly.com/wp-content/uploads/2021/11/90-Day-Fiances-Amira-Lollysa-Moves-On-From-Ex-Andrew-With-Mystery-Man-001.jpg?crop=0px%2C0px%2C1200px%2C680px&amp;resize=120%2C68 120w, https://www.intouchweekly.com/wp-content/uploads/2021/11/90-Day-Fiances-Amira-Lollysa-Moves-On-From-Ex-Andrew-With-Mystery-Man-001.jpg?crop=0px%2C0px%2C1200px%2C680px&amp;resize=230%2C129 230w, https://www.intouchweekly.com/wp-content/uploads/2021/11/90-Day-Fiances-Amira-Lollysa-Moves-On-From-Ex-Andrew-With-Mystery-Man-001.jpg?crop=0px%2C0px%2C1200px%2C680px&amp;resize=408%2C230 408w, https://www.intouchweekly.com/wp-content/uploads/2021/11/90-Day-Fiances-Amira-Lollysa-Moves-On-From-Ex-Andrew-With-Mystery-Man-001.jpg?crop=0px%2C0px%2C1200px%2C680px&amp;resize=480%2C270 480w, https://www.intouchweekly.com/wp-content/uploads/2021/11/90-Day-Fiances-Amira-Lollysa-Moves-On-From-Ex-Andrew-With-Mystery-Man-001.jpg?crop=0px%2C0px%2C1200px%2C680px&amp;resize=630%2C354 630w, https://www.intouchweekly.com/wp-content/uploads/2021/11/90-Day-Fiances-Amira-Lollysa-Moves-On-From-Ex-Andrew-With-Mystery-Man-001.jpg?crop=0px%2C0px%2C1200px%2C680px&amp;resize=940%2C529 940w, https://www.intouchweekly.com/wp-content/uploads/2021/11/90-Day-Fiances-Amira-Lollysa-Moves-On-From-Ex-Andrew-With-Mystery-Man-001.jpg?crop=0px%2C0px%2C1200px%2C680px&amp;resize=960%2C540 960w, https://www.intouchweekly.com/wp-content/uploads/2021/11/90-Day-Fiances-Amira-Lollysa-Moves-On-From-Ex-Andrew-With-Mystery-Man-001.jpg?crop=0px%2C0px%2C1200px%2C680px&amp;resize=1200%2C675 1200w" sizes="(max-width: 400px) 408px, 408px" alt="90 Day Fiances Amira Lollysa Moves On From Ex Andrew With Mystery Man Hes Begging Get Her Back" data-fallback-img="https://www.intouchweekly.com/wp-content/uploads/2021/11/90-Day-Fiances-Amira-Lollysa-Moves-On-From-Ex-Andrew-With-Mystery-Man-001.jpg?fit=1200%2C1293" width="480" height="270"></div>			</figure>
		</a>
	
	<h2 class="article__item-title">
		<a href="https://www.intouchweekly.com/posts/who-is-90-day-fiance-amira-dating-moves-on-from-ex-andrew/">90 Day Fiance's Amira Lollysa Moves On From Ex Andrew With Mystery Man</a>
	</h2>
</article>

<article class="article__item">
			<a class="article__item-thumbnail" href="https://www.intouchweekly.com/posts/brad-pitt-happy-daughter-shiloh-is-coming-out-of-her-shell/">
						<figure class="article__item-figure">
				<div style="padding-bottom:56.25%;" class="ratio-based-placeholder"><img src="https://www.intouchweekly.com/wp-content/themes/ami-bauer/assets/build/images/placeholders/placeholder-16x9.svg" data-src="https://www.intouchweekly.com/wp-content/uploads/2021/11/Copy-of-Single-Bubble-Blue-9-1.png?crop=0px%2C0px%2C2400px%2C1359px&#038;resize=480%2C270" data-srcset="https://www.intouchweekly.com/wp-content/uploads/2021/11/Copy-of-Single-Bubble-Blue-9-1.png?crop=0px%2C0px%2C2400px%2C1359px&amp;resize=120%2C68 120w, https://www.intouchweekly.com/wp-content/uploads/2021/11/Copy-of-Single-Bubble-Blue-9-1.png?crop=0px%2C0px%2C2400px%2C1359px&amp;resize=230%2C129 230w, https://www.intouchweekly.com/wp-content/uploads/2021/11/Copy-of-Single-Bubble-Blue-9-1.png?crop=0px%2C0px%2C2400px%2C1359px&amp;resize=408%2C230 408w, https://www.intouchweekly.com/wp-content/uploads/2021/11/Copy-of-Single-Bubble-Blue-9-1.png?crop=0px%2C0px%2C2400px%2C1359px&amp;resize=480%2C270 480w, https://www.intouchweekly.com/wp-content/uploads/2021/11/Copy-of-Single-Bubble-Blue-9-1.png?crop=0px%2C0px%2C2400px%2C1359px&amp;resize=630%2C354 630w, https://www.intouchweekly.com/wp-content/uploads/2021/11/Copy-of-Single-Bubble-Blue-9-1.png?crop=0px%2C0px%2C2400px%2C1359px&amp;resize=940%2C529 940w, https://www.intouchweekly.com/wp-content/uploads/2021/11/Copy-of-Single-Bubble-Blue-9-1.png?crop=0px%2C0px%2C2400px%2C1359px&amp;resize=960%2C540 960w, https://www.intouchweekly.com/wp-content/uploads/2021/11/Copy-of-Single-Bubble-Blue-9-1.png?crop=0px%2C0px%2C2400px%2C1359px&amp;resize=1200%2C675 1200w, https://www.intouchweekly.com/wp-content/uploads/2021/11/Copy-of-Single-Bubble-Blue-9-1.png?crop=0px%2C0px%2C2400px%2C1359px&amp;resize=1260%2C709 1260w, https://www.intouchweekly.com/wp-content/uploads/2021/11/Copy-of-Single-Bubble-Blue-9-1.png?crop=0px%2C0px%2C2400px%2C1359px&amp;resize=1920%2C1080 1920w" sizes="(max-width: 400px) 408px, 408px" alt="Brad pitt feelings children walking red carpet" data-fallback-img="https://www.intouchweekly.com/wp-content/uploads/2021/11/Copy-of-Single-Bubble-Blue-9-1.png?fit=2400%2C2400" width="480" height="270"></div>			</figure>
		</a>
	
	<h2 class="article__item-title">
		<a href="https://www.intouchweekly.com/posts/brad-pitt-happy-daughter-shiloh-is-coming-out-of-her-shell/">Brad Pitt 'Proud' to See Shiloh 'Coming Out of Her Shell' on Red Carpets</a>
	</h2>
</article>

<article class="article__item">
			<a class="article__item-thumbnail" href="https://www.intouchweekly.com/posts/julianne-hough-and-boyfriend-charlie-wilson-dating-for-a-few-weeks/">
						<figure class="article__item-figure">
				<div style="padding-bottom:56.25%;" class="ratio-based-placeholder"><img src="https://www.intouchweekly.com/wp-content/themes/ami-bauer/assets/build/images/placeholders/placeholder-16x9.svg" data-src="https://www.intouchweekly.com/wp-content/uploads/2021/11/shutterstock_editorial_12467476bj.jpg?crop=0px%2C457px%2C3712px%2C2103px&#038;resize=480%2C270" data-srcset="https://www.intouchweekly.com/wp-content/uploads/2021/11/shutterstock_editorial_12467476bj.jpg?crop=0px%2C457px%2C3712px%2C2103px&amp;resize=120%2C68 120w, https://www.intouchweekly.com/wp-content/uploads/2021/11/shutterstock_editorial_12467476bj.jpg?crop=0px%2C457px%2C3712px%2C2103px&amp;resize=230%2C129 230w, https://www.intouchweekly.com/wp-content/uploads/2021/11/shutterstock_editorial_12467476bj.jpg?crop=0px%2C457px%2C3712px%2C2103px&amp;resize=408%2C230 408w, https://www.intouchweekly.com/wp-content/uploads/2021/11/shutterstock_editorial_12467476bj.jpg?crop=0px%2C457px%2C3712px%2C2103px&amp;resize=480%2C270 480w, https://www.intouchweekly.com/wp-content/uploads/2021/11/shutterstock_editorial_12467476bj.jpg?crop=0px%2C457px%2C3712px%2C2103px&amp;resize=630%2C354 630w, https://www.intouchweekly.com/wp-content/uploads/2021/11/shutterstock_editorial_12467476bj.jpg?crop=0px%2C457px%2C3712px%2C2103px&amp;resize=940%2C529 940w, https://www.intouchweekly.com/wp-content/uploads/2021/11/shutterstock_editorial_12467476bj.jpg?crop=0px%2C457px%2C3712px%2C2103px&amp;resize=960%2C540 960w, https://www.intouchweekly.com/wp-content/uploads/2021/11/shutterstock_editorial_12467476bj.jpg?crop=0px%2C457px%2C3712px%2C2103px&amp;resize=1200%2C675 1200w, https://www.intouchweekly.com/wp-content/uploads/2021/11/shutterstock_editorial_12467476bj.jpg?crop=0px%2C457px%2C3712px%2C2103px&amp;resize=1260%2C709 1260w, https://www.intouchweekly.com/wp-content/uploads/2021/11/shutterstock_editorial_12467476bj.jpg?crop=0px%2C457px%2C3712px%2C2103px&amp;resize=1920%2C1080 1920w" sizes="(max-width: 400px) 408px, 408px" alt="Julianne Hough new boyfriend" data-fallback-img="https://www.intouchweekly.com/wp-content/uploads/2021/11/shutterstock_editorial_12467476bj.jpg?fit=3712%2C5568" width="480" height="270"></div>			</figure>
		</a>
	
	<h2 class="article__item-title">
		<a href="https://www.intouchweekly.com/posts/julianne-hough-and-boyfriend-charlie-wilson-dating-for-a-few-weeks/">New Love! Julianne Hough Has Been Dating Charlie Wilson for ‘a Few Weeks'</a>
	</h2>
</article>

<article class="article__item">
			<a class="article__item-thumbnail" href="https://www.intouchweekly.com/posts/kris-jenner-approves-of-kim-kardashian-pete-davidson-relationship/">
						<figure class="article__item-figure">
				<div style="padding-bottom:56.25%;" class="ratio-based-placeholder"><img src="https://www.intouchweekly.com/wp-content/themes/ami-bauer/assets/build/images/placeholders/placeholder-16x9.svg" data-src="https://www.intouchweekly.com/wp-content/uploads/2021/11/Kris-Jenner-100-Percent-Approves-of-Kim-Kardashians-Relationship-With-Pete-Davidson.jpg?crop=0px%2C0px%2C2000px%2C1133px&#038;resize=480%2C270" data-srcset="https://www.intouchweekly.com/wp-content/uploads/2021/11/Kris-Jenner-100-Percent-Approves-of-Kim-Kardashians-Relationship-With-Pete-Davidson.jpg?crop=0px%2C0px%2C2000px%2C1133px&amp;resize=120%2C68 120w, https://www.intouchweekly.com/wp-content/uploads/2021/11/Kris-Jenner-100-Percent-Approves-of-Kim-Kardashians-Relationship-With-Pete-Davidson.jpg?crop=0px%2C0px%2C2000px%2C1133px&amp;resize=230%2C129 230w, https://www.intouchweekly.com/wp-content/uploads/2021/11/Kris-Jenner-100-Percent-Approves-of-Kim-Kardashians-Relationship-With-Pete-Davidson.jpg?crop=0px%2C0px%2C2000px%2C1133px&amp;resize=408%2C230 408w, https://www.intouchweekly.com/wp-content/uploads/2021/11/Kris-Jenner-100-Percent-Approves-of-Kim-Kardashians-Relationship-With-Pete-Davidson.jpg?crop=0px%2C0px%2C2000px%2C1133px&amp;resize=480%2C270 480w, https://www.intouchweekly.com/wp-content/uploads/2021/11/Kris-Jenner-100-Percent-Approves-of-Kim-Kardashians-Relationship-With-Pete-Davidson.jpg?crop=0px%2C0px%2C2000px%2C1133px&amp;resize=630%2C354 630w, https://www.intouchweekly.com/wp-content/uploads/2021/11/Kris-Jenner-100-Percent-Approves-of-Kim-Kardashians-Relationship-With-Pete-Davidson.jpg?crop=0px%2C0px%2C2000px%2C1133px&amp;resize=940%2C529 940w, https://www.intouchweekly.com/wp-content/uploads/2021/11/Kris-Jenner-100-Percent-Approves-of-Kim-Kardashians-Relationship-With-Pete-Davidson.jpg?crop=0px%2C0px%2C2000px%2C1133px&amp;resize=960%2C540 960w, https://www.intouchweekly.com/wp-content/uploads/2021/11/Kris-Jenner-100-Percent-Approves-of-Kim-Kardashians-Relationship-With-Pete-Davidson.jpg?crop=0px%2C0px%2C2000px%2C1133px&amp;resize=1200%2C675 1200w, https://www.intouchweekly.com/wp-content/uploads/2021/11/Kris-Jenner-100-Percent-Approves-of-Kim-Kardashians-Relationship-With-Pete-Davidson.jpg?crop=0px%2C0px%2C2000px%2C1133px&amp;resize=1260%2C709 1260w, https://www.intouchweekly.com/wp-content/uploads/2021/11/Kris-Jenner-100-Percent-Approves-of-Kim-Kardashians-Relationship-With-Pete-Davidson.jpg?crop=0px%2C0px%2C2000px%2C1133px&amp;resize=1920%2C1080 1920w" sizes="(max-width: 400px) 408px, 408px" alt="Kris Jenner ‘100 Percent Approves’ of Kim Kardashian’s Relationship With Pete Davidson" data-fallback-img="https://www.intouchweekly.com/wp-content/uploads/2021/11/Kris-Jenner-100-Percent-Approves-of-Kim-Kardashians-Relationship-With-Pete-Davidson.jpg?fit=2000%2C2000" width="480" height="270"></div>			</figure>
		</a>
	
	<h2 class="article__item-title">
		<a href="https://www.intouchweekly.com/posts/kris-jenner-approves-of-kim-kardashian-pete-davidson-relationship/">Does Kris Jenner 'Approve' of Kim Kardashian and Pete Davidson Dating?</a>
	</h2>
</article>

<article class="article__item">
			<a class="article__item-thumbnail" href="https://www.intouchweekly.com/posts/ariana-grande-is-super-supportive-of-ex-pete-davidson-dating-kim-kardashian-no-jealousy/">
						<figure class="article__item-figure">
				<div style="padding-bottom:56.25%;" class="ratio-based-placeholder"><img src="https://www.intouchweekly.com/wp-content/themes/ami-bauer/assets/build/images/placeholders/placeholder-16x9.svg" data-src="https://www.intouchweekly.com/wp-content/uploads/2021/11/IT-Ariana-Grande-Feelings-About-Pete-Davison-and-Kim-Kardashian-Dating.png?crop=0px%2C14px%2C2400px%2C1359px&#038;resize=480%2C270" data-srcset="https://www.intouchweekly.com/wp-content/uploads/2021/11/IT-Ariana-Grande-Feelings-About-Pete-Davison-and-Kim-Kardashian-Dating.png?crop=0px%2C14px%2C2400px%2C1359px&amp;resize=120%2C68 120w, https://www.intouchweekly.com/wp-content/uploads/2021/11/IT-Ariana-Grande-Feelings-About-Pete-Davison-and-Kim-Kardashian-Dating.png?crop=0px%2C14px%2C2400px%2C1359px&amp;resize=230%2C129 230w, https://www.intouchweekly.com/wp-content/uploads/2021/11/IT-Ariana-Grande-Feelings-About-Pete-Davison-and-Kim-Kardashian-Dating.png?crop=0px%2C14px%2C2400px%2C1359px&amp;resize=408%2C230 408w, https://www.intouchweekly.com/wp-content/uploads/2021/11/IT-Ariana-Grande-Feelings-About-Pete-Davison-and-Kim-Kardashian-Dating.png?crop=0px%2C14px%2C2400px%2C1359px&amp;resize=480%2C270 480w, https://www.intouchweekly.com/wp-content/uploads/2021/11/IT-Ariana-Grande-Feelings-About-Pete-Davison-and-Kim-Kardashian-Dating.png?crop=0px%2C14px%2C2400px%2C1359px&amp;resize=630%2C354 630w, https://www.intouchweekly.com/wp-content/uploads/2021/11/IT-Ariana-Grande-Feelings-About-Pete-Davison-and-Kim-Kardashian-Dating.png?crop=0px%2C14px%2C2400px%2C1359px&amp;resize=940%2C529 940w, https://www.intouchweekly.com/wp-content/uploads/2021/11/IT-Ariana-Grande-Feelings-About-Pete-Davison-and-Kim-Kardashian-Dating.png?crop=0px%2C14px%2C2400px%2C1359px&amp;resize=960%2C540 960w, https://www.intouchweekly.com/wp-content/uploads/2021/11/IT-Ariana-Grande-Feelings-About-Pete-Davison-and-Kim-Kardashian-Dating.png?crop=0px%2C14px%2C2400px%2C1359px&amp;resize=1200%2C675 1200w, https://www.intouchweekly.com/wp-content/uploads/2021/11/IT-Ariana-Grande-Feelings-About-Pete-Davison-and-Kim-Kardashian-Dating.png?crop=0px%2C14px%2C2400px%2C1359px&amp;resize=1260%2C709 1260w, https://www.intouchweekly.com/wp-content/uploads/2021/11/IT-Ariana-Grande-Feelings-About-Pete-Davison-and-Kim-Kardashian-Dating.png?crop=0px%2C14px%2C2400px%2C1359px&amp;resize=1920%2C1080 1920w" sizes="(max-width: 400px) 408px, 408px" alt="Ariana Grande Feelings About Pete Davison and Kim Kardashian Dating" data-fallback-img="https://www.intouchweekly.com/wp-content/uploads/2021/11/IT-Ariana-Grande-Feelings-About-Pete-Davison-and-Kim-Kardashian-Dating.png?fit=2400%2C2400" width="480" height="270"></div>			</figure>
		</a>
	
	<h2 class="article__item-title">
		<a href="https://www.intouchweekly.com/posts/ariana-grande-is-super-supportive-of-ex-pete-davidson-dating-kim-kardashian-no-jealousy/">How Ariana Grande Really Feels About Pete Davidson and Kim Kardashian</a>
	</h2>
</article>

<article class="article__item">
			<a class="article__item-thumbnail" href="https://www.intouchweekly.com/posts/maitland-ward-making-thanksgiving-with-my-feet-video-for-fans/">
							<div class="video-icon video__block-icon"><svg><use xlink:href="#icon-video" /></svg></div>
						<figure class="article__item-figure">
				<div style="padding-bottom:56.25%;" class="ratio-based-placeholder"><img src="https://www.intouchweekly.com/wp-content/themes/ami-bauer/assets/build/images/placeholders/placeholder-16x9.svg" data-src="https://www.intouchweekly.com/wp-content/uploads/2021/11/Maitland-Ward-Creating-Video-Of-Her-Making-Thanksgiving-With-My-Feet-For-Fans-004.jpg?crop=0px%2C65px%2C1200px%2C680px&#038;resize=480%2C270" data-srcset="https://www.intouchweekly.com/wp-content/uploads/2021/11/Maitland-Ward-Creating-Video-Of-Her-Making-Thanksgiving-With-My-Feet-For-Fans-004.jpg?crop=0px%2C65px%2C1200px%2C680px&amp;resize=120%2C68 120w, https://www.intouchweekly.com/wp-content/uploads/2021/11/Maitland-Ward-Creating-Video-Of-Her-Making-Thanksgiving-With-My-Feet-For-Fans-004.jpg?crop=0px%2C65px%2C1200px%2C680px&amp;resize=230%2C129 230w, https://www.intouchweekly.com/wp-content/uploads/2021/11/Maitland-Ward-Creating-Video-Of-Her-Making-Thanksgiving-With-My-Feet-For-Fans-004.jpg?crop=0px%2C65px%2C1200px%2C680px&amp;resize=408%2C230 408w, https://www.intouchweekly.com/wp-content/uploads/2021/11/Maitland-Ward-Creating-Video-Of-Her-Making-Thanksgiving-With-My-Feet-For-Fans-004.jpg?crop=0px%2C65px%2C1200px%2C680px&amp;resize=480%2C270 480w, https://www.intouchweekly.com/wp-content/uploads/2021/11/Maitland-Ward-Creating-Video-Of-Her-Making-Thanksgiving-With-My-Feet-For-Fans-004.jpg?crop=0px%2C65px%2C1200px%2C680px&amp;resize=630%2C354 630w, https://www.intouchweekly.com/wp-content/uploads/2021/11/Maitland-Ward-Creating-Video-Of-Her-Making-Thanksgiving-With-My-Feet-For-Fans-004.jpg?crop=0px%2C65px%2C1200px%2C680px&amp;resize=940%2C529 940w, https://www.intouchweekly.com/wp-content/uploads/2021/11/Maitland-Ward-Creating-Video-Of-Her-Making-Thanksgiving-With-My-Feet-For-Fans-004.jpg?crop=0px%2C65px%2C1200px%2C680px&amp;resize=960%2C540 960w, https://www.intouchweekly.com/wp-content/uploads/2021/11/Maitland-Ward-Creating-Video-Of-Her-Making-Thanksgiving-With-My-Feet-For-Fans-004.jpg?crop=0px%2C65px%2C1200px%2C680px&amp;resize=1200%2C675 1200w" sizes="(max-width: 400px) 408px, 408px" alt="Maitland Ward Creating Video Of Her Making Thanksgiving With My Feet For Fans" data-fallback-img="https://www.intouchweekly.com/wp-content/uploads/2021/11/Maitland-Ward-Creating-Video-Of-Her-Making-Thanksgiving-With-My-Feet-For-Fans-004.jpg?fit=1200%2C1479" width="480" height="270"></div>			</figure>
		</a>
	
	<h2 class="article__item-title">
		<a href="https://www.intouchweekly.com/posts/maitland-ward-making-thanksgiving-with-my-feet-video-for-fans/">Maitland Ward Says She Will Be 'Making Thanksgiving With My Feet'</a>
	</h2>
</article>
					</div>
				</div>
			</div>
		</div>
	</div>

	<div class="l-grid">
		<div class="l-container l-container__related-articles">
			
<div class="l-grid__main-default" id="infSec_1">
	<div class="post-related">
			<div class="lazyload-anchor" data-page-id="336941" data-page-type="single-post" data-count="30" data-paged="1" data-excluded="[421867,421851,421677,421672,421665,421628,421437,421361,421385]" data-ads="{&quot;sh&quot;:1,&quot;mb&quot;:3}"></div>	</div>
</div>

<div class="post-sidebar">
	<div class="ad-container__sticky-wrapper">
		<div class="ad-container sticky-top">
			<div class="dfp-wrapper  desktop-only" data-slot="rr3"><div id="rr3" class="dfp-slot dfp-container rr3 "></div></div>		</div>
	</div>
</div>
		</div>
	</div>


<footer class="site-footer">
	<div class="site-footer__inner">
		<div class="site-footer__left">
			<a href="https://www.intouchweekly.com/" class="site-footer__logo" title="Home" rel="home">
				<span class="hidden-except-readers">In Touch Weekly logo</span>
				<svg class="logo">
					<use xlink:href="#logo-intouch-footer"></use>
				</svg>
			</a>

			<div class="site-footer__left__inner">
				<div class="site-footer__social">
					<span class="site-footer__social__heading">Follow us!</span>
					<ul class="site-footer__social__list">
						<li><a href="http://www.facebook.com/InTouchWeekly" class="site-footer__social__link" rel="nofollow"> <span class="hidden-except-readers">Social icon facebook</span><svg class="icon icon-facebook"><use xlink:href="#icon-facebook"></use></svg></a></li><li><a href="https://twitter.com/intouchweekly" class="site-footer__social__link" rel="nofollow"> <span class="hidden-except-readers">Social icon twitter</span><svg class="icon icon-twitter"><use xlink:href="#icon-twitter"></use></svg></a></li><li><a href="https://www.instagram.com/intouchweekly/?hl=en" class="site-footer__social__link" rel="nofollow"> <span class="hidden-except-readers">Social icon instagram</span><svg class="icon icon-instagram"><use xlink:href="#icon-instagram"></use></svg></a></li>					</ul>
				</div>

				                    <div class="site-footer__newsletter-link">
                        <a href="/newsletter">Sign up for our e-newsletter</a>
                    </div>
				
				<div class="site-footer__notification">
					<p class="site-footer__notification-text">In Touch Weekly has affiliate partnerships so we may receive compensation for some links to products and services.</p>
					<p class="site-footer__notification-text">In Touch Weekly is part of the A360 Media Entertainment Group.<br>Copyright © A360 Media LLC 2021. All Rights Reserved</p>
				</div>
			</div>

		</div>

		<div class="site-footer__right">
			<div class="site-footer__menu">
				<h3 class="site-footer__heading">In Touch Weekly</h3>
				<div class="site-footer__links"><ul id="menu-footer-menu-1" class="site-footer__links__list"><li id="menu-item-201709" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-201709"><a href="https://www.intouchweekly.com/archives/">Archives</a></li>
<li id="menu-item-260471" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-260471"><a href="https://www.intouchweekly.com/posts/category/news/">News</a></li>
<li id="menu-item-260470" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-260470"><a href="https://www.intouchweekly.com/posts/category/reality-tv/">Reality TV</a></li>
<li id="menu-item-260472" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-260472"><a href="https://www.intouchweekly.com/posts/category/true-crime/">True Crime</a></li>
<li id="menu-item-260473" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-260473"><a href="https://www.intouchweekly.com/posts/category/entertainment/">Entertainment</a></li>
<li id="menu-item-260475" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-260475"><a href="https://www.intouchweekly.com/posts/category/omg/">OMG!</a></li>
<li id="menu-item-260474" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-260474"><a href="https://www.intouchweekly.com/posts/category/style/">Style</a></li>
<li id="menu-item-403227" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-403227"><a href="https://www.intouchweekly.com/posts/category/must-haves/">Must-Haves</a></li>
<li id="menu-item-260469" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-260469"><a href="/newsletter">Newsletter</a></li>
</ul></div>
				<!-- OneTrust Cookies Settings button start -->
				<a class="optanon-toggle-display" name="Manage Cookies">Manage Cookies</a>
				<!-- OneTrust Cookies Settings button end -->
			</div>

			<div class="site-footer__menu">
				<h3 class="site-footer__heading">A360 Media LLC</h3>
				<div class="site-footer__links"><ul id="menu-footer-menu-2" class="site-footer__links__list"><li id="menu-item-130808" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-130808"><a href="https://a360media.com/privacy-policy">Privacy Policy</a></li>
<li id="menu-item-130809" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-130809"><a href="https://a360media.com/terms-and-conditions">Terms &#038; Conditions</a></li>
<li id="menu-item-130810" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-130810"><a href="https://www.intouchweekly.com/contact/">Contact Us</a></li>
<li id="menu-item-134887" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-134887"><a href="https://a360media.cloud.buysub.com/">Subscriber Service</a></li>
<li id="menu-item-260468" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-260468"><a href="https://shop.getspecialissues.com/">Shop Special Issues</a></li>
<li id="menu-item-130811" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-130811"><a href="/archives/">SIte Map</a></li>
<li id="menu-item-298102" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-298102"><a href="https://www.intouchweekly.com/accessibility-statement/">Accessibility Statement</a></li>
<li id="menu-item-298103" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-298103"><a href="https://a360media.com/cookie-policy">Cookie Policy</a></li>
</ul></div>			</div>

			<div class="site-footer__cta">
				<div class="site-footer__cta__inner">
					<h3 class="site-footer__heading">Want more?</h3>
					<div class="textwidget custom-html-widget"><img src="https://www.intouchweekly.com/wp-content/themes/ami-bauer/assets/build/images/placeholders/placeholder-1x1.svg" data-src="https://www.intouchweekly.com/wp-content/uploads/2020/10/IT4420_cover_final.jpg?w=300" data-srcset="https://www.intouchweekly.com/wp-content/uploads/2020/10/IT4420_cover_final.jpg?w=200 1x, https://www.intouchweekly.com/wp-content/uploads/2020/10/IT4420_cover_final.jpg?w=400 2x" sizes="200px" alt="In This Issue of In Touch Weekly" class="img-responsive img-cover" width="161" height="218"></div>					<a class="site-footer__cta-link" target="_blank" rel="nofollow noopener" href="https://w1.buysub.com/servlet/OrdersGateway?cds_mag_code=NTW&#038;cds_page_id=230030">Subscribe!</a>
					<a class="site-footer__cta-link" target="_blank" rel="nofollow noopener" href="https://w1.buysub.com/servlet/GiftsGateway?cds_mag_code=NTW">Give as a Gift</a>
					<a class="site-footer__cta-link" target="_blank" rel="nofollow noopener" href="https://a360media.cloud.buysub.com/">Subscriber Services</a>
				</div>
			</div>
		</div>
	</div>

</footer>
</div>

	<style type="text/css" media="screen">
		@media screen and ( max-width: 782px ) {
			html {
				margin-top: 0px !important;
			}
			* html body {
				margin-top: 0px !important;
			}
			#wpadminbar {
				display: none;
			}
		}
	</style>
		<script>
		jQuery(document).ready(function ( $ ) {
			$('a[href^="http"]')
				.not('[href^="' + location.protocol + '//' + location.hostname + '"],[href^="https://ciam-ui.kubestage.hearstapps.net"],[href^="https://www.mylo.id"]')
				.attr('target', '_blank');
		});
	</script>
			<script id='main-js-js-extra'>
var ajaxurl = "\/wp-admin\/admin-ajax.php";
var obj = {"templateUrl":"https:\/\/www.intouchweekly.com\/wp-content\/themes\/ami-bauer","restEndpoint":"https:\/\/www.intouchweekly.com\/wp-json\/ami\/v1\/"};
</script>
<script type="text/javascript" src="https://www.intouchweekly.com/_static/??/wp-content/mu-plugins/jetpack-10.3/_inc/build/photon/photon.min.js,/wp-content/themes/ami-bauer/assets/build/js/main.bundle.js?m=1637166939j" ></script><script class='optanon-category-C0004' type='text/plain' src='https://static.adsafeprotected.com/vans-adapter-google-ima.js' id='ami-googleima-js'></script>
<script id='newsletter-sign-up-js-extra'>
var amiNewsletterStrings = {"userEndpoint":"https:\/\/www.intouchweekly.com\/wp-json\/ami\/v1\/newsletter\/user","listEndpoint":"https:\/\/www.intouchweekly.com\/wp-json\/ami\/v1\/newsletter\/list","processMessage":"Sending your request...","defaultError":"An internal error has occurred. Please try again later..","invalidEmailError":"Please enter a valid email and try again."};
</script>
<script type="text/javascript" src="https://www.intouchweekly.com/wp-content/client-mu-plugins/shared/assets/js/dist/newsletterSignUp.bundle.js?m=1637162907g" ></script><script class='optanon-category-C0003' type='text/plain' src='https://www.intouchweekly.com/wp-content/client-mu-plugins/shared/assets/js/dist/overlayRecircWidget.bundle.js?ver=5.8.2' id='overlay-recirc-widget-script-js'></script>
<script id='sharing-js-js-extra'>
var sharing_js_options = {"lang":"en","counts":"","is_stats_active":"1"};
</script>
<script src='https://www.intouchweekly.com/wp-content/mu-plugins/jetpack-10.3/_inc/build/sharedaddy/sharing.min.js?ver=10.3' id='sharing-js-js'></script>
<script id='sharing-js-js-after'>
var windowOpen;
			( function () {
				function matches( el, sel ) {
					return !! (
						el.matches && el.matches( sel ) ||
						el.msMatchesSelector && el.msMatchesSelector( sel )
					);
				}

				document.body.addEventListener( 'click', function ( event ) {
					if ( ! event.target ) {
						return;
					}

					var el;
					if ( matches( event.target, 'a.share-facebook' ) ) {
						el = event.target;
					} else if ( event.target.parentNode && matches( event.target.parentNode, 'a.share-facebook' ) ) {
						el = event.target.parentNode;
					}

					if ( el ) {
						event.preventDefault();

						// If there's another sharing window open, close it.
						if ( typeof windowOpen !== 'undefined' ) {
							windowOpen.close();
						}
						windowOpen = window.open( el.getAttribute( 'href' ), 'wpcomfacebook', 'menubar=1,resizable=1,width=600,height=400' );
						return false;
					}
				} );
			} )();
var windowOpen;
			( function () {
				function matches( el, sel ) {
					return !! (
						el.matches && el.matches( sel ) ||
						el.msMatchesSelector && el.msMatchesSelector( sel )
					);
				}

				document.body.addEventListener( 'click', function ( event ) {
					if ( ! event.target ) {
						return;
					}

					var el;
					if ( matches( event.target, 'a.share-twitter' ) ) {
						el = event.target;
					} else if ( event.target.parentNode && matches( event.target.parentNode, 'a.share-twitter' ) ) {
						el = event.target.parentNode;
					}

					if ( el ) {
						event.preventDefault();

						// If there's another sharing window open, close it.
						if ( typeof windowOpen !== 'undefined' ) {
							windowOpen.close();
						}
						windowOpen = window.open( el.getAttribute( 'href' ), 'wpcomtwitter', 'menubar=1,resizable=1,width=600,height=350' );
						return false;
					}
				} );
			} )();
</script>
		<script>
			// US-1872 Call AJAX from windows.onload
			( function( $ ) {
				$( window ).load( () => {

					const cachedId = localStorage.getItem( 'perClientId' );

					if ( null === cachedId || "" === cachedId ) {
						const clientId = Date.now() + Math.random();

						if ( window.location.hostname.indexOf( 'usmagazine' ) !== -1 && !!window.Worker ) {

							//console.log("WWW creating worker for permutive button ");
							var worker = new Worker( '/wp-content/themes/ajax-onload.js' );
							worker.onmessage = function( ev ) {

								const newClientId = ev.data;

								console.log( '%c Got via Worker: ' + newClientId, 'background: #27ae60; color: #000; padding: 2px 10px 2px 5px' );

								if ( newClientId ) {
									localStorage.setItem( 'perClientId', newClientId );
									let identities = [{
										"id": newClientId,
										"tag": "publisherUserId",
										"priority": 0
									}
									];
									try {
										let bc = localStorage.getItem( 'blueconic' );
										if ( typeof bc != null ) {
											let bc = JSON.parse( localStorage.getItem( 'blueconic' ) );
											if ( typeof bc.user !== 'undefined' ) {
												identities.push( {
													"id": bc.user.hashedEmail[0],
													"tag": "email_sha256",
													"priority": 1
												} );
											}
										}
										let username = getCookie( 'mylo_username' );
										if ( undefined !== username ) {
											identities.push( {
												"id": username,
												"tag": "mylo_username",
												"priority": 2
											} );
										}
									} catch ( e ) {
										console.log( 'permutive identity: ', e );
									}
									window.permutive.identify( identities );
									console.log( 'identity', identities );
								}
							};
							worker.postMessage( ['permutive', clientId] );
						} else {

							$.ajax( {
								url: '/wp-admin/admin-ajax.php?action=get_client_id&clientId=' + clientId
							} ).done( ( ajaxResponse ) => {
								const parsedResponse = JSON.parse( ajaxResponse );

								console.log( '%c Got: ' + parsedResponse.clientId, 'background: #27ae60; color: #000; padding: 2px 10px 2px 5px' );

								if ( parsedResponse.hasOwnProperty( 'clientId' ) ) {
									localStorage.setItem( 'perClientId', parsedResponse.clientId );
									let identities = [{
										"id": parsedResponse.clientId,
										"tag": "publisherUserId",
										"priority": 0
									}
									];
									try {
										let bc = localStorage.getItem( 'blueconic' );
										if ( typeof bc != null ) {
											let bc = JSON.parse( localStorage.getItem( 'blueconic' ) );
											if ( typeof bc.user !== 'undefined' ) {
												identities.push( {
													"id": bc.user.hashedEmail[0],
													"tag": "email_sha256",
													"priority": 1
												} );
											}
										}
										let username = getCookie( 'mylo_username' );
										if ( undefined !== username ) {
											identities.push( {
												"id": username,
												"tag": "mylo_username",
												"priority": 2
											} );
										}
									} catch ( e ) {
										console.log( 'permutive identity: ', e );
									}
									window.permutive.identify( identities );
									console.log( 'identity', identities );
								}

							} );
						}
					} else {
						let identities = [{
							"id": cachedId,
							"tag": "publisherUserId",
							"priority": 0
						}
						];
						try {
							let bc = localStorage.getItem( 'blueconic' );
							if ( typeof bc != null ) {
								let bc = JSON.parse( localStorage.getItem( 'blueconic' ) );
								if ( typeof bc.user !== 'undefined' ) {
									identities.push( {
										"id": bc.user.hashedEmail[0],
										"tag": "email_sha256",
										"priority": 1
									} );
								}
							}
							let username = getCookie( 'mylo_username' );
							if ( undefined !== username ) {
								identities.push( {
									"id": username,
									"tag": "mylo_username",
									"priority": 2
								} );
							}
						} catch ( e ) {
							console.log( 'permutive identity: ', e );
						}
						window.permutive.identify( identities );
						console.log( 'identity', identities );
					}
				} );
			} )( jQuery );
		</script>

			<script>
		( function( $ ) {
			$( document ).ready( () => {
				if ( getCookie( 'mylo_token' ) !== undefined ) {
					$.ajax( {
						url: '/wp-json/mylo/v1/is-logged-in/'
					} ).done( ( ajaxResponse ) => {
						// const parsedResponse = JSON.parse( ajaxResponse );
						console.log( 'LOGIN', ajaxResponse );
						if ( 'undefined' !== typeof switchMyloControls ) {
							switchMyloControls( ajaxResponse );
						}

						$( '.header-mylo, .header-mylo__mobile' ).addClass( 'visible' );
					} );
				} else {
					$( '.header-mylo, .header-mylo__mobile' ).addClass( 'visible' );
				}
			} );
		} )( jQuery );
	</script>

	<template id="mylo-account-controls">
		<span class="header-mylo__label">Account</span>
		<div class="header-mylo__dropdown">
			<a class="header-mylo__account" href="https://www.mylo.id/account?client_id=6628dtuhkmdqca1squ18er2cq4&#038;logout_uri=https://www.intouchweekly.com/auth/logout">
				<svg class="header-mylo__user-icon icon"><use xlink:href="#icon-user"></use></svg>
				<span>My Account</span>
			</a>
			<a class="header-mylo__sign-out" href="https://www.mylo.id/logout?client_id=6628dtuhkmdqca1squ18er2cq4&#038;logout_uri=https://www.intouchweekly.com/auth/logout">
				<svg class="header-mylo__signout-icon icon"><use xlink:href="#icon-signout"></use></svg>
				<span>Sign Out</span>
			</a>
		</div>
	</template>
	<script src='https://stats.wp.com/e-202147.js' defer></script>
<script>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:10.3',blog:'149114667',post:'336941',tz:'-5',srv:'www.intouchweekly.com'} ]);
	_stq.push([ 'clickTrackerInit', '149114667', '336941' ]);
</script>
</body>
</html>
