<!DOCTYPE html>
<html lang="en-US">
    <head>
        <meta charset="UTF-8"/>
        <meta name="viewport" content="width=device-width, initial-scale=1.0"/>
		<link rel="preload" as="image" href="/wp-content/uploads/2022/06/Kim-pete-IT-featured.jpg?crop=0px%2C48px%2C2276px%2C1291px&#038;resize=940%2C529&#038;quality=86&#038;strip=all" imagesrcset="/wp-content/uploads/2022/06/Kim-pete-IT-featured.jpg?crop=0px%2C48px%2C2276px%2C1291px&amp;resize=120%2C68&amp;quality=86&amp;strip=all 120w, /wp-content/uploads/2022/06/Kim-pete-IT-featured.jpg?crop=0px%2C48px%2C2276px%2C1291px&amp;resize=230%2C129&amp;quality=86&amp;strip=all 230w, /wp-content/uploads/2022/06/Kim-pete-IT-featured.jpg?crop=0px%2C48px%2C2276px%2C1291px&amp;resize=408%2C230&amp;quality=86&amp;strip=all 408w, /wp-content/uploads/2022/06/Kim-pete-IT-featured.jpg?crop=0px%2C48px%2C2276px%2C1291px&amp;resize=480%2C270&amp;quality=86&amp;strip=all 480w, /wp-content/uploads/2022/06/Kim-pete-IT-featured.jpg?crop=0px%2C48px%2C2276px%2C1291px&amp;resize=630%2C354&amp;quality=86&amp;strip=all 630w, /wp-content/uploads/2022/06/Kim-pete-IT-featured.jpg?crop=0px%2C48px%2C2276px%2C1291px&amp;resize=940%2C529&amp;quality=86&amp;strip=all 940w, /wp-content/uploads/2022/06/Kim-pete-IT-featured.jpg?crop=0px%2C48px%2C2276px%2C1291px&amp;resize=960%2C540&amp;quality=86&amp;strip=all 960w, /wp-content/uploads/2022/06/Kim-pete-IT-featured.jpg?crop=0px%2C48px%2C2276px%2C1291px&amp;resize=1200%2C675&amp;quality=86&amp;strip=all 1200w, /wp-content/uploads/2022/06/Kim-pete-IT-featured.jpg?crop=0px%2C48px%2C2276px%2C1291px&amp;resize=1260%2C709&amp;quality=86&amp;strip=all 1260w, /wp-content/uploads/2022/06/Kim-pete-IT-featured.jpg?crop=0px%2C48px%2C2276px%2C1291px&amp;resize=1920%2C1080&amp;quality=86&amp;strip=all 1920w" imagesizes="(max-width: 600px) 100vw, 940px" />        <link rel="profile" href="http://gmpg.org/xfn/11"/>
        <link rel="pingback" href="https://www.intouchweekly.com/xmlrpc.php"/>
        <link rel="apple-touch-icon" sizes="180x180" href="https://www.intouchweekly.com/wp-content/themes/ami-bauer/assets/source/images/favicon/intouch/apple-touch-icon.png">
        <link rel="icon" type="image/png" sizes="32x32" href="https://www.intouchweekly.com/wp-content/themes/ami-bauer/assets/source/images/favicon/intouch/favicon-32x32.png">
        <link rel="icon" type="image/png" sizes="16x16" href="https://www.intouchweekly.com/wp-content/themes/ami-bauer/assets/source/images/favicon/intouch/favicon-16x16.png">
        <link rel="mask-icon" href="https://www.intouchweekly.com/wp-content/themes/ami-bauer/assets/source/images/favicon/intouch/safari-pinned-tab.svg" color="#636363">
        <meta name="theme-color" content="#ffffff">

					<link rel="preload" href="https://www.intouchweekly.com/wp-content/themes/ami-bauer/assets/build/fonts/FjallaOne-Regular.woff2" as="font" type="font/woff2" crossorigin>
			<link rel="preload" href="https://www.intouchweekly.com/wp-content/themes/ami-bauer/assets/build/fonts/Raleway-Bold.woff2" as="font" type="font/woff2" crossorigin>
			<link rel="preload" href="https://www.intouchweekly.com/wp-content/themes/ami-bauer/assets/build/fonts/Raleway-ExtraBold.woff2" as="font" type="font/woff2" crossorigin>
		
							<script type="text/javascript">
			window.googletag = window.googletag || {}, window.googletag.cmd = window.googletag.cmd || [], window.googletag.cmd.push( function() {
				if ( 0 === window.googletag.pubads().getTargeting( "permutive" ).length ) {
					var g = window.localStorage.getItem( "_pdfps" );
					window.googletag.pubads().setTargeting( "permutive", g ? JSON.parse( g ) : [] )
				}
			} );
			window.ntvConfig = window.ntvConfig || {};
			window.ntvConfig.keyValues = window.ntvConfig.keyValues || {};
			var segs = localStorage.getItem( '_pnativo' );
			if ( segs ) {
				window.ntvConfig.keyValues.permutive = segs;
			}
			!function( n, e, o, r, i ) {
				if ( !e ) {
					e = e || {}, window.permutive = e, e.q = [], e.config = i || {}, e.config.projectId = o, e.config.apiKey = r, e.config.environment = e.config.environment || "production";
					for ( var t = ["addon", "identify", "track", "trigger", "query", "segment", "segments", "ready", "on", "once", "user", "consent"], c = 0; c < t.length; c++ ) {
						var f = t[c];
						e[f] = function( n ) {
							return function() {
								var o = Array.prototype.slice.call( arguments, 0 );
								e.q.push( {functionName: n, arguments: o} )
							}
						}( f )
					}
				}
			}( document, window.permutive, "410f7cce-1402-4d0e-8d36-f430b2eb2066", "9fc95048-71ef-4f85-a2f7-d7e9ca5b8d45", {"consentRequired": true} );
			var permutiveData = {"page":{"url":"\/posts\/kim-kardashian-hints-at-having-best-sex-with-pete-davidson\/","category":"post","title":"Kim Kardashian Seemingly Reveals She&#8217;s Having the &#8216;Best Sex&#8217; With Pete Davidson","type":"article","id":452328,"article":{"title":"Kim Kardashian Seemingly Reveals She&#8217;s Having the &#8216;Best Sex&#8217; With Pete Davidson","category":["News"],"tags":["Kim Kardashian","Pete Davidson"],"audience":{"category":[],"subCategory":[]},"retailers":[],"celebrity":[],"publishDate":"2022-06-02T00:05:22-04:00"}}};
			if ( localStorage.getItem( 'blueconic' ) ) {
				permutiveData.page.blueconic = JSON.parse( localStorage.getItem( 'blueconic' ) );
			}
			permutive.addon( "web", permutiveData );
		</script>
		<script type="text/javascript" async src="https://cdn.permutive.com/410f7cce-1402-4d0e-8d36-f430b2eb2066-web.js"></script>
		
	<!-- OneTrust Cookies Consent Notice start -->
	<script src="https://cdn.cookielaw.org/scripttemplates/otSDKStub.js"  type="text/javascript" charset="UTF-8" data-domain-script="36677945-95df-4551-ae71-315d352a975d"></script>
	<script src="https://cdn.cookielaw.org/opt-out/otCCPAiab.js" type="text/javascript" charset="UTF-8" ccpa-opt-out-ids="C0005,C0004,C0002,BG17" ccpa-opt-out-geo="ca" ccpa-opt-out-lspa="false"></script>
	<script type="text/javascript">
		function OptanonWrapper() {
			var allIframes = document.querySelectorAll( 'iframe[class*="optanon-category"]' );
			allIframes.forEach (function( iframe ) {
				var thisIframeCategories = iframe.classList.value.match(/C000\d+/g);

				// Check if user allowed every category assigned to this iframe
				var shouldBeLoaded = thisIframeCategories.every( function( item ) {
					return OptanonActiveGroups.match( item );
				});

				// Load iframe if every category is allowed
				if ( shouldBeLoaded ) {
					loadIframe( iframe );
				}
			});

			// load iframe element
			function loadIframe( element ) {
				if ( element.tagName.toLowerCase() == "iframe" && !element.getAttribute( "src" ) && element.dataset.src ) {
					element.setAttribute( "src", element.dataset.src );
				}
			}

			if ( window.permutive ) {
				if ( OptanonActiveGroups.indexOf( ',C0004,' ) === -1 ) {
					permutive.consent({ "opt_in": false });
				} else {
					permutive.consent({ "opt_in": true, "token": "AMI" });
				}
			}
		}
	</script>
	<!-- OneTrust Cookies Consent Notice end -->

	
			<script>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</script>

			<script type="text/plain" class="optanon-category-C0004" src="//d17tqr44y57o31.cloudfront.net/script.js"></script>
			<meta name='robots' content='index, follow, max-image-preview:large, max-snippet:-1, max-video-preview:-1' />
<!-- Jetpack Site Verification Tags -->
		<script>
			function getCookie(name) {
				var matches = document.cookie.match(new RegExp(
						"(?:^|; )" + name.replace(/([\.$?*|{}\(\)\[\]\\\/\+^])/g, '\\$1') + "=([^;]*)"
				));
				return matches ? decodeURIComponent(matches[1]) : undefined;
			}

			window.dataLayer = window.dataLayer || [];
			dataLayer = [{"pageCategory":"post","env":"prod","sponsored":"off","vupulse":"on","nodeId":452328,"contentType":"article","nodeCategory":["News"],"nodeTags":["Kim Kardashian","Pete Davidson"],"contentUpdatedDate":"2022\/06\/01","contentPublishDate":"2022\/06\/02","pageTitle":"Kim Kardashian Seemingly Reveals She&#8217;s Having the &#8216;Best Sex&#8217; With Pete Davidson","sponsorshipName":"","comments":"on","author":"In Touch Staff","skimlinks":"on","zergnet":"on","gotchosen":"on","audience_cat":[],"audience_subcat":[],"exclusive":"off","globaladrefresh":"0","homepagerefresh":"on","gallerypostrefresh":"on","videopostrefresh":"on","audiopostrefresh":"on","standardpostrefresh":"on","desktoprefresh":"on","mobilerefresh":"on","tragedy":"off","advertorial":"off","branded":"off","refresh":"on"}];

			var site_display_format = 'desktop';

			if ( window.innerWidth < 768 ) {
				site_display_format = 'mobile';
			} else if ( window.innerWidth >= 768 && window.innerWidth <= 1024 ) {
				site_display_format = 'tablet';
			}

			dataLayer.push( { siteDisplayFormat : site_display_format } );

			var username = getCookie('mylo_username');
			if ( undefined !== username ) {
				dataLayer.push( {userName: username} );
			}

			var name = 'setAgeInfo';
			var matches = document.cookie.match(new RegExp(
				"(?:^|; )" + name.replace(/([\.$?*|{}\(\)\[\]\\\/\+^])/g, '\\$1') + "=([^;]*)"
			));

			dataLayer.push( { userAge : matches ? decodeURIComponent( matches[1] ) : '14' } );
		</script>
		
	<!-- This site is optimized with the Yoast SEO plugin v16.8 - https://yoast.com/wordpress/plugins/seo/ -->
	<title>Kim Kardashian Hints at Having &#039;Best Sex&#039; With Pete Davidson</title>
	<meta name="description" content="Kim Kardashian seemingly revealed that she is having the &#039;best sex&#039; with Pete Davidson during the June 2 &#039;Kardashians&#039; episode." />
	<link rel="canonical" href="https://www.lifeandstylemag.com/posts/kim-kardashian-was-dtf-pete-davidson-after-hearing-about-bde/" />
	<meta property="og:locale" content="en_US" />
	<meta property="og:type" content="article" />
	<meta property="og:title" content="Kim Kardashian Seemingly Reveals She&#039;s Having the &#039;Best Sex&#039; With Pete" />
	<meta property="og:description" content="Kim Kardashian seemingly revealed that she is having the &#039;best sex&#039; with Pete Davidson during the June 2 &#039;Kardashians&#039; episode." />
	<meta property="og:url" content="https://www.lifeandstylemag.com/posts/kim-kardashian-was-dtf-pete-davidson-after-hearing-about-bde/" />
	<meta property="og:site_name" content="In Touch Weekly" />
	<meta property="article:publisher" content="http://www.facebook.com/InTouchWeekly" />
	<meta property="article:published_time" content="2022-06-02T04:05:22+00:00" />
	<meta property="article:modified_time" content="2022-06-01T19:38:05+00:00" />
	<meta name="twitter:card" content="summary_large_image" />
	<meta name="twitter:title" content="Kim Kardashian Seemingly Reveals She&#039;s Having the &#039;Best Sex&#039; With Pete" />
	<meta name="twitter:description" content="Kim Kardashian seemingly revealed that she is having the &#039;best sex&#039; with Pete Davidson during the June 2 &#039;Kardashians&#039; episode." />
	<meta name="twitter:image" content="https://www.intouchweekly.com/wp-content/uploads/2022/06/Kim-pete-IT-featured.jpg?crop=0px%2C48px%2C2276px%2C1194px&amp;resize=1200%2C630&amp;quality=86&amp;strip=all" />
	<meta name="twitter:creator" content="@intouchweekly" />
	<meta name="twitter:site" content="@intouchweekly" />
<script type="application/ld+json">{"@context":"http:\/\/schema.org","@type":"WebPage","@id":"https:\/\/www.lifeandstylemag.com\/posts\/kim-kardashian-was-dtf-pete-davidson-after-hearing-about-bde\/#webpage","publisher":{"@id":"https:\/\/www.lifeandstylemag.com\/posts\/kim-kardashian-was-dtf-pete-davidson-after-hearing-about-bde\/#organization"},"isPartOf":{"@id":"https:\/\/www.lifeandstylemag.com\/posts\/kim-kardashian-was-dtf-pete-davidson-after-hearing-about-bde\/#website"}}</script>
<script type="application/ld+json">{"@context":"http:\/\/schema.org","@type":"Organization","name":"In Touch Weekly","url":"https:\/\/www.intouchweekly.com","parentOrganization":"a360 Media LLC","logo":{"@type":"ImageObject","url":"https:\/\/www.intouchweekly.com\/wp-content\/themes\/ami-bauer\/assets\/source\/images\/icons\/logo-intouch.svg"},"address":{"@type":"PostalAddress","streetAddress":"4 New York Plaza","addresslocality":"New York, NY","postalCode":"10004"},"telephone":"212-545-4800","sameAs":["http:\/\/www.facebook.com\/InTouchWeekly","https:\/\/twitter.com\/intouchweekly","https:\/\/www.instagram.com\/intouchweekly\/?hl=en","https:\/\/plus.google.com\/+intouchweekly"]}</script>
<script type="application/ld+json">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</script>
	<script type="application/ld+json" class="yoast-schema-graph">{"@context":"https://schema.org","@graph":[{"@type":"WebSite","@id":"https://www.intouchweekly.com/#website","url":"https://www.intouchweekly.com/","name":"In Touch Weekly","description":"","inLanguage":"en-US"},{"@type":"ImageObject","@id":"https://www.lifeandstylemag.com/posts/kim-kardashian-was-dtf-pete-davidson-after-hearing-about-bde/#primaryimage","inLanguage":"en-US","url":"https://www.intouchweekly.com/wp-content/uploads/2022/06/Kim-pete-IT-featured.jpg?fit=2276%2C2743&quality=86&strip=all","contentUrl":"https://www.intouchweekly.com/wp-content/uploads/2022/06/Kim-pete-IT-featured.jpg?fit=2276%2C2743&quality=86&strip=all","width":2276,"height":2743,"caption":"Mandatory Credit: Photo by Matt Baron/Shutterstock (12918939qq) Pete Davidson and Kim Kardashian White House Correspondent's Dinner, Washington, D.C, USA - 30 Apr 2022"},{"@type":"WebPage","@id":"https://www.lifeandstylemag.com/posts/kim-kardashian-was-dtf-pete-davidson-after-hearing-about-bde/#webpage","url":"https://www.lifeandstylemag.com/posts/kim-kardashian-was-dtf-pete-davidson-after-hearing-about-bde/","name":"Kim Kardashian Hints at Having 'Best Sex' With Pete Davidson","isPartOf":{"@id":"https://www.intouchweekly.com/#website"},"primaryImageOfPage":{"@id":"https://www.lifeandstylemag.com/posts/kim-kardashian-was-dtf-pete-davidson-after-hearing-about-bde/#primaryimage"},"datePublished":"2022-06-02T04:05:22+00:00","dateModified":"2022-06-01T19:38:05+00:00","author":{"@id":"https://www.intouchweekly.com/#/schema/person/4fd7f0f758bf039335d271809c19bca5"},"description":"Kim Kardashian seemingly revealed that she is having the 'best sex' with Pete Davidson during the June 2 'Kardashians' episode.","breadcrumb":{"@id":"https://www.lifeandstylemag.com/posts/kim-kardashian-was-dtf-pete-davidson-after-hearing-about-bde/#breadcrumb"},"inLanguage":"en-US","potentialAction":[{"@type":"ReadAction","target":["https://www.lifeandstylemag.com/posts/kim-kardashian-was-dtf-pete-davidson-after-hearing-about-bde/"]}]},{"@type":"BreadcrumbList","@id":"https://www.lifeandstylemag.com/posts/kim-kardashian-was-dtf-pete-davidson-after-hearing-about-bde/#breadcrumb","itemListElement":[{"@type":"ListItem","position":1,"name":"Home","item":"https://www.intouchweekly.com/"},{"@type":"ListItem","position":2,"name":"Kim Kardashian Seemingly Reveals She&#8217;s Having the &#8216;Best Sex&#8217; With Pete Davidson"}]},{"@type":"Person","@id":"https://www.intouchweekly.com/#/schema/person/4fd7f0f758bf039335d271809c19bca5","name":"In Touch Staff","image":{"@type":"ImageObject","@id":"https://www.intouchweekly.com/#personlogo","inLanguage":"en-US","url":"https://secure.gravatar.com/avatar/df0cdf10f04170b94dce27cc934dc0ae?s=96&d=mm&r=g","contentUrl":"https://secure.gravatar.com/avatar/df0cdf10f04170b94dce27cc934dc0ae?s=96&d=mm&r=g","caption":"In Touch Staff"},"sameAs":["https://intouchweekly.com"],"url":"https://www.intouchweekly.com/authors/in-touch-weekly-36933/"}]}</script>
	<!-- / Yoast SEO plugin. -->


<meta content="593583017" property="fb:admins" /><meta content="75932763901" property="fb:pages" /><link rel='dns-prefetch' href='//static.adsafeprotected.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="text/xml" title="In Touch Weekly &raquo; Feed" href="https://www.intouchweekly.com/feed/" />
	<script>
		function gptAdsWindowWidth() {
			var w = window,
				d = document,
				e = d.documentElement,
				x = Math.max( e.scrollWidth, e.offsetWidth, e.clientWidth );
			return x;
		}

		function adsParseUrlParams( val ) {
			var result = false,
				tmp = [];
			var items = location.search.substr( 1 ).split( "&" );
			for ( var index = 0; index < items.length; index++ ) {
				tmp = items[ index ].split( "=" );
				if ( tmp[ 0 ] === val ) {
					result = decodeURIComponent( tmp[ 1 ] );
				}
			}
			return result;
		}

		function getCookie(name) {
			var matches = document.cookie.match(new RegExp(
				"(?:^|; )" + name.replace(/([\.$?*|{}\(\)\[\]\\\/\+^])/g, '\\$1') + "=([^;]*)"
			));
			return matches ? decodeURIComponent(matches[1]) : undefined;
		}

		function setCookie(name, value, options) {
			options = options || {};

			var expires = options.expires;

			if (typeof expires == "number" && expires) {
				var d = new Date();
				d.setTime(d.getTime() + expires * 1000);
				expires = options.expires = d;
			}
			if (expires && expires.toUTCString) {
				options.expires = expires.toUTCString();
			}

			value = encodeURIComponent(value);

			var updatedCookie = name + "=" + value;

			for (var propName in options) {
				updatedCookie += "; " + propName;
				var propValue = options[propName];
				if (propValue !== true) {
					updatedCookie += "=" + propValue;
				}
			}

			document.cookie = updatedCookie;
		}

		function amiGetCookie( name ) {
			return getCookie(name);
		}

		window.gptNetwork = '/4216/ami.itw/';
		window.pageID = '452328';
		window.keyword = 'post';
		window.cType = 'Article';
		window.category = 'news';
		window.topic = 'kim-kardashian-11902,pete-davidson';

		var spons = "no";

		window.adsRefresh = {};
		window.adsRefresh.impr = [];
		window.adsRefresh.ads = [];
	</script>    	<script type="text/plain" class="optanon-category-C0004" async src="https://securepubads.g.doubleclick.net/tag/js/gpt.js"></script>
	<script type="text/plain" class="optanon-category-C0004" async src="https://cdn.adsafeprotected.com/iasPET.1.js "></script>
	<script type="text/plain" class="optanon-category-C0004" async src="https://c.amazon-adsystem.com/aax2/apstag.js"></script>
			<script type="text/plain" class="optanon-category-C0004" src="//d3jdulus8lb392.cloudfront.net/ami/intouch-weekly/main.js" async=""></script>
		<link rel="stylesheet" href="https://d3jdulus8lb392.cloudfront.net/ami/intouch-weekly/main.css">
	<script type="text/javascript">
window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/14.0.0\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/14.0.0\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/www.intouchweekly.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=6.0"}};
/*! This file is auto-generated */
!function(e,a,t){var n,r,o,i=a.createElement("canvas"),p=i.getContext&&i.getContext("2d");function s(e,t){var a=String.fromCharCode,e=(p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,e),0,0),i.toDataURL());return p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,t),0,0),e===i.toDataURL()}function c(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(o=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},r=0;r<o.length;r++)t.supports[o[r]]=function(e){if(!p||!p.fillText)return!1;switch(p.textBaseline="top",p.font="600 32px Arial",e){case"flag":return s([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])?!1:!s([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!s([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]);case"emoji":return!s([129777,127995,8205,129778,127999],[129777,127995,8203,129778,127999])}return!1}(o[r]),t.supports.everything=t.supports.everything&&t.supports[o[r]],"flag"!==o[r]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[o[r]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(e=t.source||{}).concatemoji?c(e.concatemoji):e.wpemoji&&e.twemoji&&(c(e.twemoji),c(e.wpemoji)))}(window,document,window._wpemojiSettings);
</script>
<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 0.07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<link rel='stylesheet' id='all-css-0' href='https://www.intouchweekly.com/_static/??-eJx9jcEKwjAQRH/IdJGqtAfxW+JmqdFNGjIbSv/eIgj24vHN8GZoKS5m1hYE9AQlCdGLSpJsOyjqV6lOZfK8dinmjoED/dO37pd3Es/ZPhfNFW1TzCCIr/wgUQ+LXKoAFCKMNofqFpsEV2YY3F1nfjnYqoLv7C1dj5dzP/bjcBreky5QRg==' type='text/css' media='all' />
<style id='global-styles-inline-css'>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</style>
<link rel='stylesheet' id='all-css-2' href='https://www.intouchweekly.com/_static/??-eJyNjkEOwjAMBD9EcCsgggPiKSh1rCYlcUrtCPX3FC5UggO3OezsLjxGg4WVWCFXM6baRxa45zWWbiBUgw4DAYqA6Jxou9AGVr4GyiTgcjSdqzSBEyEV6GpM/uOZyFoqhi9/tT+Qjg5vpm22J7hGRuiJaYpLVH7j3225+JqWmxLcRN55P78xcv+quORzaw87a5u9PT4BpfRovw==' type='text/css' media='all' />
<script type="text/javascript" src="https://www.intouchweekly.com/_static/??-eJzTLy/QzcxLzilNSS3WzwKiwtLUokoopZebmaeXVayjj0+Rbm5melFiSSpUsX2uraGZqbGlsaWFiUUWAK+/IjA=" ></script><link rel="https://api.w.org/" href="https://www.intouchweekly.com/wp-json/" /><link rel="alternate" type="application/json" href="https://www.intouchweekly.com/wp-json/wp/v2/posts/452328" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.intouchweekly.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://www.intouchweekly.com/wp-includes/wlwmanifest.xml" /> 
<meta name="generator" content="WordPress 6.0" />
<link rel='shortlink' href='https://wp.me/pa5Fxh-1TFC' />
<link rel="alternate" type="application/json+oembed" href="https://www.intouchweekly.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.intouchweekly.com%2Fposts%2Fkim-kardashian-hints-at-having-best-sex-with-pete-davidson%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://www.intouchweekly.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.intouchweekly.com%2Fposts%2Fkim-kardashian-hints-at-having-best-sex-with-pete-davidson%2F&#038;format=xml" />
<style type='text/css'>img#wpstats{display:none}</style>
			<script type="text/plain" class="optanon-category-C0004" async src="https://ovp.iris.tv/libs/context/iris-context.min.js"></script>
		<script>
			var irisToken = decodeURIComponent( "H3P3EPZRWRKIIFW" );
			// Initialize Iris Context API
			window.addEventListener('IrisContextAPI', function() {
				window.irisContext = window.IrisContextAPI({
					client_token: irisToken,
				});
			});
		</script>
			<script type="text/plain" class="optanon-category-C0004" async src="//js-sec.indexww.com/ht/p/183518-190707627379353.js"></script>
	<script>
		var headertag = headertag || {};
		headertag.cmd = headertag.cmd || [];
	</script>
	<meta property="og:updated_time" content="2022-06-01T19:38:05+00:00" />
<meta property="og:image" content="https://www.intouchweekly.com/wp-content/uploads/2022/06/Kim-pete-IT-featured.jpg?crop=0px%2C48px%2C2276px%2C1194px&#038;resize=1200%2C630&#038;quality=86&#038;strip=all" />
<meta property="og:image:secure_url" content="https://www.intouchweekly.com/wp-content/uploads/2022/06/Kim-pete-IT-featured.jpg?crop=0px%2C48px%2C2276px%2C1194px&#038;resize=1200%2C630&#038;quality=86&#038;strip=all" />
<meta property="og:image:width" content="1200" />
<meta property="og:image:height" content="630" />
	<script>
		/**
		 * Will resolve when amazon is loaded on DOM
		 * * @return {Promise}
		 */
		const waitForAmazon = new Promise((resolve, reject) => {
			amzn_check(resolve, 100, 50 );
			setTimeout(resolve, 5000);
		});

		function amzn_check(resolve, interval, retriesLeft) {
			if ( typeof window.apstag == 'object' && window.apstag ) {
				console.log( 'AMI jwp - Amazon loaded' );
				return resolve();
			}

			if ( --retriesLeft > 0 ) {
				if ( typeof window.apstag != 'object' && !window.apstag ) {
					setTimeout( function(){ amzn_check( resolve, interval, retriesLeft ); }, interval );
					console.log( 'AMI jwp Amazon not loaded ' );
				}
			} else {
				console.log( 'AMI jwp No Retries left - Amazon not loaded' );
				return resolve();
			}
		}


		window.jwVastTag = {};
		window.prerollTag = {};
		window.jwpDef = {};
		window.jwpBids = {};
	</script>
	<link rel="amphtml" href="https://www.intouchweekly.com/posts/kim-kardashian-hints-at-having-best-sex-with-pete-davidson/amp/"><link rel="icon" href="https://www.intouchweekly.com/wp-content/uploads/2020/11/android-chrome-192x192-1.jpeg?fit=32%2C32&#038;quality=86&#038;strip=all" sizes="32x32" />
<link rel="icon" href="https://www.intouchweekly.com/wp-content/uploads/2020/11/android-chrome-192x192-1.jpeg?fit=192%2C192&#038;quality=86&#038;strip=all" sizes="192x192" />
<link rel="apple-touch-icon" href="https://www.intouchweekly.com/wp-content/uploads/2020/11/android-chrome-192x192-1.jpeg?fit=180%2C180&#038;quality=86&#038;strip=all" />
<meta name="msapplication-TileImage" content="https://www.intouchweekly.com/wp-content/uploads/2020/11/android-chrome-192x192-1.jpeg?fit=192%2C192&#038;quality=86&#038;strip=all" />
			<!-- Google Tag Manager -->
			<script>( function( w, d, s, l, i ) {
					w[l] = w[l] || [];
					w[l].push( {
						'gtm.start':
							new Date().getTime(), event: 'gtm.js'
					} );
					var f = d.getElementsByTagName( s )[0],
						j = d.createElement( s ), dl = l != 'dataLayer' ? '&l=' + l : '';
					j.async = true;
					j.src =
						'https://www.googletagmanager.com/gtm.js?id=' + i + dl + "";
					f.parentNode.insertBefore( j, f );
				} )( window, document, 'script', 'dataLayer', "GTM-KRVDT6T");</script>		<!-- End Google Tag Manager -->
				<script>
		var gtm_lock = setTimeout( function() {
			if ( "undefined" === typeof OnetrustActiveGroups || OnetrustActiveGroups.indexOf( ',C0002,' ) || OnetrustActiveGroups.indexOf( ',C0003,' ) || OnetrustActiveGroups.indexOf( ',C0004,' ) ) {
				window.dataLayer = window.dataLayer || [];
				dataLayer.push( {event: 'delayed_load'} );
			}
		}, 5000 );

		window.addEventListener( 'load', function( event ) {
			if ( "undefined" === typeof OnetrustActiveGroups || OnetrustActiveGroups.indexOf( ',C0002,' ) || OnetrustActiveGroups.indexOf( ',C0003,' ) || OnetrustActiveGroups.indexOf( ',C0004,' ) ) {
				window.dataLayer = window.dataLayer || [];
				dataLayer.push( {event: 'delayed_load'} );
				clearTimeout( gtm_lock );
			}
		} );

	</script>
	<style type="text/css" id="wp-custom-css">/* Hide total on search page */
.search__total {
	display: none;
}

/* Fix for sharethrough units */
.post-content .dfp-slot[class*='sh-gal'] {
	margin: 30px auto 40px;
}

/* Center mobile ads */
.ds_cpp,
.dfp-wrapper.mobile-only {
	margin-left: auto;
	margin-right: auto;
}

/* Gallery slide caption text */
.list-gallery .gallery-item__caption {
	font-size: 18px;
  font-size: 1.125rem;
	line-height: 1.2;
}

/* Fix for SpotIm huge widget on mobile */
@media screen and (max-width: 1023px) {
	#comments-wrapper {
		max-width: 100vw;
	}
}</style>
		
    </head>

<body class="post-template-default single single-post postid-452328 single-format-standard">
	<svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 0 0" width="0" height="0" focusable="false" role="none" style="visibility: hidden; position: absolute; left: -9999px; overflow: hidden;" ><defs><filter id="wp-duotone-dark-grayscale"><feColorMatrix color-interpolation-filters="sRGB" type="matrix" values=" .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 " /><feComponentTransfer color-interpolation-filters="sRGB" ><feFuncR type="table" tableValues="0 0.49803921568627" /><feFuncG type="table" tableValues="0 0.49803921568627" /><feFuncB type="table" tableValues="0 0.49803921568627" /><feFuncA type="table" tableValues="1 1" /></feComponentTransfer><feComposite in2="SourceGraphic" operator="in" /></filter></defs></svg><svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 0 0" width="0" height="0" focusable="false" role="none" style="visibility: hidden; position: absolute; left: -9999px; overflow: hidden;" ><defs><filter id="wp-duotone-grayscale"><feColorMatrix color-interpolation-filters="sRGB" type="matrix" values=" .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 " /><feComponentTransfer color-interpolation-filters="sRGB" ><feFuncR type="table" tableValues="0 1" /><feFuncG type="table" tableValues="0 1" /><feFuncB type="table" tableValues="0 1" /><feFuncA type="table" tableValues="1 1" /></feComponentTransfer><feComposite in2="SourceGraphic" operator="in" /></filter></defs></svg><svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 0 0" width="0" height="0" focusable="false" role="none" style="visibility: hidden; position: absolute; left: -9999px; overflow: hidden;" ><defs><filter id="wp-duotone-purple-yellow"><feColorMatrix color-interpolation-filters="sRGB" type="matrix" values=" .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 " /><feComponentTransfer color-interpolation-filters="sRGB" ><feFuncR type="table" tableValues="0.54901960784314 0.98823529411765" /><feFuncG type="table" tableValues="0 1" /><feFuncB type="table" tableValues="0.71764705882353 0.25490196078431" /><feFuncA type="table" tableValues="1 1" /></feComponentTransfer><feComposite in2="SourceGraphic" operator="in" /></filter></defs></svg><svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 0 0" width="0" height="0" focusable="false" role="none" style="visibility: hidden; position: absolute; left: -9999px; overflow: hidden;" ><defs><filter id="wp-duotone-blue-red"><feColorMatrix color-interpolation-filters="sRGB" type="matrix" values=" .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 " /><feComponentTransfer color-interpolation-filters="sRGB" ><feFuncR type="table" tableValues="0 1" /><feFuncG type="table" tableValues="0 0.27843137254902" /><feFuncB type="table" tableValues="0.5921568627451 0.27843137254902" /><feFuncA type="table" tableValues="1 1" /></feComponentTransfer><feComposite in2="SourceGraphic" operator="in" /></filter></defs></svg><svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 0 0" width="0" height="0" focusable="false" role="none" style="visibility: hidden; position: absolute; left: -9999px; overflow: hidden;" ><defs><filter id="wp-duotone-midnight"><feColorMatrix color-interpolation-filters="sRGB" type="matrix" values=" .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 " /><feComponentTransfer color-interpolation-filters="sRGB" ><feFuncR type="table" tableValues="0 0" /><feFuncG type="table" tableValues="0 0.64705882352941" /><feFuncB type="table" tableValues="0 1" /><feFuncA type="table" tableValues="1 1" /></feComponentTransfer><feComposite in2="SourceGraphic" operator="in" /></filter></defs></svg><svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 0 0" width="0" height="0" focusable="false" role="none" style="visibility: hidden; position: absolute; left: -9999px; overflow: hidden;" ><defs><filter id="wp-duotone-magenta-yellow"><feColorMatrix color-interpolation-filters="sRGB" type="matrix" values=" .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 " /><feComponentTransfer color-interpolation-filters="sRGB" ><feFuncR type="table" tableValues="0.78039215686275 1" /><feFuncG type="table" tableValues="0 0.94901960784314" /><feFuncB type="table" tableValues="0.35294117647059 0.47058823529412" /><feFuncA type="table" tableValues="1 1" /></feComponentTransfer><feComposite in2="SourceGraphic" operator="in" /></filter></defs></svg><svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 0 0" width="0" height="0" focusable="false" role="none" style="visibility: hidden; position: absolute; left: -9999px; overflow: hidden;" ><defs><filter id="wp-duotone-purple-green"><feColorMatrix color-interpolation-filters="sRGB" type="matrix" values=" .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 " /><feComponentTransfer color-interpolation-filters="sRGB" ><feFuncR type="table" tableValues="0.65098039215686 0.40392156862745" /><feFuncG type="table" tableValues="0 1" /><feFuncB type="table" tableValues="0.44705882352941 0.4" /><feFuncA type="table" tableValues="1 1" /></feComponentTransfer><feComposite in2="SourceGraphic" operator="in" /></filter></defs></svg><svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 0 0" width="0" height="0" focusable="false" role="none" style="visibility: hidden; position: absolute; left: -9999px; overflow: hidden;" ><defs><filter id="wp-duotone-blue-orange"><feColorMatrix color-interpolation-filters="sRGB" type="matrix" values=" .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 " /><feComponentTransfer color-interpolation-filters="sRGB" ><feFuncR type="table" tableValues="0.098039215686275 1" /><feFuncG type="table" tableValues="0 0.66274509803922" /><feFuncB type="table" tableValues="0.84705882352941 0.41960784313725" /><feFuncA type="table" tableValues="1 1" /></feComponentTransfer><feComposite in2="SourceGraphic" operator="in" /></filter></defs></svg>			<!-- Google Tag Manager (noscript) -->
			<noscript>
				<iframe src="https://www.googletagmanager.com/ns.html?id=GTM-KRVDT6T" height="0" width="0" style="display:none;visibility:hidden"></iframe>
			</noscript>		<!-- End Google Tag Manager (noscript) -->
					<div id="page-box">
		<header id="header" class="header">
							<div class="desktop-only color__variation">
					<div class="color__variation-first"></div>
					<div class="color__variation-second"></div>
					<div class="color__variation-third"></div>
				</div>
						<div class="header__mobile">
				<div class="extended-menu-btn desktop-hidden">
					<div id="menu-trigger">
						<span></span><span></span><span></span>
						<div class="hidden-except-readers">Open main menu button</div>
					</div>
				</div>
				<a href="https://www.intouchweekly.com" class="container__full-block  header__logo">
											<svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 423.8 106.6" class="site-logo"><defs></defs><path class="cls-1" d="M170.1 63.9v-.6c0-13 5.6-21.6 14.2-21.6s14 8.4 14 22.4c0 12.9-5.5 21.3-14 21.3-8.7-.1-13.9-8-14.2-21.5m-21.2-.2c.8 24.9 14.1 39.5 35.3 39.5 21 0 35.5-16.2 35.5-40s-14.4-39.8-35.5-39.8-35.3 16.2-35.3 39.8zM29.6 26.8h17.1L71 65.4V26.8h19.5v74H73.3L49.8 64.7v36.1H29.6v-74z"/><path class="cls-1" d="M123 23.5H98.5l-3-20.2h77.7l-2.9 20.2h-24.5v77.3H123V23.5zM359.6 75.3c-4.2 18.3-15 27-32.9 27-12.9 0-21.1-3.2-27.3-11.5-5.4-7.1-7.9-15.7-7.9-26.9 0-24.4 12.8-38.9 34.4-38.9 18.4 0 28.6 8 33.1 26.1l-20.2 3.4c-1.6-7.4-6-11.5-12.2-11.5-8.7 0-13.8 7.7-13.8 21s5 20.7 13.7 20.7c6.7 0 10.7-4 12.9-12.6zM362.2 26.7h19.9v27.5h18.5V26.7h19.9v74.1h-19.8V69.6h-18.5v31.2h-20V26.7zM26.4 100.8H3.3V28.9A16.2 16.2 0 0 0 15 34.4a15.6 15.6 0 0 0 11.4-5.2z"/><path class="cls-1" d="M26.4 24.7c-3 3.6-7 5.9-11.4 5.9a14.67 14.67 0 0 1-11.7-6.3V3.5h23.2v21.2zM274.1 26.7h-7.7V73a10.9 10.9 0 0 1-21.8 0V26.7h-21.1v47c0 7.2.8 12.4 2.8 16.9 3.1 7.1 10.1 11.4 18.1 11.4 9.7 0 17.1-4 23.4-12.8v11.5h19.5v-74z"/></svg>
									</a>
				<div class="header__search">
					<div class="header-mylo__mobile">
						<a class="mylo-signin__mobile" href="https://www.mylo.id/login?client_id=6628dtuhkmdqca1squ18er2cq4&#038;redirect_uri=https://www.intouchweekly.com/auth/login">
							<span>Login</span>
						</a>
					</div>
					<a class="header__text-subscribe" href="https://w1.buysub.com/servlet/OrdersGateway?cds_mag_code=NTW&#038;cds_page_id=230030" target="blank" rel="nofollow">
						SUBSCRIBE
					</a>
										<svg class="header__search-icon">
						<use xlink:href="#icon-search"/>
					</svg>
					<div class="search__close-icon">
						<span></span><span></span>
					</div>
				</div>
				<div class="search-box">
					<form role="search" method="get" action="/search-results/">
						<input type="search" name="_s" placeholder="Search..." required value="">
						<button type="submit"><svg><use xlink:href="#icon-search"/></svg></button>
					</form>
				</div>
			</div>
			<div id="mobile-nav" class="container__full">
									<div class="color-line">
						<div class="color-line-one"></div>
						<div class="color-line-two"></div>
						<div class="color-line-three"></div>
					</div>
								<nav class="container__full-block header-nav-primary__wrapper" role="navigation"
					 aria-label="Header Primary Nav">
					<div class="header-nav-primary ae-exclude">
						<ul id="menu-main-redesign-menu" class="site-header__main-nav__list"><li id="menu-item-258605" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-258605 site-header__main-nav__list__item"><a href="https://www.intouchweekly.com/posts/category/news/">News</a></li>
<li id="menu-item-258606" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-258606 site-header__main-nav__list__item"><a href="https://www.intouchweekly.com/posts/category/reality-tv/">Reality TV</a></li>
<li id="menu-item-372340" class="menu-item--new menu-item menu-item-type-post_type menu-item-object-page menu-item-372340 site-header__main-nav__list__item"><a href="https://www.intouchweekly.com/sampler/">Top Picks</a></li>
<li id="menu-item-258607" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-258607 site-header__main-nav__list__item"><a href="https://www.intouchweekly.com/posts/category/true-crime/">True Crime</a></li>
<li id="menu-item-258609" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-258609 site-header__main-nav__list__item"><a href="https://www.intouchweekly.com/posts/category/entertainment/">Entertainment</a></li>
<li id="menu-item-258610" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-258610 site-header__main-nav__list__item"><a href="https://www.intouchweekly.com/posts/category/omg/">OMG!</a></li>
<li id="menu-item-258611" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-258611 site-header__main-nav__list__item"><a href="https://www.intouchweekly.com/posts/category/style/">Style</a></li>
<li id="menu-item-261937" class="desktop-hidden menu-item menu-item-type-custom menu-item-object-custom menu-item-261937 site-header__main-nav__list__item"><a href="https://shop.getspecialissues.com/">Shop Special Issues</a></li>
<li id="menu-item-261938" class="desktop-hidden menu-item menu-item-type-custom menu-item-object-custom menu-item-261938 site-header__main-nav__list__item"><a href="https://a360media.com/privacy-policy">Privacy Policy</a></li>
<li id="menu-item-261940" class="desktop-hidden menu-item menu-item-type-custom menu-item-object-custom menu-item-261940 site-header__main-nav__list__item"><a href="https://a360media.com/terms-and-conditions">Terms &#038; Conditions</a></li>
</ul>					</div>
				</nav>
				<a href="https://www.intouchweekly.com" class="container__full-block  header__logo desktop-l-only">
											<svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 423.8 106.6" class="site-logo"><defs></defs><path class="cls-1" d="M170.1 63.9v-.6c0-13 5.6-21.6 14.2-21.6s14 8.4 14 22.4c0 12.9-5.5 21.3-14 21.3-8.7-.1-13.9-8-14.2-21.5m-21.2-.2c.8 24.9 14.1 39.5 35.3 39.5 21 0 35.5-16.2 35.5-40s-14.4-39.8-35.5-39.8-35.3 16.2-35.3 39.8zM29.6 26.8h17.1L71 65.4V26.8h19.5v74H73.3L49.8 64.7v36.1H29.6v-74z"/><path class="cls-1" d="M123 23.5H98.5l-3-20.2h77.7l-2.9 20.2h-24.5v77.3H123V23.5zM359.6 75.3c-4.2 18.3-15 27-32.9 27-12.9 0-21.1-3.2-27.3-11.5-5.4-7.1-7.9-15.7-7.9-26.9 0-24.4 12.8-38.9 34.4-38.9 18.4 0 28.6 8 33.1 26.1l-20.2 3.4c-1.6-7.4-6-11.5-12.2-11.5-8.7 0-13.8 7.7-13.8 21s5 20.7 13.7 20.7c6.7 0 10.7-4 12.9-12.6zM362.2 26.7h19.9v27.5h18.5V26.7h19.9v74.1h-19.8V69.6h-18.5v31.2h-20V26.7zM26.4 100.8H3.3V28.9A16.2 16.2 0 0 0 15 34.4a15.6 15.6 0 0 0 11.4-5.2z"/><path class="cls-1" d="M26.4 24.7c-3 3.6-7 5.9-11.4 5.9a14.67 14.67 0 0 1-11.7-6.3V3.5h23.2v21.2zM274.1 26.7h-7.7V73a10.9 10.9 0 0 1-21.8 0V26.7h-21.1v47c0 7.2.8 12.4 2.8 16.9 3.1 7.1 10.1 11.4 18.1 11.4 9.7 0 17.1-4 23.4-12.8v11.5h19.5v-74z"/></svg>
									</a>

									<div class="header__tools">
								<div class="header__close">
					<div id="menu-trigger-close" class="desktop-hidden">
						<span></span><span></span>
					</div>
				</div>
				<div class="header__search">
					<svg class="header__search-icon desktop-l-only">
						<use xlink:href="#icon-search"/>
					</svg>
					<div class="search__close-icon">
						<span></span><span></span>
					</div>
					<div class="search-box">
						<form role="search" method="get" action="/search-results/">
							<input type="search" name="_s" placeholder="Search..." required value="">
							<button type="submit"><svg><use xlink:href="#icon-search"/></svg></button>
						</form>
					</div>
				</div>
                <div class="header__accessibility desktop-l-only">
                    <a href="/accessibility-statement/" target="_blank">
                        <svg class="header__accessibility-icon">
                            <use xlink:href="#icon-accessibility"/>
                        </svg>
                    </a>
                </div>
				<ul class="header__icons">
					<li class="cookies-dropdown__wrapper desktop-l-only">
						<span class="cookies-dropdown__trigger"><svg class="cookies-dropdown__icon"><use xlink:href="#icon-cookie"></use></svg></span>
						<ul class="cookies-dropdown__list">
							<li class="cookies-dropdown__item">
								<a href="https://a360media.com/privacy-policy/" target="_blank">Privacy Policy</a>
							</li>
							<li class="cookies-dropdown__item">
								<a href="https://a360media.com/cookie-policy/" target="_blank">Cookie Policy</a>
							</li>

							<li class="cookies-dropdown__item">
								<!-- OneTrust Cookies Settings button start -->
								<a class="optanon-toggle-display" name="Manage Cookies">Manage Cookies</a>
								<!-- OneTrust Cookies Settings button end -->
							</li>

						</ul>
					</li>

					<li class="header__icons-accessibility desktop-hidden">
                        <a class="header__icons-icon" href="/accessibility-statement/" target="_blank">
                            <svg class="icon-accessibility__icon"><use xlink:href="#icon-accessibility"></use></svg>
                        </a>
                    </li>

					<li class="cookies-icon__mobile">
						<!-- OneTrust Cookies Settings button start -->
						<a class="optanon-toggle-display">
							<svg class="cookies-mobile__icon"><use xlink:href="#icon-cookie"></use></svg>
						</a>
						<!-- OneTrust Cookies Settings button end -->
					</li>

					<li><a href="http://www.facebook.com/InTouchWeekly" class="header__icons-icon" rel="nofollow"> <span class="hidden-except-readers">Social icon facebook</span><svg class="icon icon-facebook"><use xlink:href="#icon-facebook-b"></use></svg></a></li><li><a href="https://www.instagram.com/intouchweekly/?hl=en" class="header__icons-icon" rel="nofollow"> <span class="hidden-except-readers">Social icon instagram</span><svg class="icon icon-instagram"><use xlink:href="#icon-instagram-b"></use></svg></a></li><li><a href="https://twitter.com/intouchweekly" class="header__icons-icon" rel="nofollow"> <span class="hidden-except-readers">Social icon twitter</span><svg class="icon icon-twitter"><use xlink:href="#icon-twitter-b"></use></svg></a></li>				</ul>
				<div class="header__text">
										<a class="header__text-subscribe" href="https://w1.buysub.com/servlet/OrdersGateway?cds_mag_code=NTW&#038;cds_page_id=230030" target="blank" rel="nofollow">
						SUBSCRIBE <span >NOW!</span>
					</a>
											<a class="header__text-pay" href="#" id="send-scoop-trigger">WE PAY FOR SCOOPS</a>
										<div class="header-mylo">
						<a class="header-mylo__signin" href="https://www.mylo.id/login?client_id=6628dtuhkmdqca1squ18er2cq4&#038;redirect_uri=https://www.intouchweekly.com/auth/login">
							<svg class="header-mylo__signin-icon"><use xlink:href="#icon-signin"></use></svg>
							<span>Login</span>
						</a>
					</div>
				</div>
									</div>
									<!--  Send us a scoop popup	-->
					<div class="send-scoop__container" id="send-scoop-popup">
						<div class="page-wrapper">
							<div class="send-scoop__close-btn" id="send-scoop-close"><span class="hidden-except-readers">Got a Hot tip form close button</span></div>
							<h2 class="send-scoop__title">Send us a scoop!</h2>
							<form id="send-scoop__form" class="send-scoop__form" novalidate="novalidate">
								<input type="hidden" name="action" value="ok_tip_form">
								<div class="sender-info">
									<div class="field-container">
										<label for="scoop-form-name" class="hidden-except-readers">Input your name</label> <input placeholder="Your name..." type="text" name="name" value="" required="required" aria-required="true" id="scoop-form-name">
									</div>
									<div class="field-container">
										<label for="scoop-form-email" class="hidden-except-readers">Input your email</label> <input placeholder="Your email..." type="email" name="email" value="" required="required" aria-required="true" id="scoop-form-email">
									</div>
									<div class="field-container">
										<label for="scoop-form-phone" class="hidden-except-readers">Input your phone number</label> <input placeholder="Your phone number..." type="text" name="phone" value="" required="required" aria-required="true" id="scoop-form-phone">
									</div>
									<div class="sender-msg">
										<label for="scoop-message" class="hidden-except-readers">Enter scoop message here</label> <textarea placeholder="The Scoop..." name="tip" required="required" aria-required="true" id="scoop-message"></textarea>
									</div>
									<button type="submit" class="send-scoop__submit" id="scoop-form-send-btn" value="scoop-form-send-btn">SEND THE GOODS!</button>
								</div>
							</form>
						</div>
					</div>
							</div>

		</header>
		<!-- First big banner block -->
		<div class="ad-slot-top banner first mobile-hidden">
			<div class="ad-container horizontal">
				<div class="dfp-wrapper  mobile-hidden" data-slot="leader1"><div id="leader1" class="dfp-slot dfp-container leader1 "></div></div>			</div>
		</div>
		<div class="l-container">
		<div class="l-grid__post">
			<div class="l-grid__post-content">
				
<div class="l-grid__main-post">
	<div class="l-grid__main-post_content">
		
					<header class="post-header__wrapper">
				<div class="post-header__inner">
																	<figure class="post-hero">
														<div style="padding-bottom:56.276595744681%;" class="ratio-based-placeholder"><img src="https://www.intouchweekly.com/wp-content/uploads/2022/06/Kim-pete-IT-featured.jpg?crop=0px%2C48px%2C2276px%2C1291px&#038;resize=940%2C529&#038;quality=86&#038;strip=all" srcset="https://www.intouchweekly.com/wp-content/uploads/2022/06/Kim-pete-IT-featured.jpg?crop=0px%2C48px%2C2276px%2C1291px&amp;resize=120%2C68&amp;quality=86&amp;strip=all 120w, https://www.intouchweekly.com/wp-content/uploads/2022/06/Kim-pete-IT-featured.jpg?crop=0px%2C48px%2C2276px%2C1291px&amp;resize=230%2C129&amp;quality=86&amp;strip=all 230w, https://www.intouchweekly.com/wp-content/uploads/2022/06/Kim-pete-IT-featured.jpg?crop=0px%2C48px%2C2276px%2C1291px&amp;resize=408%2C230&amp;quality=86&amp;strip=all 408w, https://www.intouchweekly.com/wp-content/uploads/2022/06/Kim-pete-IT-featured.jpg?crop=0px%2C48px%2C2276px%2C1291px&amp;resize=480%2C270&amp;quality=86&amp;strip=all 480w, https://www.intouchweekly.com/wp-content/uploads/2022/06/Kim-pete-IT-featured.jpg?crop=0px%2C48px%2C2276px%2C1291px&amp;resize=630%2C354&amp;quality=86&amp;strip=all 630w, https://www.intouchweekly.com/wp-content/uploads/2022/06/Kim-pete-IT-featured.jpg?crop=0px%2C48px%2C2276px%2C1291px&amp;resize=940%2C529&amp;quality=86&amp;strip=all 940w, https://www.intouchweekly.com/wp-content/uploads/2022/06/Kim-pete-IT-featured.jpg?crop=0px%2C48px%2C2276px%2C1291px&amp;resize=960%2C540&amp;quality=86&amp;strip=all 960w, https://www.intouchweekly.com/wp-content/uploads/2022/06/Kim-pete-IT-featured.jpg?crop=0px%2C48px%2C2276px%2C1291px&amp;resize=1200%2C675&amp;quality=86&amp;strip=all 1200w, https://www.intouchweekly.com/wp-content/uploads/2022/06/Kim-pete-IT-featured.jpg?crop=0px%2C48px%2C2276px%2C1291px&amp;resize=1260%2C709&amp;quality=86&amp;strip=all 1260w, https://www.intouchweekly.com/wp-content/uploads/2022/06/Kim-pete-IT-featured.jpg?crop=0px%2C48px%2C2276px%2C1291px&amp;resize=1920%2C1080&amp;quality=86&amp;strip=all 1920w" sizes="(max-width: 600px) 100vw, 940px" alt="Kim Kardashian Seemingly Reveals That She&#039;s Having the &#039;Best Sex&#039; With Pete Davidson" data-fallback-img="https://www.intouchweekly.com/wp-content/uploads/2022/06/Kim-pete-IT-featured.jpg?fit=2276%2C2743&#038;quality=86&#038;strip=all" width="940" height="529"></div>															<p class="photo-credit">Matt Baron/Shutterstock</p>
													</figure>
						
					
<div class="post-header">
	<h1 class="post-header__title">Kim Kardashian Seemingly Reveals She&#8217;s Having the &#8216;Best Sex&#8217; With Pete Davidson</h1>
	</div>

<div class="post-meta">
	
<div class="post-meta__category">
				<a class="article_category" href="https://www.intouchweekly.com/posts/category/news/">News</a>
	</div>
	<div class="post-meta__inner">
		
<div class="post-meta__inner-date">Jun 2, 2022 12:05 am<span class="divider-dot">· </span></div>
		    <div class="post-meta__inner-author"> By <span>
            <a href="https://www.intouchweekly.com/authors/in-touch-weekly-36933/" title="In Touch Staff" rel="author" class="">In Touch Staff</a>        </span>
    </div>
    	</div>
</div>
				</div>

				<div class="post-header__sidebar">
					
<div class="post-sidebar__pictures">
	<div class="post-sidebar__header">
					<svg><use xlink:href="#icon-in-logo" /></svg>
							<span>Top stories</span>
			</div>

			<div class="post-sidebar__grid">
							<article class="article__item">

					<a class="article__item-thumbnail" href="https://www.intouchweekly.com/posts/octomom-nadya-sulemans-kids-today-see-her-14-children-now/">
																					<div class="gallery-icon gallery__block-icon"><svg><use xlink:href="#icon-photos" /></svg></div>
														<figure class="article__item-figure">
								<div class="item__figure-source ok-thumb ok-standard-thumb">
									<div style="padding-bottom:100%;" class="ratio-based-placeholder"><img src="https://www.intouchweekly.com/wp-content/themes/ami-bauer/assets/build/images/placeholders/placeholder-1x1.svg" data-src="https://www.intouchweekly.com/wp-content/uploads/2020/01/Octomom-Nadya-Suleman-Children.jpg?resize=90%2C90&#038;quality=86&#038;strip=all" data-srcset="https://www.intouchweekly.com/wp-content/uploads/2020/01/Octomom-Nadya-Suleman-Children.jpg?resize=90%2C90&amp;quality=86&amp;strip=all 90w, https://www.intouchweekly.com/wp-content/uploads/2020/01/Octomom-Nadya-Suleman-Children.jpg?resize=180%2C180&amp;quality=86&amp;strip=all 180w, https://www.intouchweekly.com/wp-content/uploads/2020/01/Octomom-Nadya-Suleman-Children.jpg?resize=300%2C300&amp;quality=86&amp;strip=all 300w, https://www.intouchweekly.com/wp-content/uploads/2020/01/Octomom-Nadya-Suleman-Children.jpg?resize=408%2C408&amp;quality=86&amp;strip=all 408w, https://www.intouchweekly.com/wp-content/uploads/2020/01/Octomom-Nadya-Suleman-Children.jpg?resize=600%2C600&amp;quality=86&amp;strip=all 600w, https://www.intouchweekly.com/wp-content/uploads/2020/01/Octomom-Nadya-Suleman-Children.jpg?resize=816%2C816&amp;quality=86&amp;strip=all 816w" sizes="(min-width: 1024px) 90px, 300px" alt="Octomom Nadya Suleman Children" data-fallback-img="https://www.intouchweekly.com/wp-content/uploads/2020/01/Octomom-Nadya-Suleman-Children.jpg?fit=2000%2C993&#038;quality=86&#038;strip=all" width="90" height="90"></div>								</div>
							</figure>
											</a>

					<h2 class="article__item-title">
						<a href="https://www.intouchweekly.com/posts/octomom-nadya-sulemans-kids-today-see-her-14-children-now/">'Octomom' Nadya Suleman Is a Proud Mom of 14: See Her Kids Today!</a>
					</h2>

				</article>
							<article class="article__item">

					<a class="article__item-thumbnail" href="https://www.intouchweekly.com/posts/duggar-kids-houses-154627/">
																					<div class="gallery-icon gallery__block-icon"><svg><use xlink:href="#icon-photos" /></svg></div>
														<figure class="article__item-figure">
								<div class="item__figure-source ok-thumb ok-standard-thumb">
									<div style="padding-bottom:100%;" class="ratio-based-placeholder"><img src="https://www.intouchweekly.com/wp-content/themes/ami-bauer/assets/build/images/placeholders/placeholder-1x1.svg" data-src="https://www.intouchweekly.com/wp-content/uploads/2020/02/The-Duggar-Kids-Keep-Their-Houses-Messy-and-Gross-Photos.jpeg?crop=0px%2C0px%2C2400px%2C2400px&#038;resize=90%2C90&#038;quality=86&#038;strip=all" data-srcset="https://www.intouchweekly.com/wp-content/uploads/2020/02/The-Duggar-Kids-Keep-Their-Houses-Messy-and-Gross-Photos.jpeg?crop=0px%2C0px%2C2400px%2C2400px&amp;resize=90%2C90&amp;quality=86&amp;strip=all 90w, https://www.intouchweekly.com/wp-content/uploads/2020/02/The-Duggar-Kids-Keep-Their-Houses-Messy-and-Gross-Photos.jpeg?crop=0px%2C0px%2C2400px%2C2400px&amp;resize=180%2C180&amp;quality=86&amp;strip=all 180w, https://www.intouchweekly.com/wp-content/uploads/2020/02/The-Duggar-Kids-Keep-Their-Houses-Messy-and-Gross-Photos.jpeg?crop=0px%2C0px%2C2400px%2C2400px&amp;resize=300%2C300&amp;quality=86&amp;strip=all 300w, https://www.intouchweekly.com/wp-content/uploads/2020/02/The-Duggar-Kids-Keep-Their-Houses-Messy-and-Gross-Photos.jpeg?crop=0px%2C0px%2C2400px%2C2400px&amp;resize=408%2C408&amp;quality=86&amp;strip=all 408w, https://www.intouchweekly.com/wp-content/uploads/2020/02/The-Duggar-Kids-Keep-Their-Houses-Messy-and-Gross-Photos.jpeg?crop=0px%2C0px%2C2400px%2C2400px&amp;resize=600%2C600&amp;quality=86&amp;strip=all 600w, https://www.intouchweekly.com/wp-content/uploads/2020/02/The-Duggar-Kids-Keep-Their-Houses-Messy-and-Gross-Photos.jpeg?crop=0px%2C0px%2C2400px%2C2400px&amp;resize=816%2C816&amp;quality=86&amp;strip=all 816w, https://www.intouchweekly.com/wp-content/uploads/2020/02/The-Duggar-Kids-Keep-Their-Houses-Messy-and-Gross-Photos.jpeg?crop=0px%2C0px%2C2400px%2C2400px&amp;resize=1200%2C1200&amp;quality=86&amp;strip=all 1200w" sizes="(min-width: 1024px) 90px, 300px" alt="The Duggar Kids Keep Their Houses Messy and Gross Photos" data-fallback-img="https://www.intouchweekly.com/wp-content/uploads/2020/02/The-Duggar-Kids-Keep-Their-Houses-Messy-and-Gross-Photos.jpeg?fit=2400%2C2400&#038;quality=86&#038;strip=all" width="90" height="90"></div>								</div>
							</figure>
											</a>

					<h2 class="article__item-title">
						<a href="https://www.intouchweekly.com/posts/duggar-kids-houses-154627/">Is Every Duggar Ridiculously Messy? See the 'Counting On' Kids' Houses</a>
					</h2>

				</article>
							<article class="article__item">

					<a class="article__item-thumbnail" href="https://www.intouchweekly.com/posts/jen-arnold-and-bill-kleins-kids-little-couples-will-and-zoey-now/">
																					<div class="gallery-icon gallery__block-icon"><svg><use xlink:href="#icon-photos" /></svg></div>
														<figure class="article__item-figure">
								<div class="item__figure-source ok-thumb ok-standard-thumb">
									<div style="padding-bottom:100%;" class="ratio-based-placeholder"><img src="https://www.intouchweekly.com/wp-content/themes/ami-bauer/assets/build/images/placeholders/placeholder-1x1.svg" data-src="https://www.intouchweekly.com/wp-content/uploads/2021/02/The-Little-Couple-Jen-Arnold-Kids-With-Husband-Bill-William-and-Zoey.jpg?crop=0px%2C0px%2C1384px%2C1384px&#038;resize=90%2C90&#038;quality=86&#038;strip=all" data-srcset="https://www.intouchweekly.com/wp-content/uploads/2021/02/The-Little-Couple-Jen-Arnold-Kids-With-Husband-Bill-William-and-Zoey.jpg?crop=0px%2C0px%2C1384px%2C1384px&amp;resize=90%2C90&amp;quality=86&amp;strip=all 90w, https://www.intouchweekly.com/wp-content/uploads/2021/02/The-Little-Couple-Jen-Arnold-Kids-With-Husband-Bill-William-and-Zoey.jpg?crop=0px%2C0px%2C1384px%2C1384px&amp;resize=180%2C180&amp;quality=86&amp;strip=all 180w, https://www.intouchweekly.com/wp-content/uploads/2021/02/The-Little-Couple-Jen-Arnold-Kids-With-Husband-Bill-William-and-Zoey.jpg?crop=0px%2C0px%2C1384px%2C1384px&amp;resize=300%2C300&amp;quality=86&amp;strip=all 300w, https://www.intouchweekly.com/wp-content/uploads/2021/02/The-Little-Couple-Jen-Arnold-Kids-With-Husband-Bill-William-and-Zoey.jpg?crop=0px%2C0px%2C1384px%2C1384px&amp;resize=408%2C408&amp;quality=86&amp;strip=all 408w, https://www.intouchweekly.com/wp-content/uploads/2021/02/The-Little-Couple-Jen-Arnold-Kids-With-Husband-Bill-William-and-Zoey.jpg?crop=0px%2C0px%2C1384px%2C1384px&amp;resize=600%2C600&amp;quality=86&amp;strip=all 600w, https://www.intouchweekly.com/wp-content/uploads/2021/02/The-Little-Couple-Jen-Arnold-Kids-With-Husband-Bill-William-and-Zoey.jpg?crop=0px%2C0px%2C1384px%2C1384px&amp;resize=816%2C816&amp;quality=86&amp;strip=all 816w, https://www.intouchweekly.com/wp-content/uploads/2021/02/The-Little-Couple-Jen-Arnold-Kids-With-Husband-Bill-William-and-Zoey.jpg?crop=0px%2C0px%2C1384px%2C1384px&amp;resize=1200%2C1200&amp;quality=86&amp;strip=all 1200w" sizes="(min-width: 1024px) 90px, 300px" alt="The Little Couple Jen Arnold Kids With Husband Bill William and Zoey" data-fallback-img="https://www.intouchweekly.com/wp-content/uploads/2021/02/The-Little-Couple-Jen-Arnold-Kids-With-Husband-Bill-William-and-Zoey.jpg?fit=1384%2C2000&#038;quality=86&#038;strip=all" width="90" height="90"></div>								</div>
							</figure>
											</a>

					<h2 class="article__item-title">
						<a href="https://www.intouchweekly.com/posts/jen-arnold-and-bill-kleins-kids-little-couples-will-and-zoey-now/">Look How Much the Little Couple's Kids Will and Zoey Have Grown Up</a>
					</h2>

				</article>
							<article class="article__item">

					<a class="article__item-thumbnail" href="https://www.intouchweekly.com/posts/kardashian-jenner-family-2021-met-gala-outfits-and-photos/">
																					<div class="gallery-icon gallery__block-icon"><svg><use xlink:href="#icon-photos" /></svg></div>
														<figure class="article__item-figure">
								<div class="item__figure-source ok-thumb ok-standard-thumb">
									<div style="padding-bottom:100%;" class="ratio-based-placeholder"><img src="https://www.intouchweekly.com/wp-content/themes/ami-bauer/assets/build/images/placeholders/placeholder-1x1.svg" data-src="https://www.intouchweekly.com/wp-content/uploads/2021/09/Copy-of-Split-3.jpeg?resize=90%2C90&#038;quality=86&#038;strip=all" data-srcset="https://www.intouchweekly.com/wp-content/uploads/2021/09/Copy-of-Split-3.jpeg?resize=90%2C90&amp;quality=86&amp;strip=all 90w, https://www.intouchweekly.com/wp-content/uploads/2021/09/Copy-of-Split-3.jpeg?resize=180%2C180&amp;quality=86&amp;strip=all 180w, https://www.intouchweekly.com/wp-content/uploads/2021/09/Copy-of-Split-3.jpeg?resize=300%2C300&amp;quality=86&amp;strip=all 300w, https://www.intouchweekly.com/wp-content/uploads/2021/09/Copy-of-Split-3.jpeg?resize=408%2C408&amp;quality=86&amp;strip=all 408w, https://www.intouchweekly.com/wp-content/uploads/2021/09/Copy-of-Split-3.jpeg?resize=600%2C600&amp;quality=86&amp;strip=all 600w, https://www.intouchweekly.com/wp-content/uploads/2021/09/Copy-of-Split-3.jpeg?resize=816%2C816&amp;quality=86&amp;strip=all 816w, https://www.intouchweekly.com/wp-content/uploads/2021/09/Copy-of-Split-3.jpeg?resize=1200%2C1200&amp;quality=86&amp;strip=all 1200w" sizes="(min-width: 1024px) 90px, 300px" alt="kardashians at 2021 met gala red carpet" data-fallback-img="https://www.intouchweekly.com/wp-content/uploads/2021/09/Copy-of-Split-3.jpeg?fit=2000%2C2000&#038;quality=86&#038;strip=all" width="90" height="90"></div>								</div>
							</figure>
											</a>

					<h2 class="article__item-title">
						<a href="https://www.intouchweekly.com/posts/kardashian-jenner-family-2021-met-gala-outfits-and-photos/">Every Look From the Kardashian-Jenner Family at the 2021 Met Gala</a>
					</h2>

				</article>
							<article class="article__item">

					<a class="article__item-thumbnail" href="https://www.intouchweekly.com/posts/gabby-petitos-final-text-messages-with-mom-show-more-tension-with-brian-laundrie/">
																					<div class="video-icon video__block-icon"><svg><use xlink:href="#icon-video" /></svg></div>
														<figure class="article__item-figure">
								<div class="item__figure-source ok-thumb ok-standard-thumb">
									<div style="padding-bottom:100%;" class="ratio-based-placeholder"><img src="https://www.intouchweekly.com/wp-content/themes/ami-bauer/assets/build/images/placeholders/placeholder-1x1.svg" data-src="https://www.intouchweekly.com/wp-content/uploads/2021/09/Copy-of-Single-Bubble-Blue-12.jpeg?resize=90%2C90&#038;quality=86&#038;strip=all" data-srcset="https://www.intouchweekly.com/wp-content/uploads/2021/09/Copy-of-Single-Bubble-Blue-12.jpeg?resize=90%2C90&amp;quality=86&amp;strip=all 90w, https://www.intouchweekly.com/wp-content/uploads/2021/09/Copy-of-Single-Bubble-Blue-12.jpeg?resize=180%2C180&amp;quality=86&amp;strip=all 180w, https://www.intouchweekly.com/wp-content/uploads/2021/09/Copy-of-Single-Bubble-Blue-12.jpeg?resize=300%2C300&amp;quality=86&amp;strip=all 300w, https://www.intouchweekly.com/wp-content/uploads/2021/09/Copy-of-Single-Bubble-Blue-12.jpeg?resize=408%2C408&amp;quality=86&amp;strip=all 408w, https://www.intouchweekly.com/wp-content/uploads/2021/09/Copy-of-Single-Bubble-Blue-12.jpeg?resize=600%2C600&amp;quality=86&amp;strip=all 600w, https://www.intouchweekly.com/wp-content/uploads/2021/09/Copy-of-Single-Bubble-Blue-12.jpeg?resize=816%2C816&amp;quality=86&amp;strip=all 816w, https://www.intouchweekly.com/wp-content/uploads/2021/09/Copy-of-Single-Bubble-Blue-12.jpeg?resize=1200%2C1200&amp;quality=86&amp;strip=all 1200w" sizes="(min-width: 1024px) 90px, 300px" alt="gabby-petito-missing-final-text" data-fallback-img="https://www.intouchweekly.com/wp-content/uploads/2021/09/Copy-of-Single-Bubble-Blue-12.jpeg?fit=2400%2C2400&#038;quality=86&#038;strip=all" width="90" height="90"></div>								</div>
							</figure>
											</a>

					<h2 class="article__item-title">
						<a href="https://www.intouchweekly.com/posts/gabby-petitos-final-text-messages-with-mom-show-more-tension-with-brian-laundrie/">Gabby Petito's Texts Show 'More and More Tension' With Brian Laundrie</a>
					</h2>

				</article>
					</div>
	</div>
				</div>
			</header>
		
		<div class="post-content">
			<div class="dfp-wrapper ad_outer_med mobile-only" data-slot="mb1"><div id="mb1" class="dfp-slot dfp-container mb1 advertisement ad-in"></div></div>			<div class="dfp-wrapper  mobile-hidden" data-slot="leader-inline1"><div id="leader-inline1" class="dfp-slot dfp-container leader-inline1 "></div></div>
			<div class="track-ga">
				<p>Finally! <a href="https://www.intouchweekly.com/tags/kim-kardashian-11902/"><strong>Kim Kardashian</strong></a> spilled all the tea on her relationship with <a href="https://www.intouchweekly.com/tags/pete-davidson/"><strong>Pete Davidson</strong></a> during the Thursday, June 2, episode of <a href="https://www.intouchweekly.com/posts/kim-kardashian-jokes-about-a-fourth-wedding-amid-pete-romance/"><em>The Kardashians</em></a>.</p>
<p>In her confessional during the episode titled “Never Go Against the Family,” the Skims founder, 41, told producers that they “stalked” her “long enough,” so it was time for her to share <a href="https://www.lifeandstylemag.com/posts/kim-kardashian-was-dtf-pete-davidson-after-hearing-about-bde/">“how it went down with Pete.”</a></p>
<p>“I wasn’t even thinking, like, ‘Oh, my God, I’m gonna be in a relationship with him,'” Kim added. “I was just thinking, like … <a href="https://www.intouchweekly.com/posts/pete-davidson-net-worth-how-the-actor-makes-money/">I heard about this BDE</a>. [I] need to get out there. I need to just, like, jump start my … I was just basically DTF.”</p>
<div class="link-related link-related__with-thumb">
	<a href="https://www.intouchweekly.com/posts/kim-kardashian-not-wearing-a-bra-braless-photos-of-the-kuwtk-star/" target="_blank" data-track-category="Article Page" data-track-action="Tap Interstitial Link" data-track-label="https://www.intouchweekly.com/posts/kim-kardashian-not-wearing-a-bra-braless-photos-of-the-kuwtk-star/" class="link-related__link">
					<span class="link-related__image">
				<div style="padding-bottom:56.666666666667%;" class="ratio-based-placeholder"><img src="https://www.intouchweekly.com/wp-content/themes/ami-bauer/assets/build/images/placeholders/placeholder-16x9.svg" data-src="https://www.intouchweekly.com/wp-content/uploads/2021/07/Kim-Kardashian-Braless-Photos.jpeg?crop=0px%2C0px%2C2400px%2C1359px&amp;resize=120%2C68&amp;quality=86&amp;strip=all" data-srcset="https://www.intouchweekly.com/wp-content/uploads/2021/07/Kim-Kardashian-Braless-Photos.jpeg?crop=0px%2C0px%2C2400px%2C1359px&amp;resize=120%2C68&amp;quality=86&amp;strip=all 120w, https://www.intouchweekly.com/wp-content/uploads/2021/07/Kim-Kardashian-Braless-Photos.jpeg?crop=0px%2C0px%2C2400px%2C1359px&amp;resize=230%2C129&amp;quality=86&amp;strip=all 230w, https://www.intouchweekly.com/wp-content/uploads/2021/07/Kim-Kardashian-Braless-Photos.jpeg?crop=0px%2C0px%2C2400px%2C1359px&amp;resize=408%2C230&amp;quality=86&amp;strip=all 408w, https://www.intouchweekly.com/wp-content/uploads/2021/07/Kim-Kardashian-Braless-Photos.jpeg?crop=0px%2C0px%2C2400px%2C1359px&amp;resize=480%2C270&amp;quality=86&amp;strip=all 480w, https://www.intouchweekly.com/wp-content/uploads/2021/07/Kim-Kardashian-Braless-Photos.jpeg?crop=0px%2C0px%2C2400px%2C1359px&amp;resize=630%2C354&amp;quality=86&amp;strip=all 630w, https://www.intouchweekly.com/wp-content/uploads/2021/07/Kim-Kardashian-Braless-Photos.jpeg?crop=0px%2C0px%2C2400px%2C1359px&amp;resize=940%2C529&amp;quality=86&amp;strip=all 940w, https://www.intouchweekly.com/wp-content/uploads/2021/07/Kim-Kardashian-Braless-Photos.jpeg?crop=0px%2C0px%2C2400px%2C1359px&amp;resize=960%2C540&amp;quality=86&amp;strip=all 960w, https://www.intouchweekly.com/wp-content/uploads/2021/07/Kim-Kardashian-Braless-Photos.jpeg?crop=0px%2C0px%2C2400px%2C1359px&amp;resize=1200%2C675&amp;quality=86&amp;strip=all 1200w, https://www.intouchweekly.com/wp-content/uploads/2021/07/Kim-Kardashian-Braless-Photos.jpeg?crop=0px%2C0px%2C2400px%2C1359px&amp;resize=1260%2C709&amp;quality=86&amp;strip=all 1260w, https://www.intouchweekly.com/wp-content/uploads/2021/07/Kim-Kardashian-Braless-Photos.jpeg?crop=0px%2C0px%2C2400px%2C1359px&amp;resize=1920%2C1080&amp;quality=86&amp;strip=all 1920w" sizes="120px" alt="Can You ~ Keep Up~ With Kim Kardashian's Braless Moments Over the Years? See Photos!" data-fallback-img="https://www.intouchweekly.com/wp-content/uploads/2021/07/Kim-Kardashian-Braless-Photos.jpeg?fit=2400%2C2400&amp;quality=86&amp;strip=all" width="120" height="68"></div>									<div class="gallery-icon gallery__block-icon"><svg><use xlink:href="#icon-photos"></use></svg></div>
											</span>
		
		<span class="link-related__content">
			<span class="link-related__title">

						Can You ~ Keep Up~ With Kim Kardashian's Braless Moments? See Photos!
			</span>

					</span>
	</a>
</div>

<p>Elsewhere in the episode, Kim chatted with sisters <a href="https://www.intouchweekly.com/tags/khloe-kardashian-17677/"><strong>Khloé</strong></a> and <strong><a href="https://www.intouchweekly.com/tags/kourtney-kardashian-11944/">Kourtney Kardashian</a> </strong>to give more insight into her romance, saying that it’s not a “hysterical comedy show at all times” like people think. “No, it’s normal,” she explained. Kim also told her sisters about one night where Pete put “pimple medicine” on her nose after she fell asleep. She noted that the “one thing we seriously have in common” is their love for skincare.</p>
<p>“I’m not chasing anything, and that is the best feeling,” Kim shared. “When I turned 40, everyone told me it was the ‘best sex of your life.’ … And, so far [wink].”</p>
<figure class="wp-caption alignnone"><div class="ratio-based-placeholder" style="padding-bottom:56.25%;"><img class="alignnone size-large wp-image-452329" src="https://www.intouchweekly.com/wp-content/uploads/2022/06/Kim-pete01.jpg?fit=400%2C225&#038;quality=86&#038;strip=all&#038;resize=400%2C225" alt="Kim Kardashian Seemingly Reveals That She's Having the 'Best Sex' With Pete Davidson" width="400" height="225" srcset="https://www.intouchweekly.com/wp-content/uploads/2022/06/Kim-pete01.jpg?fit=200%2C113&amp;quality=86&amp;strip=all 200w, https://www.intouchweekly.com/wp-content/uploads/2022/06/Kim-pete01.jpg?fit=300%2C169&amp;quality=86&amp;strip=all 300w, https://www.intouchweekly.com/wp-content/uploads/2022/06/Kim-pete01.jpg?fit=400%2C225&#038;quality=86&#038;strip=all&#038;resize=400%2C225 400w, https://www.intouchweekly.com/wp-content/uploads/2022/06/Kim-pete01.jpg?fit=500%2C281&amp;quality=86&amp;strip=all 500w, https://www.intouchweekly.com/wp-content/uploads/2022/06/Kim-pete01.jpg?fit=600%2C338&amp;quality=86&amp;strip=all 600w, https://www.intouchweekly.com/wp-content/uploads/2022/06/Kim-pete01.jpg?fit=700%2C394&amp;quality=86&amp;strip=all 700w, https://www.intouchweekly.com/wp-content/uploads/2022/06/Kim-pete01.jpg?fit=800%2C450&amp;quality=86&amp;strip=all 800w, https://www.intouchweekly.com/wp-content/uploads/2022/06/Kim-pete01.jpg?fit=900%2C506&amp;quality=86&amp;strip=all 900w, https://www.intouchweekly.com/wp-content/uploads/2022/06/Kim-pete01.jpg?fit=1000%2C563&amp;quality=86&amp;strip=all 1000w, https://www.intouchweekly.com/wp-content/uploads/2022/06/Kim-pete01.jpg?fit=1200%2C675&amp;quality=86&amp;strip=all 1200w, https://www.intouchweekly.com/wp-content/uploads/2022/06/Kim-pete01.jpg?fit=1400%2C788&amp;quality=86&amp;strip=all 1400w, https://www.intouchweekly.com/wp-content/uploads/2022/06/Kim-pete01.jpg?fit=1600%2C900&amp;quality=86&amp;strip=all 1600w, https://www.intouchweekly.com/wp-content/uploads/2022/06/Kim-pete01.jpg?fit=1800%2C1013&amp;quality=86&amp;strip=all 1800w" sizes="(max-width: 400px) 400px, (max-width: 600px) 600px, 830px" data-recalc-dims="1"></div><figcaption class="photo-credit"><span class="credit">Photo courtesy of Hulu</span></figcaption></figure><p>During her confessionals, Kim took a walk down memory lane and recalled there being “a vibe” when kissing Pete, 28, <a href="https://www.intouchweekly.com/posts/how-did-kim-kardashian-pete-davidson-meet-first-talk-details/">during her <em>Saturday Night Live </em>hosting gig</a> in October 2021. “Maybe I just need to try something different,” Kim told viewers, saying that the <em>King of Staten Island</em> star didn’t go to her afterparty. Then, she took matters into her own hands and got his number from the producers at <em>SNL</em>.</p>
<p>The former <a href="https://www.intouchweekly.com/tags/kuwtk-12529/"><em>Keeping Up With the Kardashians</em></a> star also referred to Pete as “the best human being I have ever met.”</p>
<p>When revealing why she likes him, Kim said being funny was “fourth” on her list. “Always wants the best for people. Can handle anything. Always does it with grace. He’s really, really thoughtful and humble and genuine,” the reality star shared, noting that “genuine” would be the “perfect word” to describe him.</p>
<div class="link-related link-related__with-thumb">
	<a href="https://www.intouchweekly.com/posts/kim-kardashian-and-pete-davidson-kiss-photos-of-hot-moment/" target="_blank" data-track-category="Article Page" data-track-action="Tap Interstitial Link" data-track-label="https://www.intouchweekly.com/posts/kim-kardashian-and-pete-davidson-kiss-photos-of-hot-moment/" class="link-related__link">
					<span class="link-related__image">
				<div style="padding-bottom:56.666666666667%;" class="ratio-based-placeholder"><img src="https://www.intouchweekly.com/wp-content/themes/ami-bauer/assets/build/images/placeholders/placeholder-16x9.svg" data-src="https://www.intouchweekly.com/wp-content/uploads/2022/05/Kim-Kardashian-Pete-Davidson-Kiss-IT.jpg?crop=0px%2C0px%2C2791px%2C1582px&amp;resize=120%2C68&amp;quality=86&amp;strip=all" data-srcset="https://www.intouchweekly.com/wp-content/uploads/2022/05/Kim-Kardashian-Pete-Davidson-Kiss-IT.jpg?crop=0px%2C0px%2C2791px%2C1582px&amp;resize=120%2C68&amp;quality=86&amp;strip=all 120w, https://www.intouchweekly.com/wp-content/uploads/2022/05/Kim-Kardashian-Pete-Davidson-Kiss-IT.jpg?crop=0px%2C0px%2C2791px%2C1582px&amp;resize=230%2C129&amp;quality=86&amp;strip=all 230w, https://www.intouchweekly.com/wp-content/uploads/2022/05/Kim-Kardashian-Pete-Davidson-Kiss-IT.jpg?crop=0px%2C0px%2C2791px%2C1582px&amp;resize=408%2C230&amp;quality=86&amp;strip=all 408w, https://www.intouchweekly.com/wp-content/uploads/2022/05/Kim-Kardashian-Pete-Davidson-Kiss-IT.jpg?crop=0px%2C0px%2C2791px%2C1582px&amp;resize=480%2C270&amp;quality=86&amp;strip=all 480w, https://www.intouchweekly.com/wp-content/uploads/2022/05/Kim-Kardashian-Pete-Davidson-Kiss-IT.jpg?crop=0px%2C0px%2C2791px%2C1582px&amp;resize=630%2C354&amp;quality=86&amp;strip=all 630w, https://www.intouchweekly.com/wp-content/uploads/2022/05/Kim-Kardashian-Pete-Davidson-Kiss-IT.jpg?crop=0px%2C0px%2C2791px%2C1582px&amp;resize=940%2C529&amp;quality=86&amp;strip=all 940w, https://www.intouchweekly.com/wp-content/uploads/2022/05/Kim-Kardashian-Pete-Davidson-Kiss-IT.jpg?crop=0px%2C0px%2C2791px%2C1582px&amp;resize=960%2C540&amp;quality=86&amp;strip=all 960w, https://www.intouchweekly.com/wp-content/uploads/2022/05/Kim-Kardashian-Pete-Davidson-Kiss-IT.jpg?crop=0px%2C0px%2C2791px%2C1582px&amp;resize=1200%2C675&amp;quality=86&amp;strip=all 1200w, https://www.intouchweekly.com/wp-content/uploads/2022/05/Kim-Kardashian-Pete-Davidson-Kiss-IT.jpg?crop=0px%2C0px%2C2791px%2C1582px&amp;resize=1260%2C709&amp;quality=86&amp;strip=all 1260w, https://www.intouchweekly.com/wp-content/uploads/2022/05/Kim-Kardashian-Pete-Davidson-Kiss-IT.jpg?crop=0px%2C0px%2C2791px%2C1582px&amp;resize=1920%2C1080&amp;quality=86&amp;strip=all 1920w" sizes="120px" alt="Kim Kardashian and Pete Davidson Share Intimate Moment and Kiss on Instagram Story" data-fallback-img="https://www.intouchweekly.com/wp-content/uploads/2022/05/Kim-Kardashian-Pete-Davidson-Kiss-IT.jpg?fit=2791%2C4238&amp;quality=86&amp;strip=all" width="120" height="68"></div>											</span>
		
		<span class="link-related__content">
			<span class="link-related__title">

						Kim Kardashian and Pete Davidson Share Steamy Kiss: Photos
			</span>

					</span>
	</a>
</div>

<p>Following her <em>SNL</em> hosting gig, Kim and Pete made headlines after they <a href="https://www.intouchweekly.com/posts/kim-kardashian-pete-davidson-pack-on-the-pda-in-london-pictures/">were spotted on multiple dates</a>. Months later, they went Instagram official in March 2022. The couple took things to the next level in April of that same year when making their <a href="https://www.intouchweekly.com/posts/kim-kardashians-bf-pete-davidson-grabs-her-butt-red-carpet-debut/">red carpet debut</a> at the White House Correspondents Dinner, and it’s been nothing but pure bliss ever since.</p>				<div class="youtube-cta">
	<p>
		<strong>
			<em>For access to all our exclusive celebrity videos and interviews – <a href="https://www.youtube.com/channel/UC-pi_mLzGF4RoMfpHbYgtUg?sub_confirmation=1" target="_blank">Subscribe on YouTube!</a></em>
		</strong>
	</p>
</div>							</div>

			
			<div class="share-alt">
				<span class="comment-icon"><svg><use xlink:href="#comment"></use></svg></span><div class="sharedaddy sd-sharing-enabled"><div class="robots-nocontent sd-block sd-social sd-social-icon sd-sharing"><div class="sd-content"><ul><li class="share-facebook"><a rel="nofollow noopener noreferrer" data-shared="sharing-facebook-452328" class="share-facebook sd-button share-icon no-text" href="https://www.intouchweekly.com/posts/kim-kardashian-hints-at-having-best-sex-with-pete-davidson/?share=facebook" target="_blank" title="Click to share on Facebook"><span></span><span class="sharing-screen-reader-text">Click to share on Facebook (Opens in new window)</span></a></li><li class="share-twitter"><a rel="nofollow noopener noreferrer" data-shared="sharing-twitter-452328" class="share-twitter sd-button share-icon no-text" href="https://www.intouchweekly.com/posts/kim-kardashian-hints-at-having-best-sex-with-pete-davidson/?share=twitter" target="_blank" title="Click to share on Twitter"><span></span><span class="sharing-screen-reader-text">Click to share on Twitter (Opens in new window)</span></a></li><li class="share-pinterest"><a rel="nofollow noopener noreferrer" data-shared="sharing-pinterest-452328" class="share-pinterest sd-button share-icon no-text" href="https://www.intouchweekly.com/posts/kim-kardashian-hints-at-having-best-sex-with-pete-davidson/?share=pinterest" target="_blank" title="Click to share on Pinterest"><span></span><span class="sharing-screen-reader-text">Click to share on Pinterest (Opens in new window)</span></a></li><li class="share-end"></li></ul></div></div></div>			</div>

			<div id="rc-widget-intouchmb"></div>
				<div class="in-page__tags-block">
		<ul class="in-page__tags-block__tags-list">
			<li class="in-page__tags-block__title">Tags:</li>
			<li class="in-page__tags-block__tags-list__item"><a href="https://www.intouchweekly.com/tags/kim-kardashian-11902/" rel="tag">Kim Kardashian</a></li><li class="in-page__tags-block__tags-list__item"><a href="https://www.intouchweekly.com/tags/pete-davidson/" rel="tag">Pete Davidson</a></li>		</ul>
	</div>
	
			
		</div>
	</div>

	

			<div id="promocenter-box">
			<div id="block-4" class="widget_block widget_media_image">
<figure class="wp-block-image size-large"><a href="https://winit.intouchweekly.com/sweepstakes/2000-cash-sweepstakes?utm_content=2000-cash-beach"><img loading="lazy" width="1820" height="910" src="https://www.intouchweekly.com/wp-content/uploads/2022/05/11-1.png?resize=1024%2C512&amp;quality=86&amp;strip=all" alt="Sweepstakes: Win $2,000 Cash!" class="wp-image-451489" srcset="https://www.intouchweekly.com/wp-content/uploads/2022/05/11-1.png?w=1820&amp;quality=86&amp;strip=all 1820w, https://www.intouchweekly.com/wp-content/uploads/2022/05/11-1.png?w=150&amp;quality=86&amp;strip=all 150w, https://www.intouchweekly.com/wp-content/uploads/2022/05/11-1.png?w=300&amp;quality=86&amp;strip=all 300w, https://www.intouchweekly.com/wp-content/uploads/2022/05/11-1.png?w=768&amp;quality=86&amp;strip=all 768w, https://www.intouchweekly.com/wp-content/uploads/2022/05/11-1.png?w=1024&amp;quality=86&amp;strip=all 1024w" sizes="(max-width: 1820px) 100vw, 1820px" /></a></figure>
</div>		</div>
	
	<div id="comments-wrapper"><div id="spotImCommentsDiv"
     data-spotim-module="recirculation"
     data-spot-id="sp_tcLBc9rX"
     data-post-id="452328"
     data-post-url="https://www.intouchweekly.com/?p=452328"
     data-post-tags="Kim Kardashian, Pete Davidson">
</div>
</div></div>
				
<div class="post-sidebar">
	<div class="dfp-wrapper  desktop-only" data-slot="rr1"><div id="rr1" class="dfp-slot dfp-container rr1 ad-container sticky-top"></div></div>	
<div class="post-sidebar__pictures">
	<div class="post-sidebar__header">
					<svg><use xlink:href="#icon-in-logo" /></svg>
							<span>Top stories</span>
			</div>

			<div class="post-sidebar__grid">
							<article class="article__item">

					<a class="article__item-thumbnail" href="https://www.intouchweekly.com/posts/octomom-nadya-sulemans-kids-today-see-her-14-children-now/">
																					<div class="gallery-icon gallery__block-icon"><svg><use xlink:href="#icon-photos" /></svg></div>
														<figure class="article__item-figure">
								<div class="item__figure-source ok-thumb ok-standard-thumb">
									<div style="padding-bottom:100%;" class="ratio-based-placeholder"><img src="https://www.intouchweekly.com/wp-content/themes/ami-bauer/assets/build/images/placeholders/placeholder-1x1.svg" data-src="https://www.intouchweekly.com/wp-content/uploads/2020/01/Octomom-Nadya-Suleman-Children.jpg?resize=90%2C90&#038;quality=86&#038;strip=all" data-srcset="https://www.intouchweekly.com/wp-content/uploads/2020/01/Octomom-Nadya-Suleman-Children.jpg?resize=90%2C90&amp;quality=86&amp;strip=all 90w, https://www.intouchweekly.com/wp-content/uploads/2020/01/Octomom-Nadya-Suleman-Children.jpg?resize=180%2C180&amp;quality=86&amp;strip=all 180w, https://www.intouchweekly.com/wp-content/uploads/2020/01/Octomom-Nadya-Suleman-Children.jpg?resize=300%2C300&amp;quality=86&amp;strip=all 300w, https://www.intouchweekly.com/wp-content/uploads/2020/01/Octomom-Nadya-Suleman-Children.jpg?resize=408%2C408&amp;quality=86&amp;strip=all 408w, https://www.intouchweekly.com/wp-content/uploads/2020/01/Octomom-Nadya-Suleman-Children.jpg?resize=600%2C600&amp;quality=86&amp;strip=all 600w, https://www.intouchweekly.com/wp-content/uploads/2020/01/Octomom-Nadya-Suleman-Children.jpg?resize=816%2C816&amp;quality=86&amp;strip=all 816w" sizes="(min-width: 1024px) 90px, 300px" alt="Octomom Nadya Suleman Children" data-fallback-img="https://www.intouchweekly.com/wp-content/uploads/2020/01/Octomom-Nadya-Suleman-Children.jpg?fit=2000%2C993&#038;quality=86&#038;strip=all" width="90" height="90"></div>								</div>
							</figure>
											</a>

					<h2 class="article__item-title">
						<a href="https://www.intouchweekly.com/posts/octomom-nadya-sulemans-kids-today-see-her-14-children-now/">'Octomom' Nadya Suleman Is a Proud Mom of 14: See Her Kids Today!</a>
					</h2>

				</article>
							<article class="article__item">

					<a class="article__item-thumbnail" href="https://www.intouchweekly.com/posts/duggar-kids-houses-154627/">
																					<div class="gallery-icon gallery__block-icon"><svg><use xlink:href="#icon-photos" /></svg></div>
														<figure class="article__item-figure">
								<div class="item__figure-source ok-thumb ok-standard-thumb">
									<div style="padding-bottom:100%;" class="ratio-based-placeholder"><img src="https://www.intouchweekly.com/wp-content/themes/ami-bauer/assets/build/images/placeholders/placeholder-1x1.svg" data-src="https://www.intouchweekly.com/wp-content/uploads/2020/02/The-Duggar-Kids-Keep-Their-Houses-Messy-and-Gross-Photos.jpeg?crop=0px%2C0px%2C2400px%2C2400px&#038;resize=90%2C90&#038;quality=86&#038;strip=all" data-srcset="https://www.intouchweekly.com/wp-content/uploads/2020/02/The-Duggar-Kids-Keep-Their-Houses-Messy-and-Gross-Photos.jpeg?crop=0px%2C0px%2C2400px%2C2400px&amp;resize=90%2C90&amp;quality=86&amp;strip=all 90w, https://www.intouchweekly.com/wp-content/uploads/2020/02/The-Duggar-Kids-Keep-Their-Houses-Messy-and-Gross-Photos.jpeg?crop=0px%2C0px%2C2400px%2C2400px&amp;resize=180%2C180&amp;quality=86&amp;strip=all 180w, https://www.intouchweekly.com/wp-content/uploads/2020/02/The-Duggar-Kids-Keep-Their-Houses-Messy-and-Gross-Photos.jpeg?crop=0px%2C0px%2C2400px%2C2400px&amp;resize=300%2C300&amp;quality=86&amp;strip=all 300w, https://www.intouchweekly.com/wp-content/uploads/2020/02/The-Duggar-Kids-Keep-Their-Houses-Messy-and-Gross-Photos.jpeg?crop=0px%2C0px%2C2400px%2C2400px&amp;resize=408%2C408&amp;quality=86&amp;strip=all 408w, https://www.intouchweekly.com/wp-content/uploads/2020/02/The-Duggar-Kids-Keep-Their-Houses-Messy-and-Gross-Photos.jpeg?crop=0px%2C0px%2C2400px%2C2400px&amp;resize=600%2C600&amp;quality=86&amp;strip=all 600w, https://www.intouchweekly.com/wp-content/uploads/2020/02/The-Duggar-Kids-Keep-Their-Houses-Messy-and-Gross-Photos.jpeg?crop=0px%2C0px%2C2400px%2C2400px&amp;resize=816%2C816&amp;quality=86&amp;strip=all 816w, https://www.intouchweekly.com/wp-content/uploads/2020/02/The-Duggar-Kids-Keep-Their-Houses-Messy-and-Gross-Photos.jpeg?crop=0px%2C0px%2C2400px%2C2400px&amp;resize=1200%2C1200&amp;quality=86&amp;strip=all 1200w" sizes="(min-width: 1024px) 90px, 300px" alt="The Duggar Kids Keep Their Houses Messy and Gross Photos" data-fallback-img="https://www.intouchweekly.com/wp-content/uploads/2020/02/The-Duggar-Kids-Keep-Their-Houses-Messy-and-Gross-Photos.jpeg?fit=2400%2C2400&#038;quality=86&#038;strip=all" width="90" height="90"></div>								</div>
							</figure>
											</a>

					<h2 class="article__item-title">
						<a href="https://www.intouchweekly.com/posts/duggar-kids-houses-154627/">Is Every Duggar Ridiculously Messy? See the 'Counting On' Kids' Houses</a>
					</h2>

				</article>
							<article class="article__item">

					<a class="article__item-thumbnail" href="https://www.intouchweekly.com/posts/jen-arnold-and-bill-kleins-kids-little-couples-will-and-zoey-now/">
																					<div class="gallery-icon gallery__block-icon"><svg><use xlink:href="#icon-photos" /></svg></div>
														<figure class="article__item-figure">
								<div class="item__figure-source ok-thumb ok-standard-thumb">
									<div style="padding-bottom:100%;" class="ratio-based-placeholder"><img src="https://www.intouchweekly.com/wp-content/themes/ami-bauer/assets/build/images/placeholders/placeholder-1x1.svg" data-src="https://www.intouchweekly.com/wp-content/uploads/2021/02/The-Little-Couple-Jen-Arnold-Kids-With-Husband-Bill-William-and-Zoey.jpg?crop=0px%2C0px%2C1384px%2C1384px&#038;resize=90%2C90&#038;quality=86&#038;strip=all" data-srcset="https://www.intouchweekly.com/wp-content/uploads/2021/02/The-Little-Couple-Jen-Arnold-Kids-With-Husband-Bill-William-and-Zoey.jpg?crop=0px%2C0px%2C1384px%2C1384px&amp;resize=90%2C90&amp;quality=86&amp;strip=all 90w, https://www.intouchweekly.com/wp-content/uploads/2021/02/The-Little-Couple-Jen-Arnold-Kids-With-Husband-Bill-William-and-Zoey.jpg?crop=0px%2C0px%2C1384px%2C1384px&amp;resize=180%2C180&amp;quality=86&amp;strip=all 180w, https://www.intouchweekly.com/wp-content/uploads/2021/02/The-Little-Couple-Jen-Arnold-Kids-With-Husband-Bill-William-and-Zoey.jpg?crop=0px%2C0px%2C1384px%2C1384px&amp;resize=300%2C300&amp;quality=86&amp;strip=all 300w, https://www.intouchweekly.com/wp-content/uploads/2021/02/The-Little-Couple-Jen-Arnold-Kids-With-Husband-Bill-William-and-Zoey.jpg?crop=0px%2C0px%2C1384px%2C1384px&amp;resize=408%2C408&amp;quality=86&amp;strip=all 408w, https://www.intouchweekly.com/wp-content/uploads/2021/02/The-Little-Couple-Jen-Arnold-Kids-With-Husband-Bill-William-and-Zoey.jpg?crop=0px%2C0px%2C1384px%2C1384px&amp;resize=600%2C600&amp;quality=86&amp;strip=all 600w, https://www.intouchweekly.com/wp-content/uploads/2021/02/The-Little-Couple-Jen-Arnold-Kids-With-Husband-Bill-William-and-Zoey.jpg?crop=0px%2C0px%2C1384px%2C1384px&amp;resize=816%2C816&amp;quality=86&amp;strip=all 816w, https://www.intouchweekly.com/wp-content/uploads/2021/02/The-Little-Couple-Jen-Arnold-Kids-With-Husband-Bill-William-and-Zoey.jpg?crop=0px%2C0px%2C1384px%2C1384px&amp;resize=1200%2C1200&amp;quality=86&amp;strip=all 1200w" sizes="(min-width: 1024px) 90px, 300px" alt="The Little Couple Jen Arnold Kids With Husband Bill William and Zoey" data-fallback-img="https://www.intouchweekly.com/wp-content/uploads/2021/02/The-Little-Couple-Jen-Arnold-Kids-With-Husband-Bill-William-and-Zoey.jpg?fit=1384%2C2000&#038;quality=86&#038;strip=all" width="90" height="90"></div>								</div>
							</figure>
											</a>

					<h2 class="article__item-title">
						<a href="https://www.intouchweekly.com/posts/jen-arnold-and-bill-kleins-kids-little-couples-will-and-zoey-now/">Look How Much the Little Couple's Kids Will and Zoey Have Grown Up</a>
					</h2>

				</article>
							<article class="article__item">

					<a class="article__item-thumbnail" href="https://www.intouchweekly.com/posts/kardashian-jenner-family-2021-met-gala-outfits-and-photos/">
																					<div class="gallery-icon gallery__block-icon"><svg><use xlink:href="#icon-photos" /></svg></div>
														<figure class="article__item-figure">
								<div class="item__figure-source ok-thumb ok-standard-thumb">
									<div style="padding-bottom:100%;" class="ratio-based-placeholder"><img src="https://www.intouchweekly.com/wp-content/themes/ami-bauer/assets/build/images/placeholders/placeholder-1x1.svg" data-src="https://www.intouchweekly.com/wp-content/uploads/2021/09/Copy-of-Split-3.jpeg?resize=90%2C90&#038;quality=86&#038;strip=all" data-srcset="https://www.intouchweekly.com/wp-content/uploads/2021/09/Copy-of-Split-3.jpeg?resize=90%2C90&amp;quality=86&amp;strip=all 90w, https://www.intouchweekly.com/wp-content/uploads/2021/09/Copy-of-Split-3.jpeg?resize=180%2C180&amp;quality=86&amp;strip=all 180w, https://www.intouchweekly.com/wp-content/uploads/2021/09/Copy-of-Split-3.jpeg?resize=300%2C300&amp;quality=86&amp;strip=all 300w, https://www.intouchweekly.com/wp-content/uploads/2021/09/Copy-of-Split-3.jpeg?resize=408%2C408&amp;quality=86&amp;strip=all 408w, https://www.intouchweekly.com/wp-content/uploads/2021/09/Copy-of-Split-3.jpeg?resize=600%2C600&amp;quality=86&amp;strip=all 600w, https://www.intouchweekly.com/wp-content/uploads/2021/09/Copy-of-Split-3.jpeg?resize=816%2C816&amp;quality=86&amp;strip=all 816w, https://www.intouchweekly.com/wp-content/uploads/2021/09/Copy-of-Split-3.jpeg?resize=1200%2C1200&amp;quality=86&amp;strip=all 1200w" sizes="(min-width: 1024px) 90px, 300px" alt="kardashians at 2021 met gala red carpet" data-fallback-img="https://www.intouchweekly.com/wp-content/uploads/2021/09/Copy-of-Split-3.jpeg?fit=2000%2C2000&#038;quality=86&#038;strip=all" width="90" height="90"></div>								</div>
							</figure>
											</a>

					<h2 class="article__item-title">
						<a href="https://www.intouchweekly.com/posts/kardashian-jenner-family-2021-met-gala-outfits-and-photos/">Every Look From the Kardashian-Jenner Family at the 2021 Met Gala</a>
					</h2>

				</article>
							<article class="article__item">

					<a class="article__item-thumbnail" href="https://www.intouchweekly.com/posts/gabby-petitos-final-text-messages-with-mom-show-more-tension-with-brian-laundrie/">
																					<div class="video-icon video__block-icon"><svg><use xlink:href="#icon-video" /></svg></div>
														<figure class="article__item-figure">
								<div class="item__figure-source ok-thumb ok-standard-thumb">
									<div style="padding-bottom:100%;" class="ratio-based-placeholder"><img src="https://www.intouchweekly.com/wp-content/themes/ami-bauer/assets/build/images/placeholders/placeholder-1x1.svg" data-src="https://www.intouchweekly.com/wp-content/uploads/2021/09/Copy-of-Single-Bubble-Blue-12.jpeg?resize=90%2C90&#038;quality=86&#038;strip=all" data-srcset="https://www.intouchweekly.com/wp-content/uploads/2021/09/Copy-of-Single-Bubble-Blue-12.jpeg?resize=90%2C90&amp;quality=86&amp;strip=all 90w, https://www.intouchweekly.com/wp-content/uploads/2021/09/Copy-of-Single-Bubble-Blue-12.jpeg?resize=180%2C180&amp;quality=86&amp;strip=all 180w, https://www.intouchweekly.com/wp-content/uploads/2021/09/Copy-of-Single-Bubble-Blue-12.jpeg?resize=300%2C300&amp;quality=86&amp;strip=all 300w, https://www.intouchweekly.com/wp-content/uploads/2021/09/Copy-of-Single-Bubble-Blue-12.jpeg?resize=408%2C408&amp;quality=86&amp;strip=all 408w, https://www.intouchweekly.com/wp-content/uploads/2021/09/Copy-of-Single-Bubble-Blue-12.jpeg?resize=600%2C600&amp;quality=86&amp;strip=all 600w, https://www.intouchweekly.com/wp-content/uploads/2021/09/Copy-of-Single-Bubble-Blue-12.jpeg?resize=816%2C816&amp;quality=86&amp;strip=all 816w, https://www.intouchweekly.com/wp-content/uploads/2021/09/Copy-of-Single-Bubble-Blue-12.jpeg?resize=1200%2C1200&amp;quality=86&amp;strip=all 1200w" sizes="(min-width: 1024px) 90px, 300px" alt="gabby-petito-missing-final-text" data-fallback-img="https://www.intouchweekly.com/wp-content/uploads/2021/09/Copy-of-Single-Bubble-Blue-12.jpeg?fit=2400%2C2400&#038;quality=86&#038;strip=all" width="90" height="90"></div>								</div>
							</figure>
											</a>

					<h2 class="article__item-title">
						<a href="https://www.intouchweekly.com/posts/gabby-petitos-final-text-messages-with-mom-show-more-tension-with-brian-laundrie/">Gabby Petito's Texts Show 'More and More Tension' With Brian Laundrie</a>
					</h2>

				</article>
					</div>
	</div>
<div id="promoblock-box"><div id="block-2" class="widget_block widget_media_image">
<figure class="wp-block-image size-full"><a href="http://pubads.g.doubleclick.net/gampad/clk?id=6009546398&amp;iu=/4216"><img loading="lazy" width="300" height="490" src="https://www.intouchweekly.com/wp-content/uploads/2022/05/TITANIC_300x490.jpg" alt="" class="wp-image-448516" srcset="https://www.intouchweekly.com/wp-content/uploads/2022/05/TITANIC_300x490.jpg?w=300&amp;quality=86&amp;strip=all 300w, https://www.intouchweekly.com/wp-content/uploads/2022/05/TITANIC_300x490.jpg?w=92&amp;quality=86&amp;strip=all 92w, https://www.intouchweekly.com/wp-content/uploads/2022/05/TITANIC_300x490.jpg?w=184&amp;quality=86&amp;strip=all 184w" sizes="(max-width: 300px) 100vw, 300px" /></a></figure>
</div><div id="block-3" class="widget_block"><p><iframe loading="lazy" src="https://securepubads.g.doubleclick.net/gampad/adx?iu=/4216/ITW.LTG&amp;sz=1x1" width="1" height="1" style="position:absolute; visibility:hidden"></iframe></p></div></div>			<script>
				document.addEventListener("DOMContentLoaded", function() {
					if(window.innerWidth < 1024) {// Get the element
						var elem = document.getElementById('promoblock-box');
						var target = document.querySelector('.l-grid__main-post_content');
						elem.parentNode.removeChild(elem);
						target.appendChild(elem)
					}
				});
			</script>
			<div id="rc-widget-intouchdt"></div>	<div class="ad-container__sticky-wrapper">
		<div class="ad-container sticky-top">
			<div class="dfp-wrapper  desktop-only" data-slot="rr2"><div id="rr2" class="dfp-slot dfp-container rr2 "></div></div>		</div>
	</div>
</div>
			</div>
		</div>
	</div>

	
<div class="full-container">

			<div class="l-container">
			<div class="l-grid">
				<div class="l-grid__main-slider">
					<div class="block__title">
													<svg><use xlink:href="#icon-in-logo" /></svg>
												<span>Exclusives</span>
					</div>
					<div class="l-grid__main-sliderblock slider">
						
<article class="article__item">
			<a class="article__item-thumbnail" href="https://www.intouchweekly.com/posts/anna-duggar-would-not-consider-leaving-josh-for-another-man/">
						<figure class="article__item-figure">
				<div style="padding-bottom:56.25%;" class="ratio-based-placeholder"><img src="https://www.intouchweekly.com/wp-content/themes/ami-bauer/assets/build/images/placeholders/placeholder-16x9.svg" data-src="https://www.intouchweekly.com/wp-content/uploads/2022/05/Josh-and-Anna-Duggar-Surprised-by-12-Year-Sentence-After-Child-Porn-Case-It-Could-Have-Been-Worse-.jpeg?crop=0px%2C0px%2C731px%2C414px&#038;resize=480%2C270&#038;quality=86&#038;strip=all" data-srcset="https://www.intouchweekly.com/wp-content/uploads/2022/05/Josh-and-Anna-Duggar-Surprised-by-12-Year-Sentence-After-Child-Porn-Case-It-Could-Have-Been-Worse-.jpeg?crop=0px%2C0px%2C731px%2C414px&amp;resize=120%2C68&amp;quality=86&amp;strip=all 120w, https://www.intouchweekly.com/wp-content/uploads/2022/05/Josh-and-Anna-Duggar-Surprised-by-12-Year-Sentence-After-Child-Porn-Case-It-Could-Have-Been-Worse-.jpeg?crop=0px%2C0px%2C731px%2C414px&amp;resize=230%2C129&amp;quality=86&amp;strip=all 230w, https://www.intouchweekly.com/wp-content/uploads/2022/05/Josh-and-Anna-Duggar-Surprised-by-12-Year-Sentence-After-Child-Porn-Case-It-Could-Have-Been-Worse-.jpeg?crop=0px%2C0px%2C731px%2C414px&amp;resize=408%2C230&amp;quality=86&amp;strip=all 408w, https://www.intouchweekly.com/wp-content/uploads/2022/05/Josh-and-Anna-Duggar-Surprised-by-12-Year-Sentence-After-Child-Porn-Case-It-Could-Have-Been-Worse-.jpeg?crop=0px%2C0px%2C731px%2C414px&amp;resize=480%2C270&amp;quality=86&amp;strip=all 480w, https://www.intouchweekly.com/wp-content/uploads/2022/05/Josh-and-Anna-Duggar-Surprised-by-12-Year-Sentence-After-Child-Porn-Case-It-Could-Have-Been-Worse-.jpeg?crop=0px%2C0px%2C731px%2C414px&amp;resize=630%2C354&amp;quality=86&amp;strip=all 630w" sizes="(max-width: 400px) 408px, 408px" alt="Josh and Anna Duggar &#039;Surprised&#039; by 12-Year Sentence After Child Porn Case: &#039;It Could Have Been Worse&#039;" data-fallback-img="https://www.intouchweekly.com/wp-content/uploads/2022/05/Josh-and-Anna-Duggar-Surprised-by-12-Year-Sentence-After-Child-Porn-Case-It-Could-Have-Been-Worse-.jpeg?fit=731%2C732&#038;quality=86&#038;strip=all" width="480" height="270"></div>			</figure>
		</a>
	
	<h2 class="article__item-title">
		<a href="https://www.intouchweekly.com/posts/anna-duggar-would-not-consider-leaving-josh-for-another-man/">Anna Duggar Would Not 'Consider' Leaving Josh Duggar for a 'Another Man'</a>
	</h2>
</article>

<article class="article__item">
			<a class="article__item-thumbnail" href="https://www.intouchweekly.com/posts/jim-bob-and-michelle-duggar-want-anna-duggar-to-stay-with-them/">
						<figure class="article__item-figure">
				<div style="padding-bottom:56.25%;" class="ratio-based-placeholder"><img src="https://www.intouchweekly.com/wp-content/themes/ami-bauer/assets/build/images/placeholders/placeholder-16x9.svg" data-src="https://www.intouchweekly.com/wp-content/uploads/2022/05/Jim-Bob-Michelle-Anna-Duggar.jpg?crop=14px%2C9px%2C2386px%2C1353px&#038;resize=480%2C270&#038;quality=86&#038;strip=all" data-srcset="https://www.intouchweekly.com/wp-content/uploads/2022/05/Jim-Bob-Michelle-Anna-Duggar.jpg?crop=14px%2C9px%2C2386px%2C1353px&amp;resize=120%2C68&amp;quality=86&amp;strip=all 120w, https://www.intouchweekly.com/wp-content/uploads/2022/05/Jim-Bob-Michelle-Anna-Duggar.jpg?crop=14px%2C9px%2C2386px%2C1353px&amp;resize=230%2C129&amp;quality=86&amp;strip=all 230w, https://www.intouchweekly.com/wp-content/uploads/2022/05/Jim-Bob-Michelle-Anna-Duggar.jpg?crop=14px%2C9px%2C2386px%2C1353px&amp;resize=408%2C230&amp;quality=86&amp;strip=all 408w, https://www.intouchweekly.com/wp-content/uploads/2022/05/Jim-Bob-Michelle-Anna-Duggar.jpg?crop=14px%2C9px%2C2386px%2C1353px&amp;resize=480%2C270&amp;quality=86&amp;strip=all 480w, https://www.intouchweekly.com/wp-content/uploads/2022/05/Jim-Bob-Michelle-Anna-Duggar.jpg?crop=14px%2C9px%2C2386px%2C1353px&amp;resize=630%2C354&amp;quality=86&amp;strip=all 630w, https://www.intouchweekly.com/wp-content/uploads/2022/05/Jim-Bob-Michelle-Anna-Duggar.jpg?crop=14px%2C9px%2C2386px%2C1353px&amp;resize=940%2C529&amp;quality=86&amp;strip=all 940w, https://www.intouchweekly.com/wp-content/uploads/2022/05/Jim-Bob-Michelle-Anna-Duggar.jpg?crop=14px%2C9px%2C2386px%2C1353px&amp;resize=960%2C540&amp;quality=86&amp;strip=all 960w, https://www.intouchweekly.com/wp-content/uploads/2022/05/Jim-Bob-Michelle-Anna-Duggar.jpg?crop=14px%2C9px%2C2386px%2C1353px&amp;resize=1200%2C675&amp;quality=86&amp;strip=all 1200w, https://www.intouchweekly.com/wp-content/uploads/2022/05/Jim-Bob-Michelle-Anna-Duggar.jpg?crop=14px%2C9px%2C2386px%2C1353px&amp;resize=1260%2C709&amp;quality=86&amp;strip=all 1260w, https://www.intouchweekly.com/wp-content/uploads/2022/05/Jim-Bob-Michelle-Anna-Duggar.jpg?crop=14px%2C9px%2C2386px%2C1353px&amp;resize=1920%2C1080&amp;quality=86&amp;strip=all 1920w" sizes="(max-width: 400px) 408px, 408px" alt="Jim-Bob-Michelle-Duggar" data-fallback-img="https://www.intouchweekly.com/wp-content/uploads/2022/05/Jim-Bob-Michelle-Anna-Duggar.jpg?fit=2400%2C2400&#038;quality=86&#038;strip=all" width="480" height="270"></div>			</figure>
		</a>
	
	<h2 class="article__item-title">
		<a href="https://www.intouchweekly.com/posts/jim-bob-and-michelle-duggar-want-anna-duggar-to-stay-with-them/">Jim Bob and Michelle Duggar Want Josh’s Wife Anna to ‘Stay With Them’</a>
	</h2>
</article>

<article class="article__item">
			<a class="article__item-thumbnail" href="https://www.intouchweekly.com/posts/anna-duggar-relieved-josh-prison-sentencing-is-over/">
						<figure class="article__item-figure">
				<div style="padding-bottom:56.25%;" class="ratio-based-placeholder"><img src="https://www.intouchweekly.com/wp-content/themes/ami-bauer/assets/build/images/placeholders/placeholder-16x9.svg" data-src="https://www.intouchweekly.com/wp-content/uploads/2022/05/Josh-and-Anna-Duggar-Surprised-by-12-Year-Sentence-After-Child-Porn-Case-It-Could-Have-Been-Worse-.jpeg?crop=0px%2C0px%2C731px%2C414px&#038;resize=480%2C270&#038;quality=86&#038;strip=all" data-srcset="https://www.intouchweekly.com/wp-content/uploads/2022/05/Josh-and-Anna-Duggar-Surprised-by-12-Year-Sentence-After-Child-Porn-Case-It-Could-Have-Been-Worse-.jpeg?crop=0px%2C0px%2C731px%2C414px&amp;resize=120%2C68&amp;quality=86&amp;strip=all 120w, https://www.intouchweekly.com/wp-content/uploads/2022/05/Josh-and-Anna-Duggar-Surprised-by-12-Year-Sentence-After-Child-Porn-Case-It-Could-Have-Been-Worse-.jpeg?crop=0px%2C0px%2C731px%2C414px&amp;resize=230%2C129&amp;quality=86&amp;strip=all 230w, https://www.intouchweekly.com/wp-content/uploads/2022/05/Josh-and-Anna-Duggar-Surprised-by-12-Year-Sentence-After-Child-Porn-Case-It-Could-Have-Been-Worse-.jpeg?crop=0px%2C0px%2C731px%2C414px&amp;resize=408%2C230&amp;quality=86&amp;strip=all 408w, https://www.intouchweekly.com/wp-content/uploads/2022/05/Josh-and-Anna-Duggar-Surprised-by-12-Year-Sentence-After-Child-Porn-Case-It-Could-Have-Been-Worse-.jpeg?crop=0px%2C0px%2C731px%2C414px&amp;resize=480%2C270&amp;quality=86&amp;strip=all 480w, https://www.intouchweekly.com/wp-content/uploads/2022/05/Josh-and-Anna-Duggar-Surprised-by-12-Year-Sentence-After-Child-Porn-Case-It-Could-Have-Been-Worse-.jpeg?crop=0px%2C0px%2C731px%2C414px&amp;resize=630%2C354&amp;quality=86&amp;strip=all 630w" sizes="(max-width: 400px) 408px, 408px" alt="Josh and Anna Duggar &#039;Surprised&#039; by 12-Year Sentence After Child Porn Case: &#039;It Could Have Been Worse&#039;" data-fallback-img="https://www.intouchweekly.com/wp-content/uploads/2022/05/Josh-and-Anna-Duggar-Surprised-by-12-Year-Sentence-After-Child-Porn-Case-It-Could-Have-Been-Worse-.jpeg?fit=731%2C732&#038;quality=86&#038;strip=all" width="480" height="270"></div>			</figure>
		</a>
	
	<h2 class="article__item-title">
		<a href="https://www.intouchweekly.com/posts/anna-duggar-relieved-josh-prison-sentencing-is-over/">Anna Duggar Is ‘Relieved’ Josh Sentencing Is Over, ‘Isn’t Shocked’ By Prison Time</a>
	</h2>
</article>

<article class="article__item">
			<a class="article__item-thumbnail" href="https://www.intouchweekly.com/posts/anna-duggars-reaction-to-josh-duggars-prison-sentence/">
						<figure class="article__item-figure">
				<div style="padding-bottom:56.25%;" class="ratio-based-placeholder"><img src="https://www.intouchweekly.com/wp-content/themes/ami-bauer/assets/build/images/placeholders/placeholder-16x9.svg" data-src="https://www.intouchweekly.com/wp-content/uploads/2022/04/Anna-Duggar-All-Smiles-During-Rare-Outing-as-Husband-Josh-Awaits-Sentencing-in-Jail-Main.jpg?crop=0px%2C0px%2C2000px%2C1133px&#038;resize=480%2C270&#038;quality=86&#038;strip=all" data-srcset="https://www.intouchweekly.com/wp-content/uploads/2022/04/Anna-Duggar-All-Smiles-During-Rare-Outing-as-Husband-Josh-Awaits-Sentencing-in-Jail-Main.jpg?crop=0px%2C0px%2C2000px%2C1133px&amp;resize=120%2C68&amp;quality=86&amp;strip=all 120w, https://www.intouchweekly.com/wp-content/uploads/2022/04/Anna-Duggar-All-Smiles-During-Rare-Outing-as-Husband-Josh-Awaits-Sentencing-in-Jail-Main.jpg?crop=0px%2C0px%2C2000px%2C1133px&amp;resize=230%2C129&amp;quality=86&amp;strip=all 230w, https://www.intouchweekly.com/wp-content/uploads/2022/04/Anna-Duggar-All-Smiles-During-Rare-Outing-as-Husband-Josh-Awaits-Sentencing-in-Jail-Main.jpg?crop=0px%2C0px%2C2000px%2C1133px&amp;resize=408%2C230&amp;quality=86&amp;strip=all 408w, https://www.intouchweekly.com/wp-content/uploads/2022/04/Anna-Duggar-All-Smiles-During-Rare-Outing-as-Husband-Josh-Awaits-Sentencing-in-Jail-Main.jpg?crop=0px%2C0px%2C2000px%2C1133px&amp;resize=480%2C270&amp;quality=86&amp;strip=all 480w, https://www.intouchweekly.com/wp-content/uploads/2022/04/Anna-Duggar-All-Smiles-During-Rare-Outing-as-Husband-Josh-Awaits-Sentencing-in-Jail-Main.jpg?crop=0px%2C0px%2C2000px%2C1133px&amp;resize=630%2C354&amp;quality=86&amp;strip=all 630w, https://www.intouchweekly.com/wp-content/uploads/2022/04/Anna-Duggar-All-Smiles-During-Rare-Outing-as-Husband-Josh-Awaits-Sentencing-in-Jail-Main.jpg?crop=0px%2C0px%2C2000px%2C1133px&amp;resize=940%2C529&amp;quality=86&amp;strip=all 940w, https://www.intouchweekly.com/wp-content/uploads/2022/04/Anna-Duggar-All-Smiles-During-Rare-Outing-as-Husband-Josh-Awaits-Sentencing-in-Jail-Main.jpg?crop=0px%2C0px%2C2000px%2C1133px&amp;resize=960%2C540&amp;quality=86&amp;strip=all 960w, https://www.intouchweekly.com/wp-content/uploads/2022/04/Anna-Duggar-All-Smiles-During-Rare-Outing-as-Husband-Josh-Awaits-Sentencing-in-Jail-Main.jpg?crop=0px%2C0px%2C2000px%2C1133px&amp;resize=1200%2C675&amp;quality=86&amp;strip=all 1200w, https://www.intouchweekly.com/wp-content/uploads/2022/04/Anna-Duggar-All-Smiles-During-Rare-Outing-as-Husband-Josh-Awaits-Sentencing-in-Jail-Main.jpg?crop=0px%2C0px%2C2000px%2C1133px&amp;resize=1260%2C709&amp;quality=86&amp;strip=all 1260w, https://www.intouchweekly.com/wp-content/uploads/2022/04/Anna-Duggar-All-Smiles-During-Rare-Outing-as-Husband-Josh-Awaits-Sentencing-in-Jail-Main.jpg?crop=0px%2C0px%2C2000px%2C1133px&amp;resize=1920%2C1080&amp;quality=86&amp;strip=all 1920w" sizes="(max-width: 400px) 408px, 408px" alt="Anna Duggar All Smiles During Rare Outing as Husband Josh Awaits Sentencing in Jail" data-fallback-img="https://www.intouchweekly.com/wp-content/uploads/2022/04/Anna-Duggar-All-Smiles-During-Rare-Outing-as-Husband-Josh-Awaits-Sentencing-in-Jail-Main.jpg?fit=2000%2C2000&#038;quality=86&#038;strip=all" width="480" height="270"></div>			</figure>
		</a>
	
	<h2 class="article__item-title">
		<a href="https://www.intouchweekly.com/posts/anna-duggars-reaction-to-josh-duggars-prison-sentence/">How Anna Duggar Reacted to Husband Josh’s 12.5-Year Prison Sentence</a>
	</h2>
</article>

<article class="article__item">
			<a class="article__item-thumbnail" href="https://www.intouchweekly.com/posts/the-little-couples-jen-arnolds-kids-will-and-zoey-miss-florida/">
							<div class="video-icon video__block-icon"><svg><use xlink:href="#icon-video" /></svg></div>
						<figure class="article__item-figure">
				<div style="padding-bottom:56.25%;" class="ratio-based-placeholder"><img src="https://www.intouchweekly.com/wp-content/themes/ami-bauer/assets/build/images/placeholders/placeholder-16x9.svg" data-src="https://www.intouchweekly.com/wp-content/uploads/2022/05/Jen-Arnold-Kids-Miss-Florida.jpg?crop=0px%2C412px%2C1440px%2C816px&#038;resize=480%2C270&#038;quality=86&#038;strip=all" data-srcset="https://www.intouchweekly.com/wp-content/uploads/2022/05/Jen-Arnold-Kids-Miss-Florida.jpg?crop=0px%2C412px%2C1440px%2C816px&amp;resize=120%2C68&amp;quality=86&amp;strip=all 120w, https://www.intouchweekly.com/wp-content/uploads/2022/05/Jen-Arnold-Kids-Miss-Florida.jpg?crop=0px%2C412px%2C1440px%2C816px&amp;resize=230%2C129&amp;quality=86&amp;strip=all 230w, https://www.intouchweekly.com/wp-content/uploads/2022/05/Jen-Arnold-Kids-Miss-Florida.jpg?crop=0px%2C412px%2C1440px%2C816px&amp;resize=408%2C230&amp;quality=86&amp;strip=all 408w, https://www.intouchweekly.com/wp-content/uploads/2022/05/Jen-Arnold-Kids-Miss-Florida.jpg?crop=0px%2C412px%2C1440px%2C816px&amp;resize=480%2C270&amp;quality=86&amp;strip=all 480w, https://www.intouchweekly.com/wp-content/uploads/2022/05/Jen-Arnold-Kids-Miss-Florida.jpg?crop=0px%2C412px%2C1440px%2C816px&amp;resize=630%2C354&amp;quality=86&amp;strip=all 630w, https://www.intouchweekly.com/wp-content/uploads/2022/05/Jen-Arnold-Kids-Miss-Florida.jpg?crop=0px%2C412px%2C1440px%2C816px&amp;resize=940%2C529&amp;quality=86&amp;strip=all 940w, https://www.intouchweekly.com/wp-content/uploads/2022/05/Jen-Arnold-Kids-Miss-Florida.jpg?crop=0px%2C412px%2C1440px%2C816px&amp;resize=960%2C540&amp;quality=86&amp;strip=all 960w, https://www.intouchweekly.com/wp-content/uploads/2022/05/Jen-Arnold-Kids-Miss-Florida.jpg?crop=0px%2C412px%2C1440px%2C816px&amp;resize=1200%2C675&amp;quality=86&amp;strip=all 1200w, https://www.intouchweekly.com/wp-content/uploads/2022/05/Jen-Arnold-Kids-Miss-Florida.jpg?crop=0px%2C412px%2C1440px%2C816px&amp;resize=1260%2C709&amp;quality=86&amp;strip=all 1260w" sizes="(max-width: 400px) 408px, 408px" alt="‘The Little Couple’ Star Jen Arnold Says Kids Will and Zoey Miss Florida But Are ‘Embracing’ Boston" data-fallback-img="https://www.intouchweekly.com/wp-content/uploads/2022/05/Jen-Arnold-Kids-Miss-Florida.jpg?fit=1440%2C1440&#038;quality=86&#038;strip=all" width="480" height="270"></div>			</figure>
		</a>
	
	<h2 class="article__item-title">
		<a href="https://www.intouchweekly.com/posts/the-little-couples-jen-arnolds-kids-will-and-zoey-miss-florida/">The Little Couple’s Jen Arnold Says Kids Will and Zoey 'Miss' Florida</a>
	</h2>
</article>

<article class="article__item">
			<a class="article__item-thumbnail" href="https://www.intouchweekly.com/posts/scott-disick-feels-hurt-after-kourtney-kardashian-wedding/">
						<figure class="article__item-figure">
				<div style="padding-bottom:56.25%;" class="ratio-based-placeholder"><img src="https://www.intouchweekly.com/wp-content/themes/ami-bauer/assets/build/images/placeholders/placeholder-16x9.svg" data-src="https://www.intouchweekly.com/wp-content/uploads/2022/05/Scott-Disick-Kourtney-Kardashian-Travis-Barker-Hurt.jpg?crop=0px%2C0px%2C2000px%2C1133px&#038;resize=480%2C270&#038;quality=86&#038;strip=all" data-srcset="https://www.intouchweekly.com/wp-content/uploads/2022/05/Scott-Disick-Kourtney-Kardashian-Travis-Barker-Hurt.jpg?crop=0px%2C0px%2C2000px%2C1133px&amp;resize=120%2C68&amp;quality=86&amp;strip=all 120w, https://www.intouchweekly.com/wp-content/uploads/2022/05/Scott-Disick-Kourtney-Kardashian-Travis-Barker-Hurt.jpg?crop=0px%2C0px%2C2000px%2C1133px&amp;resize=230%2C129&amp;quality=86&amp;strip=all 230w, https://www.intouchweekly.com/wp-content/uploads/2022/05/Scott-Disick-Kourtney-Kardashian-Travis-Barker-Hurt.jpg?crop=0px%2C0px%2C2000px%2C1133px&amp;resize=408%2C230&amp;quality=86&amp;strip=all 408w, https://www.intouchweekly.com/wp-content/uploads/2022/05/Scott-Disick-Kourtney-Kardashian-Travis-Barker-Hurt.jpg?crop=0px%2C0px%2C2000px%2C1133px&amp;resize=480%2C270&amp;quality=86&amp;strip=all 480w, https://www.intouchweekly.com/wp-content/uploads/2022/05/Scott-Disick-Kourtney-Kardashian-Travis-Barker-Hurt.jpg?crop=0px%2C0px%2C2000px%2C1133px&amp;resize=630%2C354&amp;quality=86&amp;strip=all 630w, https://www.intouchweekly.com/wp-content/uploads/2022/05/Scott-Disick-Kourtney-Kardashian-Travis-Barker-Hurt.jpg?crop=0px%2C0px%2C2000px%2C1133px&amp;resize=940%2C529&amp;quality=86&amp;strip=all 940w, https://www.intouchweekly.com/wp-content/uploads/2022/05/Scott-Disick-Kourtney-Kardashian-Travis-Barker-Hurt.jpg?crop=0px%2C0px%2C2000px%2C1133px&amp;resize=960%2C540&amp;quality=86&amp;strip=all 960w, https://www.intouchweekly.com/wp-content/uploads/2022/05/Scott-Disick-Kourtney-Kardashian-Travis-Barker-Hurt.jpg?crop=0px%2C0px%2C2000px%2C1133px&amp;resize=1200%2C675&amp;quality=86&amp;strip=all 1200w, https://www.intouchweekly.com/wp-content/uploads/2022/05/Scott-Disick-Kourtney-Kardashian-Travis-Barker-Hurt.jpg?crop=0px%2C0px%2C2000px%2C1133px&amp;resize=1260%2C709&amp;quality=86&amp;strip=all 1260w, https://www.intouchweekly.com/wp-content/uploads/2022/05/Scott-Disick-Kourtney-Kardashian-Travis-Barker-Hurt.jpg?crop=0px%2C0px%2C2000px%2C1133px&amp;resize=1920%2C1080&amp;quality=86&amp;strip=all 1920w" sizes="(max-width: 400px) 408px, 408px" alt="How Scott Disick Feels After Kourtney Kardashian and Travis Barker&#039;s Wedding: &#039;Deep Down It Hurts&#039;" data-fallback-img="https://www.intouchweekly.com/wp-content/uploads/2022/05/Scott-Disick-Kourtney-Kardashian-Travis-Barker-Hurt.jpg?fit=2000%2C2000&#038;quality=86&#038;strip=all" width="480" height="270"></div>			</figure>
		</a>
	
	<h2 class="article__item-title">
		<a href="https://www.intouchweekly.com/posts/scott-disick-feels-hurt-after-kourtney-kardashian-wedding/">How Scott Disick Feels After Kourtney and Travis' Wedding: 'It Hurts'</a>
	</h2>
</article>

<article class="article__item">
			<a class="article__item-thumbnail" href="https://www.intouchweekly.com/posts/the-little-couples-jen-arnold-gives-update-on-kids-will-and-zoey/">
							<div class="video-icon video__block-icon"><svg><use xlink:href="#icon-video" /></svg></div>
						<figure class="article__item-figure">
				<div style="padding-bottom:56.25%;" class="ratio-based-placeholder"><img src="https://www.intouchweekly.com/wp-content/themes/ami-bauer/assets/build/images/placeholders/placeholder-16x9.svg" data-src="https://www.intouchweekly.com/wp-content/uploads/2022/05/Jen-Arnold-Updates-Will-Zoey-2.jpg?crop=0px%2C0px%2C2400px%2C1359px&#038;resize=480%2C270&#038;quality=86&#038;strip=all" data-srcset="https://www.intouchweekly.com/wp-content/uploads/2022/05/Jen-Arnold-Updates-Will-Zoey-2.jpg?crop=0px%2C0px%2C2400px%2C1359px&amp;resize=120%2C68&amp;quality=86&amp;strip=all 120w, https://www.intouchweekly.com/wp-content/uploads/2022/05/Jen-Arnold-Updates-Will-Zoey-2.jpg?crop=0px%2C0px%2C2400px%2C1359px&amp;resize=230%2C129&amp;quality=86&amp;strip=all 230w, https://www.intouchweekly.com/wp-content/uploads/2022/05/Jen-Arnold-Updates-Will-Zoey-2.jpg?crop=0px%2C0px%2C2400px%2C1359px&amp;resize=408%2C230&amp;quality=86&amp;strip=all 408w, https://www.intouchweekly.com/wp-content/uploads/2022/05/Jen-Arnold-Updates-Will-Zoey-2.jpg?crop=0px%2C0px%2C2400px%2C1359px&amp;resize=480%2C270&amp;quality=86&amp;strip=all 480w, https://www.intouchweekly.com/wp-content/uploads/2022/05/Jen-Arnold-Updates-Will-Zoey-2.jpg?crop=0px%2C0px%2C2400px%2C1359px&amp;resize=630%2C354&amp;quality=86&amp;strip=all 630w, https://www.intouchweekly.com/wp-content/uploads/2022/05/Jen-Arnold-Updates-Will-Zoey-2.jpg?crop=0px%2C0px%2C2400px%2C1359px&amp;resize=940%2C529&amp;quality=86&amp;strip=all 940w, https://www.intouchweekly.com/wp-content/uploads/2022/05/Jen-Arnold-Updates-Will-Zoey-2.jpg?crop=0px%2C0px%2C2400px%2C1359px&amp;resize=960%2C540&amp;quality=86&amp;strip=all 960w, https://www.intouchweekly.com/wp-content/uploads/2022/05/Jen-Arnold-Updates-Will-Zoey-2.jpg?crop=0px%2C0px%2C2400px%2C1359px&amp;resize=1200%2C675&amp;quality=86&amp;strip=all 1200w, https://www.intouchweekly.com/wp-content/uploads/2022/05/Jen-Arnold-Updates-Will-Zoey-2.jpg?crop=0px%2C0px%2C2400px%2C1359px&amp;resize=1260%2C709&amp;quality=86&amp;strip=all 1260w, https://www.intouchweekly.com/wp-content/uploads/2022/05/Jen-Arnold-Updates-Will-Zoey-2.jpg?crop=0px%2C0px%2C2400px%2C1359px&amp;resize=1920%2C1080&amp;quality=86&amp;strip=all 1920w" sizes="(max-width: 400px) 408px, 408px" alt="‘The Little Couple’ Star Jen Arnold Says Kids Will and Zoey Are ‘Growing Up Before My Eyes’" data-fallback-img="https://www.intouchweekly.com/wp-content/uploads/2022/05/Jen-Arnold-Updates-Will-Zoey-2.jpg?fit=2400%2C2400&#038;quality=86&#038;strip=all" width="480" height="270"></div>			</figure>
		</a>
	
	<h2 class="article__item-title">
		<a href="https://www.intouchweekly.com/posts/the-little-couples-jen-arnold-gives-update-on-kids-will-and-zoey/">'The Little Couple’ Star Jen Arnold Shares Updates on Kids Will and Zoey</a>
	</h2>
</article>

<article class="article__item">
			<a class="article__item-thumbnail" href="https://www.intouchweekly.com/posts/rihanna-and-asap-rocky-are-so-in-love-with-baby-no-1/">
						<figure class="article__item-figure">
				<div style="padding-bottom:56.25%;" class="ratio-based-placeholder"><img src="https://www.intouchweekly.com/wp-content/themes/ami-bauer/assets/build/images/placeholders/placeholder-16x9.svg" data-src="https://www.intouchweekly.com/wp-content/uploads/2022/03/RIHANNA-GIVES-BIRTH-AAP.jpg?crop=0px%2C60px%2C3488px%2C1976px&#038;resize=480%2C270&#038;quality=86&#038;strip=all" data-srcset="https://www.intouchweekly.com/wp-content/uploads/2022/03/RIHANNA-GIVES-BIRTH-AAP.jpg?crop=0px%2C60px%2C3488px%2C1976px&amp;resize=120%2C68&amp;quality=86&amp;strip=all 120w, https://www.intouchweekly.com/wp-content/uploads/2022/03/RIHANNA-GIVES-BIRTH-AAP.jpg?crop=0px%2C60px%2C3488px%2C1976px&amp;resize=230%2C129&amp;quality=86&amp;strip=all 230w, https://www.intouchweekly.com/wp-content/uploads/2022/03/RIHANNA-GIVES-BIRTH-AAP.jpg?crop=0px%2C60px%2C3488px%2C1976px&amp;resize=408%2C230&amp;quality=86&amp;strip=all 408w, https://www.intouchweekly.com/wp-content/uploads/2022/03/RIHANNA-GIVES-BIRTH-AAP.jpg?crop=0px%2C60px%2C3488px%2C1976px&amp;resize=480%2C270&amp;quality=86&amp;strip=all 480w, https://www.intouchweekly.com/wp-content/uploads/2022/03/RIHANNA-GIVES-BIRTH-AAP.jpg?crop=0px%2C60px%2C3488px%2C1976px&amp;resize=630%2C354&amp;quality=86&amp;strip=all 630w, https://www.intouchweekly.com/wp-content/uploads/2022/03/RIHANNA-GIVES-BIRTH-AAP.jpg?crop=0px%2C60px%2C3488px%2C1976px&amp;resize=940%2C529&amp;quality=86&amp;strip=all 940w, https://www.intouchweekly.com/wp-content/uploads/2022/03/RIHANNA-GIVES-BIRTH-AAP.jpg?crop=0px%2C60px%2C3488px%2C1976px&amp;resize=960%2C540&amp;quality=86&amp;strip=all 960w, https://www.intouchweekly.com/wp-content/uploads/2022/03/RIHANNA-GIVES-BIRTH-AAP.jpg?crop=0px%2C60px%2C3488px%2C1976px&amp;resize=1200%2C675&amp;quality=86&amp;strip=all 1200w, https://www.intouchweekly.com/wp-content/uploads/2022/03/RIHANNA-GIVES-BIRTH-AAP.jpg?crop=0px%2C60px%2C3488px%2C1976px&amp;resize=1260%2C709&amp;quality=86&amp;strip=all 1260w, https://www.intouchweekly.com/wp-content/uploads/2022/03/RIHANNA-GIVES-BIRTH-AAP.jpg?crop=0px%2C60px%2C3488px%2C1976px&amp;resize=1920%2C1080&amp;quality=86&amp;strip=all 1920w" sizes="(max-width: 400px) 408px, 408px" alt="Rihanna and Boyfriend A$AP Rocky Welcome Baby No. 1 Together" data-fallback-img="https://www.intouchweekly.com/wp-content/uploads/2022/03/RIHANNA-GIVES-BIRTH-AAP.jpg?fit=3488%2C4360&#038;quality=86&#038;strip=all" width="480" height="270"></div>			</figure>
		</a>
	
	<h2 class="article__item-title">
		<a href="https://www.intouchweekly.com/posts/rihanna-and-asap-rocky-are-so-in-love-with-baby-no-1/">Rihanna and ASAP Rocky Are ‘So in Love’ With Their ‘Adorable’ Baby Boy</a>
	</h2>
</article>

<article class="article__item">
			<a class="article__item-thumbnail" href="https://www.intouchweekly.com/posts/why-rob-kardashian-skipped-kourtney-and-travis-wedding/">
							<div class="video-icon video__block-icon"><svg><use xlink:href="#icon-video" /></svg></div>
						<figure class="article__item-figure">
				<div style="padding-bottom:56.25%;" class="ratio-based-placeholder"><img src="https://www.intouchweekly.com/wp-content/themes/ami-bauer/assets/build/images/placeholders/placeholder-16x9.svg" data-src="https://www.intouchweekly.com/wp-content/uploads/2022/05/Copy-of-Single-Bubble-White-20.jpg?crop=0px%2C35px%2C2400px%2C1360px&#038;resize=480%2C270&#038;quality=86&#038;strip=all" data-srcset="https://www.intouchweekly.com/wp-content/uploads/2022/05/Copy-of-Single-Bubble-White-20.jpg?crop=0px%2C35px%2C2400px%2C1360px&amp;resize=120%2C68&amp;quality=86&amp;strip=all 120w, https://www.intouchweekly.com/wp-content/uploads/2022/05/Copy-of-Single-Bubble-White-20.jpg?crop=0px%2C35px%2C2400px%2C1360px&amp;resize=230%2C129&amp;quality=86&amp;strip=all 230w, https://www.intouchweekly.com/wp-content/uploads/2022/05/Copy-of-Single-Bubble-White-20.jpg?crop=0px%2C35px%2C2400px%2C1360px&amp;resize=408%2C230&amp;quality=86&amp;strip=all 408w, https://www.intouchweekly.com/wp-content/uploads/2022/05/Copy-of-Single-Bubble-White-20.jpg?crop=0px%2C35px%2C2400px%2C1360px&amp;resize=480%2C270&amp;quality=86&amp;strip=all 480w, https://www.intouchweekly.com/wp-content/uploads/2022/05/Copy-of-Single-Bubble-White-20.jpg?crop=0px%2C35px%2C2400px%2C1360px&amp;resize=630%2C354&amp;quality=86&amp;strip=all 630w, https://www.intouchweekly.com/wp-content/uploads/2022/05/Copy-of-Single-Bubble-White-20.jpg?crop=0px%2C35px%2C2400px%2C1360px&amp;resize=940%2C529&amp;quality=86&amp;strip=all 940w, https://www.intouchweekly.com/wp-content/uploads/2022/05/Copy-of-Single-Bubble-White-20.jpg?crop=0px%2C35px%2C2400px%2C1360px&amp;resize=960%2C540&amp;quality=86&amp;strip=all 960w, https://www.intouchweekly.com/wp-content/uploads/2022/05/Copy-of-Single-Bubble-White-20.jpg?crop=0px%2C35px%2C2400px%2C1360px&amp;resize=1200%2C675&amp;quality=86&amp;strip=all 1200w, https://www.intouchweekly.com/wp-content/uploads/2022/05/Copy-of-Single-Bubble-White-20.jpg?crop=0px%2C35px%2C2400px%2C1360px&amp;resize=1260%2C709&amp;quality=86&amp;strip=all 1260w, https://www.intouchweekly.com/wp-content/uploads/2022/05/Copy-of-Single-Bubble-White-20.jpg?crop=0px%2C35px%2C2400px%2C1360px&amp;resize=1920%2C1080&amp;quality=86&amp;strip=all 1920w" sizes="(max-width: 400px) 408px, 408px" alt="Why Rob Kardashian Skipped Kourtney and Travis&#039; Wedding" data-fallback-img="https://www.intouchweekly.com/wp-content/uploads/2022/05/Copy-of-Single-Bubble-White-20.jpg?fit=2400%2C2400&#038;quality=86&#038;strip=all" width="480" height="270"></div>			</figure>
		</a>
	
	<h2 class="article__item-title">
		<a href="https://www.intouchweekly.com/posts/why-rob-kardashian-skipped-kourtney-and-travis-wedding/">Why Rob Kardashian Skipped Kourtney and Travis' Wedding in Italy</a>
	</h2>
</article>
					</div>
				</div>
			</div>
		</div>
	</div>

	<div class="l-grid">
		<div class="l-container l-container__related-articles">
			
<div class="l-grid__main-default" id="infSec_1">
	<div class="post-related">
			<div class="lazyload-anchor" data-page-id="452328" data-page-type="single-post" data-count="30" data-paged="1" data-excluded="[451362,451173,451153,449870,451031,450829,450815,450719,450400]" data-ads="{&quot;sh&quot;:1,&quot;mb&quot;:3}"></div>	</div>
</div>

<div class="post-sidebar">
	<div class="ad-container__sticky-wrapper">
		<div class="ad-container sticky-top">
			<div class="dfp-wrapper  desktop-only" data-slot="rr3"><div id="rr3" class="dfp-slot dfp-container rr3 "></div></div>		</div>
	</div>
</div>
		</div>
	</div>


<div class="recirc-widget collapsed mobile-hidden" data-widget-delay="5">
	<div class="recirc-widget__img-close">
		<a href="https://winit.intouchweekly.com/sweepstakes/2000-cash-sweepstakes?utm_content=blue-text&#038;utm_source=itwsite&#038;utm_medium=overlayrecirccirclewidget&#038;utm_campaign=itwwidget" target="_blank">		<div class="recirc-widget__img" style="background: #00b9ff;">
			<img src="https://www.intouchweekly.com/wp-content/themes/ami-bauer/assets/build/images/placeholders/placeholder-1x1.svg" data-src="https://www.intouchweekly.com/wp-content/uploads/2022/05/Windy-Circle-Sticker-2.png?resize=90%2C90&#038;quality=86&#038;strip=all" data-srcset="https://www.intouchweekly.com/wp-content/uploads/2022/05/Windy-Circle-Sticker-2.png?resize=90%2C90&amp;quality=86&amp;strip=all 90w, https://www.intouchweekly.com/wp-content/uploads/2022/05/Windy-Circle-Sticker-2.png?resize=180%2C180&amp;quality=86&amp;strip=all 180w, https://www.intouchweekly.com/wp-content/uploads/2022/05/Windy-Circle-Sticker-2.png?resize=300%2C300&amp;quality=86&amp;strip=all 300w, https://www.intouchweekly.com/wp-content/uploads/2022/05/Windy-Circle-Sticker-2.png?resize=408%2C408&amp;quality=86&amp;strip=all 408w, https://www.intouchweekly.com/wp-content/uploads/2022/05/Windy-Circle-Sticker-2.png?resize=600%2C600&amp;quality=86&amp;strip=all 600w, https://www.intouchweekly.com/wp-content/uploads/2022/05/Windy-Circle-Sticker-2.png?resize=816%2C816&amp;quality=86&amp;strip=all 816w" sizes="60px" alt="Win $2,000 Cash!" data-fallback-img="https://www.intouchweekly.com/wp-content/uploads/2022/05/Windy-Circle-Sticker-2.png?fit=1181%2C1181&#038;quality=86&#038;strip=all" width="90" height="90">		</div>
		</a>
		<span class="recirc-widget__close">
            <svg class="close" xmlns="http://www.w3.org/2000/svg" x="0px" y="0px" viewBox="0 0 241.171 241.171"><g><path d="M138.138,120.754l99.118-98.576c4.752-4.704,4.752-12.319,0-17.011c-4.74-4.704-12.439-4.704-17.179,0
					l-99.033,98.492L21.095,3.699c-4.74-4.752-12.439-4.752-17.179,0c-4.74,4.764-4.74,12.475,0,17.227l99.876,99.888L3.555,220.497
					c-4.74,4.704-4.74,12.319,0,17.011c4.74,4.704,12.439,4.704,17.179,0l100.152-99.599l99.551,99.563
					c4.74,4.752,12.439,4.752,17.179,0c4.74-4.764,4.74-12.475,0-17.227L138.138,120.754z"/></g></svg>
            <i class="hidden-except-readers">Close widget</i>
        </span>
	</div>

	<div class="recirc-widget__text">
		<p class="recirc-widget__title" style="background: #00b9ff;">
			<a href="https://winit.intouchweekly.com/sweepstakes/2000-cash-sweepstakes?utm_content=blue-text&#038;utm_source=itwsite&#038;utm_medium=overlayrecirccirclewidget&#038;utm_campaign=itwwidget" target="_blank">Enter to Win!</a>		</p>

		<span class="recirc-widget__toggle" style="background: #00b9ff;">
			<svg xmlns="http://www.w3.org/2000/svg"  x="0px" y="0px" viewBox="0 0 15.1 8.3"><path d="M13.7,0.3L7.5,6.5L1.3,0.3C1,0,0.5,0,0.2,0.3C0,0.6,0,1,0.2,1.3L7,8.1c0.3,0.3,0.7,0.3,1,0l6.8-6.7c0.3-0.3,0.4-0.7,0.1-1.1
	C14.6,0,14.2,0,13.8,0.2C13.8,0.3,13.8,0.3,13.7,0.3z"/></svg>
            <i class="hidden-except-readers">Collapse widget</i>
        </span>
	</div>
</div>

<footer class="site-footer">
	<div class="site-footer__inner">
		<div class="site-footer__left">
			<a href="https://www.intouchweekly.com/" class="site-footer__logo" title="Home" rel="home">
				<span class="hidden-except-readers">In Touch Weekly logo</span>
				<svg class="logo">
					<use xlink:href="#logo-intouch-footer"></use>
				</svg>
			</a>

			<div class="site-footer__left__inner">
				<div class="site-footer__social">
					<span class="site-footer__social__heading">Follow us!</span>
					<ul class="site-footer__social__list">
						<li><a href="http://www.facebook.com/InTouchWeekly" class="site-footer__social__link" rel="nofollow"> <span class="hidden-except-readers">Social icon facebook</span><svg class="icon icon-facebook"><use xlink:href="#icon-facebook"></use></svg></a></li><li><a href="https://twitter.com/intouchweekly" class="site-footer__social__link" rel="nofollow"> <span class="hidden-except-readers">Social icon twitter</span><svg class="icon icon-twitter"><use xlink:href="#icon-twitter"></use></svg></a></li><li><a href="https://www.instagram.com/intouchweekly/?hl=en" class="site-footer__social__link" rel="nofollow"> <span class="hidden-except-readers">Social icon instagram</span><svg class="icon icon-instagram"><use xlink:href="#icon-instagram"></use></svg></a></li>					</ul>
				</div>

				                    <div class="site-footer__newsletter-link">
                        <a href="/newsletter">Sign up for our e-newsletter</a>
                    </div>
				
				<div class="site-footer__notification">
					<p class="site-footer__notification-text">In Touch Weekly has affiliate partnerships so we may receive compensation for some links to products and services.</p>
					<p class="site-footer__notification-text">In Touch Weekly is part of the A360 Media Entertainment Group.<br>Copyright © A360 Media LLC 2022. All Rights Reserved</p>
				</div>
			</div>

		</div>

		<div class="site-footer__right">
			<div class="site-footer__menu">
				<h3 class="site-footer__heading">In Touch Weekly</h3>
				<div class="site-footer__links"><ul id="menu-footer-menu-1" class="site-footer__links__list"><li id="menu-item-201709" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-201709"><a href="https://www.intouchweekly.com/archives/">Archives</a></li>
<li id="menu-item-260471" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-260471"><a href="https://www.intouchweekly.com/posts/category/news/">News</a></li>
<li id="menu-item-260470" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-260470"><a href="https://www.intouchweekly.com/posts/category/reality-tv/">Reality TV</a></li>
<li id="menu-item-260472" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-260472"><a href="https://www.intouchweekly.com/posts/category/true-crime/">True Crime</a></li>
<li id="menu-item-260473" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-260473"><a href="https://www.intouchweekly.com/posts/category/entertainment/">Entertainment</a></li>
<li id="menu-item-260475" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-260475"><a href="https://www.intouchweekly.com/posts/category/omg/">OMG!</a></li>
<li id="menu-item-260474" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-260474"><a href="https://www.intouchweekly.com/posts/category/style/">Style</a></li>
<li id="menu-item-403227" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-403227"><a href="https://www.intouchweekly.com/posts/category/must-haves/">Must-Haves</a></li>
<li id="menu-item-260469" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-260469"><a href="/newsletter">Newsletter</a></li>
</ul></div>
				<!-- OneTrust Cookies Settings button start -->
				<a class="optanon-toggle-display" name="Manage Cookies">Manage Cookies</a>
				<!-- OneTrust Cookies Settings button end -->
			</div>

			<div class="site-footer__menu">
				<h3 class="site-footer__heading">A360 Media LLC</h3>
				<div class="site-footer__links"><ul id="menu-footer-menu-2" class="site-footer__links__list"><li id="menu-item-130808" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-130808"><a href="https://a360media.com/privacy-policy">Privacy Policy</a></li>
<li id="menu-item-130809" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-130809"><a href="https://a360media.com/terms-and-conditions">Terms &#038; Conditions</a></li>
<li id="menu-item-130810" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-130810"><a href="https://www.intouchweekly.com/contact/">Contact Us</a></li>
<li id="menu-item-134887" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-134887"><a href="https://a360media.cloud.buysub.com/">Subscriber Service</a></li>
<li id="menu-item-260468" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-260468"><a href="https://shop.getspecialissues.com/">Shop Special Issues</a></li>
<li id="menu-item-130811" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-130811"><a href="/archives/">SIte Map</a></li>
<li id="menu-item-298102" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-298102"><a href="https://www.intouchweekly.com/accessibility-statement/">Accessibility Statement</a></li>
<li id="menu-item-298103" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-298103"><a href="https://a360media.com/cookie-policy">Cookie Policy</a></li>
</ul></div>			</div>

			<div class="site-footer__cta">
				<div class="site-footer__cta__inner">
					<h3 class="site-footer__heading">Want more?</h3>
					<div class="textwidget custom-html-widget"><img src="https://www.intouchweekly.com/wp-content/themes/ami-bauer/assets/build/images/placeholders/placeholder-1x1.svg" data-src="https://www.intouchweekly.com/wp-content/uploads/2020/10/IT4420_cover_final.jpg?w=300" data-srcset="https://www.intouchweekly.com/wp-content/uploads/2020/10/IT4420_cover_final.jpg?w=200 1x, https://www.intouchweekly.com/wp-content/uploads/2020/10/IT4420_cover_final.jpg?w=400 2x" sizes="200px" alt="In This Issue of In Touch Weekly" class="img-responsive img-cover" width="161" height="218"></div>					<a class="site-footer__cta-link" target="_blank" rel="nofollow noopener" href="https://w1.buysub.com/servlet/OrdersGateway?cds_mag_code=NTW&#038;cds_page_id=230030">Subscribe!</a>
					<a class="site-footer__cta-link" target="_blank" rel="nofollow noopener" href="https://w1.buysub.com/servlet/GiftsGateway?cds_mag_code=NTW">Give as a Gift</a>
					<a class="site-footer__cta-link" target="_blank" rel="nofollow noopener" href="https://a360media.cloud.buysub.com/">Subscriber Services</a>
				</div>
			</div>
		</div>
	</div>

</footer>
</div>

	<style type="text/css" media="screen">
		@media screen and ( max-width: 782px ) {
			html {
				margin-top: 0px !important;
			}
			* html body {
				margin-top: 0px !important;
			}
			#wpadminbar {
				display: none;
			}
		}
	</style>
		<script>
		jQuery(document).ready(function ( $ ) {
			$('a[href^="http"]')
				.not('[href^="' + location.protocol + '//' + location.hostname + '"],[href^="https://ciam-ui.kubestage.hearstapps.net"],[href^="https://www.mylo.id"]')
				.attr('target', '_blank');
		});
	</script>
			<script id='main-js-js-extra'>
var ajaxurl = "\/wp-admin\/admin-ajax.php";
var obj = {"templateUrl":"https:\/\/www.intouchweekly.com\/wp-content\/themes\/ami-bauer","restEndpoint":"https:\/\/www.intouchweekly.com\/wp-json\/ami\/v1\/"};
</script>
<script type="text/javascript" src="https://www.intouchweekly.com/_static/??/wp-content/mu-plugins/jetpack-10.9/_inc/build/photon/photon.min.js,/wp-content/themes/ami-bauer/assets/build/js/main.bundle.js?m=1653660468j" ></script><script class='optanon-category-C0004' type='text/plain' src='https://static.adsafeprotected.com/vans-adapter-google-ima.js' id='ami-googleima-js'></script>
<script class='optanon-category-C0003' type='text/plain' src='https://www.intouchweekly.com/wp-content/client-mu-plugins/shared/assets/js/dist/overlayRecircWidget.bundle.js?ver=6.0' id='overlay-recirc-widget-script-js'></script>
<script id='newsletter-sign-up-js-extra'>
var amiNewsletterStrings = {"userEndpoint":"https:\/\/www.intouchweekly.com\/wp-json\/ami\/v1\/newsletter\/user","listEndpoint":"https:\/\/www.intouchweekly.com\/wp-json\/ami\/v1\/newsletter\/list","processMessage":"Sending your request...","defaultError":"An internal error has occurred. Please try again later..","invalidEmailError":"Please enter a valid email and try again."};
</script>
<script type="text/javascript" src="https://www.intouchweekly.com/wp-content/client-mu-plugins/shared/assets/js/dist/newsletterSignUp.bundle.js?m=1653305531g" ></script><script id='sharing-js-js-extra'>
var sharing_js_options = {"lang":"en","counts":"","is_stats_active":"1"};
</script>
<script src='https://www.intouchweekly.com/wp-content/mu-plugins/jetpack-10.9/_inc/build/sharedaddy/sharing.min.js?ver=10.9' id='sharing-js-js'></script>
<script id='sharing-js-js-after'>
var windowOpen;
			( function () {
				function matches( el, sel ) {
					return !! (
						el.matches && el.matches( sel ) ||
						el.msMatchesSelector && el.msMatchesSelector( sel )
					);
				}

				document.body.addEventListener( 'click', function ( event ) {
					if ( ! event.target ) {
						return;
					}

					var el;
					if ( matches( event.target, 'a.share-facebook' ) ) {
						el = event.target;
					} else if ( event.target.parentNode && matches( event.target.parentNode, 'a.share-facebook' ) ) {
						el = event.target.parentNode;
					}

					if ( el ) {
						event.preventDefault();

						// If there's another sharing window open, close it.
						if ( typeof windowOpen !== 'undefined' ) {
							windowOpen.close();
						}
						windowOpen = window.open( el.getAttribute( 'href' ), 'wpcomfacebook', 'menubar=1,resizable=1,width=600,height=400' );
						return false;
					}
				} );
			} )();
var windowOpen;
			( function () {
				function matches( el, sel ) {
					return !! (
						el.matches && el.matches( sel ) ||
						el.msMatchesSelector && el.msMatchesSelector( sel )
					);
				}

				document.body.addEventListener( 'click', function ( event ) {
					if ( ! event.target ) {
						return;
					}

					var el;
					if ( matches( event.target, 'a.share-twitter' ) ) {
						el = event.target;
					} else if ( event.target.parentNode && matches( event.target.parentNode, 'a.share-twitter' ) ) {
						el = event.target.parentNode;
					}

					if ( el ) {
						event.preventDefault();

						// If there's another sharing window open, close it.
						if ( typeof windowOpen !== 'undefined' ) {
							windowOpen.close();
						}
						windowOpen = window.open( el.getAttribute( 'href' ), 'wpcomtwitter', 'menubar=1,resizable=1,width=600,height=350' );
						return false;
					}
				} );
			} )();
</script>
		<script>
			// US-1872 Call AJAX from windows.onload
			( function( $ ) {
				$( window ).load( () => {

					const cachedId = localStorage.getItem( 'perClientId' );

					if ( null === cachedId || "" === cachedId ) {
						const clientId = Date.now() + Math.random();

						if ( window.location.hostname.indexOf( 'usmagazine' ) !== -1 && !!window.Worker ) {

							//console.log("WWW creating worker for permutive button ");
							var worker = new Worker( '/wp-content/themes/ajax-onload.js' );
							worker.onmessage = function( ev ) {

								const newClientId = ev.data;

								console.log( '%c Got via Worker: ' + newClientId, 'background: #27ae60; color: #000; padding: 2px 10px 2px 5px' );

								if ( newClientId ) {
									localStorage.setItem( 'perClientId', newClientId );
									let identities = [{
										"id": newClientId,
										"tag": "publisherUserId",
										"priority": 0
									}
									];
									try {
										let bc = localStorage.getItem( 'blueconic' );
										if ( typeof bc != null ) {
											let bc = JSON.parse( localStorage.getItem( 'blueconic' ) );
											if ( typeof bc.user !== 'undefined' ) {
												identities.push( {
													"id": bc.user.hashedEmail[0],
													"tag": "email_sha256",
													"priority": 1
												} );
											}
										}
										let username = getCookie( 'mylo_username' );
										if ( undefined !== username ) {
											identities.push( {
												"id": username,
												"tag": "mylo_username",
												"priority": 2
											} );
										}
									} catch ( e ) {
										console.log( 'permutive identity: ', e );
									}
									window.permutive.identify( identities );
									console.log( 'identity', identities );
								}
							};
							worker.postMessage( ['permutive', clientId] );
						} else {

							$.ajax( {
								url: '/wp-admin/admin-ajax.php?action=get_client_id&clientId=' + clientId
							} ).done( ( ajaxResponse ) => {
								const parsedResponse = JSON.parse( ajaxResponse );

								console.log( '%c Got: ' + parsedResponse.clientId, 'background: #27ae60; color: #000; padding: 2px 10px 2px 5px' );

								if ( parsedResponse.hasOwnProperty( 'clientId' ) ) {
									localStorage.setItem( 'perClientId', parsedResponse.clientId );
									let identities = [{
										"id": parsedResponse.clientId,
										"tag": "publisherUserId",
										"priority": 0
									}
									];
									try {
										let bc = localStorage.getItem( 'blueconic' );
										if ( typeof bc != null ) {
											let bc = JSON.parse( localStorage.getItem( 'blueconic' ) );
											if ( typeof bc.user !== 'undefined' ) {
												identities.push( {
													"id": bc.user.hashedEmail[0],
													"tag": "email_sha256",
													"priority": 1
												} );
											}
										}
										let username = getCookie( 'mylo_username' );
										if ( undefined !== username ) {
											identities.push( {
												"id": username,
												"tag": "mylo_username",
												"priority": 2
											} );
										}
									} catch ( e ) {
										console.log( 'permutive identity: ', e );
									}
									window.permutive.identify( identities );
									console.log( 'identity', identities );
								}

							} );
						}
					} else {
						let identities = [{
							"id": cachedId,
							"tag": "publisherUserId",
							"priority": 0
						}
						];
						try {
							let bc = localStorage.getItem( 'blueconic' );
							if ( typeof bc != null ) {
								let bc = JSON.parse( localStorage.getItem( 'blueconic' ) );
								if ( typeof bc.user !== 'undefined' ) {
									identities.push( {
										"id": bc.user.hashedEmail[0],
										"tag": "email_sha256",
										"priority": 1
									} );
								}
							}
							let username = getCookie( 'mylo_username' );
							if ( undefined !== username ) {
								identities.push( {
									"id": username,
									"tag": "mylo_username",
									"priority": 2
								} );
							}
						} catch ( e ) {
							console.log( 'permutive identity: ', e );
						}
						window.permutive.identify( identities );
						console.log( 'identity', identities );
					}
				} );
			} )( jQuery );
		</script>

			<script>
		( function( $ ) {
			$( document ).ready( () => {
				if ( getCookie( 'mylo_token' ) !== undefined ) {
					$.ajax( {
						url: '/wp-json/mylo/v1/is-logged-in/'
					} ).done( ( ajaxResponse ) => {
						// const parsedResponse = JSON.parse( ajaxResponse );
						console.log( 'LOGIN', ajaxResponse );
						if ( 'undefined' !== typeof switchMyloControls ) {
							switchMyloControls( ajaxResponse );
						}

						$( '.header-mylo, .header-mylo__mobile' ).addClass( 'visible' );
					} );
				} else {
					$( '.header-mylo, .header-mylo__mobile' ).addClass( 'visible' );
				}
			} );
		} )( jQuery );
	</script>

	<template id="mylo-account-controls">
		<span class="header-mylo__label">Account</span>
		<div class="header-mylo__dropdown">
			<a class="header-mylo__account" href="https://www.mylo.id/account?client_id=6628dtuhkmdqca1squ18er2cq4&#038;logout_uri=https://www.intouchweekly.com/auth/logout">
				<svg class="header-mylo__user-icon icon"><use xlink:href="#icon-user"></use></svg>
				<span>My Account</span>
			</a>
			<a class="header-mylo__sign-out" href="https://www.mylo.id/logout?client_id=6628dtuhkmdqca1squ18er2cq4&#038;logout_uri=https://www.intouchweekly.com/auth/logout">
				<svg class="header-mylo__signout-icon icon"><use xlink:href="#icon-signout"></use></svg>
				<span>Sign Out</span>
			</a>
		</div>
	</template>
	<script src='https://stats.wp.com/e-202222.js' defer></script>
<script>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:10.9',blog:'149114667',post:'452328',tz:'-4',srv:'www.intouchweekly.com',hp:'vip'} ]);
	_stq.push([ 'clickTrackerInit', '149114667', '452328' ]);
</script>
</body>
</html>
