<!DOCTYPE html>
<html lang="en-US">
    <head>
        <meta charset="UTF-8"/>
        <meta name="viewport" content="width=device-width, initial-scale=1.0"/>
        <link rel="profile" href="http://gmpg.org/xfn/11"/>
        <link rel="pingback" href="https://www.intouchweekly.com/xmlrpc.php"/>
        <link rel="apple-touch-icon" sizes="180x180" href="https://www.intouchweekly.com/wp-content/themes/ami-bauer/assets/source/images/favicon/intouch/apple-touch-icon.png">
        <link rel="icon" type="image/png" sizes="32x32" href="https://www.intouchweekly.com/wp-content/themes/ami-bauer/assets/source/images/favicon/intouch/favicon-32x32.png">
        <link rel="icon" type="image/png" sizes="16x16" href="https://www.intouchweekly.com/wp-content/themes/ami-bauer/assets/source/images/favicon/intouch/favicon-16x16.png">
        <link rel="mask-icon" href="https://www.intouchweekly.com/wp-content/themes/ami-bauer/assets/source/images/favicon/intouch/safari-pinned-tab.svg" color="#636363">
        <meta name="theme-color" content="#ffffff">

					
	<!-- OneTrust Cookies Consent Notice start -->
	<script src="https://cdn.cookielaw.org/scripttemplates/otSDKStub.js"  type="text/javascript" charset="UTF-8" data-domain-script="36677945-95df-4551-ae71-315d352a975d"></script>
	<script src="https://cdn.cookielaw.org/opt-out/otCCPAiab.js" type="text/javascript" charset="UTF-8" ccpa-opt-out-ids="C0005,C0004,C0002,BG17" ccpa-opt-out-geo="ca" ccpa-opt-out-lspa="false"></script>
	<script type="text/javascript">
		function OptanonWrapper() {
			var allIframes = document.querySelectorAll( 'iframe[class*="optanon-category"]' );
			allIframes.forEach (function( iframe ) {
				var thisIframeCategories = iframe.classList.value.match(/C000\d+/g);

				// Check if user allowed every category assigned to this iframe
				var shouldBeLoaded = thisIframeCategories.every( function( item ) {
					return OptanonActiveGroups.match( item );
				});

				// Load iframe if every category is allowed
				if ( shouldBeLoaded ) {
					loadIframe( iframe );
				}
			});

			// load iframe element
			function loadIframe( element ) {
				if ( element.tagName.toLowerCase() == "iframe" && !element.getAttribute( "src" ) && element.dataset.src ) {
					element.setAttribute( "src", element.dataset.src );
				}
			}
		}
	</script>
	<!-- OneTrust Cookies Consent Notice end -->

	
			<script>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</script>


			<!-- Jetpack Site Verification Tags -->
<meta name="msvalidate.01" content="097DBAAF43A9B61E9E4259AA7D75B069" />
		<script>
			window.dataLayer = window.dataLayer || [];
			dataLayer = [{"pageCategory":"post","env":"prod","sponsored":"off","vupulse":"on","nodeId":375636,"contentType":"article","nodeCategory":["News"],"nodeTags":["Celebrity Couples","Kardashians","Khloe Kardashian","Pregnancy","Tristan Thompson"],"contentUpdatedDate":"2021\/02\/01","contentPublishDate":"2021\/02\/01","pageTitle":"Khloe Kardashian&#8217;s Pal Stephanie Shepherd Fuels Pregnancy Speculation: &#8216;Baby Blues&#8217;","sponsorshipName":"","comments":"on","author":"","sponsorship_name":"none","skimlinks":"on","zergnet":"on","gotchosen":"on","audience_cat":[],"audience_subcat":[],"exclusive":"off","globaladrefresh":"20000","homepagerefresh":"on","gallerypostrefresh":"on","videopostrefresh":"on","audiopostrefresh":"on","standardpostrefresh":"on","desktoprefresh":"on","mobilerefresh":"on","tragedy":"off","advertorial":"off","refresh":"on"}];

			var site_display_format = 'desktop';

			if ( window.innerWidth < 768 ) {
				site_display_format = 'mobile';
			} else if ( window.innerWidth >= 768 && window.innerWidth <= 1024 ) {
				site_display_format = 'tablet';
			}

			dataLayer.push( { siteDisplayFormat : site_display_format } );

			var name = 'setAgeInfo';
			var matches = document.cookie.match(new RegExp(
				"(?:^|; )" + name.replace(/([\.$?*|{}\(\)\[\]\\\/\+^])/g, '\\$1') + "=([^;]*)"
			));

			dataLayer.push( { userAge : matches ? decodeURIComponent( matches[1] ) : '14' } );
		</script>
		
	<!-- This site is optimized with the Yoast SEO plugin v15.3 - https://yoast.com/wordpress/plugins/seo/ -->
	<title>Khloe Kardashian Fuels Pregnancy Speculation on Girls’ Trip</title>
	<meta name="description" content="Khloe Kardashian sparked pregnancy rumors during her girls’ trip to Turks and Caicos after her pal Stephanie Shepherd left a cryptic comment." />
	<meta name="robots" content="index, follow, max-snippet:-1, max-image-preview:large, max-video-preview:-1" />
	<link rel="canonical" href="https://www.lifeandstylemag.com/posts/khloe-kardashian-sparks-pregnancy-rumors-on-turks-and-caicos-trip/" />
	<meta property="og:locale" content="en_US" />
	<meta property="og:type" content="article" />
	<meta property="og:title" content="Khloe Kardashian&#039;s Pal Stephanie Shepherd Fuels Pregnancy Speculation " />
	<meta property="og:description" content="Khloe Kardashian sparked pregnancy rumors during her girls’ trip to Turks and Caicos after her pal Stephanie Shepherd left a cryptic comment." />
	<meta property="og:url" content="https://www.lifeandstylemag.com/posts/khloe-kardashian-sparks-pregnancy-rumors-on-turks-and-caicos-trip/" />
	<meta property="og:site_name" content="In Touch Weekly" />
	<meta property="article:publisher" content="http://www.facebook.com/InTouchWeekly" />
	<meta property="article:published_time" content="2021-02-01T15:01:49+00:00" />
	<meta property="article:modified_time" content="2021-02-01T14:51:51+00:00" />
	<meta property="fb:app_id" content="437388016401044" />
	<meta name="twitter:card" content="summary_large_image" />
	<meta name="twitter:title" content="Khloe Kardashian&#039;s Pal Stephanie Shepherd Fuels Pregnancy Speculation " />
	<meta name="twitter:description" content="Khloe Kardashian sparked pregnancy rumors during her girls’ trip to Turks and Caicos after her pal Stephanie Shepherd left a cryptic comment." />
	<meta name="twitter:image" content="https://www.intouchweekly.com/wp-content/uploads/2021/02/144003287_111070034302899_9015573559952554709_n.jpg?crop=0px%2C654px%2C1080px%2C568px&amp;resize=1200%2C630" />
	<meta name="twitter:creator" content="@intouchweekly" />
	<meta name="twitter:site" content="@intouchweekly" />
<script type="application/ld+json">{"@context":"http:\/\/schema.org","@type":"WebPage","@id":"https:\/\/www.lifeandstylemag.com\/posts\/khloe-kardashian-sparks-pregnancy-rumors-on-turks-and-caicos-trip\/#webpage","publisher":{"@id":"https:\/\/www.lifeandstylemag.com\/posts\/khloe-kardashian-sparks-pregnancy-rumors-on-turks-and-caicos-trip\/#organization"},"isPartOf":{"@id":"https:\/\/www.lifeandstylemag.com\/posts\/khloe-kardashian-sparks-pregnancy-rumors-on-turks-and-caicos-trip\/#website"}}</script>
<script type="application/ld+json">{"@context":"http:\/\/schema.org","@type":"Organization","name":"In Touch Weekly","url":"https:\/\/www.intouchweekly.com","parentOrganization":"a360 Media LLC","logo":{"@type":"ImageObject","url":"https:\/\/www.intouchweekly.com\/wp-content\/themes\/ami-bauer\/assets\/source\/images\/icons\/logo-intouch.svg"},"address":{"@type":"PostalAddress","streetAddress":"4 New York Plaza","addresslocality":"New York, NY","postalCode":"10004"},"telephone":"212-545-4800","sameAs":["http:\/\/www.facebook.com\/InTouchWeekly","https:\/\/twitter.com\/intouchweekly","https:\/\/www.instagram.com\/intouchweekly\/?hl=en","https:\/\/plus.google.com\/+intouchweekly"]}</script>
<script type="application/ld+json">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</script>
	<script type="application/ld+json" class="yoast-schema-graph">{"@context":"https://schema.org","@graph":[{"@type":"WebSite","@id":"https://www.intouchweekly.com/#website","url":"https://www.intouchweekly.com/","name":"In Touch Weekly","description":"","inLanguage":"en-US"},{"@type":"ImageObject","@id":"https://www.lifeandstylemag.com/posts/khloe-kardashian-sparks-pregnancy-rumors-on-turks-and-caicos-trip/#primaryimage","inLanguage":"en-US","url":"https://www.intouchweekly.com/wp-content/uploads/2021/02/144003287_111070034302899_9015573559952554709_n.jpg?fit=1080%2C1346","width":1080,"height":1346,"caption":"Khloe Kardashian Fuels Pregnancy Speculation on Girls\u2019 Trip Turks and Caicos"},{"@type":"WebPage","@id":"https://www.lifeandstylemag.com/posts/khloe-kardashian-sparks-pregnancy-rumors-on-turks-and-caicos-trip/#webpage","url":"https://www.lifeandstylemag.com/posts/khloe-kardashian-sparks-pregnancy-rumors-on-turks-and-caicos-trip/","name":"Khloe Kardashian Fuels Pregnancy Speculation on Girls\u2019 Trip","isPartOf":{"@id":"https://www.intouchweekly.com/#website"},"primaryImageOfPage":{"@id":"https://www.lifeandstylemag.com/posts/khloe-kardashian-sparks-pregnancy-rumors-on-turks-and-caicos-trip/#primaryimage"},"datePublished":"2021-02-01T15:01:49+00:00","dateModified":"2021-02-01T14:51:51+00:00","author":{"@id":"https://www.intouchweekly.com/#/schema/person/4fd7f0f758bf039335d271809c19bca5"},"description":"Khloe Kardashian sparked pregnancy rumors during her girls\u2019 trip to Turks and Caicos after her pal Stephanie Shepherd left a cryptic comment.","inLanguage":"en-US","potentialAction":[{"@type":"ReadAction","target":["https://www.lifeandstylemag.com/posts/khloe-kardashian-sparks-pregnancy-rumors-on-turks-and-caicos-trip/"]}]},{"@type":"Person","@id":"https://www.intouchweekly.com/#/schema/person/4fd7f0f758bf039335d271809c19bca5","name":"In Touch Staff","image":{"@type":"ImageObject","@id":"https://www.intouchweekly.com/#personlogo","inLanguage":"en-US","url":"https://secure.gravatar.com/avatar/c71bed0a9484223b31f8ebdd087a2247?s=96&d=mm&r=g","caption":"In Touch Staff"},"sameAs":["https://intouchweekly.com"]}]}</script>
	<!-- / Yoast SEO plugin. -->


<meta content="593583017" property="fb:admins" /><meta content="75932763901" property="fb:pages" /><link rel='dns-prefetch' href='//www.google.com' />
<link rel='dns-prefetch' href='//static.adsafeprotected.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="text/xml" title="In Touch Weekly &raquo; Feed" href="https://www.intouchweekly.com/feed/" />
	<script>
		function gptAdsWindowWidth() {
			var w = window,
				d = document,
				e = d.documentElement,
				x = Math.max( e.scrollWidth, e.offsetWidth, e.clientWidth );
			return x;
		}

		function adsParseUrlParams( val ) {
			var result = false,
				tmp = [];
			var items = location.search.substr( 1 ).split( "&" );
			for ( var index = 0; index < items.length; index++ ) {
				tmp = items[ index ].split( "=" );
				if ( tmp[ 0 ] === val ) {
					result = decodeURIComponent( tmp[ 1 ] );
				}
			}
			return result;
		}

		function getCookie(name) {
			var matches = document.cookie.match(new RegExp(
				"(?:^|; )" + name.replace(/([\.$?*|{}\(\)\[\]\\\/\+^])/g, '\\$1') + "=([^;]*)"
			));
			return matches ? decodeURIComponent(matches[1]) : undefined;
		}

		function setCookie(name, value, options) {
			options = options || {};

			var expires = options.expires;

			if (typeof expires == "number" && expires) {
				var d = new Date();
				d.setTime(d.getTime() + expires * 1000);
				expires = options.expires = d;
			}
			if (expires && expires.toUTCString) {
				options.expires = expires.toUTCString();
			}

			value = encodeURIComponent(value);

			var updatedCookie = name + "=" + value;

			for (var propName in options) {
				updatedCookie += "; " + propName;
				var propValue = options[propName];
				if (propValue !== true) {
					updatedCookie += "=" + propValue;
				}
			}

			document.cookie = updatedCookie;
		}

		function amiGetCookie( name ) {
			return getCookie(name);
		}

		window.gptNetwork = '/4216/ami.itw/';
		window.pageID = '375636';
		window.keyword = 'post';
		window.cType = 'Article';
		window.adUnitZone = 'news';

		var spons = "no";

		window.adsRefresh = {};
		window.adsRefresh.impr = [];
		window.adsRefresh.ads = [];
	</script>    		<script type="text/plain" class="optanon-category-C0004" src="//d3jdulus8lb392.cloudfront.net/ami/intouch-weekly/main.js" async=""></script>
			<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.0.1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.0.1\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/www.intouchweekly.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.6"}};
			!function(e,a,t){var r,n,o,i,p=a.createElement("canvas"),s=p.getContext&&p.getContext("2d");function c(e,t){var a=String.fromCharCode;s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,e),0,0);var r=p.toDataURL();return s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,t),0,0),r===p.toDataURL()}function l(e){if(!s||!s.fillText)return!1;switch(s.textBaseline="top",s.font="600 32px Arial",e){case"flag":return!c([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])&&(!c([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!c([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]));case"emoji":return!c([55357,56424,8205,55356,57212],[55357,56424,8203,55356,57212])}return!1}function d(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(i=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},o=0;o<i.length;o++)t.supports[i[o]]=l(i[o]),t.supports.everything=t.supports.everything&&t.supports[i[o]],"flag"!==i[o]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[i[o]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(r=t.source||{}).concatemoji?d(r.concatemoji):r.wpemoji&&r.twemoji&&(d(r.twemoji),d(r.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<link rel='stylesheet' id='all-css-0' href='https://www.intouchweekly.com/_static/??-eJyNjksOwjAMRC9EalARaheIo6B8rNaQTxU7Qrk9pltYsJvFvDcDr81Q9rEFZPDMEIgFXCz+aSK5amsHlh5xSJQHLRxACV+yYBaQFZNyNpFxtmEFy4zC4BrFsOt2VhekNL9+8amZLbaFMsMDZbM6Og8j3PURLJixkjb5d/xXlkpoUU/yaisGG0LfI+XlY7il6+lynOfxPE3jG0DaYyg=' type='text/css' media='all' />
<style id='wp-block-library-inline-css'>
.has-text-align-justify{text-align:justify;}
</style>
<script type='text/javascript' src='https://www.intouchweekly.com/_static/??-eJzTLy/QzcxLzilNSS3WzwKiwtLUokoopZebmaeXVayjj0+Rbm5melFiSSpUsX2uraGZgbmJmZmRqXkWAK97IiQ='></script>
<link rel="https://api.w.org/" href="https://www.intouchweekly.com/wp-json/" /><link rel="alternate" type="application/json" href="https://www.intouchweekly.com/wp-json/wp/v2/posts/375636" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.intouchweekly.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://www.intouchweekly.com/wp-includes/wlwmanifest.xml" /> 
<meta name="generator" content="WordPress 5.6" />
<link rel='shortlink' href='https://wp.me/pa5Fxh-1zIE' />
<link rel="alternate" type="application/json+oembed" href="https://www.intouchweekly.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.intouchweekly.com%2Fposts%2Fkhloe-kardashian-fuels-pregnancy-speculation-on-girls-trip%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://www.intouchweekly.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.intouchweekly.com%2Fposts%2Fkhloe-kardashian-fuels-pregnancy-speculation-on-girls-trip%2F&#038;format=xml" />
<style type='text/css'>img#wpstats{display:none}</style>	<script type="text/javascript">
		var onloadCallback = function () {
			grecaptcha.render('captcha_div', {
				'sitekey': '6Le3wfsSAAAAACvmSPuxMZp6mKxCn62rYP2EcJeP',
				'size': 'compact',
				'theme': 'dark'
			});
		};
	</script>
	<meta property="og:updated_time" content="2021-02-01T14:51:51+00:00" />
<meta property="og:image" content="https://www.intouchweekly.com/wp-content/uploads/2021/02/144003287_111070034302899_9015573559952554709_n.jpg?crop=0px%2C654px%2C1080px%2C568px&#038;resize=1200%2C630" />
<meta property="og:image:secure_url" content="https://www.intouchweekly.com/wp-content/uploads/2021/02/144003287_111070034302899_9015573559952554709_n.jpg?crop=0px%2C654px%2C1080px%2C568px&#038;resize=1200%2C630" />
<meta property="og:image:width" content="1200" />
<meta property="og:image:height" content="630" />
	<script>
		window.jwVastTag = {};
		window.prerollTag = {};
		window.jwpDef = {};
		window.jwpBids = {};
	</script>
	<link rel="icon" href="https://www.intouchweekly.com/wp-content/uploads/2020/11/android-chrome-192x192-1.png?fit=32%2C32" sizes="32x32" />
<link rel="icon" href="https://www.intouchweekly.com/wp-content/uploads/2020/11/android-chrome-192x192-1.png?fit=192%2C192" sizes="192x192" />
<link rel="apple-touch-icon" href="https://www.intouchweekly.com/wp-content/uploads/2020/11/android-chrome-192x192-1.png?fit=180%2C180" />
<meta name="msapplication-TileImage" content="https://www.intouchweekly.com/wp-content/uploads/2020/11/android-chrome-192x192-1.png?fit=192%2C192" />
			<!-- Google Tag Manager -->
			<script>( function( w, d, s, l, i ) {
					w[l] = w[l] || [];
					w[l].push( {
						'gtm.start':
							new Date().getTime(), event: 'gtm.js'
					} );
					var f = d.getElementsByTagName( s )[0],
						j = d.createElement( s ), dl = l != 'dataLayer' ? '&l=' + l : '';
					j.async = true;
					j.src =
						'https://www.googletagmanager.com/gtm.js?id=' + i + dl + "";
					f.parentNode.insertBefore( j, f );
				} )( window, document, 'script', 'dataLayer', "GTM-KRVDT6T");</script>		<!-- End Google Tag Manager -->
						<style type="text/css" id="wp-custom-css">
				/* Hide total on search page */
.search__total {
	display: none;
}

/* Fix for sharethrough units */
.post-content .dfp-slot[class*='sh-gal'] {
	margin: 30px auto 40px;
}

/* Center mobile ads */
.ds_cpp,
.dfp-wrapper.mobile-only {
	margin-left: auto;
	margin-right: auto;
}

/* Gallery slide caption text */
.list-gallery .gallery-item__caption {
	font-size: 18px;
  font-size: 1.125rem;
	line-height: 1.2;
}

/* Fix for SpotIm huge widget on mobile */
@media screen and (max-width: 1023px) {
	#comments-wrapper {
		max-width: 100vw;
	}
}
			</style>
		
		
    </head>

<body class="post-template-default single single-post postid-375636 single-format-standard">
				<!-- Google Tag Manager (noscript) -->
			<noscript>
				<iframe src="https://www.googletagmanager.com/ns.html?id=GTM-KRVDT6T" height="0" width="0" style="display:none;visibility:hidden"></iframe>
			</noscript>		<!-- End Google Tag Manager (noscript) -->
					<!-- First big banner block -->
	<div class="ad-slot-top banner first mobile-hidden">
		<div class="ad-container horizontal">
			<div class="dfp-wrapper  mobile-hidden" data-slot="leader1"><div id="leader1" class="dfp-slot dfp-container leader1 "></div></div>		</div>
	</div>

	<div id="page-box">

		<header id="header" class="header">
							<div class="desktop-only color__variation">
					<div class="color__variation-first"></div>
					<div class="color__variation-second"></div>
					<div class="color__variation-third"></div>
				</div>
						<div class="header__mobile">
				<div class="extended-menu-btn desktop-hidden">
					<div id="menu-trigger">
						<span></span><span></span><span></span>
						<div class="hidden-except-readers">Open main menu button</div>
					</div>
				</div>
				<a href="https://www.intouchweekly.com" class="container__full-block  header__logo">
					<svg class="site-logo">
													<use xlink:href="#logo-intouch"></use>
											</svg>
				</a>
				<div class="header__search">
					<svg class="header__search-icon">
						<use xlink:href="#icon-search"/>
					</svg>
					<div class="search__close-icon">
						<span></span><span></span>
					</div>
				</div>
				<div class="search-box">
					<form role="search" method="get" action="/search-results/">
						<input type="search" name="_s" placeholder="Search..." required value="">
						<button type="submit"><svg><use xlink:href="#icon-search"/></svg></button>
					</form>
				</div>
			</div>
			<div id="mobile-nav" class="container__full">
									<div class="color-line">
						<div class="color-line-one"></div>
						<div class="color-line-two"></div>
						<div class="color-line-three"></div>
					</div>
								<nav class="container__full-block header-nav-primary__wrapper" role="navigation"
					 aria-label="Header Primary Nav">
					<div class="header-nav-primary ae-exclude">
						<ul id="menu-main-redesign-menu" class="site-header__main-nav__list"><li id="menu-item-258605" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-258605 site-header__main-nav__list__item"><a href="https://www.intouchweekly.com/posts/category/news/">News</a></li>
<li id="menu-item-258606" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-258606 site-header__main-nav__list__item"><a href="https://www.intouchweekly.com/posts/category/reality-tv/">Reality TV</a></li>
<li id="menu-item-372340" class="menu-item--new menu-item menu-item-type-post_type menu-item-object-page menu-item-372340 site-header__main-nav__list__item"><a href="https://www.intouchweekly.com/sampler/">Top Picks</a></li>
<li id="menu-item-258607" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-258607 site-header__main-nav__list__item"><a href="https://www.intouchweekly.com/posts/category/true-crime/">True Crime</a></li>
<li id="menu-item-258609" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-258609 site-header__main-nav__list__item"><a href="https://www.intouchweekly.com/posts/category/entertainment/">Entertainment</a></li>
<li id="menu-item-258610" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-258610 site-header__main-nav__list__item"><a href="https://www.intouchweekly.com/posts/category/omg/">OMG!</a></li>
<li id="menu-item-258611" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-258611 site-header__main-nav__list__item"><a href="https://www.intouchweekly.com/posts/category/style/">Style</a></li>
<li id="menu-item-261937" class="desktop-hidden menu-item menu-item-type-custom menu-item-object-custom menu-item-261937 site-header__main-nav__list__item"><a href="https://shop.getspecialissues.com/">Shop Special Issues</a></li>
<li id="menu-item-261938" class="desktop-hidden menu-item menu-item-type-custom menu-item-object-custom menu-item-261938 site-header__main-nav__list__item"><a href="https://a360media.com/privacy-policy">Privacy Piolicy</a></li>
<li id="menu-item-261940" class="desktop-hidden menu-item menu-item-type-custom menu-item-object-custom menu-item-261940 site-header__main-nav__list__item"><a href="https://a360media.com/terms-and-conditions">Terms &#038; Conditions</a></li>
</ul>					</div>
				</nav>
				<a href="https://www.intouchweekly.com" class="container__full-block  header__logo desktop-l-only">
					<svg class="site-logo">
													<use xlink:href="#logo-intouch"></use>
											</svg>
				</a>

								<div class="header__tools">
								<div class="header__close">
					<div id="menu-trigger-close" class="desktop-hidden">
						<span></span><span></span>
					</div>
				</div>
				<div class="header__search">
					<svg class="header__search-icon desktop-l-only">
						<use xlink:href="#icon-search"/>
					</svg>
					<div class="search__close-icon">
						<span></span><span></span>
					</div>
					<div class="search-box">
						<form role="search" method="get" action="/search-results/">
							<input type="search" name="_s" placeholder="Search..." required value="">
							<button type="submit"><svg><use xlink:href="#icon-search"/></svg></button>
						</form>
					</div>
				</div>
                <div class="header__accessibility desktop-l-only">
                    <a href="/accessibility-statement/" target="_blank">
                        <svg class="header__accessibility-icon">
                            <use xlink:href="#icon-accessibility"/>
                        </svg>
                    </a>
                </div>
				<ul class="header__icons">
					<li class="cookies-dropdown__wrapper desktop-l-only">
						<span class="cookies-dropdown__trigger"><svg class="cookies-dropdown__icon"><use xlink:href="#icon-cookie"></use></svg></span>
						<ul class="cookies-dropdown__list">
							<li class="cookies-dropdown__item">
								<a href="https://a360media.com/privacy-policy/" target="_blank">Privacy Policy</a>
							</li>
							<li class="cookies-dropdown__item">
								<a href="https://a360media.com/cookie-policy/" target="_blank">Cookie Policy</a>
							</li>

							<li class="cookies-dropdown__item">
								<!-- OneTrust Cookies Settings button start -->
								<a class="optanon-toggle-display" name="Manage Cookies">Manage Cookies</a>
								<!-- OneTrust Cookies Settings button end -->
							</li>

						</ul>
					</li>

					<li class="header__icons-accessibility desktop-hidden">
                        <a class="header__icons-icon" href="/accessibility-statement/" target="_blank">
                            <svg class="icon-accessibility__icon"><use xlink:href="#icon-accessibility"></use></svg>
                        </a>
                    </li>

					<li class="cookies-icon__mobile">
						<!-- OneTrust Cookies Settings button start -->
						<a class="optanon-toggle-display">
							<svg class="cookies-mobile__icon"><use xlink:href="#icon-cookie"></use></svg>
						</a>
						<!-- OneTrust Cookies Settings button end -->
					</li>

					<li><a href="http://www.facebook.com/InTouchWeekly" class="header__icons-icon" rel="nofollow"> <span class="hidden-except-readers">Social icon facebook</span><svg class="icon icon-facebook"><use xlink:href="#icon-facebook-b"></use></svg></a></li><li><a href="https://www.instagram.com/intouchweekly/?hl=en" class="header__icons-icon" rel="nofollow"> <span class="hidden-except-readers">Social icon instagram</span><svg class="icon icon-instagram"><use xlink:href="#icon-instagram-b"></use></svg></a></li><li><a href="https://twitter.com/intouchweekly" class="header__icons-icon" rel="nofollow"> <span class="hidden-except-readers">Social icon twitter</span><svg class="icon icon-twitter"><use xlink:href="#icon-twitter-b"></use></svg></a></li>				</ul>
				<div class="header__text">
										<a class="header__text-subscribe" href="https://w1.buysub.com/servlet/OrdersGateway?cds_mag_code=NTW&#038;cds_page_id=230030" target="blank" rel="nofollow">
						SUBSCRIBE <span >NOW!</span>
					</a>
											<a class="header__text-pay" href="#" id="send-scoop-trigger">WE PAY FOR SCOOPS</a>
									</div>
								</div>
												<!--  Send us a scoop popup	-->
				<div class="send-scoop__container" id="send-scoop-popup">
					<div class="page-wrapper">
						<div class="send-scoop__close-btn" id="send-scoop-close"><span class="hidden-except-readers">Got a Hot tip form close button</span></div>
						<h2 class="send-scoop__title">Send us a scoop!</h2>
						<form id="send-scoop__form" class="send-scoop__form" novalidate="novalidate">
							<input type="hidden" name="action" value="ok_tip_form">
							<div class="sender-info">
								<div class="field-container">
									<label for="scoop-form-name" class="hidden-except-readers">Input your name</label> <input placeholder="Your name..." type="text" name="name" value="" required="required" aria-required="true" id="scoop-form-name">
								</div>
								<div class="field-container">
									<label for="scoop-form-email" class="hidden-except-readers">Input your email</label> <input placeholder="Your email..." type="email" name="email" value="" required="required" aria-required="true" id="scoop-form-email">
								</div>
								<div class="field-container">
									<label for="scoop-form-phone" class="hidden-except-readers">Input your phone number</label> <input placeholder="Your phone number..." type="text" name="phone" value="" required="required" aria-required="true" id="scoop-form-phone">
								</div>
								<div class="sender-msg">
									<label for="scoop-message" class="hidden-except-readers">Enter scoop message here</label> <textarea placeholder="The Scoop..." name="tip" required="required" aria-required="true" id="scoop-message"></textarea>
									<div id="captcha_div"></div>
								</div>
								<button type="submit" class="send-scoop__submit" id="scoop-form-send-btn" value="scoop-form-send-btn">SEND THE GOODS!</button>
							</div>
						</form>
					</div>
				</div>
							</div>

		</header>

		<div class="l-container">
		<div class="l-grid__post">
			<div class="l-grid__post-content">
				
<div class="l-grid__main-post">
	<div class="l-grid__main-post_content">
		
					<header class="post-header__wrapper">
				<div class="post-header__inner">
					
<div class="post-header">
	<h1 class="post-header__title">Khloe Kardashian&#8217;s Pal Stephanie Shepherd Fuels Pregnancy Speculation: &#8216;Baby Blues&#8217;</h1>
	</div>

<div class="post-meta">
	
<div class="post-meta__category">
				<a class="article_category" href="https://www.intouchweekly.com/posts/category/news/">News</a>
	</div>
	<div class="post-meta__inner">
		
<div class="post-meta__inner-date">Feb 1, 2021 10:01 am<span class="divider-dot">· </span></div>
		    <div class="post-meta__inner-author"> By <span>
            <a href="https://www.intouchweekly.com/authors/in-touch-weekly-36933/" title="In Touch Staff" rel="author" class="">In Touch Staff</a>        </span>
    </div>
    	</div>
</div>

											<figure class="post-hero">
														<img src="https://www.intouchweekly.com/wp-content/uploads/2021/02/144003287_111070034302899_9015573559952554709_n.jpg?crop=0px%2C649px%2C1080px%2C612px&#038;resize=120%2C68" srcset="https://www.intouchweekly.com/wp-content/uploads/2021/02/144003287_111070034302899_9015573559952554709_n.jpg?crop=0px%2C649px%2C1080px%2C612px&amp;resize=120%2C68 120w, https://www.intouchweekly.com/wp-content/uploads/2021/02/144003287_111070034302899_9015573559952554709_n.jpg?crop=0px%2C649px%2C1080px%2C612px&amp;resize=230%2C129 230w, https://www.intouchweekly.com/wp-content/uploads/2021/02/144003287_111070034302899_9015573559952554709_n.jpg?crop=0px%2C649px%2C1080px%2C612px&amp;resize=408%2C230 408w, https://www.intouchweekly.com/wp-content/uploads/2021/02/144003287_111070034302899_9015573559952554709_n.jpg?crop=0px%2C649px%2C1080px%2C612px&amp;resize=630%2C354 630w, https://www.intouchweekly.com/wp-content/uploads/2021/02/144003287_111070034302899_9015573559952554709_n.jpg?crop=0px%2C649px%2C1080px%2C612px&amp;resize=940%2C529 940w" sizes="(max-width: 600px) 600px, 940px" alt="Khloe Kardashian Fuels Pregnancy Speculation on Girls’ Trip Turks and Caicos" data-fallback-img="https://www.intouchweekly.com/wp-content/uploads/2021/02/144003287_111070034302899_9015573559952554709_n.jpg?fit=1080%2C1346">															<p class="photo-credit">Courtesy Khloe Kardashian/Instagram</p>
													</figure>
										</div>

				<div class="post-header__sidebar">
					
<div class="post-sidebar__pictures">
	<div class="post-sidebar__header">
					<svg><use xlink:href="#icon-in-logo" /></svg>
							<span>Top stories</span>
			</div>

			<div class="post-sidebar__grid">
							<article class="article__item">

					<a class="article__item-thumbnail" href="https://www.intouchweekly.com/posts/meghan-markle-trades-old-fashioned-royal-dress-code-for-sweats/">
																					<div class="video-icon video__block-icon"><svg><use xlink:href="#icon-video" /></svg></div>
														<figure class="article__item-figure">
								<div class="item__figure-source ok-thumb ok-standard-thumb">
									<img src="https://www.intouchweekly.com/wp-content/uploads/2020/01/Meghan-Markle-Hated-Royal-Dress-Code-Shes-Much-More-Comfortable-Wearing-Casual-Clothes.jpg?resize=90%2C90" srcset="https://www.intouchweekly.com/wp-content/uploads/2020/01/Meghan-Markle-Hated-Royal-Dress-Code-Shes-Much-More-Comfortable-Wearing-Casual-Clothes.jpg?resize=90%2C90 90w, https://www.intouchweekly.com/wp-content/uploads/2020/01/Meghan-Markle-Hated-Royal-Dress-Code-Shes-Much-More-Comfortable-Wearing-Casual-Clothes.jpg?resize=180%2C180 180w, https://www.intouchweekly.com/wp-content/uploads/2020/01/Meghan-Markle-Hated-Royal-Dress-Code-Shes-Much-More-Comfortable-Wearing-Casual-Clothes.jpg?resize=300%2C300 300w, https://www.intouchweekly.com/wp-content/uploads/2020/01/Meghan-Markle-Hated-Royal-Dress-Code-Shes-Much-More-Comfortable-Wearing-Casual-Clothes.jpg?resize=408%2C408 408w, https://www.intouchweekly.com/wp-content/uploads/2020/01/Meghan-Markle-Hated-Royal-Dress-Code-Shes-Much-More-Comfortable-Wearing-Casual-Clothes.jpg?resize=600%2C600 600w, https://www.intouchweekly.com/wp-content/uploads/2020/01/Meghan-Markle-Hated-Royal-Dress-Code-Shes-Much-More-Comfortable-Wearing-Casual-Clothes.jpg?resize=816%2C816 816w, https://www.intouchweekly.com/wp-content/uploads/2020/01/Meghan-Markle-Hated-Royal-Dress-Code-Shes-Much-More-Comfortable-Wearing-Casual-Clothes.jpg?resize=1200%2C1200 1200w" sizes="(min-width: 1024px) 90px, 300px" alt="Exclusive: Meghan Markle &#039;Hated&#039; Royal Dress Code: She&#039;s &#039;Much More Comfortable Wearing Casual Clothes&#039;Exclusive: Meghan Markle &#039;Hated&#039; Royal Dress Code: She&#039;s &#039;Much More Comfortable Wearing Casual Clothes&#039;" data-fallback-img="https://www.intouchweekly.com/wp-content/uploads/2020/01/Meghan-Markle-Hated-Royal-Dress-Code-Shes-Much-More-Comfortable-Wearing-Casual-Clothes.jpg?fit=2000%2C2000">								</div>
							</figure>
											</a>

					<h2 class="article__item-title">
						<a href="https://www.intouchweekly.com/posts/meghan-markle-trades-old-fashioned-royal-dress-code-for-sweats/">Meghan Markle ‘Hated’ Her Royal Dress Code: She’d Rather Wear ‘Sweats’</a>
					</h2>

				</article>
							<article class="article__item">

					<a class="article__item-thumbnail" href="https://www.intouchweekly.com/posts/married-at-first-sight-still-married-127836/">
																					<div class="gallery-icon gallery__block-icon"><svg><use xlink:href="#icon-photos" /></svg></div>
														<figure class="article__item-figure">
								<div class="item__figure-source ok-thumb ok-standard-thumb">
									<img src="https://www.intouchweekly.com/wp-content/uploads/2018/04/Jamie-and-Doug-Season-1-MAFS.jpg?crop=0px%2C0px%2C750px%2C750px&#038;resize=90%2C90" srcset="https://www.intouchweekly.com/wp-content/uploads/2018/04/Jamie-and-Doug-Season-1-MAFS.jpg?crop=0px%2C0px%2C750px%2C750px&amp;resize=90%2C90 90w, https://www.intouchweekly.com/wp-content/uploads/2018/04/Jamie-and-Doug-Season-1-MAFS.jpg?crop=0px%2C0px%2C750px%2C750px&amp;resize=180%2C180 180w, https://www.intouchweekly.com/wp-content/uploads/2018/04/Jamie-and-Doug-Season-1-MAFS.jpg?crop=0px%2C0px%2C750px%2C750px&amp;resize=300%2C300 300w, https://www.intouchweekly.com/wp-content/uploads/2018/04/Jamie-and-Doug-Season-1-MAFS.jpg?crop=0px%2C0px%2C750px%2C750px&amp;resize=408%2C408 408w, https://www.intouchweekly.com/wp-content/uploads/2018/04/Jamie-and-Doug-Season-1-MAFS.jpg?crop=0px%2C0px%2C750px%2C750px&amp;resize=600%2C600 600w" sizes="(min-width: 1024px) 90px, 300px" alt="Jamie and Doug Season 1 MAFS" data-fallback-img="https://www.intouchweekly.com/wp-content/uploads/2018/04/Jamie-and-Doug-Season-1-MAFS.jpg?fit=750%2C750">								</div>
							</figure>
											</a>

					<h2 class="article__item-title">
						<a href="https://www.intouchweekly.com/posts/married-at-first-sight-still-married-127836/">Still Together? See Where the 'Married at First Sight' Couples Are Now</a>
					</h2>

				</article>
							<article class="article__item">

					<a class="article__item-thumbnail" href="https://www.intouchweekly.com/posts/kobe-bryant-family-pictures-see-photos-of-his-wife-and-kids/">
																					<div class="gallery-icon gallery__block-icon"><svg><use xlink:href="#icon-photos" /></svg></div>
														<figure class="article__item-figure">
								<div class="item__figure-source ok-thumb ok-standard-thumb">
									<img src="https://www.intouchweekly.com/wp-content/uploads/2020/01/Screen-Shot-2020-01-27-at-4.09.35-PM.png?resize=90%2C90" srcset="https://www.intouchweekly.com/wp-content/uploads/2020/01/Screen-Shot-2020-01-27-at-4.09.35-PM.png?resize=90%2C90 90w, https://www.intouchweekly.com/wp-content/uploads/2020/01/Screen-Shot-2020-01-27-at-4.09.35-PM.png?resize=180%2C180 180w, https://www.intouchweekly.com/wp-content/uploads/2020/01/Screen-Shot-2020-01-27-at-4.09.35-PM.png?resize=300%2C300 300w, https://www.intouchweekly.com/wp-content/uploads/2020/01/Screen-Shot-2020-01-27-at-4.09.35-PM.png?resize=408%2C408 408w, https://www.intouchweekly.com/wp-content/uploads/2020/01/Screen-Shot-2020-01-27-at-4.09.35-PM.png?resize=600%2C600 600w" sizes="(min-width: 1024px) 90px, 300px" alt="Kobe Bryant Family Photos" data-fallback-img="https://www.intouchweekly.com/wp-content/uploads/2020/01/Screen-Shot-2020-01-27-at-4.09.35-PM.png?fit=964%2C602">								</div>
							</figure>
											</a>

					<h2 class="article__item-title">
						<a href="https://www.intouchweekly.com/posts/kobe-bryant-family-pictures-see-photos-of-his-wife-and-kids/">These Photos of Kobe Bryant Prove How Much He Loved His Family</a>
					</h2>

				</article>
							<article class="article__item">

					<a class="article__item-thumbnail" href="https://www.intouchweekly.com/posts/who-are-kobe-bryants-wife-and-kids-he-had-4-daughters-with-vanessa/">
																					<div class="video-icon video__block-icon"><svg><use xlink:href="#icon-video" /></svg></div>
														<figure class="article__item-figure">
								<div class="item__figure-source ok-thumb ok-standard-thumb">
									<img src="https://www.intouchweekly.com/wp-content/uploads/2020/01/Who-Are-Kobe-Bryants-Wife-and-Kids.jpg?crop=0px%2C69px%2C3150px%2C3150px&#038;resize=90%2C90" srcset="https://www.intouchweekly.com/wp-content/uploads/2020/01/Who-Are-Kobe-Bryants-Wife-and-Kids.jpg?crop=0px%2C69px%2C3150px%2C3150px&amp;resize=90%2C90 90w, https://www.intouchweekly.com/wp-content/uploads/2020/01/Who-Are-Kobe-Bryants-Wife-and-Kids.jpg?crop=0px%2C69px%2C3150px%2C3150px&amp;resize=180%2C180 180w, https://www.intouchweekly.com/wp-content/uploads/2020/01/Who-Are-Kobe-Bryants-Wife-and-Kids.jpg?crop=0px%2C69px%2C3150px%2C3150px&amp;resize=300%2C300 300w, https://www.intouchweekly.com/wp-content/uploads/2020/01/Who-Are-Kobe-Bryants-Wife-and-Kids.jpg?crop=0px%2C69px%2C3150px%2C3150px&amp;resize=408%2C408 408w, https://www.intouchweekly.com/wp-content/uploads/2020/01/Who-Are-Kobe-Bryants-Wife-and-Kids.jpg?crop=0px%2C69px%2C3150px%2C3150px&amp;resize=600%2C600 600w, https://www.intouchweekly.com/wp-content/uploads/2020/01/Who-Are-Kobe-Bryants-Wife-and-Kids.jpg?crop=0px%2C69px%2C3150px%2C3150px&amp;resize=816%2C816 816w, https://www.intouchweekly.com/wp-content/uploads/2020/01/Who-Are-Kobe-Bryants-Wife-and-Kids.jpg?crop=0px%2C69px%2C3150px%2C3150px&amp;resize=1200%2C1200 1200w" sizes="(min-width: 1024px) 90px, 300px" alt="Who Are Kobe Bryant&#039;s Wife and Kids?" data-fallback-img="https://www.intouchweekly.com/wp-content/uploads/2020/01/Who-Are-Kobe-Bryants-Wife-and-Kids.jpg?fit=3150%2C3726">								</div>
							</figure>
											</a>

					<h2 class="article__item-title">
						<a href="https://www.intouchweekly.com/posts/who-are-kobe-bryants-wife-and-kids-he-had-4-daughters-with-vanessa/">Kobe Bryant Was a Family Man and Had 4 Daughters With Wife Vanessa</a>
					</h2>

				</article>
							<article class="article__item">

					<a class="article__item-thumbnail" href="https://www.intouchweekly.com/posts/duggars-wearing-pants-159940/">
																					<div class="gallery-icon gallery__block-icon"><svg><use xlink:href="#icon-photos" /></svg></div>
														<figure class="article__item-figure">
								<div class="item__figure-source ok-thumb ok-standard-thumb">
									<img src="https://www.intouchweekly.com/wp-content/uploads/2018/05/Duggar-Girls-Wearing-Pants-and-Jeans.jpg?resize=90%2C90" srcset="https://www.intouchweekly.com/wp-content/uploads/2018/05/Duggar-Girls-Wearing-Pants-and-Jeans.jpg?resize=90%2C90 90w, https://www.intouchweekly.com/wp-content/uploads/2018/05/Duggar-Girls-Wearing-Pants-and-Jeans.jpg?resize=180%2C180 180w, https://www.intouchweekly.com/wp-content/uploads/2018/05/Duggar-Girls-Wearing-Pants-and-Jeans.jpg?resize=300%2C300 300w, https://www.intouchweekly.com/wp-content/uploads/2018/05/Duggar-Girls-Wearing-Pants-and-Jeans.jpg?resize=408%2C408 408w, https://www.intouchweekly.com/wp-content/uploads/2018/05/Duggar-Girls-Wearing-Pants-and-Jeans.jpg?resize=600%2C600 600w, https://www.intouchweekly.com/wp-content/uploads/2018/05/Duggar-Girls-Wearing-Pants-and-Jeans.jpg?resize=816%2C816 816w, https://www.intouchweekly.com/wp-content/uploads/2018/05/Duggar-Girls-Wearing-Pants-and-Jeans.jpg?resize=1200%2C1200 1200w" sizes="(min-width: 1024px) 90px, 300px" alt="Duggar Girls Wearing Pants and Jeans" data-fallback-img="https://www.intouchweekly.com/wp-content/uploads/2018/05/Duggar-Girls-Wearing-Pants-and-Jeans.jpg?fit=2500%2C2000">								</div>
							</figure>
											</a>

					<h2 class="article__item-title">
						<a href="https://www.intouchweekly.com/posts/duggars-wearing-pants-159940/">So Much for That Dress Code! Almost All the Duggar Girls Have Worn Pants</a>
					</h2>

				</article>
					</div>
	</div>
				</div>
			</header>
		
		<div class="post-content">
			<div class="dfp-wrapper  mobile-only" data-slot="mb1"><div id="mb1" class="dfp-slot dfp-container mb1 "></div></div>			<div class="dfp-wrapper  mobile-hidden" data-slot="leader-inline1"><div id="leader-inline1" class="dfp-slot dfp-container leader-inline1 "></div></div>
			<div class="track-ga">
				<p><span class="s1">Baby on the brain? <a href="https://www.intouchweekly.com/tags/khloe-kardashian-17677/"><b>Khloé Kardashian</b></a> sparked <a href="https://www.lifeandstylemag.com/posts/is-khloe-kardashian-pregnant-again-baby-no-2-clues-with-tristan/">pregnancy rumors</a> during a <a href="https://www.intouchweekly.com/posts/inside-the-kardashian-jenner-girls-turks-and-caicos-trip/">girls’ trip to Turks and Caicos</a> after she and pal <a href="https://www.intouchweekly.com/posts/steph-shepherd-says-reunion-with-kim-kardashian-was-not-awkward/"><b>Stephanie Shepherd</b></a> had a cryptic comment exchange on Instagram.</span></p>
<div class="link-related">
	<a href="https://www.intouchweekly.com/posts/tristan-thompsons-comments-on-khloe-kardashians-pics-are-thirsty/" target="_blank" data-track-category="Article Page" data-track-action="Tap Interstitial Link" data-track-label="https://www.intouchweekly.com/posts/tristan-thompsons-comments-on-khloe-kardashians-pics-are-thirsty/" class="link-related__link">
		
		
				Tristan Thompson Can't Stop Thirsting Over Khloe Kardashian's Photos
		
					</a>
</div>

<p><span class="s1">The <i><a href="https://www.intouchweekly.com/tags/kuwtk-12529/">Keeping Up With the Kardashians</a> </i>star, 36, shared a stunning photo of herself on Sunday, January 31, posing on a staircase while wearing a blue minidress. Her hair was pulled tightly back as she flaunted all her gorgeous curves.</span></p>
<figure class="wp-caption alignnone"><img loading="lazy" class="alignnone size-large wp-image-375642" src="https://www.intouchweekly.com/wp-content/uploads/2021/02/145400787_241709577550690_8204372238032086898_n.jpg?w=819&#038;resize=819%2C1024" alt="Khloe Kardashian Sparks Pregnancy Rumors on Turks and Caicos Trip" width="819" height="1024" srcset="https://www.intouchweekly.com/wp-content/uploads/2021/02/145400787_241709577550690_8204372238032086898_n.jpg?w=400 400w, https://www.intouchweekly.com/wp-content/uploads/2021/02/145400787_241709577550690_8204372238032086898_n.jpg?w=600 600w, https://www.intouchweekly.com/wp-content/uploads/2021/02/145400787_241709577550690_8204372238032086898_n.jpg?w=800 800w, https://www.intouchweekly.com/wp-content/uploads/2021/02/145400787_241709577550690_8204372238032086898_n.jpg?w=830 830w, https://www.intouchweekly.com/wp-content/uploads/2021/02/145400787_241709577550690_8204372238032086898_n.jpg?w=1200 1200w, https://www.intouchweekly.com/wp-content/uploads/2021/02/145400787_241709577550690_8204372238032086898_n.jpg?w=1660 1660w" sizes="(max-width: 400px) 400px, (max-width: 600px) 600px, 830px" data-recalc-dims="1"><figcaption class="photo-credit"><span class="credit">Courtesy Khloe Kardashian/Instagram</span></figcaption></figure><p class="p1"><span class="s1">“Baby blues,” Stephanie, 31, commented while adding two cold face emojis.</span></p>
<p class="p1"><span class="s1">“I guess that could have been my caption. Next time, I’m consulting with you,” the Good American founder responded. While Steph could have been referring to the color of KoKo’s dress, her comment started pregnancy speculation from fans.</span></p>
<figure class="wp-caption alignnone"><img loading="lazy" class="alignnone size-large wp-image-375645" src="https://www.intouchweekly.com/wp-content/uploads/2021/02/Image-from-iOS-116.png?w=1024&#038;resize=1024%2C710" alt="Khloe Kardashian's Pal Stephanie Shepherd Fuels Pregnancy Speculation: 'Baby Blues'" width="1024" height="710" srcset="https://www.intouchweekly.com/wp-content/uploads/2021/02/Image-from-iOS-116.png?w=400 400w, https://www.intouchweekly.com/wp-content/uploads/2021/02/Image-from-iOS-116.png?w=600 600w, https://www.intouchweekly.com/wp-content/uploads/2021/02/Image-from-iOS-116.png?w=800 800w, https://www.intouchweekly.com/wp-content/uploads/2021/02/Image-from-iOS-116.png?w=830 830w, https://www.intouchweekly.com/wp-content/uploads/2021/02/Image-from-iOS-116.png?w=1200 1200w, https://www.intouchweekly.com/wp-content/uploads/2021/02/Image-from-iOS-116.png?w=1660 1660w" sizes="(max-width: 400px) 400px, (max-width: 600px) 600px, 830px" data-recalc-dims="1"><figcaption class="photo-credit"><span class="credit">Courtesy Khloe Kardashian/Instagram</span></figcaption></figure><p class="p1"><span class="s1">“Does this mean Khloé’s pregnant with a boy? Because [right now] I’m taking everything as a clue,” one user commented with a laughing emoji. “Pregnant?” someone else questioned.</span></p>
<p class="p1"><span class="s1">Khloé and her <a href="https://www.lifeandstylemag.com/posts/khloe-kardashian-shares-tristan-thompsons-welcome-balloons/">off-and-on boyfriend</a>, <a href="https://www.intouchweekly.com/tags/tristan-thompson-39973/"><b>Tristan Thompson</b></a>, have been teasing the idea of possibly <a href="https://www.intouchweekly.com/posts/khloe-kardashian-definitely-wants-baby-no-2-with-tristan-thompson/">having more kids</a>. The pair share daughter <a href="https://www.lifeandstylemag.com/tags/true-thompson/">True Thompson</a>, whom they welcomed in 2018.</span></p>
<p class="p1"><span class="s1">An insider told <i><a href="https://www.lifeandstylemag.com/posts/kim-kardashian-all-for-khloe-and-tristan-getting-married/">Life &amp; Style</a> </i>in January 2021 the <i>Revenge Body</i> host is “<a href="https://www.intouchweekly.com/posts/kim-kardashian-supports-khloe-and-tristan-getting-married/">open to marriage</a> if things work out” with the <a href="https://www.intouchweekly.com/posts/khloe-kardashian-leaving-social-media-after-tristan-reunion/">Boston Celtics player</a>, 29, despite their rocky past, which includes <a href="https://www.intouchweekly.com/posts/khloe-kardashian-and-tristan-thompsons-relationship-timeline/">two public cheating scandals</a>.</span></p>
<p class="p1"><span class="s1">“She envisions her dream wedding, and she definitely wants to have another baby, regardless of whether they’re married,” continued the insider. “But the timing needs to be right before she reaches the point of walking down the aisle.”</span></p>
<p class="p1"><span class="s1">In addition, the reality TV couple talked about expanding their family on <i>KUWTK</i>. Khloé asked if Tristan would be open to <a href="https://www.intouchweekly.com/posts/khloe-kardashian-asked-tristan-thompson-to-be-her-sperm-donor/">being her “sperm donor”</a> during season 19 before they <a href="https://www.intouchweekly.com/posts/khloe-kardashian-and-tristan-thompson-back-together-he-changed/">rekindled their relationship</a> while <a href="https://www.intouchweekly.com/posts/khloe-kardashian-and-tristan-thompson-are-getting-along-in-isolation/">quarantining together amid the coronavirus pandemic</a>. During promos for the 20th and final season of the famous family’s reality show, the mom of one can be heard telling the Canadian athlete, “I just feel like it’s now time to have another kid.”</span></p>
<script type="text/plain" class="optanon-category-C0002-C0004 optanon-category-C0002-C0004" src="https://content.jwplatform.com/libraries/8t2DpQMJ.js"></script><div class="ami-fluid-video-wrapper"><div id="jwplayer_25JlR6dB_8t2DpQMJ_div"></div>
		<script type="text/plain" class="optanon-category-C0002-C0004">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</script></div>
<p class="p1"><span class="s1">In July 2020, Khloé talked about possibly having more children during an interview with <a href="https://www.youtube.com/watch?v=YysU7JlD9Zo&amp;ab_channel=SiriusXM">SiriusXM Hits 1</a>. “True is two now and is getting big. It goes so fast. I know why people keep having kids now, but then they just all turn into teenagers,” the reality starlet explained at the time. “I don’t think I could handle the amount [mom <a href="https://www.intouchweekly.com/tags/kris-jenner-12165/"><b>Kris Jenner</b></a>] had, but I love kids. I love my nieces and nephews. I love children, so I definitely would.”</span></p>
<div class="link-related link-related__with-thumb link-related__video-node">
	<a href="https://www.intouchweekly.com/posts/kardashian-love-triangles-the-most-awkward-kuwtk-romances/" target="_blank" data-track-category="Article Page" data-track-action="Tap Interstitial Link" data-track-label="https://www.intouchweekly.com/posts/kardashian-love-triangles-the-most-awkward-kuwtk-romances/" class="link-related__link">
					<span class="link-related__image">
				<img src="https://www.intouchweekly.com/wp-content/uploads/2019/05/Love-Triangles-KUWTK-01.jpg?resize=120%2C68&#038;w=1180" srcset="https://www.intouchweekly.com/wp-content/uploads/2019/05/Love-Triangles-KUWTK-01.jpg?resize=120%2C68&#038;w=1180 120w, https://www.intouchweekly.com/wp-content/uploads/2019/05/Love-Triangles-KUWTK-01.jpg?resize=230%2C129 230w, https://www.intouchweekly.com/wp-content/uploads/2019/05/Love-Triangles-KUWTK-01.jpg?resize=408%2C230 408w, https://www.intouchweekly.com/wp-content/uploads/2019/05/Love-Triangles-KUWTK-01.jpg?resize=630%2C354 630w, https://www.intouchweekly.com/wp-content/uploads/2019/05/Love-Triangles-KUWTK-01.jpg?resize=940%2C529 940w, https://www.intouchweekly.com/wp-content/uploads/2019/05/Love-Triangles-KUWTK-01.jpg?resize=1200%2C675 1200w, https://www.intouchweekly.com/wp-content/uploads/2019/05/Love-Triangles-KUWTK-01.jpg?resize=1260%2C709 1260w" sizes="120px" alt="Love Triangles KUWTK" data-fallback-img="https://www.intouchweekly.com/wp-content/uploads/2019/05/Love-Triangles-KUWTK-01.jpg?fit=1600%2C900" data-recalc-dims="1"><div class="video-icon video__block-icon"><svg><use xlink:href="#icon-video"></use></svg></div>
							</span>
		
		<span class="link-related__content"><span class="link-related__title">
				These Awkward Love Triangles From 'KUWTK' Will Make Your Head Spin
		</span>
				</span>	</a>
</div>

<p class="p1"><span class="s1">That’s not to say Khloé wouldn’t be perfectly happy with one child. “I am totally content with True,” she added. “If all I had was True, she’s fulfilled everything I could have wanted. She’s so perfect. If I have another one, what a blessing, but if not, I am fine with it.”</span></p>
<p class="p1"><span class="s1">Time will tell what the future holds for Khloé and Tristan!</span></p>				<div class="youtube-cta">
	<p>
		<strong>
			<em>For access to all our exclusive celebrity videos and interviews – <a href="https://www.youtube.com/channel/UC-pi_mLzGF4RoMfpHbYgtUg?sub_confirmation=1" target="_blank">Subscribe on YouTube!</a></em>
		</strong>
	</p>
</div>							</div>

			
			<div class="share-alt">
				<span class="comment-icon"><svg><use xlink:href="#comment"></use></svg></span><div class="sharedaddy sd-sharing-enabled"><div class="robots-nocontent sd-block sd-social sd-social-icon sd-sharing"><div class="sd-content"><ul><li class="share-facebook"><a rel="nofollow noopener noreferrer" data-shared="sharing-facebook-375636" class="share-facebook sd-button share-icon no-text" href="https://www.intouchweekly.com/posts/khloe-kardashian-fuels-pregnancy-speculation-on-girls-trip/?share=facebook" target="_blank" title="Click to share on Facebook"><span></span><span class="sharing-screen-reader-text">Click to share on Facebook (Opens in new window)</span></a></li><li class="share-twitter"><a rel="nofollow noopener noreferrer" data-shared="sharing-twitter-375636" class="share-twitter sd-button share-icon no-text" href="https://www.intouchweekly.com/posts/khloe-kardashian-fuels-pregnancy-speculation-on-girls-trip/?share=twitter" target="_blank" title="Click to share on Twitter"><span></span><span class="sharing-screen-reader-text">Click to share on Twitter (Opens in new window)</span></a></li><li class="share-pinterest"><a rel="nofollow noopener noreferrer" data-shared="sharing-pinterest-375636" class="share-pinterest sd-button share-icon no-text" href="https://www.intouchweekly.com/posts/khloe-kardashian-fuels-pregnancy-speculation-on-girls-trip/?share=pinterest" target="_blank" title="Click to share on Pinterest"><span></span><span class="sharing-screen-reader-text">Click to share on Pinterest (Opens in new window)</span></a></li><li class="share-end"></li></ul></div></div></div>			</div>

			<div id="rc-widget-intouchmb"></div>
				<div class="in-page__tags-block">
		<ul class="in-page__tags-block__tags-list">
			<li class="in-page__tags-block__title">Tags:</li>
			<li class="in-page__tags-block__tags-list__item"><a href="https://www.intouchweekly.com/tags/celebrity-couples-49034/" rel="tag">Celebrity Couples</a></li><li class="in-page__tags-block__tags-list__item"><a href="https://www.intouchweekly.com/tags/kardashians-12183/" rel="tag">Kardashians</a></li><li class="in-page__tags-block__tags-list__item"><a href="https://www.intouchweekly.com/tags/khloe-kardashian-17677/" rel="tag">Khloe Kardashian</a></li><li class="in-page__tags-block__tags-list__item"><a href="https://www.intouchweekly.com/tags/pregnancy-12344/" rel="tag">Pregnancy</a></li><li class="in-page__tags-block__tags-list__item"><a href="https://www.intouchweekly.com/tags/tristan-thompson-39973/" rel="tag">Tristan Thompson</a></li>		</ul>
	</div>
	
			
		</div>
	</div>

			<div class="gcwp-carousel"></div>
		<div id="zergnet-widget-68225"></div>
	
	

	<div id="comments-wrapper"><div id="spotImCommentsDiv"
     data-spotim-module="recirculation"
     data-spot-id="sp_tcLBc9rX"
     data-post-id="375636"
     data-post-url="https://www.intouchweekly.com/?p=375636"
     data-post-tags="Celebrity Couples, Kardashians, Khloe Kardashian, Pregnancy, Tristan Thompson">
</div>
</div></div>
				
<div class="post-sidebar">
	<div class="dfp-wrapper  desktop-only" data-slot="rr1"><div id="rr1" class="dfp-slot dfp-container rr1 ad-container sticky-top"></div></div>	
<div class="post-sidebar__pictures">
	<div class="post-sidebar__header">
					<svg><use xlink:href="#icon-in-logo" /></svg>
							<span>Top stories</span>
			</div>

			<div class="post-sidebar__grid">
							<article class="article__item">

					<a class="article__item-thumbnail" href="https://www.intouchweekly.com/posts/meghan-markle-trades-old-fashioned-royal-dress-code-for-sweats/">
																					<div class="video-icon video__block-icon"><svg><use xlink:href="#icon-video" /></svg></div>
														<figure class="article__item-figure">
								<div class="item__figure-source ok-thumb ok-standard-thumb">
									<img src="https://www.intouchweekly.com/wp-content/uploads/2020/01/Meghan-Markle-Hated-Royal-Dress-Code-Shes-Much-More-Comfortable-Wearing-Casual-Clothes.jpg?resize=90%2C90" srcset="https://www.intouchweekly.com/wp-content/uploads/2020/01/Meghan-Markle-Hated-Royal-Dress-Code-Shes-Much-More-Comfortable-Wearing-Casual-Clothes.jpg?resize=90%2C90 90w, https://www.intouchweekly.com/wp-content/uploads/2020/01/Meghan-Markle-Hated-Royal-Dress-Code-Shes-Much-More-Comfortable-Wearing-Casual-Clothes.jpg?resize=180%2C180 180w, https://www.intouchweekly.com/wp-content/uploads/2020/01/Meghan-Markle-Hated-Royal-Dress-Code-Shes-Much-More-Comfortable-Wearing-Casual-Clothes.jpg?resize=300%2C300 300w, https://www.intouchweekly.com/wp-content/uploads/2020/01/Meghan-Markle-Hated-Royal-Dress-Code-Shes-Much-More-Comfortable-Wearing-Casual-Clothes.jpg?resize=408%2C408 408w, https://www.intouchweekly.com/wp-content/uploads/2020/01/Meghan-Markle-Hated-Royal-Dress-Code-Shes-Much-More-Comfortable-Wearing-Casual-Clothes.jpg?resize=600%2C600 600w, https://www.intouchweekly.com/wp-content/uploads/2020/01/Meghan-Markle-Hated-Royal-Dress-Code-Shes-Much-More-Comfortable-Wearing-Casual-Clothes.jpg?resize=816%2C816 816w, https://www.intouchweekly.com/wp-content/uploads/2020/01/Meghan-Markle-Hated-Royal-Dress-Code-Shes-Much-More-Comfortable-Wearing-Casual-Clothes.jpg?resize=1200%2C1200 1200w" sizes="(min-width: 1024px) 90px, 300px" alt="Exclusive: Meghan Markle &#039;Hated&#039; Royal Dress Code: She&#039;s &#039;Much More Comfortable Wearing Casual Clothes&#039;Exclusive: Meghan Markle &#039;Hated&#039; Royal Dress Code: She&#039;s &#039;Much More Comfortable Wearing Casual Clothes&#039;" data-fallback-img="https://www.intouchweekly.com/wp-content/uploads/2020/01/Meghan-Markle-Hated-Royal-Dress-Code-Shes-Much-More-Comfortable-Wearing-Casual-Clothes.jpg?fit=2000%2C2000">								</div>
							</figure>
											</a>

					<h2 class="article__item-title">
						<a href="https://www.intouchweekly.com/posts/meghan-markle-trades-old-fashioned-royal-dress-code-for-sweats/">Meghan Markle ‘Hated’ Her Royal Dress Code: She’d Rather Wear ‘Sweats’</a>
					</h2>

				</article>
							<article class="article__item">

					<a class="article__item-thumbnail" href="https://www.intouchweekly.com/posts/married-at-first-sight-still-married-127836/">
																					<div class="gallery-icon gallery__block-icon"><svg><use xlink:href="#icon-photos" /></svg></div>
														<figure class="article__item-figure">
								<div class="item__figure-source ok-thumb ok-standard-thumb">
									<img src="https://www.intouchweekly.com/wp-content/uploads/2018/04/Jamie-and-Doug-Season-1-MAFS.jpg?crop=0px%2C0px%2C750px%2C750px&#038;resize=90%2C90" srcset="https://www.intouchweekly.com/wp-content/uploads/2018/04/Jamie-and-Doug-Season-1-MAFS.jpg?crop=0px%2C0px%2C750px%2C750px&amp;resize=90%2C90 90w, https://www.intouchweekly.com/wp-content/uploads/2018/04/Jamie-and-Doug-Season-1-MAFS.jpg?crop=0px%2C0px%2C750px%2C750px&amp;resize=180%2C180 180w, https://www.intouchweekly.com/wp-content/uploads/2018/04/Jamie-and-Doug-Season-1-MAFS.jpg?crop=0px%2C0px%2C750px%2C750px&amp;resize=300%2C300 300w, https://www.intouchweekly.com/wp-content/uploads/2018/04/Jamie-and-Doug-Season-1-MAFS.jpg?crop=0px%2C0px%2C750px%2C750px&amp;resize=408%2C408 408w, https://www.intouchweekly.com/wp-content/uploads/2018/04/Jamie-and-Doug-Season-1-MAFS.jpg?crop=0px%2C0px%2C750px%2C750px&amp;resize=600%2C600 600w" sizes="(min-width: 1024px) 90px, 300px" alt="Jamie and Doug Season 1 MAFS" data-fallback-img="https://www.intouchweekly.com/wp-content/uploads/2018/04/Jamie-and-Doug-Season-1-MAFS.jpg?fit=750%2C750">								</div>
							</figure>
											</a>

					<h2 class="article__item-title">
						<a href="https://www.intouchweekly.com/posts/married-at-first-sight-still-married-127836/">Still Together? See Where the 'Married at First Sight' Couples Are Now</a>
					</h2>

				</article>
							<article class="article__item">

					<a class="article__item-thumbnail" href="https://www.intouchweekly.com/posts/kobe-bryant-family-pictures-see-photos-of-his-wife-and-kids/">
																					<div class="gallery-icon gallery__block-icon"><svg><use xlink:href="#icon-photos" /></svg></div>
														<figure class="article__item-figure">
								<div class="item__figure-source ok-thumb ok-standard-thumb">
									<img src="https://www.intouchweekly.com/wp-content/uploads/2020/01/Screen-Shot-2020-01-27-at-4.09.35-PM.png?resize=90%2C90" srcset="https://www.intouchweekly.com/wp-content/uploads/2020/01/Screen-Shot-2020-01-27-at-4.09.35-PM.png?resize=90%2C90 90w, https://www.intouchweekly.com/wp-content/uploads/2020/01/Screen-Shot-2020-01-27-at-4.09.35-PM.png?resize=180%2C180 180w, https://www.intouchweekly.com/wp-content/uploads/2020/01/Screen-Shot-2020-01-27-at-4.09.35-PM.png?resize=300%2C300 300w, https://www.intouchweekly.com/wp-content/uploads/2020/01/Screen-Shot-2020-01-27-at-4.09.35-PM.png?resize=408%2C408 408w, https://www.intouchweekly.com/wp-content/uploads/2020/01/Screen-Shot-2020-01-27-at-4.09.35-PM.png?resize=600%2C600 600w" sizes="(min-width: 1024px) 90px, 300px" alt="Kobe Bryant Family Photos" data-fallback-img="https://www.intouchweekly.com/wp-content/uploads/2020/01/Screen-Shot-2020-01-27-at-4.09.35-PM.png?fit=964%2C602">								</div>
							</figure>
											</a>

					<h2 class="article__item-title">
						<a href="https://www.intouchweekly.com/posts/kobe-bryant-family-pictures-see-photos-of-his-wife-and-kids/">These Photos of Kobe Bryant Prove How Much He Loved His Family</a>
					</h2>

				</article>
							<article class="article__item">

					<a class="article__item-thumbnail" href="https://www.intouchweekly.com/posts/who-are-kobe-bryants-wife-and-kids-he-had-4-daughters-with-vanessa/">
																					<div class="video-icon video__block-icon"><svg><use xlink:href="#icon-video" /></svg></div>
														<figure class="article__item-figure">
								<div class="item__figure-source ok-thumb ok-standard-thumb">
									<img src="https://www.intouchweekly.com/wp-content/uploads/2020/01/Who-Are-Kobe-Bryants-Wife-and-Kids.jpg?crop=0px%2C69px%2C3150px%2C3150px&#038;resize=90%2C90" srcset="https://www.intouchweekly.com/wp-content/uploads/2020/01/Who-Are-Kobe-Bryants-Wife-and-Kids.jpg?crop=0px%2C69px%2C3150px%2C3150px&amp;resize=90%2C90 90w, https://www.intouchweekly.com/wp-content/uploads/2020/01/Who-Are-Kobe-Bryants-Wife-and-Kids.jpg?crop=0px%2C69px%2C3150px%2C3150px&amp;resize=180%2C180 180w, https://www.intouchweekly.com/wp-content/uploads/2020/01/Who-Are-Kobe-Bryants-Wife-and-Kids.jpg?crop=0px%2C69px%2C3150px%2C3150px&amp;resize=300%2C300 300w, https://www.intouchweekly.com/wp-content/uploads/2020/01/Who-Are-Kobe-Bryants-Wife-and-Kids.jpg?crop=0px%2C69px%2C3150px%2C3150px&amp;resize=408%2C408 408w, https://www.intouchweekly.com/wp-content/uploads/2020/01/Who-Are-Kobe-Bryants-Wife-and-Kids.jpg?crop=0px%2C69px%2C3150px%2C3150px&amp;resize=600%2C600 600w, https://www.intouchweekly.com/wp-content/uploads/2020/01/Who-Are-Kobe-Bryants-Wife-and-Kids.jpg?crop=0px%2C69px%2C3150px%2C3150px&amp;resize=816%2C816 816w, https://www.intouchweekly.com/wp-content/uploads/2020/01/Who-Are-Kobe-Bryants-Wife-and-Kids.jpg?crop=0px%2C69px%2C3150px%2C3150px&amp;resize=1200%2C1200 1200w" sizes="(min-width: 1024px) 90px, 300px" alt="Who Are Kobe Bryant&#039;s Wife and Kids?" data-fallback-img="https://www.intouchweekly.com/wp-content/uploads/2020/01/Who-Are-Kobe-Bryants-Wife-and-Kids.jpg?fit=3150%2C3726">								</div>
							</figure>
											</a>

					<h2 class="article__item-title">
						<a href="https://www.intouchweekly.com/posts/who-are-kobe-bryants-wife-and-kids-he-had-4-daughters-with-vanessa/">Kobe Bryant Was a Family Man and Had 4 Daughters With Wife Vanessa</a>
					</h2>

				</article>
							<article class="article__item">

					<a class="article__item-thumbnail" href="https://www.intouchweekly.com/posts/duggars-wearing-pants-159940/">
																					<div class="gallery-icon gallery__block-icon"><svg><use xlink:href="#icon-photos" /></svg></div>
														<figure class="article__item-figure">
								<div class="item__figure-source ok-thumb ok-standard-thumb">
									<img src="https://www.intouchweekly.com/wp-content/uploads/2018/05/Duggar-Girls-Wearing-Pants-and-Jeans.jpg?resize=90%2C90" srcset="https://www.intouchweekly.com/wp-content/uploads/2018/05/Duggar-Girls-Wearing-Pants-and-Jeans.jpg?resize=90%2C90 90w, https://www.intouchweekly.com/wp-content/uploads/2018/05/Duggar-Girls-Wearing-Pants-and-Jeans.jpg?resize=180%2C180 180w, https://www.intouchweekly.com/wp-content/uploads/2018/05/Duggar-Girls-Wearing-Pants-and-Jeans.jpg?resize=300%2C300 300w, https://www.intouchweekly.com/wp-content/uploads/2018/05/Duggar-Girls-Wearing-Pants-and-Jeans.jpg?resize=408%2C408 408w, https://www.intouchweekly.com/wp-content/uploads/2018/05/Duggar-Girls-Wearing-Pants-and-Jeans.jpg?resize=600%2C600 600w, https://www.intouchweekly.com/wp-content/uploads/2018/05/Duggar-Girls-Wearing-Pants-and-Jeans.jpg?resize=816%2C816 816w, https://www.intouchweekly.com/wp-content/uploads/2018/05/Duggar-Girls-Wearing-Pants-and-Jeans.jpg?resize=1200%2C1200 1200w" sizes="(min-width: 1024px) 90px, 300px" alt="Duggar Girls Wearing Pants and Jeans" data-fallback-img="https://www.intouchweekly.com/wp-content/uploads/2018/05/Duggar-Girls-Wearing-Pants-and-Jeans.jpg?fit=2500%2C2000">								</div>
							</figure>
											</a>

					<h2 class="article__item-title">
						<a href="https://www.intouchweekly.com/posts/duggars-wearing-pants-159940/">So Much for That Dress Code! Almost All the Duggar Girls Have Worn Pants</a>
					</h2>

				</article>
					</div>
	</div>
<div id="promoblock-box"><div id="media_image-2" class="widget_media_image"><a href="https://www.lifetogo.com/collections/immunity-boosters?utm_source=AMI&#038;utm_medium=display&#038;utm_campaign=LifeToGo&#038;utm_term=300x490&#038;utm_content=LTG_IB_ENERGY_AMI_1.8.21_300x490"><img width="300" height="490" src="https://www.intouchweekly.com/wp-content/uploads/2021/01/LTG_IB_ENERGY_AMI_1.8.21_300x490.jpg?fit=300%2C490" class="image wp-image-373548  attachment-300x490 size-300x490" alt="LTG_IB_ENERGY_AMI_1.8.21_300x490" loading="lazy" style="max-width: 100%; height: auto;" /></a></div><div id="custom_html-3" class="widget_text widget_custom_html"><div class="textwidget custom-html-widget"><iframe src="https://securepubads.g.doubleclick.net/gampad/adx?iu=/4216/ITW.LTG&sz=1x1" width="1" height="1" style="position:absolute; visibility:hidden"></iframe></div></div></div>			<script>
				document.addEventListener("DOMContentLoaded", function() {
					if(window.innerWidth < 1024) {// Get the element
						var elem = document.getElementById('promoblock-box');
						var target = document.querySelector('.l-grid__main-post_content');
						elem.parentNode.removeChild(elem);
						target.appendChild(elem)
					}
				});
			</script>
			<div id="rc-widget-intouchdt"></div>	<div class="ad-container__sticky-wrapper">
		<div class="ad-container sticky-top">
			<div class="dfp-wrapper  desktop-only" data-slot="rr2"><div id="rr2" class="dfp-slot dfp-container rr2 "></div></div>		</div>
	</div>
</div>
			</div>
		</div>
	</div>

	
<div class="full-container">

			<div class="l-container">
			<div class="l-grid">
				<div class="l-grid__main-slider">
					<div class="block__title">
													<svg><use xlink:href="#icon-in-logo" /></svg>
												<span>Exclusives</span>
					</div>
					<div class="l-grid__main-sliderblock slider">
						
<article class="article__item">
			<a class="article__item-thumbnail" href="https://www.intouchweekly.com/posts/tmogs-mackenzie-mckee-clarifies-relationship-status-with-josh/">
						<figure class="article__item-figure">
				<img src="https://www.intouchweekly.com/wp-content/uploads/2020/08/Teen-Mom-OG-Star-Mackenzie-McKee-Responds-to-Rumors-Shes-Back-With-Husband-Josh-McKee.jpg?crop=0px%2C0px%2C2000px%2C1133px&#038;resize=120%2C68" srcset="https://www.intouchweekly.com/wp-content/uploads/2020/08/Teen-Mom-OG-Star-Mackenzie-McKee-Responds-to-Rumors-Shes-Back-With-Husband-Josh-McKee.jpg?crop=0px%2C0px%2C2000px%2C1133px&amp;resize=120%2C68 120w, https://www.intouchweekly.com/wp-content/uploads/2020/08/Teen-Mom-OG-Star-Mackenzie-McKee-Responds-to-Rumors-Shes-Back-With-Husband-Josh-McKee.jpg?crop=0px%2C0px%2C2000px%2C1133px&amp;resize=230%2C129 230w, https://www.intouchweekly.com/wp-content/uploads/2020/08/Teen-Mom-OG-Star-Mackenzie-McKee-Responds-to-Rumors-Shes-Back-With-Husband-Josh-McKee.jpg?crop=0px%2C0px%2C2000px%2C1133px&amp;resize=408%2C230 408w, https://www.intouchweekly.com/wp-content/uploads/2020/08/Teen-Mom-OG-Star-Mackenzie-McKee-Responds-to-Rumors-Shes-Back-With-Husband-Josh-McKee.jpg?crop=0px%2C0px%2C2000px%2C1133px&amp;resize=630%2C354 630w, https://www.intouchweekly.com/wp-content/uploads/2020/08/Teen-Mom-OG-Star-Mackenzie-McKee-Responds-to-Rumors-Shes-Back-With-Husband-Josh-McKee.jpg?crop=0px%2C0px%2C2000px%2C1133px&amp;resize=940%2C529 940w, https://www.intouchweekly.com/wp-content/uploads/2020/08/Teen-Mom-OG-Star-Mackenzie-McKee-Responds-to-Rumors-Shes-Back-With-Husband-Josh-McKee.jpg?crop=0px%2C0px%2C2000px%2C1133px&amp;resize=1200%2C675 1200w, https://www.intouchweekly.com/wp-content/uploads/2020/08/Teen-Mom-OG-Star-Mackenzie-McKee-Responds-to-Rumors-Shes-Back-With-Husband-Josh-McKee.jpg?crop=0px%2C0px%2C2000px%2C1133px&amp;resize=1260%2C709 1260w, https://www.intouchweekly.com/wp-content/uploads/2020/08/Teen-Mom-OG-Star-Mackenzie-McKee-Responds-to-Rumors-Shes-Back-With-Husband-Josh-McKee.jpg?crop=0px%2C0px%2C2000px%2C1133px&amp;resize=1920%2C1080 1920w" sizes="(max-width: 400px) 408px, 408px" alt="Mackenzie McKee Wearing Workout Gear with Inset Photo of Mackenzie and Josh McKee Selfie" data-fallback-img="https://www.intouchweekly.com/wp-content/uploads/2020/08/Teen-Mom-OG-Star-Mackenzie-McKee-Responds-to-Rumors-Shes-Back-With-Husband-Josh-McKee.jpg?fit=2000%2C2000">			</figure>
		</a>
	
	<h2 class="article__item-title">
		<a href="https://www.intouchweekly.com/posts/tmogs-mackenzie-mckee-clarifies-relationship-status-with-josh/">TMOG's Mackenzie McKee Clarifies Relationship Status With Josh</a>
	</h2>
</article>

<article class="article__item">
			<a class="article__item-thumbnail" href="https://www.intouchweekly.com/posts/tmogs-cheyenne-reveals-where-bf-zach-stands-with-ex-cory/">
						<figure class="article__item-figure">
				<img src="https://www.intouchweekly.com/wp-content/uploads/2021/01/Teen-Mom-OG-Cheyenne-Floyd-Reveals-Where-BF-Zach-Davis-Stands-Now-With-Ex-Cory-Wharton.jpg?crop=0px%2C0px%2C2000px%2C1133px&#038;resize=120%2C68" srcset="https://www.intouchweekly.com/wp-content/uploads/2021/01/Teen-Mom-OG-Cheyenne-Floyd-Reveals-Where-BF-Zach-Davis-Stands-Now-With-Ex-Cory-Wharton.jpg?crop=0px%2C0px%2C2000px%2C1133px&amp;resize=120%2C68 120w, https://www.intouchweekly.com/wp-content/uploads/2021/01/Teen-Mom-OG-Cheyenne-Floyd-Reveals-Where-BF-Zach-Davis-Stands-Now-With-Ex-Cory-Wharton.jpg?crop=0px%2C0px%2C2000px%2C1133px&amp;resize=230%2C129 230w, https://www.intouchweekly.com/wp-content/uploads/2021/01/Teen-Mom-OG-Cheyenne-Floyd-Reveals-Where-BF-Zach-Davis-Stands-Now-With-Ex-Cory-Wharton.jpg?crop=0px%2C0px%2C2000px%2C1133px&amp;resize=408%2C230 408w, https://www.intouchweekly.com/wp-content/uploads/2021/01/Teen-Mom-OG-Cheyenne-Floyd-Reveals-Where-BF-Zach-Davis-Stands-Now-With-Ex-Cory-Wharton.jpg?crop=0px%2C0px%2C2000px%2C1133px&amp;resize=630%2C354 630w, https://www.intouchweekly.com/wp-content/uploads/2021/01/Teen-Mom-OG-Cheyenne-Floyd-Reveals-Where-BF-Zach-Davis-Stands-Now-With-Ex-Cory-Wharton.jpg?crop=0px%2C0px%2C2000px%2C1133px&amp;resize=940%2C529 940w, https://www.intouchweekly.com/wp-content/uploads/2021/01/Teen-Mom-OG-Cheyenne-Floyd-Reveals-Where-BF-Zach-Davis-Stands-Now-With-Ex-Cory-Wharton.jpg?crop=0px%2C0px%2C2000px%2C1133px&amp;resize=1200%2C675 1200w, https://www.intouchweekly.com/wp-content/uploads/2021/01/Teen-Mom-OG-Cheyenne-Floyd-Reveals-Where-BF-Zach-Davis-Stands-Now-With-Ex-Cory-Wharton.jpg?crop=0px%2C0px%2C2000px%2C1133px&amp;resize=1260%2C709 1260w, https://www.intouchweekly.com/wp-content/uploads/2021/01/Teen-Mom-OG-Cheyenne-Floyd-Reveals-Where-BF-Zach-Davis-Stands-Now-With-Ex-Cory-Wharton.jpg?crop=0px%2C0px%2C2000px%2C1133px&amp;resize=1920%2C1080 1920w" sizes="(max-width: 400px) 408px, 408px" alt="Teen Mom OG Cheyenne Floyd Reveals Where BF Zach Davis Stands Now With Ex Cory Wharton" data-fallback-img="https://www.intouchweekly.com/wp-content/uploads/2021/01/Teen-Mom-OG-Cheyenne-Floyd-Reveals-Where-BF-Zach-Davis-Stands-Now-With-Ex-Cory-Wharton.jpg?fit=2000%2C2000">			</figure>
		</a>
	
	<h2 class="article__item-title">
		<a href="https://www.intouchweekly.com/posts/tmogs-cheyenne-reveals-where-bf-zach-stands-with-ex-cory/">TMOG's Cheyenne Reveals Where BF Zach Stands With Ex Cory</a>
	</h2>
</article>

<article class="article__item">
			<a class="article__item-thumbnail" href="https://www.intouchweekly.com/posts/wendy-williams-wants-a-mature-man-after-kevin-hunter-split/">
						<figure class="article__item-figure">
				<img src="https://www.intouchweekly.com/wp-content/uploads/2021/01/Wendy-Williams-Wants-a-Mature-Man-After-Husband-Kevin-Hunter-Split.jpg?crop=0px%2C142px%2C3747px%2C2126px&#038;resize=120%2C68" srcset="https://www.intouchweekly.com/wp-content/uploads/2021/01/Wendy-Williams-Wants-a-Mature-Man-After-Husband-Kevin-Hunter-Split.jpg?crop=0px%2C142px%2C3747px%2C2126px&amp;resize=120%2C68 120w, https://www.intouchweekly.com/wp-content/uploads/2021/01/Wendy-Williams-Wants-a-Mature-Man-After-Husband-Kevin-Hunter-Split.jpg?crop=0px%2C142px%2C3747px%2C2126px&amp;resize=230%2C129 230w, https://www.intouchweekly.com/wp-content/uploads/2021/01/Wendy-Williams-Wants-a-Mature-Man-After-Husband-Kevin-Hunter-Split.jpg?crop=0px%2C142px%2C3747px%2C2126px&amp;resize=408%2C230 408w, https://www.intouchweekly.com/wp-content/uploads/2021/01/Wendy-Williams-Wants-a-Mature-Man-After-Husband-Kevin-Hunter-Split.jpg?crop=0px%2C142px%2C3747px%2C2126px&amp;resize=630%2C354 630w, https://www.intouchweekly.com/wp-content/uploads/2021/01/Wendy-Williams-Wants-a-Mature-Man-After-Husband-Kevin-Hunter-Split.jpg?crop=0px%2C142px%2C3747px%2C2126px&amp;resize=940%2C529 940w, https://www.intouchweekly.com/wp-content/uploads/2021/01/Wendy-Williams-Wants-a-Mature-Man-After-Husband-Kevin-Hunter-Split.jpg?crop=0px%2C142px%2C3747px%2C2126px&amp;resize=1200%2C675 1200w, https://www.intouchweekly.com/wp-content/uploads/2021/01/Wendy-Williams-Wants-a-Mature-Man-After-Husband-Kevin-Hunter-Split.jpg?crop=0px%2C142px%2C3747px%2C2126px&amp;resize=1260%2C709 1260w, https://www.intouchweekly.com/wp-content/uploads/2021/01/Wendy-Williams-Wants-a-Mature-Man-After-Husband-Kevin-Hunter-Split.jpg?crop=0px%2C142px%2C3747px%2C2126px&amp;resize=1920%2C1080 1920w" sizes="(max-width: 400px) 408px, 408px" alt="Wendy Williams Wants a &#039;Mature&#039; Man After Husband Kevin Hunter Split" data-fallback-img="https://www.intouchweekly.com/wp-content/uploads/2021/01/Wendy-Williams-Wants-a-Mature-Man-After-Husband-Kevin-Hunter-Split.jpg?fit=3747%2C5612">			</figure>
		</a>
	
	<h2 class="article__item-title">
		<a href="https://www.intouchweekly.com/posts/wendy-williams-wants-a-mature-man-after-kevin-hunter-split/">Wendy Williams Reveals What She Wants in Her Next Relationship After Split</a>
	</h2>
</article>

<article class="article__item">
			<a class="article__item-thumbnail" href="https://www.intouchweekly.com/posts/tmogs-maci-bookout-hopes-therapy-will-help-bentley-and-ryan/">
						<figure class="article__item-figure">
				<img src="https://www.intouchweekly.com/wp-content/uploads/2021/01/Teen-Mom-OG-Maci-Bookout-McKinney-Opens-Up-About-Bentley-Starting-Therapy-Amid-Uncomfortable-Relationship-With-Dad-Ryan-Edwards-Promo.jpg?crop=0px%2C0px%2C1080px%2C612px&#038;resize=120%2C68" srcset="https://www.intouchweekly.com/wp-content/uploads/2021/01/Teen-Mom-OG-Maci-Bookout-McKinney-Opens-Up-About-Bentley-Starting-Therapy-Amid-Uncomfortable-Relationship-With-Dad-Ryan-Edwards-Promo.jpg?crop=0px%2C0px%2C1080px%2C612px&amp;resize=120%2C68 120w, https://www.intouchweekly.com/wp-content/uploads/2021/01/Teen-Mom-OG-Maci-Bookout-McKinney-Opens-Up-About-Bentley-Starting-Therapy-Amid-Uncomfortable-Relationship-With-Dad-Ryan-Edwards-Promo.jpg?crop=0px%2C0px%2C1080px%2C612px&amp;resize=230%2C129 230w, https://www.intouchweekly.com/wp-content/uploads/2021/01/Teen-Mom-OG-Maci-Bookout-McKinney-Opens-Up-About-Bentley-Starting-Therapy-Amid-Uncomfortable-Relationship-With-Dad-Ryan-Edwards-Promo.jpg?crop=0px%2C0px%2C1080px%2C612px&amp;resize=408%2C230 408w, https://www.intouchweekly.com/wp-content/uploads/2021/01/Teen-Mom-OG-Maci-Bookout-McKinney-Opens-Up-About-Bentley-Starting-Therapy-Amid-Uncomfortable-Relationship-With-Dad-Ryan-Edwards-Promo.jpg?crop=0px%2C0px%2C1080px%2C612px&amp;resize=630%2C354 630w, https://www.intouchweekly.com/wp-content/uploads/2021/01/Teen-Mom-OG-Maci-Bookout-McKinney-Opens-Up-About-Bentley-Starting-Therapy-Amid-Uncomfortable-Relationship-With-Dad-Ryan-Edwards-Promo.jpg?crop=0px%2C0px%2C1080px%2C612px&amp;resize=940%2C529 940w" sizes="(max-width: 400px) 408px, 408px" alt="Teen Mom OG Maci Bookout McKinney Opens Up About Bentley Starting Therapy Amid Uncomfortable Relationship With Dad Ryan Edwards" data-fallback-img="https://www.intouchweekly.com/wp-content/uploads/2021/01/Teen-Mom-OG-Maci-Bookout-McKinney-Opens-Up-About-Bentley-Starting-Therapy-Amid-Uncomfortable-Relationship-With-Dad-Ryan-Edwards-Promo.jpg?fit=1080%2C1080">			</figure>
		</a>
	
	<h2 class="article__item-title">
		<a href="https://www.intouchweekly.com/posts/tmogs-maci-bookout-hopes-therapy-will-help-bentley-and-ryan/">TMOG's Maci Hopes Therapy Will Help Bentley's Relationship With Ryan</a>
	</h2>
</article>

<article class="article__item">
			<a class="article__item-thumbnail" href="https://www.intouchweekly.com/posts/amber-portwood-says-she-and-boyfriend-dimitri-are-dating/">
						<figure class="article__item-figure">
				<img src="https://www.intouchweekly.com/wp-content/uploads/2021/01/Amber-Portwood-Reveals-Where-She-Stands-With-Boyfriend-Dimitri-Garcia.jpg?crop=0px%2C171px%2C2965px%2C1679px&#038;resize=120%2C68" srcset="https://www.intouchweekly.com/wp-content/uploads/2021/01/Amber-Portwood-Reveals-Where-She-Stands-With-Boyfriend-Dimitri-Garcia.jpg?crop=0px%2C171px%2C2965px%2C1679px&amp;resize=120%2C68 120w, https://www.intouchweekly.com/wp-content/uploads/2021/01/Amber-Portwood-Reveals-Where-She-Stands-With-Boyfriend-Dimitri-Garcia.jpg?crop=0px%2C171px%2C2965px%2C1679px&amp;resize=230%2C129 230w, https://www.intouchweekly.com/wp-content/uploads/2021/01/Amber-Portwood-Reveals-Where-She-Stands-With-Boyfriend-Dimitri-Garcia.jpg?crop=0px%2C171px%2C2965px%2C1679px&amp;resize=408%2C230 408w, https://www.intouchweekly.com/wp-content/uploads/2021/01/Amber-Portwood-Reveals-Where-She-Stands-With-Boyfriend-Dimitri-Garcia.jpg?crop=0px%2C171px%2C2965px%2C1679px&amp;resize=630%2C354 630w, https://www.intouchweekly.com/wp-content/uploads/2021/01/Amber-Portwood-Reveals-Where-She-Stands-With-Boyfriend-Dimitri-Garcia.jpg?crop=0px%2C171px%2C2965px%2C1679px&amp;resize=940%2C529 940w, https://www.intouchweekly.com/wp-content/uploads/2021/01/Amber-Portwood-Reveals-Where-She-Stands-With-Boyfriend-Dimitri-Garcia.jpg?crop=0px%2C171px%2C2965px%2C1679px&amp;resize=1200%2C675 1200w, https://www.intouchweekly.com/wp-content/uploads/2021/01/Amber-Portwood-Reveals-Where-She-Stands-With-Boyfriend-Dimitri-Garcia.jpg?crop=0px%2C171px%2C2965px%2C1679px&amp;resize=1260%2C709 1260w, https://www.intouchweekly.com/wp-content/uploads/2021/01/Amber-Portwood-Reveals-Where-She-Stands-With-Boyfriend-Dimitri-Garcia.jpg?crop=0px%2C171px%2C2965px%2C1679px&amp;resize=1920%2C1080 1920w" sizes="(max-width: 400px) 408px, 408px" alt="Amber Portwood Reveals Where She Stands With Boyfriend Dimitri Garcia" data-fallback-img="https://www.intouchweekly.com/wp-content/uploads/2021/01/Amber-Portwood-Reveals-Where-She-Stands-With-Boyfriend-Dimitri-Garcia.jpg?fit=2965%2C2961">			</figure>
		</a>
	
	<h2 class="article__item-title">
		<a href="https://www.intouchweekly.com/posts/amber-portwood-says-she-and-boyfriend-dimitri-are-dating/">Amber Portwood Reveals Where She Stands With Boyfriend Dimitri Garcia</a>
	</h2>
</article>

<article class="article__item">
			<a class="article__item-thumbnail" href="https://www.intouchweekly.com/posts/teen-mom-og-maci-defends-bentley-from-ryans-dad-larrys-comments/">
							<div class="video-icon video__block-icon"><svg><use xlink:href="#icon-video" /></svg></div>
						<figure class="article__item-figure">
				<img src="https://www.intouchweekly.com/wp-content/uploads/2021/01/Teen-Mom-OG-Maci-Defends-Bentley-From-Ryan-Dad-Larry-Comments.jpg?crop=0px%2C18px%2C2000px%2C1132px&#038;resize=120%2C68" srcset="https://www.intouchweekly.com/wp-content/uploads/2021/01/Teen-Mom-OG-Maci-Defends-Bentley-From-Ryan-Dad-Larry-Comments.jpg?crop=0px%2C18px%2C2000px%2C1132px&amp;resize=120%2C68 120w, https://www.intouchweekly.com/wp-content/uploads/2021/01/Teen-Mom-OG-Maci-Defends-Bentley-From-Ryan-Dad-Larry-Comments.jpg?crop=0px%2C18px%2C2000px%2C1132px&amp;resize=230%2C129 230w, https://www.intouchweekly.com/wp-content/uploads/2021/01/Teen-Mom-OG-Maci-Defends-Bentley-From-Ryan-Dad-Larry-Comments.jpg?crop=0px%2C18px%2C2000px%2C1132px&amp;resize=408%2C230 408w, https://www.intouchweekly.com/wp-content/uploads/2021/01/Teen-Mom-OG-Maci-Defends-Bentley-From-Ryan-Dad-Larry-Comments.jpg?crop=0px%2C18px%2C2000px%2C1132px&amp;resize=630%2C354 630w, https://www.intouchweekly.com/wp-content/uploads/2021/01/Teen-Mom-OG-Maci-Defends-Bentley-From-Ryan-Dad-Larry-Comments.jpg?crop=0px%2C18px%2C2000px%2C1132px&amp;resize=940%2C529 940w, https://www.intouchweekly.com/wp-content/uploads/2021/01/Teen-Mom-OG-Maci-Defends-Bentley-From-Ryan-Dad-Larry-Comments.jpg?crop=0px%2C18px%2C2000px%2C1132px&amp;resize=1200%2C675 1200w, https://www.intouchweekly.com/wp-content/uploads/2021/01/Teen-Mom-OG-Maci-Defends-Bentley-From-Ryan-Dad-Larry-Comments.jpg?crop=0px%2C18px%2C2000px%2C1132px&amp;resize=1260%2C709 1260w, https://www.intouchweekly.com/wp-content/uploads/2021/01/Teen-Mom-OG-Maci-Defends-Bentley-From-Ryan-Dad-Larry-Comments.jpg?crop=0px%2C18px%2C2000px%2C1132px&amp;resize=1920%2C1080 1920w" sizes="(max-width: 400px) 408px, 408px" alt="Teen Mom OG Maci Defends Bentley From Ryan Dad Larry Comments" data-fallback-img="https://www.intouchweekly.com/wp-content/uploads/2021/01/Teen-Mom-OG-Maci-Defends-Bentley-From-Ryan-Dad-Larry-Comments.jpg?fit=2000%2C2000">			</figure>
		</a>
	
	<h2 class="article__item-title">
		<a href="https://www.intouchweekly.com/posts/teen-mom-og-maci-defends-bentley-from-ryans-dad-larrys-comments/">Teen Mom OG's Maci Defends Bentley From Ryan's Dad Larry's Comments</a>
	</h2>
</article>

<article class="article__item">
			<a class="article__item-thumbnail" href="https://www.intouchweekly.com/posts/tmogs-catelynn-lowell-responds-to-tyler-baltierra-divorce-rumors/">
						<figure class="article__item-figure">
				<img src="https://www.intouchweekly.com/wp-content/uploads/2021/01/Teen-Mom-OG-Star-Catelynn-Baltierra-Slams-Tyler-Divorce-Rumors.jpg?crop=0px%2C0px%2C1080px%2C612px&#038;resize=120%2C68" srcset="https://www.intouchweekly.com/wp-content/uploads/2021/01/Teen-Mom-OG-Star-Catelynn-Baltierra-Slams-Tyler-Divorce-Rumors.jpg?crop=0px%2C0px%2C1080px%2C612px&amp;resize=120%2C68 120w, https://www.intouchweekly.com/wp-content/uploads/2021/01/Teen-Mom-OG-Star-Catelynn-Baltierra-Slams-Tyler-Divorce-Rumors.jpg?crop=0px%2C0px%2C1080px%2C612px&amp;resize=230%2C129 230w, https://www.intouchweekly.com/wp-content/uploads/2021/01/Teen-Mom-OG-Star-Catelynn-Baltierra-Slams-Tyler-Divorce-Rumors.jpg?crop=0px%2C0px%2C1080px%2C612px&amp;resize=408%2C230 408w, https://www.intouchweekly.com/wp-content/uploads/2021/01/Teen-Mom-OG-Star-Catelynn-Baltierra-Slams-Tyler-Divorce-Rumors.jpg?crop=0px%2C0px%2C1080px%2C612px&amp;resize=630%2C354 630w, https://www.intouchweekly.com/wp-content/uploads/2021/01/Teen-Mom-OG-Star-Catelynn-Baltierra-Slams-Tyler-Divorce-Rumors.jpg?crop=0px%2C0px%2C1080px%2C612px&amp;resize=940%2C529 940w" sizes="(max-width: 400px) 408px, 408px" alt="Catelynn Lowell and Tyler Baltierra Selfie Teen Mom OG Star Catelynn Baltierra Slams Tyler Divorce Rumors" data-fallback-img="https://www.intouchweekly.com/wp-content/uploads/2021/01/Teen-Mom-OG-Star-Catelynn-Baltierra-Slams-Tyler-Divorce-Rumors.jpg?fit=1080%2C1080">			</figure>
		</a>
	
	<h2 class="article__item-title">
		<a href="https://www.intouchweekly.com/posts/tmogs-catelynn-lowell-responds-to-tyler-baltierra-divorce-rumors/">'TMOG' Star Catelynn Lowell Responds to Tyler Divorce Rumors</a>
	</h2>
</article>

<article class="article__item">
			<a class="article__item-thumbnail" href="https://www.intouchweekly.com/posts/teen-mom-ogs-mackenzie-mckee-in-dark-place-after-moms-death/">
						<figure class="article__item-figure">
				<img src="https://www.intouchweekly.com/wp-content/uploads/2021/01/teen-mom-og-mackenzie-mckee-dark-place-mom-death.jpg?resize=120%2C68" srcset="https://www.intouchweekly.com/wp-content/uploads/2021/01/teen-mom-og-mackenzie-mckee-dark-place-mom-death.jpg?resize=120%2C68 120w, https://www.intouchweekly.com/wp-content/uploads/2021/01/teen-mom-og-mackenzie-mckee-dark-place-mom-death.jpg?resize=230%2C129 230w, https://www.intouchweekly.com/wp-content/uploads/2021/01/teen-mom-og-mackenzie-mckee-dark-place-mom-death.jpg?resize=408%2C230 408w, https://www.intouchweekly.com/wp-content/uploads/2021/01/teen-mom-og-mackenzie-mckee-dark-place-mom-death.jpg?resize=630%2C354 630w" sizes="(max-width: 400px) 408px, 408px" alt="teen mom og mackenzie mckee dark place mom death" data-fallback-img="https://www.intouchweekly.com/wp-content/uploads/2021/01/teen-mom-og-mackenzie-mckee-dark-place-mom-death.jpg?fit=750%2C421">			</figure>
		</a>
	
	<h2 class="article__item-title">
		<a href="https://www.intouchweekly.com/posts/teen-mom-ogs-mackenzie-mckee-in-dark-place-after-moms-death/">Teen Mom OG's Mackenzie McKee Was in a 'Dark' Place After Mom's Death</a>
	</h2>
</article>

<article class="article__item">
			<a class="article__item-thumbnail" href="https://www.intouchweekly.com/posts/teen-mom-og-how-cheyenne-and-zach-got-back-together/">
							<div class="video-icon video__block-icon"><svg><use xlink:href="#icon-video" /></svg></div>
						<figure class="article__item-figure">
				<img src="https://www.intouchweekly.com/wp-content/uploads/2021/01/Teen-Mom-OGs-Cheyenne-Reveals-How-She-Got-Back-Together-With-Zach.jpg?crop=0px%2C0px%2C1200px%2C680px&#038;resize=120%2C68" srcset="https://www.intouchweekly.com/wp-content/uploads/2021/01/Teen-Mom-OGs-Cheyenne-Reveals-How-She-Got-Back-Together-With-Zach.jpg?crop=0px%2C0px%2C1200px%2C680px&amp;resize=120%2C68 120w, https://www.intouchweekly.com/wp-content/uploads/2021/01/Teen-Mom-OGs-Cheyenne-Reveals-How-She-Got-Back-Together-With-Zach.jpg?crop=0px%2C0px%2C1200px%2C680px&amp;resize=230%2C129 230w, https://www.intouchweekly.com/wp-content/uploads/2021/01/Teen-Mom-OGs-Cheyenne-Reveals-How-She-Got-Back-Together-With-Zach.jpg?crop=0px%2C0px%2C1200px%2C680px&amp;resize=408%2C230 408w, https://www.intouchweekly.com/wp-content/uploads/2021/01/Teen-Mom-OGs-Cheyenne-Reveals-How-She-Got-Back-Together-With-Zach.jpg?crop=0px%2C0px%2C1200px%2C680px&amp;resize=630%2C354 630w, https://www.intouchweekly.com/wp-content/uploads/2021/01/Teen-Mom-OGs-Cheyenne-Reveals-How-She-Got-Back-Together-With-Zach.jpg?crop=0px%2C0px%2C1200px%2C680px&amp;resize=940%2C529 940w, https://www.intouchweekly.com/wp-content/uploads/2021/01/Teen-Mom-OGs-Cheyenne-Reveals-How-She-Got-Back-Together-With-Zach.jpg?crop=0px%2C0px%2C1200px%2C680px&amp;resize=1200%2C675 1200w" sizes="(max-width: 400px) 408px, 408px" alt="Teen Mom OG&#039;s Cheyenne Reveals How She Got Back Together With Zach" data-fallback-img="https://www.intouchweekly.com/wp-content/uploads/2021/01/Teen-Mom-OGs-Cheyenne-Reveals-How-She-Got-Back-Together-With-Zach.jpg?fit=1200%2C1200">			</figure>
		</a>
	
	<h2 class="article__item-title">
		<a href="https://www.intouchweekly.com/posts/teen-mom-og-how-cheyenne-and-zach-got-back-together/">Teen Mom OG's Cheyenne Reveals How She Got Back Together With Zach</a>
	</h2>
</article>
					</div>
				</div>
			</div>
		</div>
	</div>

	<div class="l-grid">
		<div class="l-container l-container__related-articles">
			
<div class="l-grid__main-default" id="infSec_1">
	<div class="post-related">
			<div class="lazyload-anchor" data-page-id="375636" data-page-type="single-post" data-count="30" data-paged="1" data-excluded="[375524,375477,375393,375321,375266,375183,375017,374390,374367]" data-ads="{&quot;sh&quot;:1,&quot;mb&quot;:3}"></div>	</div>
</div>

<div class="post-sidebar">
	<div class="ad-container__sticky-wrapper">
		<div class="ad-container sticky-top">
			<div class="dfp-wrapper  desktop-only" data-slot="rr3"><div id="rr3" class="dfp-slot dfp-container rr3 "></div></div>		</div>
	</div>
</div>
		</div>
	</div>


<footer class="site-footer">
	<div class="site-footer__inner">
		<div class="site-footer__left">
			<a href="https://www.intouchweekly.com/" class="site-footer__logo" title="Home" rel="home">
				<span class="hidden-except-readers">In Touch Weekly logo</span>
				<svg class="logo">
					<use xlink:href="#logo-intouch-footer"></use>
				</svg>
			</a>

			<div class="site-footer__left__inner">
				<div class="site-footer__social">
					<span class="site-footer__social__heading">Follow us!</span>
					<ul class="site-footer__social__list">
						<li><a href="http://www.facebook.com/InTouchWeekly" class="site-footer__social__link" rel="nofollow"> <span class="hidden-except-readers">Social icon facebook</span><svg class="icon icon-facebook"><use xlink:href="#icon-facebook"></use></svg></a></li><li><a href="https://twitter.com/intouchweekly" class="site-footer__social__link" rel="nofollow"> <span class="hidden-except-readers">Social icon twitter</span><svg class="icon icon-twitter"><use xlink:href="#icon-twitter"></use></svg></a></li><li><a href="https://www.instagram.com/intouchweekly/?hl=en" class="site-footer__social__link" rel="nofollow"> <span class="hidden-except-readers">Social icon instagram</span><svg class="icon icon-instagram"><use xlink:href="#icon-instagram"></use></svg></a></li>					</ul>
				</div>

				                    <div class="site-footer__newsletter-link">
                        <a href="/newsletter">Sign up for our e-newsletter</a>
                    </div>
				
				<div class="site-footer__notification">
					<p class="site-footer__notification-text">In Touch Weekly has affiliate partnerships so we may receive compensation for some links to products and services.</p>
					<p class="site-footer__notification-text">In Touch Weekly is part of the A360 Media Entertainment Group.<br>Copyright © A360 Media LLC 2021. All Rights Reserved</p>
				</div>
			</div>

		</div>

		<div class="site-footer__right">
			<div class="site-footer__menu">
				<h3 class="site-footer__heading">In Touch Weekly</h3>
				<div class="site-footer__links"><ul id="menu-footer-menu-1" class="site-footer__links__list"><li id="menu-item-201709" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-201709"><a href="https://www.intouchweekly.com/archives/">Archives</a></li>
<li id="menu-item-260471" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-260471"><a href="https://www.intouchweekly.com/posts/category/news/">News</a></li>
<li id="menu-item-260470" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-260470"><a href="https://www.intouchweekly.com/posts/category/reality-tv/">Reality TV</a></li>
<li id="menu-item-260472" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-260472"><a href="https://www.intouchweekly.com/posts/category/true-crime/">True Crime</a></li>
<li id="menu-item-260473" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-260473"><a href="https://www.intouchweekly.com/posts/category/entertainment/">Entertainment</a></li>
<li id="menu-item-260475" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-260475"><a href="https://www.intouchweekly.com/posts/category/omg/">OMG!</a></li>
<li id="menu-item-260474" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-260474"><a href="https://www.intouchweekly.com/posts/category/style/">Style</a></li>
<li id="menu-item-260469" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-260469"><a href="/newsletter">Newsletter</a></li>
</ul></div>
				<!-- OneTrust Cookies Settings button start -->
				<a class="optanon-toggle-display" name="Manage Cookies">Manage Cookies</a>
				<!-- OneTrust Cookies Settings button end -->
			</div>

			<div class="site-footer__menu">
				<h3 class="site-footer__heading">A360 Media LLC</h3>
				<div class="site-footer__links"><ul id="menu-footer-menu-2" class="site-footer__links__list"><li id="menu-item-130808" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-130808"><a href="https://a360media.com/privacy-policy">Privacy Policy</a></li>
<li id="menu-item-130809" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-130809"><a href="https://a360media.com/terms-and-conditions">Terms &#038; Conditions</a></li>
<li id="menu-item-130810" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-130810"><a href="https://www.intouchweekly.com/contact/">Contact Us</a></li>
<li id="menu-item-134887" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-134887"><a href="https://a360media.cloud.buysub.com/">Subscriber Service</a></li>
<li id="menu-item-260468" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-260468"><a href="https://shop.getspecialissues.com/">Shop Special Issues</a></li>
<li id="menu-item-130811" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-130811"><a href="/archives/">SIte Map</a></li>
<li id="menu-item-298102" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-298102"><a href="https://www.intouchweekly.com/accessibility-statement/">Accessibility Statement</a></li>
<li id="menu-item-298103" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-298103"><a href="https://a360media.com/cookie-policy">Cookie Policy</a></li>
</ul></div>			</div>

			<div class="site-footer__cta">
				<div class="site-footer__cta__inner">
					<h3 class="site-footer__heading">Want more?</h3>
					<div class="textwidget custom-html-widget"><img src="https://www.intouchweekly.com/wp-content/uploads/2020/10/IT4420_cover_final.jpg?w=300" srcset="https://www.intouchweekly.com/wp-content/uploads/2020/10/IT4420_cover_final.jpg?w=200 1x, https://www.intouchweekly.com/wp-content/uploads/2020/10/IT4420_cover_final.jpg?w=400 2x" sizes="200px" alt="In This Issue of In Touch Weekly" class="img-responsive img-cover"></div>					<a class="site-footer__cta-link" target="_blank" rel="nofollow noopener" href="https://w1.buysub.com/servlet/OrdersGateway?cds_mag_code=NTW&#038;cds_page_id=230030">Subscribe!</a>
					<a class="site-footer__cta-link" target="_blank" rel="nofollow noopener" href="https://w1.buysub.com/servlet/GiftsGateway?cds_mag_code=NTW">Give as a Gift</a>
					<a class="site-footer__cta-link" target="_blank" rel="nofollow noopener" href="https://a360media.cloud.buysub.com/">Subscriber Services</a>
				</div>
			</div>
		</div>
	</div>

</footer>
</div>

<div class="dfp-wrapper  mobile-only" data-slot="mb-sticky"><div id="mb-sticky" class="dfp-slot dfp-container mb-sticky "></div></div>	<style type="text/css" media="screen">
		@media screen and ( max-width: 782px ) {
			html {
				margin-top: 0px !important;
			}
			* html body {
				margin-top: 0px !important;
			}
			#wpadminbar {
				display: none;
			}
		}
	</style>
		<script>
		jQuery(document).ready(function ( $ ) {
			$('a[href^="http"]')
				.not('[href^="' + location.protocol + '//' + location.hostname + '"]')
				.attr('target', '_blank');
		});
	</script>
			<script id='main-js-js-extra'>
var ajaxurl = "\/wp-admin\/admin-ajax.php";
var obj = {"templateUrl":"https:\/\/www.intouchweekly.com\/wp-content\/themes\/ami-bauer","restEndpoint":"https:\/\/www.intouchweekly.com\/wp-json\/ami\/v1\/"};
</script>
<script type='text/javascript' src='https://www.intouchweekly.com/_static/??/wp-content/mu-plugins/jetpack-9.3/_inc/build/photon/photon.min.js,/wp-content/themes/ami-bauer/assets/build/js/main.bundle.js?m=1609888773j'></script>
<script src='https://www.google.com/recaptcha/api.js?onload=onloadCallback&#038;render=explicit&#038;ver=5.6' id='reCaptcha-js'></script>
<script class='optanon-category-C0004' type='text/plain' src='https://static.adsafeprotected.com/vans-adapter-google-ima.js' id='ami-googleima-js'></script>
<script id='newsletter-sign-up-js-extra'>
var amiNewsletterStrings = {"userEndpoint":"https:\/\/www.intouchweekly.com\/wp-json\/ami\/v1\/newsletter\/user","listEndpoint":"https:\/\/www.intouchweekly.com\/wp-json\/ami\/v1\/newsletter\/list","processMessage":"Sending your request...","defaultError":"An internal error has occurred. Please try again later..","invalidEmailError":"Please enter a valid email and try again."};
</script>
<script type='text/javascript' src='https://www.intouchweekly.com/wp-content/client-mu-plugins/shared/assets/js/dist/newsletterSignUp.bundle.js?m=1607936487g'></script>
<script class='optanon-category-C0003' type='text/plain' src='https://www.intouchweekly.com/wp-content/client-mu-plugins/shared/assets/js/dist/overlayRecircWidget.bundle.js?ver=5.6' id='overlay-recirc-widget-script-js'></script>
<script type='text/javascript' src='https://www.intouchweekly.com/wp-includes/js/wp-embed.min.js?m=1607466261g'></script>
<script id='sharing-js-js-extra'>
var sharing_js_options = {"lang":"en","counts":"","is_stats_active":"1"};
</script>
<script src='https://www.intouchweekly.com/wp-content/mu-plugins/jetpack-9.3/_inc/build/sharedaddy/sharing.min.js?ver=9.3.1' id='sharing-js-js'></script>
<script id='sharing-js-js-after'>
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-facebook', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomfacebook', 'menubar=1,resizable=1,width=600,height=400' );
				return false;
			});
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-twitter', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomtwitter', 'menubar=1,resizable=1,width=600,height=350' );
				return false;
			});
</script>
<script src='https://stats.wp.com/e-202105.js' defer></script>
<script>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:9.3.1',blog:'149114667',post:'375636',tz:'-5',srv:'www.intouchweekly.com'} ]);
	_stq.push([ 'clickTrackerInit', '149114667', '375636' ]);
</script>
</body>
</html>
